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Displacement Maps 

In this lesson, you’re going to learn how you can bend a flat image to make it look 
like it has more dimension. The feature used to create this type of effect is called 
a displacement map. A displacement map is a black and white image that is usu-
ally the same size as the image you’re attempting to bend. In this image, areas 
that are bright are thought of as being close to the camera. Areas that are dark 
are thought of as being far from the camera and areas that are 50% gray will not 
cause any change in the image. 

Manually Paint a Wavy Displacement Map (Timestamp 1:34)

Create a displacement map We’ll 
demonstrate the displacement 
map feature by taking a flag 
graphic and making it look as 
if it is wavy from blowing in the 
wind. Start by creating the dis-
placement map, which describes 
where the image should look as if 
it’s close to the camera and where 
it should look as if it’s farther from 
the camera.

The displacement map will be made in an empty layer so create a new, empty 
layer at the top of the layer stack. Make sure you’re working on this new layer. Ac-
tivate the Brush Tool and make sure that you’re using a large, soft-edged brush. 
Lower the brush opacity to about 30%. (The Brush settings can be found in the 
Options Bar).  

A displacement map will be used to bend this flag.
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Next, paint with black in any area you want the flag to be farther away from the 
camera. In the video example, we painted two diagonal strokes that will end up 
being bends in the flag. Since the brush opacity is lower, the black won’t be ap-
plied at full strength. You can paint over one of the strokes a second time in order 
to make it even darker and therefore make it appear to be farther from the cam-
era. 

Next switch the foreground color to white in order to change the color you’re 
painting with. White is going to push things closer to the camera. Paint over the 
flag in the areas where it should be closer to the camera. 

The Brush Tool is being used (on an empty layer) to paint black and white strokes on the  
image. These will determine what areas appear closer and what areas appear farther.
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Because the brush opacity is lower, it might be hard to see how the strokes are 
affecting the image. Temporarily turn off the visibility for the image layer. This will 
leave you with the paint strokes set against the transparent checkerboard back-
ground. You’ll want to place these strokes on a background that is 50% gray. That 
is the one shade that is not going to attempt to bend the flag at all. 

Click on the Adjustment Layer icon at the bottom of the Layers Panel and choose 
Solid Color from the pop-up menu. The Color Picker will appear. Type 50% into 
the B field. Leave the H and S fields at 0 and then click OK. This will fill the layer 
with 50% gray. In the Layers Panel, position this layer just beneath the one you 
were painting on.  

ABOVE: A solid color adjustment layer is being 
created and the layer is being filled with 50% gray. 
LEFT: The 50% gray layer is placed beneath the 
layer with the paint strokes. This is the complete 
displacement map.
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Now it’s time to save out this image so that it can be used as a displacement map. 
Click on the File menu and choose Save As. In the Save As dialog, name the file 
and place it somewhere you’ll remember on your hard drive. Make sure the For-
mat menu is set to Photoshop and then click the Save button. 

Now that the you’ve saved the image, you can turn off the visibility for the two 
layers that were used to create the map. (This is the layer you painted on and the 
50% gray layer.) Turn on the visibility for the flag image layer. 

Apply the displacement map You’ll want to con-
vert the image layer into a smart object and you 
can do that by clicking on the Layer menu and 
choosing Smart Objects > Convert to Smart Ob-
ject. (Alternatively, you could click on the Filter 
menu and choose Convert to Smart Filters. It does 
the same exact thing.) You can tell that a layer is 
a smart object because a little icon will appear in 
the bottom corner of the layer’s thumbnail in the 
Layers Panel. 

At this point, you can apply the displacement map. Click on the Filter menu and 
choose Distort > Displace. The Displace dialog box will appear. 

Note: This filter only works on 8-bit 
images. If you happen to be working 
on an image that is 16 bit, you will en-
counter an error message. 

The Horizontal Scale and Vertical 
Scale numbers determine how strong-
ly the displacement map will bend the 
image. You can enter any number be-
tween 0 and 999. It may take some tri-
al and error to figure out how “moun-
tainous” you want the bends to be. 

The icon in the bottom right 
corner of the thumbnail indicates 
that the layer is a smart object. 

In the Displace dialog, the Horizontal and  
Vertical Scale fields determine how strongly 
the image will bend.
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I like to enter the same number for the Horizontal and Vertical fields, and I used 
120 in the video example. 

The remainder of the settings in the dialog will not matter if the displacement 
map document is the same size as the image document you’re going to apply 
it to. If it was not the same size, the underlying settings will control whether the 
map is scaled or tiled and how any undefined areas (after bending) should be 
treated. In our example, the displacement map document IS the same size as the 
image document, so these extra settings won’t matter. 

One final check box will appear if you have converted the image layer into a smart 
object. It’s at the bottom of the dialog and turning it on will “Embed File Data in 
Smart Object.” This is an advanced feature that is slightly beyond the scope of 
this lesson, but it basically means that you can change the contents of the layer 
and it will still have access to the grayscale displacement map image because it 
would be embedded in the file. 

Click the OK button to exit the Displace dialog, and you will be prompted to 
navigate to the location of the displacement map image file on your hard drive. 
Choose the image and then click the Open button. The displacement map will 
then be applied to the image, and you can see that it will bend based on what 
areas were lighter and darker. 

In the image on the left, the Horizontal and Vertical Scale fields were set to 120. In the image 
on the right, the Scale fields were set to 50. You can see how this affects the waviness. 
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In the Layers Panel, you can see that the Dis-
place filter was applied as a smart filter be-
cause it shows up as a thumbnail indented be-
low the image layer. With smart filters, you can 
double-click on the name of the filter in order 
to call up the filter dialog and make changes to 
the settings. This makes it easy to experiment 
with different horizontal and vertical scale set-
tings. With the Displace filter, just be aware 
that you will again to navigate to displacement 
map file on your hard drive. 

Add shading In the case of an image like the flag, the one thing we’re missing 
(after creating the waves) is the shading. When an object is bent, there will be 
highlights and shadows in different areas. Because you created the displacement 
map within the same document as the image layer, you can easily use that dis-
placement map layer to create the shading. 

Turn on the visibility for the displacement map layer and position it so that it 
sits just above the image layer. Then, you’ll clip the layer so that it only shows up 
where the image layer is visible. That’s how a clipping mask works. It takes the 
clipped layer and makes it so that it can only be visible where the underlying layer 
is visible. 

There are a couple of methods for clipping 
a layer. You can hover your cursor over the 
line between the two layers, hold down 
the Option key (Alt on Win) and then click 
on the line. You will see the clipped layer 
becomes indented, with a down-pointing 
arrow to the left of its thumbnail. The oth-
er method would be to click on the Layer 
menu and choose to Create Clipping Mask. 

The Displace filter was applied as  
a smart filter, so it appears as an  
indented thumbnail beneath the  
image layer.

The shading layer has been clipped 
to the flag layer.
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You can change the blending mode of the shading layer in order to make the ef-
fect look more realistic. The Blending Mode menu can be found at the top of the 
Layers Panel. I like to use the Hard Light mode, but experiment with the others by 
hovering your cursor over the other modes and watching the effect in the image 
window. 

Use Texture Image as a Displacement Map (13:38)

Displacement maps can also be used to make it look as if an image is printed on 
a textured surface. In the video example, we’re going to take a graphic and make 
it look as if it was painted on a highly textured wall. We’ll place the graphic layer 
above the textured wall image layer in a single Photoshop document. 

You can actually use the texture image as the displacement map and that’s what 
we’ll do with the wall image. 

Here, we’re making the shading look more natural by changing the layer’s blending mode to 
Hard Light.
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Remove color from displacement map If you have a color image, the various 
colors in the image will change the way the image is bent, so it’s a good idea to 
remove any hint of color before saving the image as a displacement map. To do 
this, create a Black and White adjustment layer and place it directly above the 
image/texture layer. (The Adjustment Layer menu can be accessed by clicking on 
the circular icon at the bottom of the Layers Panel.) 

Set overall tone to 50% gray It’s also a good idea to 
make sure that the overall tonality of the texture image 
is near 50% gray. You can use a Curves Adjustment Lay-
er for this. After creating a Curves Adjustment Layer, 
the Properties Panel will appear, containing the curves 
settings. Activate the Targeted Adjustment Tool (it 
looks like a little hand icon on the left side of the panel) 
and click on an area that displays the average tonality 
of the image. This will place a point on the curve, rep-
resenting that tone. Next, type 128 into the output field 
just below the curve chart. This is the halfway point 
between 1 and 255, which is the range of tones you can 

A displacement map 
will be used to make 
it look as if the graph-
ic is printed on the 
textured wall. In this 
case, we’ll use the 
wall image AS the 
displacement map.

We targeted the overall tone 
of the image and set the 
Output number to 128.
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work with in Curves. Therefore, 128 represents 50% gray. The tone that you tar-
geted will now be 50% gray. 

Save displacement map document Now it’s time to create the displacement 
map. Make sure that the visibility for the graphic layer is turned off. You should 
only be seeing the gray textured image. Click on the File menu and choose Save 
As. In the Save As dialog, set the Format menu to Photoshop and type in a name 
for the document. Save the image somewhere on your hard drive that you will 
remember. I just use the desktop in the video example. 

Back in the image document, turn off the visi-
bility of the adjustment layers. They were only 
created to optimize the displacement map. 
Turn the visibility ON for the graphic layer[s] 
and convert it into a smart object (Layer > 
Smart Objects > Convert to Smart Object). 

Note: If the graphic consists of one layer only, 
it’s not imperative that the layer be convert-
ed into a smart object. I just like to do this 
because it provides more versatility. If the 
graphic consists of more than one layer, you 
will need to convert them into a single smart 
object in order for them to be bent as one 
item. 

Apply the Displace filter With the graph-
ic layer active, click on the Filter menu and 
choose Distort > Displace. In the Displace di-
alog, enter in numbers for the Horizontal and 
Vertical Scale fields (I used 100 in the exam-
ple) and click OK. You’ll be prompted to navi-
gate to the displacement map image on your 
hard drive. 

Before applying the displacement 
map, we turned off the visibility of 
the adjustment layers, activated the 
graphic layer and converted it into a 
smart object. 

The Displace filter is being applied, 
with the scale settings at 100.
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If you apply the displacement 
map and find that the graphic 
ends up looking overly messy, it 
could be that the textured im-
age used to create the map was 
too busy, containing too much 
fine detail. Remember, any little 
changes in brightness are going 
to affect the way the graphic is 
bent. 

You can correct for this by re-
moving the fine detail in the dis-
placement map. If you are using 
the image layer as the displace-
ment map, duplicate that layer 
and then apply the Gaussian Blur 
filter (Filter menu > Blur > Gauss-
ian Blur). In the Gaussian Blur di-
alog, move the Radius slider up 
just enough that you get rid of 
any fine detail. You still want to 
be able to see the larger shapes. 
When you’re done adjusting the 
Radius slider, click OK to close 
the Gaussian Blur dialog. Now 
you can save a new version of 
the displacement map document 
(File > Save As). 

Here, the result of the Displace filter was very messy. 
That’s because the textured wall used to create the 
displacement map has too much fine detail.

The Gaussian Blur filter is being used to blur the  
displacement map image, removing fine detail.
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Once again, toggle the visibility 
icons in the Layers Panel so that 
you are only viewing the textured 
image layer and the graphic layer 
above it. If the graphic is still messy 
from the first time you applied a 
displacement map, you can simply 
double-click on the Displace smart 
filter in order to run it again. This 
time, choose the new (blurred) 
displacement map file. The result 
should look much smoother. You 
can re-run the filter as many times 
as is necessary, adjusting the hor-
izontal and vertical scale settings 
until you have the ideal amount of 
bend in the image. 

The graphic is bent now, but you still need to change the blending mode so that it 
looks as if it’s truly printed on the wall. If you want it to print like ink, the Multiply 
blending mode works well. 

Another option would be to duplicate the tex-
tured image layer and place the duplicate above 
the graphic layer in the Layers Panel. Clip the du-
plicate texture layer to the underlying graphic lay-
er (Layer menu > Create Clipping Mask) and then 
change the blending mode of the texture layer. 
When using this method, I like the blending modes 
of Overlay, Soft Light and Hard Light. You can also 
adjust the opacity to achieve the optimal effect.  

After removing fine detail from the displacement 
map, the Displace filter was applied to the graphic.

A duplicate of the texture layer was placed 
above the graphic and the blending mode 
was changed to Hard Light.
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Tips & Troubleshooting (21:23)

Use a grid graphic as a guide and placeholder You can run the Displace filter 
on an image containing a simple grid in order to see how the bends in the map 
affect the image. The grid lines would serve as a visual guide. You can then easily 
switch the warping effect from the grid layer to the graphic layer you ultimately 
want to bend. You will need to convert the graphic into smart object. Then, you 
can simply drag the Displace smart filter from one layer to another. 

Correct unwanted shifting of the graphic layer If the graphic shifts after applying 
the Displace filter, it’s because the overall tonality of the displacement map is not 
50% gray. Earlier in the lesson, we learned that we can correct for this by using a 
Curves adjustment. In the Curves settings, you will use the Targeted Adjustment 
Tool to click on an area that is representative of the overall image tone and then 
set the Output field to 128. If the curve line bottoms out when you do this, you 

The displacement map was first applied to a grid graphic, which helped us to see how the 
map was bending the image. Then, the Displace smart filter was moved from the grid layer to 
the graphic layer we ultimately wanted to use.
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might need to add an extra point and position it in a way that smooths out the 
curve (see screen shot). You will need to re-save the displacement map after ap-
plying the Curves adjustment.

ABOVE: After setting the Output of the curve 
point to 128, you can see that part of the curve 
line bottomed out. RIGHT: A second point was 
placed and positioned to smooth out the curve 
line.
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Imperfect edges When it comes to displacement maps, you will notice that the 
edges of the graphics you’re bending will not look perfect. The solution for this 
is to work on a much larger image than you truly need. This may mean that you 
scale your image to 200% before applying the Displace filter. Just make sure that 
you finalize the image before you scale back down to 50%. By saying “finalize,” I 
mean that you would either select all layers and convert them to a single smart 
object or you would simply flatten the image. 


