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Pattern Preview 

In this lesson, we’re going to take a look at how to create patterns and we’ll focus 
on the following three types:

1.	 Create a repeat of a graphic to be used on something like fabric or wallpaper.

2.	 Create an organic surface (dirt, grass, etc.) that doesn’t need to be overly pre-
cise in how everything lines up. 

3.	 Create a very precise repeating pattern, such as a brick or stone wall. 

These patterns can be used to fill text, they can be used as backgrounds or they 
can be used in a retouching scenario where you might need to create a surface 
like a brick wall.

Pattern Preview (Timestamp 2:20)

With any image open, you can run the Pattern Preview command, which can be 
found under the View menu. This command will take the contents of your image 
and it will repeat it to tile and fill your entire Photoshop window. The bounds of 
the actual document will be surrounded in a blue outline. 

With an image 
open, we turned 
on the Pattern 
Preview. You 
can see that the 
bounds of the 
actual document 
is outlined in blue. 
The image repeats 
to fill the entire 
Photoshop screen.
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If you make changes to the document within the blue outline, it will interactively 
repeat that change across the entire tiled pattern. In the video example, we used 
the Brush Tool to paint on the document and you can see that the paint stroke is 
reflected in every tile. You can even extend the paint stroke outside of the edge 
of the image and it  will continue the stroke on the opposite edge. 

Smart objects vs. regular layers When Pattern Preview is turned on, objects ex-
tending beyond one side of the document bounds will automatically continue 
into the opposite side. In the video example with the retro graphics, the little 
trailer extends outside of the right side of the document. With Pattern Preview 
turned on, you can see the trailer hitch wrap around to the left side. If the layer 

As we paint, you can see that the strokes not only repeat in every instance of the image, but 
we can also paint outside of the document bounds and it will wrap to the opposite side. 
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is a smart object and you turn Pattern Preview off, that wrapping will no longer 
occur. If the layer is NOT a smart object, you can turn Pattern Preview off and you 
will still see the object appear on the opposite side, BUT it’s as of the object was 
cut into two pieces using scissors. If you move the layer, you will see that it has 
been split into two pieces. 

Above, the individual smart object layers were  
positioned in the document with Pattern Preview 
turned on. At left, Pattern Preview is turned off and 
you can see that the wrapping effect is no longer  
happening.
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Create a Graphical Pattern (10:15)

Now let’s look at how we can create a repeating graphical pattern from scratch. 
We’ll start by creating a brand new Photoshop document. In the video example, 
my document size was 800x800 pixels. Make sure that the folder containing the 
graphics you’re going to use is easily accessible. I like to open the folder in the 
Finder and then have the Finder window visible right behind my Photoshop win-
dow. This will make it easier to move the individual image files into the Photoshop 
document. Drag one of the image files from the Finder into the open document. 
When you release the mouse button, transform handles will appear around the 
layer. Use these to resize and position the layer. 

ABOVE: The first graphic is being dragged 
from the Finder into the Photoshop document.

LEFT: Transform handles appear around the 
layer and we’re using them to scale the graph-
ic layer. 
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Note: When transforming a layer, know that there is a setting in the Preferences 
that will determine whether or not the proportions remain constrained. If you 
start to resize the layer and you find that you can squish or expand it (creating a 
distortion effect), hold down the Shift key to constrain the proportions. The op-
posite is also true. If you click and drag on a corner to resize and you find that the 
proportions are constrained, hold down the Shift key to distort the layer. This is 
all a matter of preference. Sometimes, you’ll want to distort the layer. Other times 
you won’t. 

After you’ve positioned and sized the 
layer, tap the Return/Enter key to lock in 
the transformation and remove the trans-
form handles. The image will be placed 
as a smart object, and you can see the 
smart object icon appear in the bottom 
corner of the layer thumbnail. 

Continue this process with the other 
graphics, dragging and placing them 
into the document. Know that you can 
also select multiple images/graphics and 
drag them into the Photoshop document 
all at once. When you do this, Photoshop 
will present them to you one at a time so 
that you can use the transform handles 
to position the layer. When you tap the 
Return/Enter key, the next selected im-
age will appear (with transform handles) 
so that you can place it. 

After all of the graphics have been placed 
in the document, click on the View menu 
and choose Pattern Preview. The con-
tents of the document will repeat to fill 

The icon indicates that the layer is a smart 
object. 

All of the graphics have been placed in the 
document.
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the entire Photoshop window. If you zoom out , you will see that the pattern is 
infinite, with the actual document outlined in blue. 

Now you can use the Move Tool to position the graphics into a pleasing arrange-
ment. With the preview turned on, you will see the wrapping effect as the layers 
extend partially beyond the edge of the document. 

Auto Select Setting When positioning many graphic layers like this, it can be 
useful to turn on the Auto-Select Layer setting, which can be found in the Op-
tions Bar when the Move Tool is active. With this setting turned on, you can click 

on things in your document and it will 
automatically select whatever layer is 
directly beneath the cursor. This makes 
it so you don’t need to click on the in-
dividual layers in the Layers Panel in or-
der to make them active. You can sim-
ply click and drag within the document.  

The Auto-Select setting is available with the 
Move Tool is active. 

Pattern Preview 
is turned on and 
we can not posi-
tion the individual 
graphics to form a 
pleasing pattern.
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I actually find this setting to be annoying in most OTHER situations, so I’ll be sure 
to turn it off after I’m done positioning the graphic elements. 

Note that you can keep the Auto-Select Layer setting off and then temporarily 
access it by holding down the Command key (Ctrl on Win) when clicking and 
dragging with the Move Tool. When you hold down that key, it will auto-select 
the layer that’s directly beneath your cursor. If you like to keep the Auto Select 
setting on all the time, then holding down the Command key (Ctrl on Win) would 
temporarily turn it off.  

Zoom out so that you can see the pattern repeated many times. This will truly 
give you a good sense for how the pattern looks overall. With this zoomed-out 
view, I like to fine-tune the position of the graphics because I can see the move-
ment occur across the pattern at large. 

Define the pattern After all the elements have been positioned, you move on 
to save the pattern. Make sure that the Pattern Preview setting is still turned 
on when you do this. If it’s not, the elements that extend beyond the document 
bounds will not be wrapped around. They will instead be cut off. Click on the Edit 
menu and choose Define Pattern. A little box will pop up, prompting you to give 
the pattern a name. Click OK to save the pattern. 

Testing the pattern After the pattern has been defined, it’s time to test it out. 
Create a new document and use really large dimensions (so that you can see the 
pattern repeated many times). In the video example, I made this document 4,000 
x 4,000 pixels. 

Fill with pattern There are several 
ways to fill the document with a pat-
tern. You could click on the Edit menu 
and choose Fill. In the Fill dialog, set 
the Contents menu to Pattern and 
then use the Custom Pattern menu 
to choose the pattern you just creat-
ed. Click OK and the active layer will 
be filled with the pattern. 

The Fill command is one method of filling 
the document with a pattern.
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Pattern Fill layer You could also fill the document with the pattern by using a 
Pattern Fill layer. Click on the Adjustment Layer icon at the bottom of the Layers 
Panel and choose Pattern from the pop-up menu. Use the menu in the dialog that 
pops up to choose your pattern. 

Apply layer style A layer can be filled with a pattern using a layer style as well. 
Make sure that the layer you want to apply the pattern to is active. Then click on 
the Layer Style icon  (fx) at the bottom of the Layers Panel and choose Pattern 
Overlay from the pop-up menu. The Pattern Overlay settings will appear inside 
the Layer Style dialog. This feature lets you fill the entire contents of a layer with 
a pattern. Use the Pattern menu to choose the pattern. You will also find settings 
for scaling and angling the pattern. 

A Pattern Fill layer 
is being applied 
and we clicked 
on the menu to 
choose a pattern.

The Pattern Overlay layer 
style can be used to fill 
the contents of a layer 
with a pattern.
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Create a Precise Pattern from a Photograph (21:10)

Another type of pattern 
you can create is one that is 
comes from a photograph 
and needs to be very precise. 
You can take a photo of a re-
peating design and then con-
vert that into a pattern that 
can be used in Photoshop. In 
the video example, we have 
a photo of a weathered met-
al surface that is going to be 
converted into a repeating 
pattern. 

Prepare the photo in Camera Raw Start 
by opening the image in Camera Raw. 
Here, you’ll want to ensure that any 
lens corrections have been applied. Ex-
pand the Optics Panel on the right side 
of the interface and turn on the “Use 
Profile Corrections” check box. This will 
attempt to remove any vignetting that 
was caused by the lens. A vignetting 
effect would make the edges of the 
image darker than the middle and this 
would cause the repeating nature of 
the pattern to be overly obvious. I also 
like to turn on the “Remove chromatic 
aberration” check box. 

Next, expand the Geometry Panel and click on the right-most Upright icon. With 
this tool active, you can click and drag within the image to define what should be 
perfectly vertical and perfectly horizontal. In the video example, we have even-

This is the type of photograph that can be turned into a 
repeating pattern.

In Camera Raw, the “Remove chromatic aberra-
tion” and “Use profile corrections” settings are 
turned on.
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ly-spaced rivets and we dragged lines on the document over the lines of rivets 
that should be perfectly horizontal and perfectly vertical. When the mouse but-
ton is released, the image straightens based on the guides you defined. 

While you’re still in Camera Raw, 
activate the Crop Tool and at-
tempt to crop the image so that 
you’re as close as possible to 
having the kind of repeat that 
you’d like. 

In the video example, we cropped 
the image so that the top and 
bottom edges fell right in the 
gap between rows of rivets and 
the left and right edges were 
centered in the middle of the riv-
ets. Therefore, when the image 
repeats, we won’t end up with 
half of a rivet in the pattern. 

In Camera Raw, the Guided Upright tool (circled) is being used to define horizontal and  
vertical lines. 

The Crop Tool is being used in an attempt to create 
optimal pattern edges.
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Now that the image has been prepped in Camera Raw, it’s time to head to Pho-
toshop. Click on the Open button in the bottom right corner of the Camera Raw 
interface and the image will open in Photoshop. 

Preview Pattern and inspect for issues In Photoshop, turn on Pattern Preview 
(under the View menu) and inspect the initial result. This is where you will find 
any flaws in the pattern. 

In the video example, we can see that the bottom left corner is too bright and 
this makes the pattern look overly obvious. When correcting a problem like this, 
first turn OFF the Pattern Preview so that your adjustments do not wrap around 
to the other side of the repeating image. 

Pattern Preview is turned on in Photoshop. We can see an issue in that the bottom left corner 
of the repeating image is too bright.
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Additionally, it’s a good idea to convert the layer into a smart object because this 
will allow for additional functionality. Click on the Layer menu and choose Smart 
Objects > Convert to Smart Object. 

With a smart object, you can double-click on the layer thumbnail in order to open 
the contents of the smart object in a separate document. This is what you’ll do 
in order to make changes to the image. A benefit to working this way is that you 
can place the smart object document beside the pattern preview document so 
that you can see the pattern update as you make changes to the image. To get 
this view, click on the Window menu and choose Arrange > 2-up Vertical. 

In the video example, we’ll start by darkening the bottom left corner (that is cur-
rently too bright). I like to use Curves for this. We’ll create a Curves Adjustment 
Layer and make sure that the Targeted Adjustment Tool is turned on. It looks like 
a little hand icon on the left side of the Curves Properties Panel. We’ll use this tool 
to click on the part of the image we want to change. In this case, it’s the bottom 
corner that’s too bright. When we click, a point is added to the curve and two 
numbers appear beneath the chart. These Input and Output numbers indicate 
how much light is in the targeted area. 

We’re working on the image document, with the pattern document visible beside it. A Curves 
Adjustment is being used to darken the image. 
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Next, we’ll simply hover the cursor over the part of the image that has the bright-
ness we desire for that bottom corner and we’ll make a note of the numbers that 
appear in the Input/Output fields. We’ll go back to the Curves Properties Panel 
and we’ll enter that number into the Output field. This will reposition the point 
that represents the too-bright area, making the area match the darker area. The 
problem is that the rest of the curve moved as well, creating a steep curve. We’ll 
correct that by dragging the top right curve point down until the curve line be-
comes close to straight. This will make it so the rest of the image does not be-
come overly dark. 

The Curves adjustment is applying to the entire picture and we only need the ad-
justment in the lower left. We’ll use the layer mask to control this. We’ll invert the 
mask so that it’s filled with black (Image > Adjustments > Invert). This hides the 
entire Curves Adjustment Layer. Now, we can selectively add white to the mask in 
the area where the adjustment should be visible. We’ll activate the Brush Tool and 
we’ll use a large, soft-edged brush with the foreground color set to white. We’ll 
also lower the brush opacity so that the effect will be very gradual. We’ll use the 
Brush Tool to gradually paint over the bottom left corner, darkening it to match 
the rest of the image. 

ABOVE: The Curves adjustment was used to darken 
the image as a whole. RIGHT: The right curve point 
is being moved down until the curve line straightens 
out.
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The Pattern Preview document will not automatically update. We’ll need to save 
the smart object document in order for the pattern to update. (File > Save) This 
will allow us to see how the change affected the overall pattern. 

Retouch the seams When creating a pattern from a photograph like this, you’ll 
also need to retouch the edge seams so that they’re not overly obvious. The Heal-
ing Brush will be the most convenient tool for this, but the Healing Brush does not 
like to work along the edges of a document. Because of this, you’ll have to cheat 
by using the Offset filter. The Offest filter will shift the entire image contents in 
one direction, creating a wrapping effect on the other side. This will make it so the 
seam is not positioned on the edge of the document. With the seam in the middle 
of the document, you can easily use the Healing Brush without any problem. 

Note that if you have an adjustment layer, like we do in the video, the filter will 
need to be applied to both the image layer and the adjustment layer. Click on the 
Filter menu and choose Other > Offset. In the Offset dialog, use the sliders to shift 
one of the edges into the middle of the document and then click OK. If you have 
two layers, click on the other layer to make it active. Then click on the Filter menu 

The mask for the 
Curves Adjustment 
Layer was filled with 
black, which hides the 
adjustment entirely. 
Here, we are painting 
on the mask with white 
in order to reveal the 
adjustment and darken 
the bottom left corner. 
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and choose the top-most choice, which should be Offset. This will automatically 
apply the same offset settings you just used to the first layer. Now the image lay-
er and the adjustment layer should match. 

If you still have the side-by-side image view, it might be easier to go back to 
viewing the image full screen. This will just give you more screen real estate for 
the retouch work. You can do this by clicking on the Window menu and choosing 
Arrange > Consolidate All to Tabs. 

Now you can activate the Healing Brush and retouch the seam that is now posi-
tioned in the middle of the document. Apply the retouch work on a new, empty 
layer at the top of the layer stack. Make sure that the Aligned setting is turned on 
and that the Sample menu is set to Current & Below. These settings can be found 
in the Options Bar when the Healing Brush is active. Now you can use the Healing 
Brush to sample from a non-seam area and paint over the area with the seam. 
Every image will be different when it comes to the sample area. In the video ex-
ample, we painted over the line of rivets both above and below the seam before 
painting over the seam itself (in one long stroke). We made sure that the brush 
didn’t partially overlap a rivet, as this would cause the Healing Brush to mess up. 

The Offset Filter is being used to shift the edges of the document so that the seam appears 
in the middle.
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After you’ve removed the seam, save the document and then return to the pat-
tern preview document to see the result. The seam should no longer be visible. 

You’ll need to do the same thing with the vertical seam (if it was the horizontal 
one that you started with). Return to the image document and repeat the offset 
Filter and retouch work for the vertical seam. Remember that the offset will need 
to be changed for all the layers before retouching. You can either apply the offset 
filter to all of the layers (we have three in the video example) OR you can simply 
flatten the image and then apply the filter to the one, single layer. 

Define the pattern After applying the retouching, you can save the document and 
then inspect the pattern preview document. If the seams have been successfully 
removed, you can close the image document. In the pattern document, it’s time 
to actually define the pattern. Click on the Edit menu and choose Define Pattern. 
Give the pattern a name and click Save. Now you can create a new document and 
test the pattern using one of the methods above. 

The Healing Brush is being used to remove the seam. The brush tip and sample area are  
circled. 
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Create an Organic Surface Pattern (40:43)

You can also make a pattern based on a photograph of an organic surface. This 
will be similar to the process described above. Start by opening the image in 
Camera Raw and making sure the Profile Corrections and Chromatic Aberration 
check boxes are turned ON. Then open the image in Photoshop. 

Run the Offset filter and shift either the horizontal or vertical seam. Then use the 
retouching tools to remove the seam. In an organic image, the Spot Healing Brush 
often times does a good job. Repeat the process for the other seam. 

Then, turn on the Pattern Preview and zoom out to inspect the pattern. If any 
additional retouching needs to be done, you can do that in this view as long as 
the retouching occurs within the bounds of the document. Once everything looks 
good, define the pattern using the Edit menu.

The Spot Healing Brush is being used to retouch this organic surface pattern.


