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Challenge Image: Glass Panel 

In this lesson, we’re going to take a look at a chal-
lenge image that was sent in by a Masters Academy 
member. In the process of tackling this image, you 
will learn how to change the background in part of 
the image that is behind a pane of glass. This would 
not be so challenging if the part of the image that 
was behind glass was simple (like a solid color). 
That’s not what we have here, however, so we will 
actually remove the glass and then recreate it from 
scratch. 

Note that I have already prepared the replacement 
background and masked the subject of the photo-
graph. The new background image and the layer 
mask will be included in the downloadable lesson file 
for you to use. 

To make the selection, I clicked on the Select menu 
and chose Select Subject. This created a basic se-
lection around the woman. Then, I used Quick Mask 
Mode to add the foreground and railing to the se-
lection. That selection was then turned into a layer 
mask. I found an appropriate background image to 
use as a replacement, but the trees in the image were 
too sharp. This would make the background look un-
natural, so I used Camera Raw to blur the trees as 
well as introduce some grain. This will make the new 
background appear more realistic. The reason we 
are not covering the above steps in this lesson is that 
it would make the video far too long, and we have 
many other videos that cover masking in detail. This 
lesson will focus on how to reproduce the glass that 
was originally in the image. 

Above, you can see the  
original image (top) as well  
as the result of this lesson.
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Select the Glass (Timestamp 4:25)

It will require multiple layers to create the new glass panes and it will be useful to 
organize these layers into a group, or folder. We’ll create a new group by clicking 
on the little folder icon at the bottom of the Layers Panel. We’ll name the folder 
by double-clicking on the name and then typing in “Glass.” 

If we were to add a layer mask to this group, 
it will limit the areas in which any of the layers 
contained within the group can appear. We want 
the layers to only be visible in the area where 
the current glass is. Before actually adding the 
layer mask, we’ll start by selecting the glass. The 
glass has straight edges, so we’ll use the Polyg-
onal Lasso Tool, which is grouped with the regular Lasso Tool in the Toolbar on 
the left side of the interface. With this tool active, you can click in different parts 
of the image and the tool will create perfectly straight selection lines between the 
points where you click. Click back where you started to close the selection. 

The layer mask and the new 
background image are included 
with the lesson file. The pre-
masked foreground allows us to  
focus this lesson on re-creating 
the glass. 

The Polygonal Lasso Tool is grouped 
with the regular Lasso Tool.
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We’ll use the tool to make a single selection around the glass in the image. In 
order to create the cleanest selection, we’re clicking either outside the frame of 
the image (on the left and right sides) or within an area that’s not glass (like the 
woman’s clothes). This will ensure that all of the glass-defining lines are perfectly 
straight. After we close the selection (by clicking back where we started), the 
“marching ants” selection will appear on the image. We’ll convert this selection 
into a layer mask by clicking on the Layer Mask icon at the bottom of the Layers 
Panel. (Make sure the layer group/folder is active when you do this.)

The Polygonal Lasso Tool is used to  
create a selection around the glass  
panels. That selection was then turned 
into a layer mask, attached to the layer 
group.
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Now, anything that we place inside this group will only be able to show up where 
the mask is white. We’ll drag this layer group below the image layer (but above 
the background layer). 

Tip: As we go through this process, it could be useful to be able to see the entire, 
unmasked image layer now and then. If you ever need to do that, hold down the 
Shift key and click on the mask to temporarily disable it. You’ll see a red X appear 
on the mask thumbnail and the entire image will be revealed. Shift+click again to 
re-enable the mask. 

Create Base for Glass (9:28)

We have defined where the glass should appear and we now need to make it ac-
tually look like glass. In the original image, the background appears slightly dark-
er in the area where it’s behind glass, so the first thing we’re going to do is make it 
so the glass darkens the background. We’ll also shift the color a bit because glass 
usually creates a green or greenish-blue look. 

We’ll make sure that the layer group is active and we’ll create a new Curves Ad-
justment Layer. You can do this by clicking on the Adjustment Layer icon at the 
bottom of the Layers Panel and choosing Curves from the pop-up menu. Because 
the group was active at the time we created the adjustment layer, the new layer 
will appear inside the group. The curve chart will appear in the Curves Properties 
Panel. The gradient beneath the curve will tell us what tones we’re working on in 
the image. We want to adjust the bright areas, so we’ll click and drag down on 
the curve point that appears on the top, right corner of the chart. This will take 
everything that is white and darken it. We’ll drag down until we can see a clearly 
defined area that is darker. 

This made the area darker simply by adding gray. We want to give the glass a 
greenish tint as well, so we’ll use the color curves to do this. The color menu ap-
pears above the curve chart and we can use this to work on the individual red, 
green and blue curves. 
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It might seem natural to choose the green curve, since we want to add a green 
tint to the glass. That, however, is not going to be the ideal choice. When we 
use Curves, we’re working with light. If we were to move any of the curves up, 
we would be adding light to the area, and that’s not what we want. We want to 
darken the area and we can only do that by moving the curves down. So instead 
of moving the green curve up (to add green light), we will move the other two 
curves down. When we remove red and blue light, the green light will be more 
prominent. 

We’ll choose the red curve from the menu and we’ll click and drag downward 
on the right, upper point on the curve. This removes red light from the brightest 
parts of the picture. After dragging it down a bit, we’ll make a note of the number 
that appears in the Output field (below the curve chart). In the video example, 
that number was 231. 

A Curves Adjustment Layer was created inside the glass layer group. The top right curve 
point is being moved down, darkening the brightest areas. 
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We’ll then use the color menu to switch to the blue curve. We’ll click and drag 
down on the upper right point until the Output number matches the one we not-
ed for the red curve (231). 

Note: In order to see the changes, the mask for the image layer must not be de-
activated. The mask needs to be applying to the layer. 

Create Edge Highlights on Glass (13:16)

Next, we’re going to add the highlight that is created by the thickness of the 
glass. We’ll temporarily disable the mask that’s attached to the image layer (by 
Shift+clicking on the mask thumbnail). This will allow us to see the glass in that 
original image so that we know how thick it should be. We’ll use this info to create 
a selection that defines the glass edge so that we can brighten the appropriate 
area. 

The blue and red color curves were adjusted, moving the upper right curve points down. This 
removes blue and red from the brightest areas, making the green more prominent.
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We’ll use Quick Mask Mode to generate the selection. We’ll tap the Q key to enter 
Quick Mask Mode. Because there is not already an active selection, nothing will 
visually happen to the picture. If there had been an active selection, the selected 
areas would look normal and the unselected areas would have a red overlay. We 
can tell that we’re in Quick Mask Mode because the words “Quick Mask” will ap-
pear in the image tab that contains the document name. 

We’ll activate the Brush Tool and make sure that we’re using a relatively hard 
brush (~75% hardness) and that we’re painting with black. We’ll set the brush size 
to about twice as wide as we actually need. We can do this because there is al-
ready a mask that is limiting where the glass appears. If we paint along the edge 
of the glass, that mask will prevent the paint stroke from appearing too wide. In 
order to paint a straight line, we’ll click on the top edge of the glass on the far 
left, we’ll hold down the Shift key and then click on the top right edge of that first 
pane of glass. A straight line will be created between the two points where we 
click. Because we’re in Quick Mask Mode, this will create a red overlay in the area 
where we paint. 

We’ll do the same thing for the bottom highlighted edge of that first pane of 
glass. Then we’ll continue on, isolating the top and bottom highlights in all of the 
glass panes. 

LEFT: We temporarily disabled the layer mask that hides the original image background. This 
allows us to see the original glass. RIGHT: In Quick Mask Mode, we are painting over the top 
edge of the glass that should receive the highlight. 
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In Quick Mask Mode, the red overlay represents the area that WONT be selected. 
The red strokes that we currently have are covering the areas that SHOULD be 
selected, so we need to invert the mask. We can do that by clicking on the Image 
menu and choosing Adjustments > Invert. 

We can now exit Quick Mask Mode by again tapping the Q key. We’ll be left with 
the “marching ants” selection on the image. We no longer need to see the original 
background, so we can re-enable the layer mask attached to that layer. Do this by 
Shift+clicking on the mask thumbnail. 

Now we’re going to create a new adjustment layer. Whenever you create a new 
adjustment layer, it always appears above the layer you’re currently working on, 
so we’ll click on that first Curves adjustment layer to make it active. This way, the 
new one will appear just above it within the layer group that’s creating the glass.  
We’ll create a new Curves Adjustment Layer and the active selection will auto-
matically be applied to the mask. The areas that were selected (the glass high-
lights) will be the white part of the mask, which is the area where the adjustment 
will be visible. 

LEFT: In Quick Mask Mode, the Brush Tool was used isolate the edges of the glass, where the 
highlight will appear. CENTER: The Quick Mask was inverted so that only the glass edges are 
selected. RIGHT: We exited Quick Mask Mode and are left with the marching ants selection.
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The last Curves adjustment was used to darken the glass area. This one will be 
used to do the opposite. We’ll click and drag up on the bottom left curve point. 
This lightens the darkest areas. You can see that the edges of the glass become 
more defined.

In the video example, the edge effect was a little too extreme in the pane of glass 
that is farthest from the camera. To make this look more natural, we used the 
Brush Tool to paint with black, using a very soft-edged brush, over the back glass 
edges. This lessens the effect. 

Add Reflections (20:53)

We’ll once again deactivate the layer mask that’s attached to the original image 
layer. Looking at the original background, the glass has some reflections on it. 
Let’s see how we can add those. 

We isolated the edges of the glass and a Curves adjustment is being made. The bottom left 
curve point is being moved up. This is lightening the darkest areas, and you can see the  
highlights appear on the upper and bottom edges of the glass. 
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We’ll enter Quick Mask Mode and 
make sure that we’re painting with 
black. Black is what creates the red 
overlay in that mode. Now we’re not 
going to use a standard soft or hard-
edged brush to create that reflec-
tion. We’ll instead choose a brush 
that creates a more random edge. If 
you click on the brush tip in the Op-
tions Bar (above the image window), 
the brush menu will appear and you 
will find a search field. If you type in 
“pastel,” one of the search results is 
the “Pastel Medium Tip” brush. That’s 
what we’ll use in the video example. 
It’s not imperative that you use this 
specific brush. Just make sure that 
you choose one with an inconsistent 
edge. 

Note: If you do not see this brush in your menu, it’s because it was included in 
Photoshop’s Legacy Brushes and you may not have your interface set up to in-
clude them. If that’s the case, click on the little gear icon in the top right corner of 
the brush panel and choose “Legacy Brushes” from the pop-up menu.  

Now, while we’re still viewing the original background (and we’re in Quick Mask 
Mode), we’ll try to recreate the shape of the reflection by painting with black. 
Don’t worry about the paint strokes extending beyond the bottom edge of the 
glass. The layer mask that’s attached to the “glass” layer group will limit where 
they show up. 

We’re choosing the Pasted Medium Tip from the 
brush menu in the Options Bar. 
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In Quick Mask Mode, the red overlay represents the part of the image that is NOT 
selected, so we’ll want the opposite of what we have. The reflection area should 
be the only area that IS selected. We’ll invert the mask by clicking on the Image 
menu and choosing Adjustments < Invert. Now the red overlay covers everything 
EXCEPT the reflection area. We can exit Quick Mask Mode by tapping the Q key 
and we’ll end up viewing the selection as marching ants on the image. 

In Quick Mask 
Mode, we’re 
painting over 
the part of the 
glass where 
the reflection 
should appear.

A selection was created, defining where the reflections should appear in the glass. 
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We no longer need to refer to the original image background, so we can re-en-
able the layer mask that’s attached to that layer (Shift+click on the thumbnail). 

We need to create a new adjustment layer inside the layer group we created for 
the glass. We’ll click on the Adjustment Layer icon at the bottom of the Layers 
Panel and choose Curves from the pop-up menu. 

NOTE: If your adjustment layer ends up outside of the layer group, be sure to 
drag it inside the group. 

The selection will automatically be applied to the layer mask that’s attached to 
the adjustment layer, where the selected areas are now the white part of the 
mask. This is the area where the adjustment will be visible. The Curves Properties 
Panel will appear, with the Curves chart inside. We’ll click and drag up on the bot-
tom left point on the curve chart. This lightens the darkest parts of the image, but 
we’re only going to move it up a small amount (so that the effect is really subtle).

A Curves adjustment is being applied and the mask is limiting the effect to the part of the 
glass that should have the reflection. The bottom left curve point is being moved up slightly. 
This is lightening the very darkest areas. 
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We’ll then activate the Targeted Adjustment Tool, which looks like a little hand 
icon on the left side of the Properties Panel. With this tool active, we’ll click on the 
image background, where the reflection should appear, and we’ll drag up. This 
will place a point on the curve (representing the brightness of the area where we 
click) and move that point up, lightening the targeted area.

Whenever you brighten or darken an area, the colors can end up shifting a little. 
If you don’t want that to happen, you can change the blending mode of the layer 
to Luminosity. This mode will allow the layer to affect the brightness of the image, 
but not the color. We changed the blending mode of this Curves adjustment layer 
to Luminosity. (The Blending Mode menu can be found at the top of the Layers 
Panel.) 

The Targeted Adjustment Tool (circled) is being used to click and drag up on the part of the 
glass that should have the reflection.

 
 
 
The blending 
mode of the  
reflection layer is 
set to Luminosity, 
which prevents 
the layer from 
shifting the color.
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Prevent Counter-Acting Brightening/Darkening Effects (27:04)

At this point, things are still not looking completely natural. That’s because we 
have two adjustment layers that are brightening and one that is darkening. We 
need to prevent the brightening layers from being darkened by the darkening lay-
ers. The darkening layer should be the bottom-most of the glass layers. The two 
brightening layers should be above that. 

We want the effects of the brightening layers to prevent the darkening layer from 
showing up. To achieve this, we’re going to use a little-known feature in Photo-
shop. With the first brightening layer active, we’ll click on the FX icon at the bot-
tom of the Layers Panel and choose Blending Options from the pop-up menu. 
The Layer Style dialog will appear, with the Blending Options settings visible. 
Near the middle of this dialog, you will see a Knockout menu. The Knockout set-
ting tells Photoshop that wherever the current layer is visible, the layers beneath 
it should NOT be visible. We have the options of Shallow or Deep. The Shallow 
setting will only knock through things that are in the same layer group. The Deep 
setting will knock through every underlying layer in the Layers Panel. We’ll set the 
menu to Shallow and the glass area will visibly change in appearance. We’ll click 
OK to exit the Layer Style dialog and then we’ll repeat that step with the other 
brightening layer. 

In the Blending Options section of the Layer Style dialog, the Knockout menu is being set to 
Shallow.
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This works because all of the glass layers are contained within a group and the 
darkening layer (the one we want to prevent from showing up in some areas) is 
at the bottom of the group. 

Now that the brightness of the glass has changed a bit, we can fine-tune the ad-
justment layers to make everything look more ideal. Double-click on the adjust-
ment layer thumbnail in order to access the settings. In our example, it will open 
the Properties Panel to reveal the Curves chart. We’ll tweak the curve points to 
fine tune the brightness of all the effects.

Looking at the glass, I think that the reflection layer has too hard of an edge. The 
transition just feels a bit abrupt. We can fix this within the Curves Properties Pan-
el. We’ll click on that reflection layer to make it active and to open the Curves set-
tings for it. There are two icons at the top of the Properties Panel and they let us 
switch between the Curves set-
tings and the Mask settings. We’ll 
click on the second icon to access 
the Mask settings. Here, the Den-
sity slider allows us to soften the 
mask in a non-permanent way. 
We’ll drag this slider to the right 
a bit, just until the edge of the re-
flection becomes a little softer. 

The layer group contains all the adjustment layers used  
to create the glass. It is masked so that the layers only  
appear where the glass should be.

This Curves Adjustment Layer creates the lighter  
reflections in the glass and is set to Knockout Shallow.

This Curves Adjustment Layer creates highlights on the 
top and bottom edges. It’s also set to Knockout Shallow.

This Curves Adjustment Layer is used to darken the glass 
and make it appear more blue/green.

At the top of the Properties Panel, the left icon will 
present the adjustment layer settings (Curves in this 
case). The right icon will present the mask settings.
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Add More Variation in the Blacks (33:17)

We could use some more realism in the effect, 
so we will add more variation in the blacks of the 
glass. Looking at the original image layer, that’s 
what the original background had, and we cur-
rently lack that variation. 

We’ll create a brand new, empty layer at the very 
top of the layer stack, above the original image 
layer. We’re going to run a filter on this layer. 
We need to make sure that our foreground and 
background colors are black and white. Then, 
we’ll click on the Filter menu and choose Render 
> Clouds. The image will be filled with a cloud 
effect. 

We’re adjusting the adjustment layers’ mask settings and the Feather slider being increased 
slightly. This is softening the edge of the layer mask attached to the reflections layer. 

The Render > Clouds filter was 
applied to a layer at the top of the 
layer stack.
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We want to adjust the clouds so that there are some very bright areas and some 
very dark areas, and we can do that with Levels. We’ll click on the Image menu 
and choose Adjustments > Levels. The Levels dialog will appear and we’ll use the 
black and white sliders below the levels chart. We’ll drag the black slider to the 
right, creating more areas of solid black. We’ll drag the white slider to the left until 
we have more areas of solid white. We’ll click OK to exit the Levels dialog. 

The effect should only cover the glass, and 
it would be more ideal if the variation in 
brightness was smaller, so we’ll scale the lay-
er. We’ll click on the Edit menu and choose 
Free Transform. The transform handles will 
appear on the layer and we’ll use them to 
scale the layer down and position it so that 
it covers one of the glass panes. We’ll click 
the Enter/Return key to lock in the transfor-
mation.

 A Levels adjustment is being used to create more areas that are perfectly black and white.

The Free Transform command is being 
used to position the cloud layer on the 
first pane of glass. 
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Next, we’ll duplicate the layer (Command/Ctrl+J) and then position the duplicate 
on the next pane of glass. We don’t want it to be identical to the first, so we’ll 
click on the Edit menu and choose Transform > Flip Vertical. We’ll create anoth-
er duplicate and position it over the third and final pane of glass. This time, we’ll 
change it up by flipping it horizontally. 

We’re going to turn this cloud rendering into a selection, where the white ar-
eas will be selected and the black areas will not be selected. The areas that are 
shades of gray will be partially selected. There is a trick for doing this. We’ll open 
the Channels Panel, which is usually grouped with the Layers Panel. We’ll hold 
down the Command key (Ctrl on Win) and click on the top-most thumbnail (for 
the RGB channel). This will make a selection based on brightness. 

The clouds were positioned over all three glass panes. Here, we are Command+clicking on 
the RGB channel (in the Channels Panel) to create a selection based on brightness. 
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With the selection active, we can now return to the Layers Panel and discard the 
three cloud layers. We only needed them to create this selection. We’ll now use 
this selection to add a little variation in the glass. 

We’ll create a new Curves adjustment layer above the other layers INSIDE the 
layer group. Again, the selection will automatically be applied to the layer mask 
that’s attached to the adjustment layer. The Curve chart will appear and we’ll click 
and drag up (just slightly) on the bottom left curve point. This lightens the dark-
est tones. We want this to be barely perceivable.

The clouds selection was used to isolate varied parts of the glass. A Curves adjustment is 
being made to lighten the selected areas, creating more variation in brightness. 
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Then, we can use the same selection to break up the lighter, reflection area along 
the bottom of the glass. We’ll click on the Select menu and choose Reselect. 
The marching ants selection will appear again. We’ll click on the mask for the re-
flection layer to make it active. We’ll activate the Brush Tool and we’ll paint with 
black, using a large, soft-edged brush, over the glass. The strokes will only be 
applied to the selected area, which is varied, so it creates more variation in the 
glass brightness. 

Tip: If the marching ants are distracting, you can hide them by clicking on the 
View menu and toggling the Extras setting. The selection will still be active. You 
just won’t see those marching ants. 

If you do this all in one paint stroke, then you can adjust the strength of the effect 
by using the Fade command (Edit > Fade). This command takes the very last 
thing you did and allows you to lessen the effect of it. 

Add a little Variation in the Highlights (39:38)

Another thing we could do is add a little more highlights. We can do this by work-
ing on the layer mask attached to the reflection layer. With the clouds selection 
still active, we’ll paint with white (using a low brush opacity) over different parts 
of the glass, just enough to add a little more highlight variation. Remember, if you 
need, you can re-access that last selection by clicking on the Select menu and 
choosing Reselect.  

 


