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Multi-Mask Operations 

In this lesson, we’re going to take a look at how to combine multiple masks. In a 
previous lesson, we focused on how to combine selections. If you have not yet 
watched that lesson, I recommend that you do so before tackling this one. While 
both lessons accomplish the same thing, there are a few differences when you 
are working with masks. Masks are much more versatile than selections and they 
contain much more information, providing you are working in 16-bit mode. A se-
lection will always work in 8-bit mode, regardless of what mode your image is in. 
In 8-bit mode, you will have just over 250 brightness levels to work with. In 16-bit 
mode, you have thousands of brightness levels. Since masks can work in 16-bit 
mode, they too can work with thousands upon thousands of brightness levels. 

Combining Masks/Channels (Timestamp 4:47)

After making a detailed selection 
in Photoshop, you may want to 
save it for later use. Photoshop 
allows you to do that by saving 
the selection as a mask, or chan-
nel. With the selection active, 
you would click on the Select 
menu and choose Save Selec-
tion. When a selection is saved, 
it will appear within the Channels 
Panel. (The Channels Panel is 
generally grouped with the Lay-
ers Panel.) If the Channels Panel 
is not already open in your inter-
face, you can access it by clicking 
on the Window menu and choos-
ing Channels. 

You can save a selection by clicking on the Select 
menu and choosing Save Selection, or you can click on 
the Save Selection icon at the bottom of the Channels 
Panel (circled below.)  
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You can also save a selection by clicking the Save Selection icon at the bottom 
of the Channels Panel. You can click on the selection thumbnail in the Channels 
Panel in order to view the selection as a black and white mask within the main 
image window. 

You can load a saved selection by clicking on the Select menu and choosing Load 
Selection. A dialog box will appear, providing you with a menu that lists all of your 
saved selections/channels. It is essentially showing you the same thing that you 
will see in the Channels Panel. Choose the selection you want to load and then 
click OK. 

In the Load Selection dialog, the Channel menu is being used to determine which selection 
will be loaded. You can see that the list of saved selections is showing you the same thing as 
the list of channels in the Channels Panel.
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You can also combine selections by using the Load Selection dialog. After load-
ing the first selection, go back to the Load Selection dialog (found under the Se-
lect menu) and use the menu to choose the selection you would like to add to the 
currently-active selection. Then, under the “Operation” settings, click on the “Add 
to Selection” option before clicking OK. By choosing this, you will end up with a 
selection that is a combination of the two selections you loaded. You will see that 
there is also an option to subtract from the active selection.

You can also combine selections from right within the Channels Panel. Hold down 
the Command key (Ctrl on Win) and click on the thumbnail for the first channel 
you want to load as a selection. You will see the “marching ants” selection appear 
on the image. Then, hold down Shift+Command (Shift+Ctrl on Win) and click on 
the channel containing the selection you want to ADD. By holding down the Shift 
key, you are telling Photoshop to add to the selection instead of creating a new 
selection. 

You can also remove a saved selection from the active selection. To do this, hold 
down the Option+Command keys (Alt+Ctrl on Win) and click on the channel that 
you’d like to remove from the selection. 

LEFT: In the Load Selection 
dialog, we’re choosing to 
ADD the chosen selection to 
the current selection.  
ABOVE: Hold down 
Shift+Command (Shift+Ctrl 
on Win) and click on a  
channel/mask in order to  
add the contents to the  
current selection.
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The Anti Aliasing Effect (10:06)

You need to be careful when combining selections like this, and it doesn’t matter 
whether you are using normal selections or channels and masks. All selections 
have an edge that is slightly soft. This is due to the fact that there is an Anti-Alias 
setting that is turned on by default. This setting prevents the selection edges from 
being jagged, or unsmooth. This is a good thing, but it can create some issues 
when combining selections. The result can be a small gap in between the two (or 
more) selections that were combined. You would see this best by clicking on the 
channel thumbnail to view the channel/selection in the main image window. The 
selected areas will be white and the deselected areas will be black. If you see any 
hairlines between combined selections, this is due to that anti aliasing setting. 

ABOVE: You can see the hairline seam that can  
occur as a result of combining selections. 

LEFT: When viewing the mask in the main image 
window, you can use the Brush Tool, painting  
with white, to eliminate these seams. 



Multi-Mask Operations © Ben Willmore, All rights reserved 6

You can easily fix this while the selection/channel is being viewed in the image 
window. Use the Brush Tool to paint with white over any back hairline seams that 
appear between selections. 

It would, however, be nice if we could avoid this seam issue in the first place. You 
can prevent this problem by combining masks using a different method than we 
have been using up until now. So far, we have been using selections in order to 
combine masks together. If you keep them as masks, however, you will have more 
options.  

Click on the first channel you’d like to load as a selection. Then click on the Image 
menu and choose Apply Image. A dialog will appear, and it will remember the last 
settings you used. The Apply Image command will copy the information from one 
channel and paste it into another. In this case, it will allow us to take the contents 
of another channel (or saved selection) and apply it to the active channel. 

The Source menu (at the top of the dialog) is where you specify what document 
you want to copy from. The menu will list all open documents that have the same 
dimensions as the active document. In many cases, you’ll be copying from the 
same document that you’re working in.

The Layer menu will allow you to grab content from something that’s attached 
to a layer, so it will list all of the layers in the chosen source document. We are 
working in channels, and not layers, so the Layer menu can stay set to the Merged 
option. 

It’s the Channel menu that you’ll want to pay attention to. This is where you 
choose what channel, or saved selection, to copy from. This is the channel that 
will be combined with the active channel. 

Then, move on to the Blending menu. If this menu is set to the Normal blending 
mode, it will cause it to blatantly copy the chosen channel and paste it into the 
active channel. This would overwrite the contents of the current, active channel. 
That’s not what you want. You want to ADD the contents to the active channel. 
You can achieve this by changing the Blending menu to one of the Lighten options. 
This is the category of modes that begins with the Lighten mode. Switch between 
these blending modes and look at the result in the image window. You’ll want 
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to look for the mode that 
best eliminates the seam 
between selections/chan-
nels.  I find that the Lin-
ear Dodge blending mode 
does a very good job of 
doing this. Once you find 
the blending mode that 
eliminates the seam, click 
OK to exit the Apply Image 
dialog. The channel you 
chose within the Apply Im-
age settings will now be 
added to the channel that 
was already active. 

In both screen shots at left, 
the Apply Image command  
is being used to combine  
selections. In the top screen 
shot, the Blending menu is 
set to Screen and you can 
see that you can still see 
the seam between masks. In 
the bottom screen shot, the 
Blending menu is set to  
Linear Dodge and you can 
see that the seam was  
eliminated.
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Subtract From a Channel (23:02)

Now let’s say you want to subtract the contents of a channel/saved selection from 
the active channel. You could again use the Apply Image command to achieve 
this. Click on the Image menu and choose Apply Image. In the dialog, set the 
Channel menu to the channel that you want to be removed from the active chan-
nel. You want the white parts of the chosen channel to be removed from the ac-
tive channel, but white represents what is selected. Black represents what is not 
selected, so you’ll need to invert the channel so that those white parts become 
black. To do this, turn on the Invert check box within the Apply Image dialog. 

Then, you’ll use the Blending menu to determine how the chosen channel will be 
combined with the channel that’s currently active. In this case, you will need to 
use one of the Darken modes. This is the category of blending modes that begins 
with Darken. In this category, I find that the Linear Burn mode does the best job 
at eliminating unwanted seams. Click OK to exit the Apply Image dialog.   

To subtract a 
channel from the 
active channel, 
we turned on the 
Invert check box 
and are choosing 
the Linear Burn 
blending mode.
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When combining channels, there may be instances where you don’t want to com-
pletely remove something. You may just want to lessen the amount in which it 
is applied. For example, perhaps you have a channel that is designed to isolate 
a building. The building will be the white part of the channel, which is the area 
that is selected. Part of the building is in the sun and part is in the shade. The 
part that’s in the sun will not need as much of an adjustment as the area that’s in 
the shade, so we want to lesson the degree to which it’s being targeted by the 
channel. 

In the example image, we have a channel that isolates the entire building. The col-
umns of the building are in the sun and will therefore need less of an adjustment. 
We want to lesson the degree to which the channel is affecting those columns. 
We can easily accomplish that because there is another, separate channel that 
isolates only the columns. 

We’ll click on the Image menu and once again choose Apply Image. We’ll use the 
Channel menu to choose the channel that isolates the columns. We’ll again make 
sure that the Invert check box is on. This will cause the columns to become black 
instead of white. We’ll set the Blending menu to Linear Burn as well.

In order to lessen the effect, we 
will then use the Opacity setting. 
This will determine how strongly 
the chosen channel will be applied. 
As we change the opacity, we will 
see the area change to shades of 
gray. You can quickly change the 
opacity setting by clicking within 
the text field to make it active and 
then using the up and down ar-
row keys to move the number up 
and down. Hold down the Shift 
key if you’d like to move in larger 
increments. 

We’re lessening the effect of the Apply Image com-
mand by lowering the Opacity setting. You can see 
that the targeted area is becoming gray instead of 
black.
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This technique can also be very useful when working with the masks attached to 
adjustment layers, as it will enable you to determine how strongly the adjustment 
is applied to different areas. 

Use Curves to Adjust a Mask (32:54)

The Curves adjustment can be used to make changes to a mask, and this can be 
especially useful if you have a mask that has different shades of gray, like the one 
created in the lesson video. If an adjustment layer’s mask has shades of gray, it 
means that the adjustment is partially applied in those areas. The Curves adjust-
ment can be used to selectively change different areas of a mask, therefore mak-
ing the adjustment apply differently to various parts of the image. 

The Apply Image command is being applied to a mask that is attached to an adjustment 
layer, but we’re viewing the image instead of the mask. This allows us to see the effect of the 
opacity setting on the actual image. 
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To make an adjustment like this, you can opt to view the mask in the main image 
window if you’d like to see the change applied to the shades of gray. To do this, 
hold down the Option key (Alt on Win) and click on the thumbnail for the mask. 
This will display the black and white mask right within the image window. Then, 
click on the Image menu and choose Adjustments > Curves. The Curves dialog 
will appear. Make sure that the Targeted Adjustment Tool is active. It looks like a 
little hand icon on the left side of the dialog. Use this tool to click and drag on the 
tone that you’d like to change. Dragging up will lighten and dragging down will 
darken. Since you’re working on a mask, dragging up will make the adjustment 
more visible and dragging down will make the adjustment less visible.  

You can also do the same thing while viewing the regular image (instead of the 
mask). Just make sure that the mask is active when you go to make the Curves 
adjustment. By doing this, you can see how the adjustment is affecting the image 

A Curves adjustment is being applied directly to a layer mask. The Targeted Adjustment Tool 
is being used to click and drag down on a tone in the image window. This is darkening the 
targeted tone.
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itself. When adjusting a mask like this, remember that the adjustment is looking 
at the shades of gray within the mask and NOT the colored image. 

Combining Masks Without Apply Image Command (35:50)

If you aren’t comfortable using the Apply Image command, know that there is 
another way of combining masks. If you have one mask (or channel) active and 
you’d like to apply another channel to the active channel, you would first make 
a selection of that second channel. Do this by holding down the Command key 
(Ctrl on Win) and clicking on the thumbnail of the mask you’d like to select. You 
will see the marching ants selection appear. 

ABOVE: While viewing one mask within the image 
window, we Command+clicked on the highlighted 
channel in order to load it as a selection. 

LEFT: Then, we used the Fill Command to fill that 
selection with white.
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Then, you can use the Fill command (Edit > Fill) to fill that selection with white. 
This will be applied to the mask you have active. 

If you’d like that second mask to be applied to a lesser extent, you can use the 
Opacity setting within the Fill dialog. Alternatively, you could use the Fade com-
mand. After filling the selection with white, you would click on the Edit menu and 
choose Fade. This command will lessen the effect of the last step you took in 
Photoshop. Since you just filled with white, it will lessen that fill. You can use the 
Opacity slider to determine how strongly the fill should be applied. This technique 
is nice because it allows you to interactively see the result as you move the slider. 

The Fade Command is being used to reduce the effect of the Fill Command. As we move the 
Opacity slider, we can see the white fill become more gray.



Multi-Mask Operations © Ben Willmore, All rights reserved 14

Painting on Masks with Blending Modes (37:30)

When making complex selections 
that were created with masks, you 
may find that there are some tran-
sition areas that are not to your 
liking. You can use the Brush Tool 
to manually touch up these areas. 
With the Brush Tool active, you 
can hold down the Option key (Alt 
on Win) to temporarily change the 
cursor to the Eyedropper. This al-
lows you to click within the image 
to sample a specific color. This will 
set that color as your foreground 
color. When you release the Option 
key, you’ll go back to the Brush Tool 
and you’ll be painting with the col-
or you sampled. This allows you to 
quickly sample the correct shade 
that you’d need in order to paint 
and refine the mask. 

When you paint, you will need to 
either be extremely precise with 
your brush work, or you could 
use a blending mode trick. Using 
the Brush Tool with the blending 
mode of Normal will work in a very 
straightforward way. If you were 
to change the blending mode of 
the Brush Tool to Lighten, then it 

When the Brush Tool is active, hold down the 
Option key to temporarily access the eyedrop-
per. This allows you to click on a tone and set the 
foreground color, which will be used by the brush 
when you paint.

With the Brush Tool set to the Normal blending 
mode, it’s easy to get overspill when painting on a 
multi-toned mask, as you can see above.
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will only be capable of lightening things. 
If you paint over an area that is already 
lighter than the color you’re painting with, 
nothing will happen. It will only affect ar-
eas that are darker than the color you’re 
painting with. This allows you to be less 
precise with your brush work, while still 
avoiding overspill. 

If you set the brush mode to Darken, 
then it will only be capable of darkening 
an area. This means that you could paint 
over an area that is darker than the fore-
ground color and nothing will happen. 
It will only have an effect on areas that 
are lighter than the color you’re painting 
with. The area you’re working on will de-
termine whether you will want the Dark-
en or Lighten blending mode. If you need 
to avoid getting overspray onto a lighter 
area, you would use the Lighten mode. If 
you need to avoid getting overspray into 
a darker area, you would use the Darken 
mode. 

Painting with History (43:45)

Let’s look at how you can combine more than one mask, while painting in the ef-
fect to control where it happens. Start by viewing a mask or channel in the main 
image window. Then decide which mask or channel that you’d like to selectively 
add to the active mask. Click on the Image menu and choose Apply Image. 

The Brush Tool is painting with the 
color shown at left. Because the 
blending mode is set to Lighten, the 
brush does not affect any tones that 
are lighter than this color. You can 
see, inside the brush tip, that the 
lighter color is not being affected. 
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In the Apply Image dialog, use the Channel menu to choose the mask/channel 
that you want to selectively apply. Set the Blending menu to one of the lightening 
modes (Linear Dodge, for example) and then click OK. 

The second channel will be 
added to the active channel, 
but we’d rather have the ability 
to paint in this result so that we 
can selectively apply that sec-
ond channel. We can achieve 
this by using the History fea-
ture. If the History Panel is not 
already open on your screen, 
you can access it by clicking on 
the Window menu and choos-
ing History. This will show a list 
of things that you’ve done to 
the document. The last step will 
be the Apply Image command. 
If you click on the step direct-
ly above that, it will undo the 
Apply Image command. It’s the 
same thing as using the Undo 
command. The Apply Image 
step will still be visible in the 
Actions Panel and there will be 
a little square to the left of its 
name. Click on this little square and you’ll see a brush icon appear there. This rep-
resents the History Brush. If you were to paint with the History Brush, it will paint 
in a version of what the image looked like at that designated stage, regardless 
of which step is currently active in the History Panel. Activate the History Brush, 
which is found within the Toolbar on the left side of the interface and then start to 
paint on the image. You will see that it is painting in the effect of the Apply Image 
command, even though we undid that step. 

In the History Panel, we clicked on the step BEFORE 
the Apply Image step. We also assigned the History 
Brush icon to the Apply Image step. 

The History Brush is being used to selectively apply 
the result of the Apply Image step. 


