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What Causes Wonky Colors 

In this lesson, I’d like to talk about an issue that I commonly hear about and is re-
lated to color. It happens when you save an image and then open it somewhere 
else, only to find that the colors do not look the way they did when you saved it. 
There is one setting that usually causes this and we’re going to cover where it’s 
found and what you should do in order to fix it. 

Embed Color Profile (Timestamp 2:20)

When you are saving an image using the “Save As” command (found under the 
File menu), there will be a check box at the bottom of the dialog, called “Embed 
Color Profile.” I absolutely always turn this on. If you do not turn this on, there is a 
very good chance that your image is not going to look good elsewhere. 

Color Profiles Every image that you open in Photoshop is made out of red, green 
and blue behind the scenes. (This is true as long as the image is in RGB mode.) The 
words red, green and blue are not enough to describe the actual colors though. 

RGB is known as the document’s color space and there are several versions of 
this color space. The most common color spaces are sRGB, Adobe RGB and Pro-
Photo RGB and they all use different versions of the same colors.

“Embed Color Profile” in Save As dialog When you turn on the “Embed Color 
Profile” check box in the Save As dialog, that color space will be included with 
your file. When another program attempts to display that image, it knows which 
colors of red, green and blue the image is made from and it therefore knows how 
to properly display the image. 

If the “Embed Color Profile” check box is turned off, then you are saving the num-
bers that describe the colors in the image (the RGB numbers) without telling it 
what color of red, green and blue the image is made from. When the image is 
then displayed somewhere else, it’s going to assume that the image is made out 
of sRGB colors. The “s” in sRBG stands for standard. 
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LEFT: Here is a colorful image using the ProPhoto RGB color space in Photoshop. RIGHT: The 
image was saved, without embedding the profile, and then opened in a different program. 
You can see that the colors are much more dull.

The Embed Color 
Profile check box 
can be found at the 
bottom of the Save 
As dialog.
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If an image does not contain a profile, it will always be assumed to be sRGB. 

If you ALWAYS use the sRGB color space, then you won’t really need to worry 
about this setting. If you ever use other color spaces, this “Embed Color Profile” 
setting becomes much more critical. 

“Embed Color Profile” in other dialogs The “Embed Color Profile” check box will 
also be available within the settings for some of the other save/export methods. 
If you use the Export As setting (found by clicking on the File menu and choos-
ing Export), the “Embed Color Profile” check box will appear in the bottom right 
corner of the dialog.  If you choose the Save For Web option (File > Export), the 
“Embed Color Profile” setting will appear near the top right corner of the Save 
window. 

FAR LEFT: The 
Embed Color  
Profile check box 
is located in the 
bottom right  
corner of the  
Export As dialog. 

DIRECTLY LEFT: In 
the Save for Web 
dialog, it’s located 
in the upper right.
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Sticky setting The “Embed Color Profile” setting is what’s known as being “sticky.” 
This means that Photoshop will remember if the setting was turned on or off the 
next time you save your image. If you had the setting on the last time you saved 
an image, then the check box will automatically be turned on the next time you 
save an image. I have found that the checkbox can sometimes get turned off 
when Photoshop is updated. That’s just something to be aware of when upgrad-
ing to a new version of Photoshop.   

How to Tell if There is an Embedded Color Profile in Bridge (6:59)

After you’ve saved an image, there are a couple of ways to tell whether or not 
that “Embed Color Profile” check box was turned on. You can view the image 
in Bridge and open the Metadata Panel on the right side of the interface. In the 
Metadata Panel, expand the settings for File Properties. This will display a list of 
information about the file and, at the bottom of the list, is an item called Color 
Profile. If the color profile was embedded, it will be listed here. 

In Bridge, you can tell 
if the active image has 
an embedded color 
profile by looking in 
the Metadata Panel. 
If there is a profile, it 
will be listed in the File 
Properties category.
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In the lesson video, I show three tulip pictures being viewed in Bridge. These three 
images looked identical when I had them open in Photoshop. Here, in Bridge, they 
all look different and that’s because their color profile is untagged. You can see 
that in the Metadata Panel. The one that looks the dullest was using the ProPhoto 
RGB mode. This mode uses the most vivid colors of red, green and blue, so when 
displayed as sRBG (which is what happens when an image is untagged), there is 
the biggest deviation in appearance. 

How to Tell if There’s an Embedded Profile in Photoshop (11:32)

There are two areas within Photoshop that you can look at to determine whether 
an image has a color profile embedded. The first is in the bottom left corner of 
the interface, where there is a small line of text. This text will display the docu-
ment profile by default. If that was ever changed, however, you can click on the 
little arrow to the right of the text and a pop-up menu will appear. Choose the 
Document Profile option. If the document does not have an embedded profile, 
the text will read “Untagged RGB.” 

These are three different versions of the exact same image, being shown in Bridge. The only 
difference is that they used three different color spaces. They look different because the 
“Embed Color Profile” check box was turned off upon saving. 
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The other area you can look at to 
determine whether an image has an 
embedded profile is the Info Panel. If 
this panel is not already open on your 
screen, you can open it by clicking on 
the Window menu and choosing Info. 
The Info Panel will show the red, green 
and blue values for a particular area, 
and it can also display a wide variety 
of other information. Click on the lit-
tle menu in the top right corner of the 
panel and choose Panel Options. 

A dialog will appear, containing a se-
ries of check boxes. These determine 
what info is displayed in the panel. 

If the document profile is not listed in the lower left corner of the  
interface, you can use this menu to select what info should appear there. 

You can specify what information should  
appear within the Info Panel Options.
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I, personally, like my panel 
to be clean, so I keep all of 
these check boxes turned 
off EXCEPT for the “Doc-
ument Profile” check box. 
Make sure this is turned on 
and then click OK. Now, the 
Info Panel will display the 
color space for the active 
document. 

Assign Profile & Convert to Profile (12:24)

If you open an image that has no embedded profile and you feel that the image 
looks rather dull, that’s probably because the image was originally set to a color 
mode other than sRGB. If this is the case, there are a couple of things you can do 
to correct it. 

Assign Profile There are two useful settings within the Edit menu at the top of the 
screen: Assign Profile and Convert to Profile. We would use the “Assign” option 
in two instances: 

• If the profile for the image is missing

• If the profile for the image is wrong

If the profile field reads “Untagged RGB,” it means the profile is missing. Click on 
the Edit menu and choose Assign Profile. The dialog that appears will contain a 
Profile setting. Make sure this Profile setting is active (there should be a little tic 
mark in the circle to the left of its name) and then use the menu to switch be-
tween sRGB, Adobe RGB and ProPhoto RGB. The image will look different for 
each of these three settings. Choose which of the profiles you think looks most 
appropriate and then click the OK button to exit the dialog. 

You can 
choose to 
have the 
document 
profile show 
up in the Info 
Panel.
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Convert to Profile You would use this setting (under the Edit menu) if you have 
an image that is using one profile but you want it to be using another profile. 
Using this setting can be compared to converting between different systems of 
measurement, from feet to meters, for instance. You have an item that doesn’t 
change size, but you’re describing it in meters instead of feet. When it comes to 
Photoshop, we will be attempting to describe the same color using different ver-
sions of red, green and blue. 

In the Assign 
Profile dialog, 
the Profile menu 
is being used to 
switch between 
Adobe RGB, 
sRGB and  
ProPhoto RGB  
in order to  
determine which 
looks best on this 
particular image. 
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In the Convert to Profile dialog, there is an area called Destination Space. This is 
where you choose which color space you want the image to use. When choosing, 
keep the following in mind. Since ProPhoto RGB has the most vivid versions of 
red, green and blue, there will be colors that can be created in ProPhoto RGB that 
can not be created in sRGB, which has a much more limited color range. 

Within the Conversion 
Options area, there are 
settings where you tell 
Photoshop how it should 
make the conversion. 
Use the Intent menu to 
cycle between the dif-
ferent options. You don’t 
need to know what the 
words mean. Just look 
to see how each option 
affects the picture and 
decide on the one that 
looks the best. This set-
ting could have a very 
large or very small effect. 
It just depends on the im-
age. Click OK to exit the 
Convert to Profile dialog.  

LAB Values for Accurate Color Descriptions (20:55)

There is a way of accurately describing a color without providing the color space 
and that is by using the LAB values. You can find these within the Color Picker. 
The Color Picker can be accessed from many of Photoshop’s features, but the 
easiest way is by clicking on the foreground color swatch at the bottom of the 
Toolbar. 

In the Convert to Profile dialog, set the profile using the  
Profile menu and then cycle between the Intent menu  
options to find which looks best on the image. 
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In the Color Picker, it shows different sets of values for the chosen color. The LAB 
values are shown on the right side of the dialog. If you would like to reproduce 
this exact color somewhere else or if you would like to describe the color so 
someone else can create it (without providing the color space), use these values. 
These numbers are color space-independent. That means the LAB numbers will 
always produce the same color, regardless of what color space you’re using. 

RGB Color Setting (25:04) 

If an image is untagged (containing no embedded color profile), it may not be 
displayed correctly on your screen. That can be due to a particular setting. 

Click on the Edit menu and choose Color Settings. This dialog will show you all 
sorts of settings, but we’re only going to focus on the RGB menu near the upper 
left corner. If an image does not have a profile assigned to it, it’s going to use 
whatever this menu is set to. It’s set to sRGB by default, which is why untagged 
images will be displayed like sRGB. 

You can find the 
LAB values on 
the right side of 
the color picker. 
These values will 
create the same 
results,  
regardless of 
which color 
space is being 
used.



What Causes Wonky Colors © Ben Willmore, All rights reserved 12

If, however, this menu got changed, it could cause colors to look odd on screen. 
This could even cause your screen shots to look wrong. On-screen applications 
like the sRGB color space. If you took a screen shot and then opened it in Photo-
shop, it would display the image in whatever other color space was chosen within 
the Color Settings. If that color space happened to be ProPhoto RGB, the colors 
in the image will look very wrong. 

Dull Colors in Save for Web (31:50)

If you commonly use the Save for Web command (File > Export > Save for Web), 
you may find that the colors can look a little wonky, or dull. That’s because the 
Save for Web command is doing something that other programs won’t do and 
therefore, it’s not always showing you an accurate preview of what the image is 
going to look like in another program. This is tied to the “Convert to RGB” check 
box, which can be found within the settings on the right side of the dialog. Let’s 
talk about what this setting does.

If the RGB menu, within the Color Settings dialog, got changed to something OTHER than 
sRGB, it could cause the colors in your untagged images to look wrong.
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If you’re not printing your image in a high quality fashion, it is common to convert 
the image to sRGB. This is because some programs do not support color man-
agement, which means that they don’t read the color profile that is assigned to 
an image. These programs are going to assume that every single image is in sRGB 
mode. Most consumers use that setting and most devices default to that setting 
as well. 

It’s only graphic designers and photographers that really deviate from that sRGB 
setting. They deviate because the range of colors that you can make in sRGB 
is not as wide of a range as what most desktop printers are capable of making. 
Therefore, by using sRGB, they’d be limiting the range of colors in the image and 
not taking full advantage of the printer’s capabilities.  

When you use Photoshop’s Save for Web command, it’s acting like a dumb pro-
gram, or a program that would ignore the color profile. Therefore, the image will 
end up looking as if it were in sRGB mode. If the image was NOT originally in 
sRGB mode, then it will likely look dull. 

This is where the “Convert to sRGB” check box comes in. If the image you’re sav-
ing is not in sRGB, you can turn this check box on in order to convert the image 
and make it look normal again. 

Note that this Save for Web view is a little outdated because most modern pro-
grams do support color profiles and you would not need to convert the image to 
sRGB in order for them to be displayed correctly. 

The Convert to 
RGB check box 
is located on 
the right side 
of the Save for 
Web dialog.


