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Matching Perspective 

There might be instances where you need to take an object in a photograph and move it 

to a different location. For example, perhaps one window is broken or has unwanted sig-

nage on it. In that case, you could copy a similar [untainted] window and use that copy to 

cover up the problem window. In doing this, you will likely need to match the perspective 

of the copied content so that it looks natural in its new location. That perspective match-

ing is what we’re going to focus on in this lesson. 

To accomplish this technique, we’re going to learn about the Distort command, the Per-

spective Crop Tool and how to incorporate smart objects while using these features. In the 

lesson video, I start off by showing how many people might approach this task by using 

the Distort command only. This is just to demonstrate its limitations. At about 14 minutes 

into the video, we start the process from scratch and I demonstrate the ideal method of 

copying content and matching perspectives. 

LEFT: I wanted to fix the crackled window on this gasoline pump. CENTER: I found another 
image that contained a pump with the same type of window. I copied this area so that I could 
use it to hide the crackled one. RIGHT: I copied the clean window into the other document 
and adjusted the perspective so that it looks appropriate in its new location.
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Why we don’t use the Distort command by itself The Distort command will place little 

handles around the selected item. You can click and drag on these handles to move the 

corners independently of one another. The problem is that the handles appear on the 

rectangular bounding box of the selected area. In other words, it takes the area and places 

it inside the smallest rectangle that will fit the content. The handles appear on the corners 

of this rectangle. (See screen shot for a better visual explanation.) In order to better use 

this perspective technique, it will be better to get the little handles to appear on the cor-

ners of the actual item. 

In the video example, we have a service station that has similar signs running around the 

top of the structure. We’re going to copy the center sign and use it to cover up the sign 

on the left side of the structure. 

The Distort com-
mand is being used 
on this sign, which 
was isolated in the 
image. You can see 
that the position-
ing handles appear 
around the bound-
ing box instead of 
on the corners of 
the sign itself.  

To demonstrate  
perspective matching,  
we’re going to take the  
rectangular sign from the 
middle of the roof structure 
and use it to replace the  
sign on the left side of the 
roof structure. 
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Copy image layer to a new document The first thing we’re going to do is take the Back-

ground image layer and copy it into a new document. We can do that by holding down 

the Option key (Alt on Win) and dragging the layer to the New Layer icon at the bottom of 

the Layers Panel. The Duplicate Layer dialog will appear and we’ll use the Document menu 

to choose “New.” This will copy the image layer to a layer in a new document. When we 

click OK to exit the Duplicate Layer dialog, that new document will appear on the screen. 

Isolate sign using the Perspective Crop Tool Now we’re going to isolate the sign that 

we want to copy. This is the center sign that will be used to cover up the sign on the left. 

We’ll use the Perspective Crop Tool to do this. The Perspective Crop Tool is grouped with 

the regular Crop Tool in the Toolbar on the left 

side of the interface. With this tool active, you 

can click on the four corners of a rectangular 

object to define its shape and then hit the Re-

turn/Enter key. When you hit Return, it’s going 

to straighten the rectangle and discard every-

thing that was outside of the rectangle. 

We are copying the 
background, image 
layer to a new  
document. We held 
down the Option key 
(Alt on Win) while 
dragging the layer to 
the New Layer icon. 
That caused this  
dialog to appear.  

The Perspective Crop Tool is grouped 
with the regular Crop Tool in the Toolbar.
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We’ll use the tool to click on the four corners of the sign. After hitting Return, the sign will 

straighten and the rest of the image will disappear. This straightened result is what we’re 

going to use in the original image. 

Copy sign to original image document  We now need to copy this isolated sign so that 

we can paste it into our original image document. We’ll click on the Select menu and 

choose All. Then, we’ll click on the Edit menu and choose Copy. Now that it’s been copied, 

we can close this file. We’ll return to the original image document, click on the Edit menu 

and choose Paste. The copied sign will be pasted as a new layer into this original image 

document. 

LEFT: The Perspective Crop Tool 
was used to click on the four 
corners of the sign. BELOW: We 
hit the Return/Enter key and the  
sign became straightened. The 
rest of the image was discarded. 

The straightened sign has 
been pasted as a new layer 
in the original image  
document.
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Convert new layer into a smart object Before distorting this new layer to match the sign 

we want to cover up, it’s important that we convert this layer into a smart object. This will 

allow us to go back and easily adjust the sign later. If we applied the distort command to a 

layer that was NOT a smart object, then it would not remember where the corners of the 

object are. It would instead create a new bounding box around the layer, making it harder 

for us to accurately distort the layer. 

With this new layer active, we’ll click on the Layer 

menu and choose Smart Objects > Convert to Smart 

Object. You can tell that a layer has been converted 

into a smart object because a little icon will appear in 

the bottom right corner of its image thumbnail in the 

Layers Panel. 

Distort sign to match perspective Now we can use the Distort command on the sign lay-

er. We’ll click on the Edit menu and choose Transform > Distort. Four handles will appear 

around the corners of the sign. We can click and drag on the four corners individually to 

position the sign in the correct position, with the correct perspective. We’ll drag the han-

dles to match the four corners of the sign on the front of the building. This is the sign that 

we want to cover up. 

When we’re done positioning the layer, we’ll tap the Return/Enter key to lock in the trans-

formation and remove the transform handles. 

This icon indicates that a layer has 
been converted into a smart object. 

In the screen shots above, the Distort command (Edit > Transform > Distort) is being used to 
position the four corners of the sign to create the correct perspective. 



Matching Perspective © Ben Willmore, All rights reserved 7

NOTE: When positioning the transform handles, you may notice that the handles are try-

ing to snap to different areas within the image. This is a feature that is designed to assist 

you in lining up layers and objects, but it’s not always what you’ll want. If you don’t want 

this snapping to occur, hold down the Control key as you are dragging the handles to 

temporarily turn off the snapping feature.

Extra Tips Sometimes, there will not be clear cut lines to match up when you are using the 

Distort command to match the perspective of an object. If this is the case, you can click 

within the object (while the Distort handles are active) and drag to reposition the object 

to an area that will make it easier to see the correct perspective. I like to find a surface line 

in the underlying image layer. I’ll move the layer I’m distorting to that line so that I can get 

a better idea of the correct perspective. After positioning the distort handles to match the 

perspective of the surface, you can then reposition the object back to the area where it’s 

supposed to go. 

After the perspective has been set using the Distort command, we can additionally scale 

the object so that it is the correct size. We can do this by clicking on the Edit menu and 

choosing Transform > Scale. Now the transform handles can be used to scale the object 

up or down (instead of distort it). 

FAR LEFT: The  
Distort command is 
being used to place 
the sign on a gas 
pump. In this area, 
it’s hard to tell if the 
perspective is  
correct.  
DIRECTLY LEFT: 
We positioned the 
sign near an object 
whose bottom edge 
shows the correct 
perspective. This 
edge is serving as 
our guide as we set 
the perspective of 
the sign.



Matching Perspective © Ben Willmore, All rights reserved 8

Distort an object to create a more radical transformation Now we’re going to take that 

same rectangular sign that we isolated and we’re going to place it in a different image to 

create a more radical transformation. In this example, we’re going to wrap the sign around 

the top of a circular building.

We’ll start off using the same method. We’ll isolate the rectangular sign by using the Per-

spective Crop Tool to click on the four corners. When we hit the Enter key, the sign will 

straighten and the rest of the image will be discarded. 

With the sign isolated and straightened, we’ll click on the Select menu and choose All. 

Then, we’ll click on the Edit menu and choose Copy. Now that it’s been copied, we can 

close this file. We’ll open the other image document (the one in which we want to place 

the sign). We’ll click on the Edit menu and choose Paste. The copied sign will be pasted 

as a new layer into this original image document. 

Before making any changes to the sign layer, we will convert the layer into a smart object. 

We’ll click on the Layer menu and choose Smart Objects > Convert to Smart Object. 

Now we can start to work on the sign. The first thing we need to do is scale the sign. We 

want the height of the sign to match the height of the rim that runs around the top of the 

circular building. We’ll click on the Edit menu and choose Transform > Scale. The trans-

form handles will appear around the layer and we can click and drag on them to scale the 

sign to the appropriate height. 

LEFT: The sign was isolated using the Perspective Crop Tool. RIGHT: The sign was then copied 
and pasted into a different image. 
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Now that the sign has been scaled, we need to bend it so that it looks as if it’s wrapping 

around the building. We can do this by using the Warp command. We’ll click on the Edit 

menu and choose Transform > Warp. Warp handles will appear around the object (in this 

case, the sign). 

Before moving the warp handles, make sure that the Grid setting in the Options Bar is set 

to Default and that the Warp menu is set to Custom.  

The sign layer is  
being scaled so 
that it matches the 
height of the rim 
that runs around the 
top of the building.

The Warp command is active and the warp handles appear around the layer. The Grid menu is 
set to Default and the Warp menu is set to Custom.
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Now we’re going to click and drag on the warp handles to position the four corners of the 

sign. We’re just going to estimate to determine where these corners should appear on the 

rim of the building. This warp effect will look really strange at first. 

After moving the corners, you’ll notice that handles appear to come off of each corner. We 

need to use these handles to determine which direction the edges of the sign should go.  

The left and right edges of the sign should be vertical, so we’ll use the handles to point 

straight up and down. Now things should start to look a little more normal. 

Using the warp command, the four corners of the layer are being positioned on the rim of the 
building.

We are using the handles that extend from the corners to determine which direction the layer 
should be stretched when it leaves the corner.
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We need to use the other handles to define the arc of the sign so that it matches the roof 

of the building. We’ll move these handles to determine which direction Photoshop should 

stretch the picture when it leaves the handles. You can also click and drag on the edge of 

the layer itself, but know that you have to be extremely precise in order for Photoshop to 

allow you to do this. 

You can click within the middle of the layer and drag up and down to warp different areas 

within the layer. We’ll click in the middle of the sign and drag up and down to position the 

center so that the words do not look distorted. We’ll press the Return/Enter key to lock in 

the transformation and remove the handles surrounding the layer. 

The handles that extend from the corners are being positioned in order to define the arc of 
the sign. We want the sign to match the curve of the roof.

With the Warp command active, we’re clicking and dragging within the middle of the layer to 
warp the sign into place, so that it looks natural and not distorted. 
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Use blending options to adjust sign Now that the sign is warped around the building, I’d 

like to make it so that only the black text is visible. I’d like the background of the sign to 

go away. We can achieve this with by using the layer blending options. 

With the sign layer active, we’ll click the FX icon at the bottom of the Layers Panel and 

choose “Blending Options” from the pop-up menu. The Layer Styles dialog will appear 

and the blending sliders will appear near the bottom. These sliders will hide parts of the 

active layer. If we take the “This Layer” slider and move the white handle to the left, it will 

start to hide the brightest areas of the active layer. If we were to move the black slider 

handle to the right, it would start to hide the darkest areas. 

We’ll move the white slider to the left until the background on the text disappears. Then, 

we can create a soft transition by splitting the slider head in half. We’ll do this by holding 

down the Option key (Alt on Win) and dragging one half of the slider. We’ll separate the 

two slider halves just enough that it creates a soft transition so that the text doesn’t look 

jagged. We’ll click OK to close the Layer Style dialog. 

ABOVE: The blending sliders are being used 
to remove the background on the sign. The 
white slider is being moved to the left until 
only the text is visible. LEFT: The slider 
head is being split in half. This creates a 
smoother transition so that the text does 
not appear to have jagged edges. 
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Now the sign has been successfully moved to a different building in a new image. Because 

the layer is a smart object, we can easily go back and make changes if necessary. To do 

that, we would click on the Edit menu and choose Transform > Warp. The tool will remem-

ber where the warp handles were previously positioned and we can continue to tweak the 

sign. 


