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Making Glass Transparent 

In this lesson, we’re going to work on a challenge image that was submitted by 
a Masters Academy member. In the process, we’re going to learn how to make 
glass transparent in Photoshop. The image features a glass vase full of flowers set 
against a gray background. We’re going to extract the vase and flowers, removing 
the background so that the subject can be placed onto a different background. The 
trick is going to be making the glass actually transparent so that the new back-
ground shows up when looking through the vase. 

To begin, make sure that both images (the flowers and the new background) are 
open in Photoshop. It will be useful to view both of these documents side-by-
side so click on the Window menu at the top of the screen and choose Arrange > 
Two-up Vertical. Now you will be able to see both images. Move the flowers image 
into the document containing the new background by clicking on the image and 
dragging it into the document window for that new background. Note that holding 
down the Shift key before releasing the mouse button will ensure that the image 
you are moving will be perfectly centered in the new document. 

The flowers and vase are going to be placed onto a new background, shown in the document 
at left. Both documents are visible at the same time because we chose the Two-Up Vertical 
arrangement.
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Isolate the Flowers and Stems (1:52)

Make sure that the document containing both images is active. You will see both 
of the images appear as layers in the Layers Panel. The first step will be to isolate 
any areas that you can not see through to the background. To do this, you’ll need 
to get the flowers and the flower stems onto their own layer. The first step will be 
to create a selection of the flowers and stems. There are many different ways of 
creating selections, but we’ll use the Color Range command here. This will allow 
you to create a selection of the simple gray background and then you can invert 
that selection to isolate the flowers. 

Click on the Select menu and choose Color Range. 
The Color Range dialog will appear. Click on the 
Select menu at the top of the dialog and choose 
“Midtones.” This will cause the “Range” sliders to 
appear, which allows you to choose the brightness 
range that you want to be selected. The white slider 
handle will determine the brightest tone that will 
be selected and the black slider will determine the 
darkest tone that can be selected. In this image, you 
can start by dragging the white slider all the way 
to the right. This will allow it to select everything 
up to pure white. Then, use the black slider to limit 
how much of the dark portion of the image that can 
be selected. The preview window within the Color 
Range dialog will show you what areas are being 
selected. The white parts of the preview represent 
areas that are selected. The black areas represent 
areas that are not selected. Drag the black slider 
just high enough so that the subjects (the flowers) 
turn black but the background does not. Click OK to 
exit the Color Range dialog. 

In the Select Color Range dialog, 
the Select menu is being set to 
Midtones. 
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Note: In the Color Range dialog, you will also find the Fuzziness slider and we have 
used this slider in previous lessons. Know that this setting will not do much when 
the Select menu is set to Midtones and you are working with the Range sliders. 
That’s why we ignored it in this example. 

The “marching ants” selection will be-
come active in the image window. You 
can preview this selection in a more use-
ful way by entering Quick Mask Mode. 
You can enter Quick Mask Mode by tap-
ping the Q key. In this mode, everything 
that is selected will look normal and 
everything that is NOT selected will be 
covered in a red overlay. This will reveal 
any problems with the selection. In the 
video example, you can see that there 
are patches within the flowers that are 
not covered with red. We’re just trying 
to isolate the background here, so those 
patches SHOULD be covered in red so 
that they won’t be selected. 

In the Color Range 
dialog, the Range 
sliders are being 
used to limit the 
tonal range that is 
being selected. Only 
the bright tones are 
being targeted.

After making a selection using the Color 
Range command, the “marching ants”  
selection can be seen on the image at left.  
To better preview the selection, we entered 
Quick Mask Mode (right). 
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In Quick Mask Mode, you can add to or remove from the selection by using the 
Brush Tool. Painting with black will subtract from the selection (therefore adding 
the red overlay) and painting with white will add to the selection. In the video ex-
ample, we used the Brush Tool to paint (with a soft brush) with black over those 
patches in the flowers that should not be selected. 

There are a few instances where it will be 
more useful to have the Quick Mask ap-
pear as a different color. In this example, 
there is some red in the flowers so that 
can make it hard to see the Quick Mask 
in some areas. If you want to change the 
color of the Quick Mask, double-click on 
the Quick Mask icon in the Toolbar. It is 
directly beneath the foreground/back-
ground swatches at the bottom of the 
bar. This will call up a the Quick Mask Op-
tions dialog, which contains a setting for 
changing the color of the mask.

In the video example, we changed the 
mask to a vibrant green because that col-
or contrasts with the rest of the image, 
therefore allowing us to better see the 
entire mask. Then, we refined the mask 
by painting with black in the areas of the 
subject that had openings in the mask. 

In the area where the stems and vase are, 
the stems should have the green overlay 
(indicating they’re not selected) and the 
transparent glass should have no overlay. 
Use the Brush Tool to paint with white 
over areas where the transparent glass 

Click on the Quick Mask Mode icon (circled) 
to call up the Quick Mask Options. Here, you 
can change the color of the mask.

In Quick Mask Mode, we’re painting with 
black over parts of the flowers that should 
be selected, therefore adding the colored 
overlay.
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has the overlay. This will remove the overlay and ensure that the glass is selected. 
Paint with black over areas where the stems still need the overlay. Note that you 
can quickly swap the foreground and background colors by tapping the X key. 
(Think eXchange) This will allow you to quickly switch from painting with black to 
white (and back again). 

Use the reference photo in the other Photoshop document to better determine 
what areas will allow you to see through to the background. This is why the two 
documents are tiled vertically in the interface. 

In Quick Mask Mode, we’re painting with white over the parts of the vase that should be 
transparent. This is removing the overlay, therefore ensuring that the areas are not selected. 
The document on the right is being used as a reference, to better see where the openings in 
the stems are.
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If you’d like to check your work, you can do so by viewing the mask directly in the 
image window. Open the Channels Panel (It’s usually grouped with the Layers Pan-
el) and you will see the active Quick Mask at the bottom of the channel list. You 
can turn off the visibility of all the other channels by clicking the eyeball icon to the 
left of the RGB channel. This will leave only the Quick Mask channel visible, show-
ing you a black and white view of the channel in the main image window. Again, 
you can use the Brush Tool to paint with black and white to refine the mask while 
working in this channel. 

When you’re done, turn on the visibility of the other channels by again clicking on 
the eyeball icon next to the RGB channel. Then, you can return to viewing the Lay-
ers Panel. Tap the Q key to exit Quick Mask Mode and the selection will go back to 
looking like marching ants. 

The mask is being viewed as a channel and we’re painting directly in the channel to refine 
the mask.
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We selected the background because it was a simple gray, but we REALLY want 
the opposite selected: the flowers and stems. You can get the opposite of a selec-
tion by clicking on the Select menu and choosing Inverse. Now, the flowers and 
stems are selected and the background is NOT selected. 

Refine the Mask Edges with Select & Mask (12:31)

At this point, you could use a layer mask to hide the background, but there will 
likely be some problems with the edge of the mask/selection. You can preview 
what those issues might look like by using the Select & Mask feature. Click on the 
Select menu and choose Select & Mask. The Select & Mask window will take over 
the screen and the settings panel will appear on the side. 

At the top of the settings panel is the View menu. This will determine how the se-
lection will be previewed. In the lesson video, this menu is set to “On Layers,” which 
means that the selected content is being shown on top of the underlying layer. 
This underlying layer is the new background that we’re using to replace the gray 
background. 

After zooming in on the flowers, it’s very obvious that there are problems with the 
edge of the selection. There’s a bit of a gray halo around the edge of the flowers 
and this is a remnant of the original background. 

The Select & Mask interface is 
shown at left. When we zoom 
in (above), you can see the gray 
halo remnant from the original 
background.
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The Radius Slider The Select & Mask feature allows you to give Photoshop control 
over that edge so that it can decide what should be kept and what should be dis-
carded. You can control this with the Radius slider. As you move the Radius slider 
higher and higher, you are giving Photoshop control over a larger and larger area. 
If the Radius is set to two pixels, Photoshop will have control of a two-pixel radius 
around the edge of the selection. Zoom in on the image so that you can easily see 
the selection edge and then slowly move the slider up, pixel by pixel. You’ll want 
to find the lowest possible setting that still eliminates the halo around the edge of 
the subject. In the video example, we set the Radius slider to a setting of 3 pixels. 

Decontaminate Colors If the Radius slider does not completely fix the edge of the 
selection, there is another setting that could help. The “Decontaminate Colors” 
check box is located under the Output Settings category in the Select & Mask win-
dow and it can often help when the issue is due to color. When you turn on the “De-
contaminate Colors” check box, it will look at the zone in which you’ve given Pho-
toshop control over the selection and it will attempt to eliminate any colored halo 
that is residual from the original image. It works by looking at the color that is just 
inside that edge area and it pushes that color out into the edges of the selection.   

The Decontaminate Colors check box can be found  
under the Output Settings. At right, you can see the 
edge improvement after the check box was turned on.



Making Glass Transparent © Ben Willmore, All rights reserved 10

The Refine Edge Brush Tool There is another tool within Select & Mask that you 
can use to correct the selection edges in specific areas. It’s called the Refine Edge 
Brush Tool and it allows you to manually paint on the image to give Photoshop 
control over an area. It’s the second tool down in the Toolbar on the left side of the 
interface. With the Refine Edge Brush Tool active, you can paint over the edges 
where you can still see residue from the original background. The size of the brush 
can be changed by using the brush menu at the top of the interface or by using the 
left or right bracket keys ( [ ] ) on your keyboard. 

If it’s hard to accurately see the selection edges, you can use the View menu to 
change the appearance of the preview. There are many different options here. You 
can view the selection as a red overlay, like you’d see in Quick Mask Mode. You can 
view the subject against a black background or a white background, or a transpar-
ent background. In the video example, we set the View menu to “On Black,” which 
shows the selection against a black background. This allowed us to better see bits 
of leftover background in between the flowers. We used the Refine Edge Brush to 
paint in those areas (using a very small brush). 

The View menu is set to 
“On Black” and you can 
see that this shows the 
selection against a black 
background. In this view, 
we will use the Refine 
Edge Brush (circled) to 
manually paint over ar-
eas where the edges still 
have problems.
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You can still see part of the transparent vase that overlaps the stems and that’s ok. 
That’s going to be dealt with using a separate technique.

After you’re satisfied with the selection, there is one setting you’ll need to pay at-
tention to before exiting the Select & Mask window. Any time you have the Decon-
taminate Colors setting turned on, make sure that the “Output To” menu  is set to 
“New Layer with Layer Mask.” This menu is located beneath the “Decontaminate 
Colors” check box. With this setting, it’s going to duplicate the layer you’re working 
on and use a layer mask to remove the background on the duplicate layer. Click OK 
to exit the Select & Mask window and you will see that the original image layer has 
its visibility turned off in the Layers Panel and there is a new, duplicate layer with a 
layer mask that is hiding the gray background. 

Construct the Transparent Parts of the Vase (20:50)

The next step will be to construct the transparent vase. The parts of the vase that 
we can see are the highlights and the shadows. The highlights will be placed on 
one layer and the shadows will be placed on another layer. Start by duplicating the 
original image layer (the one with its visibility turned off) twice. You can duplicate 
the layer by dragging it to the New Layer icon at the bottom of the Layers Panel or 
by using the keyboard shortcut Command+J (Ctrl+J on Win). Make sure these two 
duplicates are just underneath the layer for which you created the layer mask. Re-
name one of these new layers to “Highlights” and rename the other to “Shadows” 
so that you later know their purpose. 

Before exiting the  
Select & Mask window, 
the “Output To” menu 
is set to “New Layer 
with Layer Mask.” As a 
result, you can see that 
the original image layer 
was duplicated and the 
mask was applied to that 
duplicate.
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Now, make a selection of the vase. There are 
many ways to make a selection, but in the les-
son video, we used Quick Mask Mode. (That’s 
because the vase is such a simple shape.) To 
do it this way, tap the Q key to enter Quick 
Mask Mode. Then, use the Brush Tool to paint 
with black over the vase. Because the vase has 
straight edges, you can use a trick for painting 
in a straight line. Click once with the Brush Tool, 
hold down the Shift key and then click again. By 
holding down the Shift key, you’ll be creating a 
straight line between the two points in which 
you clicked. Do this repeatedly to paint over the 
straight edges of the vase. If you get any over-
spill, remember that you can tap the X key to 
exchange the foreground/background colors so 
that you can paint with white in the area that 
was accidentally selected.

If you would like to better inspect the mask, open the Channels Panel and turn off 
the visibility of the RGB channel. This will leave only the Quick Mask channel visible 
so that you can view it as a black and white image. Turn the visibility of the RGB 
channel back on before returning to the Layers Panel. 

In Quick Mask Mode, we are painting 
with black over the vase to add the 
overlay.

Here, we are viewing 
the Quick Mask as a 
channel, which displays 
the mask as a black 
and white image. Here, 
we could use the Brush 
Tool to paint with black 
and white to refine the 
mask.
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Back in the Layers Panel, tap the Q key again 
to exit Quick Mask Mode. The “marching ants” 
selection will appear. In Quick Mask Mode, we 
defined the selection by painting with black 
on the vase. The problem is that black indi-
cates areas that are NOT selected, so every-
thing EXCEPT the vase is currently selected. 
Simply flip the selection to get the opposite 
by clicking on the Select menu and choosing 
Inverse. Now the vase will be the only thing 
selected. 

You will use this selection to create a layer 
mask for both the Shadows and Highlights 
layers. With one of those layers selected, click 
on the Layer Mask icon at the bottom of the 
Layers Panel. The active selection will be con-
verted into the mask, where the area that was 
selected (the vase) will be the only visible part 
of the layer. 

Now you’ll need to copy that layer mask to 
the other layer. (Both the Shadows and High-
lights layers should have the same mask.) You 
can copy a mask from one layer to another 
by holding down the Option key (Alt on Win) 
and dragging the layer mask from one layer to 
the other. It’s important that you hold down 
the Option key when doing this. If you simply 
dragged the layer (with no key held down), it 
would move the mask, removing it from one 
layer and placing it on another. 

We have an accurate selection of the 
vase and this selection will be used to 
create the layer mask.

We have three masked layers. The top is 
masked to reveal the flowers and stems. 
The Highlights and Shadows layers are 
masked to reveal only the glass vase. 



Making Glass Transparent © Ben Willmore, All rights reserved 14

Now you will have three masked layers. The top layer contains all of the solid stuff: 
The flowers and the stems, minus the glass. The two underlaying layers (Shadows 
and Highlights) are masked to only reveal the glass vase. Right now, you can see 
the new background behind the flowers, but you can not see through the glass of 
the vase. You’ll need to now manipulate those highlight and shadow layers so that 
they only display the highlights and shadows, respectively. This will make the vase 
look transparent so that you can see the background behind it. 

Start with the Highlights layer. Turn off the visibility of the Shadows layer (for now) 
and make sure that the Highlights layer is active. You’ll need to make it so this layer 
is only able to brighten what is underneath. You can do this by using the Blend-
ing Mode menu at the top of the Layers Panel to change the mode to Screen. The 
Screen blending mode acts like light. It takes however much light was contained 
in the layer and uses it to brighten what’s beneath it. After changing the blending 
mode, you will start to see some of the pattern from the background showing 
through. 

The blending mode of the Highlights layer is set to Screen, which makes it so the layer is only 
capable of lightening the image.
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Now compare the vase in the 
document you’re working on to 
the original image document 
next to it. In the lesson video, the 
highlights in the vase became 
much brighter than the high-
lights in the original image. If you 
want to tone down those high-
lights, you can do so by using a 
Curves adjustment layer. Click on 
the Adjustment Layer icon at the 
bottom of the Layers Panel and 
choose Curves from the pop-
up menu. A new Curves Adjust-
ment Layer will be added and 
the Properties Panel, containing 
the Curves settings, will become 
visible. 

This Curves adjustment should 
ONLY affect the Highlights lay-
er. You don’t want it to affect the 
background. In order to make it 
so an adjustment layer only af-
fects the layer underneath it, you 
will need to “clip it” to that un-
derlying layer. You can do this by clicking on the clipping mask icon at the bottom 
of Properties Panel for the adjustment layer. The icon looks like a little square with 
a down-pointing arrow next to it. When you click this, the adjustment layer will 
become indented in the Layers Panel and it will have a little down-pointing arrow 
next to it. 

A Curves  
Adjustment Layer 
was created and 
we clicked on the 
Clipping Mask icon 
(circled) to clip 
the layer to the 
underlying High-
lights Layer. This 
makes it so the 
adjustment layer 
can only affect 
the layer directly 
beneath it.
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Now you can work on the Curves Adjustment Layer. Beneath the curves chart, the 
black slider can be used to force areas to become black. The farther you drag this 
slider to the right, the more areas that will be forced to become black. Because 
the Highlights layer is set to Screen Mode (which can only lighten), the areas that 
are forced to black will simply disappear. Drag this black slider to the right while 
watching the vase in the image. It will start to look more and more transparent as 
more areas start to disappear. Position this slider to a location that looks good and 
then fine tune the result by clicking and dragging up and down on the curve line. 
This will place an additional point on the curve. 

The black slider beneath the curve was moved to the right, 
forcing more areas to black. Because the Highlights layer 
is set to Screen mode, these black areas simply disappear. 
You can see the vase before the adjustment (right) vs. after 
(above).
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Now that you have defined the highlights of the vase, it’s time to add in the shad-
ows. Click on the Shadows layer to make it active in the Layers Panel and turn 
on the layer’s visibility. While the Highlights layer can only brighten what’s under-
neath, the Shadows layer should only be able to darken what’s underneath. You can 
accomplish this by changing the layer’s blending mode to Multiply. The Multiply 
blending mode causes the layer to act like ink. 

Just like you adjusted the Highlights layer, you can also use a Curves Adjustment 
Layer to adjust this shadows layer. Click on the Adjustment Layer icon at the bot-
tom of the Layers Panel and choose Curves from the pop-up menu. A new Curves 
adjustment layer will appear and the Properties Panel will be visible. Again, you 
only want this adjustment layer to affect the underlying Shadows layer, so you’ll 
need to clip it to that layer. Click on the Clipping Mask icon at the bottom of the 
Properties Panel to clip the curves layer to the Shadows layer. 

Under the Curves chart, the little white slider will force areas to become white. The 
farther you drag this slider to the left, the more areas that will become white. Since 
the Shadows layer is set to Multiply mode, it can only darken what’s underneath. 
Therefore, the areas being forced to white will simply disappear. Drag this slider to 
the left until you can see through to more of the background. Again, you can click 
and drag on the curve line to fine tune the result. 

The white slider 
beneath the curve 
was moved to the 
left, forcing more 
areas to white. 
Because the  
Shadows layer 
is set to Multiply 
mode, these white 
areas simply  
disappear. 
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Adjust Water in the Vase (30:30)

The vase is looking pretty good now, but you could even take things a few steps 
further. There is water in the vase and the background should look different in the 
areas where you’re looking through the water. 

First make a selection of the area where the water would be. The layer masks that 
you already have can help in making this selection. Start by taking one of the layer 
masks that isolates the vase and loading that as a selection. Load a mask as a se-
lection by holding down the Command key (Ctrl on Win) and clicking on the layer 
mask thumbnail. The marching ants selection will appear. 

With this active selection, enter Quick Mask Mode by tapping the Q key. The se-
lected area (the vase) will look normal here and the rest of the image will have a 
colored overlay. You only want the water to be selected, so activate the Brush Tool 
and paint with black over the top part of the vase, leaving only the water area se-
lected. Tap the Q key again to exit Quick Mask Mode. You will be left with a march-
ing ants selection around the water. 

FAR LEFT:  
A selection was 
made around the 
vase and we en-
tered Quick Mask 
Mode.

DIRECTLY LEFT: 
We are painting 
with black over 
all areas except 
the part of the 
vase that contains 
water.
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Next, activate background layer, click on Filter menu at the top of the interface 
and choose Blur > Gaussian Blur. The Gaussian Blur dialog will appear. Here, you 
can drag the Radius slider up a bit to blur the background in the area where you’re 
looking through the water in the vase. 

Bring Back Original Highlights from Rim of Vase (33:41)

Looking at the rim of the vase, you can 
see that the highlights have become bro-
ken up a bit. Here is how you can bring 
some of the original colors back into that 
area.  The original image is still located 
near the bottom of the layer stack. Its 
visibility is currently turned off. Drag this 
layer to the top of the layer stack and 
turn on its visibility. 

 
 
 
 
 

With the background 
layer active, we are 
using the Gaussian 
Blur filter to blur the 
area inside the selec-
tion (the water area).

You can see that the highlights in the rim of 
the vase have been broken up a bit.
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Next, create a layer mask that hides the entirety of the layer. Click on the Layer 
Mask icon at the bottom of the Layers Panel to add a white layer mask. Then, click 
on the Image menu at the top of the screen and choose Adjustments > Invert. This 
will make the mask completely black. Black hides things, which means that it’s hid-
ing the entire layer. Now you can use an extremely small brush to paint with white 
over the rim of the vase. This will reveal the original colors from the rim. 

Finally, it’s a good idea to clean up the Lay-
ers Panel. Make sure that all of the layers are 
named and then place all of the layers that 
make up the vase in a layer group, or folder. 
This will make it easier to understand what’s 
going on in the document when you open it 
up again in the future.

LEFT: The original image layer was moved to the top of the layer stack and a layer mask was 
added to hide the entire layer. RIGHT: We are painting with white on the layer mask to reveal 
the original rim of the vase.

All of the layers that make up the vase 
were placed in a layer group in order to 
clean up the Layers Panel.


