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Animating a Car 

In a previous Masters Academy les-
son, we talked about basic anima-
tion and we used a series of tech-
niques to animate some text within 
a Photoshop document. In this les-
son, we’re going to build on that and 
work on a more complex animation 
project that involves a photograph. 

In the video example, we have a 
photo of a car and we want to ani-
mate this car to make it look as if it’s 
moving through a scene. This will in-
volve making the wheels turn, mak-
ing the car move up and down a bit (as if it’s hitting bumps in the road) and making 
the windows actually transparent so you can see through them to what’s behind in 
the scene. Let’s look at the step-by-step process used to achieve this. 

Image Size and Mode (Timestamp 00:48)

Image Size Before getting started on an animation project like this, take a look 
at the size of the image and what mode it’s in. When I first opened the example 
image, it was over 7000 pixels wide. That might be great for printing, but an ani-
mation is only going to be shown on a screen, which means that the file does not 
need to be that large. The resolution of an HD TV is 1920 x 1080 pixels. If you plan 
on using the animation on a 4K TV, the resolution is double that of HD. I scaled the 
image down to 1920 pixels wide to limit the file size so that Photoshop would work 
more efficiently.

8-bit vs. 16-bit I usually have Lightroom set to open images in 16-bit when moved 
into Photoshop. This can produce higher quality results when making some ad-
justments and performing certain retouching tasks. This also produces a much 

In this lesson, we’re going to remove the  
background and then animate the car. 
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higher file size and is not necessary when working with animation. When it comes 
to animation, 16-bit will slow Photoshop down considerably so I will make sure that 
the image is set to 8-bit mode. You can change the mode by clicking on the Image 
menu and choosing “Mode.” 

Place Body of Car onto its Own Layer (2:25)

The first thing that we’re go-
ing to do is get the car onto its 
own layer so that the body will 
be able to move independently 
of the wheels. This will require a 
precise selection of the car. You 
could use the Select Subject 
command (under the Select 
menu) as a starting point and 
then use additional selection 
tools to refine the selection. To 
make this project easier, I cre-
ated a saved selection, which is 
included in the practice file. To 
load this selection, click on the 
Select menu and choose “Load 
Selection.” A dialog box will ap-
pear. In this dialog, use the Channel menu to choose the “Precise Car” selection and 
then click OK. The “marching ants” selection will appear around the car.

We’ll copy the contents of the selection to its own layer by using the keyboard 
shortcut Command+J (Ctrl+J on Win). Then, to keep things organized, we’ll re-
name the new layer to “Car.” 

A selection was made of the car body and that 
selection was copied to its own layer. 
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If we look at the car body layer with the 
background layer turned off, we can com-
pletely see through the wheel wells. Another 
layer will eventually contain the wheels, but 
what’s behind them will be transparent, and 
that won’t look natural. We’ll need to fill in 
that gap between the wheels and the body 
of the car. We need to select an area to de-
fine where the inside of the wheel well would 
be and then fill that selection with black. This 
could be done quickly using the Lasso Tool, 
but there is also a saved selection for the 
wheel wells in the lesson file. Click on the Select menu and choose “Load Selection.” 
When the dialog appears, use the Channel menu to choose “Inner Wheelwells” and 
click OK. The selection will appear around the wheel wells of the car. 

We will fill this selection with black on a new layer by clicking on the Adjustment 
Layer icon at the bottom of the Layers Panel and choosing Solid Color from the 
pop-up menu. The Color Picker will appear, we’ll choose solid black and then click 
OK. The new layer will be created and it will contain black in the areas that were 
selected. We’ll drag this new layer beneath the car body layer in the Layers Panel. 

A selection was made of the wheel wells.

With the  
selection of 
the wheel wells 
active, we are 
creating a Solid 
Color layer and 
using the Color 
Picker to set that 
layer (the wheel 
wells) to black.
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Place the Wheels on Separate Layers (5:03) 

Next, we need to copy the wheels to separate layers because they will be rotating 
independently from the rest of the image. We’ll temporarily turn off the visibility 
of the wheel well layer so that we can better see what we’re doing. In this image, 
the front wheel is angled slightly and this will cause it to look wrong when rotating. 
Because of this, we’ll use the back wheel twice, moving a copy to replace the front 
wheel. 

We’ll zoom in on the back wheel and 
activate the Elliptical Marquee Tool. 
We’ll click on the very center of the 
wheel and start to drag out a selec-
tion. We’ll then hold down the Option 
key (Alt on Win), as this will take the 
location where we initially clicked 
and make it the center of the selec-
tion. We’ll also hold down the Shift 
key, which will constrain the selection 
to be perfectly round. Note that you 
need to press these two keys (Option 
and Shift) AFTER you start to drag 
out the selection. 

With the active selection of the wheel, 
we’ll make sure that the Background 
layer is active (because this is the lay-
er containing the entire car) and we’ll 
jump the selection to its own layer by 
using the keyboard shortcut Com-
mand+J (Ctrl+J on Win). We can now 
turn on the visibility of the wheel well 
layer again and drag it beneath the 
wheel layer in the Layers Panel. 

A selection was 
made of the 
wheel and that 
selection was 
copied to its  
own layer.
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Optimize the Wheel Layer (8:45)

The wheel is now on its own layer and we will inspect it closely. We’ll turn off the 
visibility of all the other layers so that we can better see the wheel. I immediately 
see two problems: The bottom has flat surface (from where it was sitting on the 
ground) and the top of the wheel is brighter than the bottom. We don’t want to 
have any flat areas and we’ll also need to adjust the layer so that the whole tire is 
evenly lit. 

Fix Lighting with a dodge and burn layer  Let’s first adjust the lighting on the tire. 
We’ll create a dodge and burn layer to do that. We’ll create a new, empty layer 
above the wheel layer and we’ll set the blending mode of this layer to Soft Light. 
(The Blending Mode menu can be found at the top of the Layers Panel.) 

We’ll activate the Brush Tool and set the foreground color to black. That’s the color 
we’ll be painting with. We’ll use a really soft-edged brush and we’ll set the opacity 
very low, around 20%. These Brush Tool settings can be found in the Options Bar 
above the image window. We’ll use a soft brush to paint over the brighter parts of 
the tire, building up the paint just enough so that the brightness matches the bot-
tom part of the tire. 

A soft brush is being 
used at 20% opacity to 
paint with black on a 
new, empty layer in the 
areas where the tire is 
too bright. This layer’s 
blending mode is set to 
Soft Light.
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As we do this, we will get paint over-
spray outside of the tire, and we can 
correct this with a clipping mask. When 
we “clip” a layer, it will only show up in 
the areas where there’s something on 
the underlying layer. There are sever-
al ways to clip a layer. In this example, 
we’ll hold down the Option key (Alt on 
Win) and hover the cursor over the hor-
izontal line between the paint layer and 
the wheel layer. When the cursor turns 
into a little square with a down-point-
ing arrow, we’ll click on the line. This will 
clip the layer and you can see that the 
layer becomes indented in the Layers 
Panel. A down-pointing arrow will ap-
pear to the left of the layer, indicating 
that it’s been clipped. Now, the paint 
will only appear in the area where the 
tire is visible. 

Un-flatten the bottom of the tire The 
next thing we need to fix is that flat, 
bottom portion of the tire. We can use 
the Clone Stamp Tool to do this. With 
the Clone Stamp Tool, we’ll copy from 
the top edge of the tire and paste it 
on the bottom, removing the flat edge. 
We’ll activate the Clone Stamp Tool and 
we’ll make sure that the tire layer is the 
active layer. 

The Option key (Alt on Win) is being held 
down while hovering the cursor on the line  
between layers. When the cursor changes to 
look like the square and arrow, we can click to 
clip the upper layer.

The dodge and burn layer is clipped to the un-
derlying wheel layer.

The Clone Stamp Tool is being used to sample 
an area from the very top of the tire.
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Using the Clone Stamp Tool, we’ll Option+Click (Alt+Click on Win) on the very top 
edge of the tire. This will set this part as the sample area. Now we will need this 
sampled content to be flipped (or rotated 180 degrees) before we paste it on the 
bottom of the tire. We can use the settings in the Clone Source Panel to manipulate 
that sample area. If the Clone Source Panel is not visible in the interface, it can be 
accessed by clicking on the Window menu and choosing Clone Source. 

In the Clone Source Panel, we’ll turn on the Flip Vertical icon (see screen shot). 
Now, if we make the brush tip large, we can see that the top of the wheel we sam-
pled has been flipped upside down. We’ll use a soft brush and we’ll paint over the 
bottom, flat part of the wheel, pasting the sampled content over that area. Before 
moving away from the Clone Stamp Tool, we’ll turn off the Flip Vertical setting 
within the Clone Source Panel so that the content is not flipped the next time we 
use the tool. 

After sampling from the top of the tire, the Flip Vertical 
setting (circled) was turned on and at left, we are painting 
the sampled content over the bottom of the tire.
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Fill in the wheel holes There is one more issue with the wheels. There are little 
holes in the wheels and we can see through some of those holes to the original 
background. We need those holes to be transparent so that we can see through 
to what’s behind them in the final animation. We need to make a selection of the 
holes. The Quick Selection Tool could be used for this, but I have a pre-made, saved 
selection that is included in the image file. To activate this selection, click on the 
Select menu and choose Load Selection. In the dialog that appears, set the Chan-
nel menu to Wheel Openings and then click OK. The selection will appear around 
the holes. We can remove the contents of the selection either by deleting it or 
creating a layer mask. To create a layer mask, we’ll hold down the Option key (Alt 
on Win) and click on the Layer Mask icon at the bottom of the Layers Panel. By 
holding down the Option key, the selection will be converted into the black part 
of the mask. The black parts of the mask will hide the layer, so the contents of the 
holes will be hidden. 

We want to be able to see through the wheel holes to what’s behind, so we made a selection 
of the holes and then removed the contents by using a layer mask.
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Spin the Tire (18:36)

Now let’s start to create some animation by spinning the tire. To keep things neat, 
we will first rename all of the layers to represent what they are. This will make things 
easier to understand within the Timeline. We will also merge the Wheel layer with 
the dodge & burn layer that was used to darken part of the wheel. We need these 
two elements on a single layer. To merge the two layers, we’ll click on the dodge & 
burn layer to make it active. Then, we’ll click on the Layer menu and choose “Merge 
Down.”

We need the Timeline Panel to be visible so we’ll 
click on the Window menu and choose Time-
line. The panel will appear along the bottom of 
the screen. There are two types of timelines to 
choose from and we’ll use the menu in the middle 
of the panel to choose “Create Video Timeline.” 
We’ll click the “Create Video Timeline” button and 
the panel will change to list all of the layers. 

Hide layer thumbnails in Timeline In the Timeline Panel, the layer thumbnails take 
up a lot of room and I, personally like to condense them. We will be using the Lay-
ers Panel to switch between layers so it’s not necessary to have them expanded 
like this. We’ll click on the little menu in the top right corner of the Timeline Panel 
and we’ll choose “Panel Options” from the pop-up menu. A dialog will appear with 
settings that allow you to choose how large the layer thumbnails should be. There 
is also the option of “None,” which will hide the thumbnails entirely. That’s what I 
chose in the video example. 

In the Timeline Panel, we are  
opting to create a Video Timeline.

LEFT: The layer thumbnails are large in the  
Timeline Panel. ABOVE: We removed the  
thumbnails so they don’t take up so much space.



Animating a Car © Ben Willmore, All rights reserved 11

We want to work on the wheel so 
we’ll hide all of the other layers in the 
Layers panel. In the Timeline Panel, 
we’ll click on the little arrow to the left 
of the Wheel layer and it will expand 
to display a list of the things that we 
can animate over time. These include 
the layer position, opacity, style, etc. 
We need the wheel to rotate, but that 
is not one of the options. We can get 
around this, however. To do that, the 
layer we’re working on needs to be a 
Smart Object. We can convert the lay-
er into a Smart Object by clicking on the Layer menu and choosing Smart Objects 
> Convert to Smart Object.  Now that the layer is a Smart Object, the “Position” 
element is replaced with a “Transform” element and this will allow the animation to 
keep track of the wheel rotation. (Transform includes changes that include scale, 
rotate, move distort, etc.) 

We clicked on the disclosure triangle for the 
wheel layer (circled) to see all of the elements 
that the animation can keep track of.

The Wheel layer was converted into a Smart Object and the animation now has the ability to 
keep track of “Transform” adjustments.
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The frame of time taken by the animation is shown at the top of the Timeline. It 
will display seconds as well as frames. In our document, 30 frames make up one 
second of time. We can zoom in and out on the Timeline by using the slider at the 
bottom of the panel. It can sometimes be helpful to zoom out on the timeline so 
that we are seeing seconds instead of individual frames. 

The Playhead is the red line that runs vertically down the Timeline and it can be 
repositioned by dragging the little blue scrubby slider at the top of the Timeline. 
it starts off on the far left side, at the very beginning of the animation. While the 
Playhead is in this location, we’ll click on the little stopwatch icon to the left of the 
“Transform” element beneath the Wheel layer. This tells the animation to keep track 
of the position, rotation and size of the layer at this point in time. A little yellow di-
amond will appear in the Timeline, indicating that the location is marked. 

Next, we’ll move the playhead to the point in time when the tire should be rotated 
half-way around. That will be at about the half-second point. Then, we’ll click on the 
Edit menu and choose “Free Transform.” The Free Transform handles will appear 
around the wheel and we’ll use them to rotate the wheel half-way around. 

We clicked on 
the watch icon 
to tell the  
animation to 
record any 
transformations. 
Here, we moved 
the Playhead to 
the half-second 
mark and we are 
using the Free 
Transform  
command to 
rotate the wheel 
half-way around.
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If, instead, we wanted to be really precise, we could type in 180 degrees in the ro-
tation field that appears within the Options Bar. We’ll click Return/Enter to lock in 
the transformation. A second little diamond will appear on the Timeline, recording 
the transformation. 

Now we already have the first yellow diamond that records the wheel in the upright 
position so we can simply copy that marker and position the copy at the one-sec-
ond mark. To copy the marker, we’ll right-click on it and choose “Copy” from the 
pop-up menu. Then, we’ll move the Playhead to the one-second mark, we’ll right-
click on one of the diamonds and choose “Paste” from the pop-up menu. 

At this point, we have the wheel start-
ing out at its upright position. It rotates 
upside down over the course of the first 
half second and it rotates back up to 
normal during the second half-second. 
Now, we just need to repeat this pro-
cess. We’ll select the second and third 
diamond markers (we can select more 
than one by holding down the Shift 
key.), we’ll right-click on one of the dia-
monds and again choose “Copy.” Then, 
we’ll position the Playhead to 1.5 seconds, right-click on an existing diamond and 
choose “Paste” from the pop-up menu. The two markers will be pasted onto the 
Timeline. We’ll repeat that process, this time selecting and copying four of the dia-
mond markers and then pasting them after another half second. 

We are copying the diamond marker by 
right-clicking on it and choosing “Copy” from 
the pop-up menu.

The diamond 
markers that  
represent the 
wheel rotation 
have been copied 
and pasted to the 
end of the  
Timeline.
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Eventually, we may need to extend the Timeline, and we can do that by dragging 
the right ends of the purple bars to the right. We’ll do this and extend the anima-
tion to 10 seconds. Then, we’ll continue copying and pasting the markers until they 
reach the end of the timeline. It is important that we ensure that there are an even 
number of markers so that the position of the wheel is the same at the start and 
end of the Timeline. This will allow for seamless looping of the animation. To see 
what the animation looks like, we can position the Playhead at the beginning of the 
Timeline and then click the triangular Play button on the left side of the Timeline 
Panel. 

Copy the Back Wheel to Use as the Front Wheel (31:55)

The back wheel is animating nicely. We need to somehow copy this back wheel 
to use as the front wheel, but we need to be careful. It’s easy to create problems 
when making changes to layers when you have an active Timeline. For example, if 
we were to duplicate the wheel when the playhead is in the middle of the Timeline, 
that duplicate will only appear once the animation reaches that part in time. We 
need two wheels to be present from the start! 

In order to make the wheel duplication task foolproof, we’re going to wrap the 
wheel layer (and the animation along with it) inside a Smart Object. Yes, the layer 
is already a Smart Object, so this means we’re going to have a Smart Object inside 
of a Smart Object! The reason for this is that we applied an animation to the Smart 
Object and now we want that animation to be wrapped inside of another Smart 
Object. 

We’ll make sure the wheel layer is active, we’ll click on the Layer menu and choose 
Smart Objects > Convert to Smart Object. You will see the Wheel layer in the Time-
line change to include the Smart Object icon. The little diamond markers (that log 
the rotation) disappear because they are now embedded inside the Smart Object. 
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Now we can copy the back wheel and use the copy as the front wheel. You can 
copy a layer by holding down the Option key (Alt on Win) and then clicking and 
dragging on the active layer. This will drag out a copy, and you will see that new 
layer appear within the Layers Panel. Note that the Move Tool must be active when 
doing this. With the Move Tool active, we’ll hold down the Option key (Alt on Win) 
and click and drag out a copy of the wheel, positioning the copy within the front 
wheel well. We can now click the Play button within the Timeline and both of the 
wheels will animate. 

The Wheel layer was converted into a Smart Object so that the animation could be embed-
ded inside that Smart Object. Here, we are duplicating the back wheel to use as the front 
wheel. 
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Flatten the Wheel Bottoms (35:37)

When a car moves down the road, the very bottom of the wheel is a bit flat, and we 
don’t have that in this animation. We need to hide the very bottoms of the wheels 
to make them look as if they flatten very slightly as they move down the road. We’ll 
do this by editing the Smart Object to add a layer mask that hides the very bottom 
of the layer, making the bottom of the wheel look flat. 

Whenever you duplicate a Smart Object, it thinks of it as two instances of the exact 
same thing. This means that we can make a change to one of the Smart Objects 
and that change will happen to the other as well. Therefore, we can flatten one of 
the wheel layers and the other will flatten as well. 

In the Layers Panel, we’ll dou-
ble-click on the thumbnail for the 
Wheel copy layer. This will open 
the Smart Object in a separate 
Photoshop document. We’ll add a 
layer mask to the wheel layer by 
clicking on the Layer Mask icon at 
the bottom of the Layers Panel. 
The mask will be completely white 
by default. When we add black to 
the mask, we will be hiding parts 
of the layer. We’ll activate the 
Brush Tool and use a semi-hard 
brush to paint with black over the 
very bottom part of the wheel, 
creating a small flat area.  We double-clicked on the wheel Smart Object layer 

and it opened in a separate document. Here, we 
added a layer mask and are painting with black on 
the mask to flatten the bottom of the wheel.
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This looks good, but we need to make 
sure that the layer can animate inde-
pendently of that layer mask. If the 
mask were to rotate as well, then the 
flat part of the wheel will go round 
and round. We need it to stay at the 
bottom, where the wheel meets the 
road. In the Layers Panel, you’ll see 
a little link icon between the layer 
thumbnail and the mask thumbnail. 
When the layer and the mask are 
linked, the mask will move along with the layer. We will click the link icon to unlink 
the two. This will allow the wheel to rotate while the mask stays in place.  

We can now save and close this Smart Object document so that we can return 
to the original car document. Here, you can see that both Smart Objects were 
changed and that both tires now have a flat area on the bottom. 

We clicked on the link icon to unlink the layer 
from the layer mask.

After making a change to one of the Smart Object wheel layers, you can see that the other 
instance of that Smart Object (the other wheel) received the change as well.
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Animate the Car Body (38:05)

Now we’re going to animate the body of the car. We’d like to make it look as if it 
were undulating up and down a bit as it moves down the road. We’ll activate the Car 
layer and we’ll expand the Car layer in the Timeline by clicking on the little arrow to 
the left of the layer name. This will expand the list of elements we can keep track 
of. One of these things is the Position of the layer. We not only need the animation 
to keep track of the position, but we also need it to keep track of transformations 
(rotation, scale, movement, etc.). To be able to do this, we need to convert the lay-
er into a Smart Object. We’ll click on the Layer menu and choose Smart Objects > 
Convert to Smart Object. Now, you can see that “Transform” is included in the list 
of things the animation can keep track of. 

We’ll make sure that the Playhead 
is at the very beginning of the 
Timeline and we’ll click the little 
watch icon to the left of the word 
“Transform.” This will tell the ani-
mation to keep track of transfor-
mations to this layer, starting with 
the current position in the Time-
line. A little diamond marker will 
appear in the Timeline.  

Now we want to make the car move a bit. We’ll move the Playhead to about the 
1-second mark, where the car will “hit a bump in the road.” We’ll click on the Edit 
menu and choose Free Transform. The transform handles will appear around the 
car and there will be a little crosshair in the middle of the layer. If you don’t see the 
little crosshair, the setting to turn it on can be found on the left side of the Options 
Bar. (It is a little check box.) This little crosshair represents the pivot point, and 
we’re going to position this point on the center of the back wheel. 

The Playhead was positioned to the beginning of the 
Timeline and we clicked the watch icon, telling the 
animation to keep track of transformations to the 
layer.
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Then, we’ll rotate the front of the car downward a bit by clicking and dragging 
down outside the right edge of the transform box. We’ll press Return/Enter to lock 
in the transformation. A second little diamond will appear in the Timeline, indicat-
ing that it is keeping track of the transformation that just occurred. 

After about another second, we want the car to return to its neutral position. We’ll 
position the Playhead at that 2-second mark. The first diamond (at the 0 mark) 
records the car in this position, so we’ll right-click on the diamond and choose 
“Copy” from the pop-up menu. We’ll then right-click on the diamond a second time 
and choose “Paste.” The pasted marker will be placed where the Playhead is posi-
tioned, at the 2-second mark.

Now we’ll make the back of the car undulate a bit. We’ll position the Playhead at 
around the 3-second mark for this. We’ll click on the Edit menu and choose Free 
Transform. This time, we’ll position the cross-hair pivot point to the center of the 
front wheel. Then, we’ll rotate the car slightly so that the back of the car is lowered 
a bit. We’ll click the Return/Enter key to lock in the transformation. 

The Free Transform crosshair (circled) was positioned on the back wheel and the front of the 
car is being rotated down a bit.



Animating a Car © Ben Willmore, All rights reserved 20

One second later, we want the car to be back to its original position. We’ll move the 
Playhead to the 4-second mark. We’ll again right-click on the original diamond (at 
the 0 mark) and choose “Copy” from the pop-up menu. Then, we’ll simply right-
click on the diamond again and choose “Paste.” The new marker will appear where 
the Playhead is, at the 4-second mark. 

The Free Transform crosshair (circled) was positioned on the front wheel and the back of the 
car is being rotated down a bit.

There are now four markers representing transformations to the car. The first marker is where 
the front of the car moves down. The second marker is where it returns to neutral. The third 
marker is where the back of the car moves down. The fourth marker is where it returns to 
neutral again.
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When we hit the Play button, 
we can see the car undulate up 
and down. We just need to copy 
the current diamond mark-
ers so that the motion repeats 
through the end of the anima-
tion. We’re going to select all 
of the markers except the first 
diamond. (The first marker and 
last marker are the same, so we 
don’t want to repeat that posi-
tion twice in a row.) We can se-
lect multiple markers by drag-
ging out a rectangle around all we want selected. With the four markers active/
selected, we’ll right-click on one and choose “Copy” from the pop-up menu. Then 
we’ll position the playhead at one second beyond the last diamond (5 seconds), 
right-click on one of the diamonds again and then choose Paste. The four diamond 
markers will be pasted into the Timeline. We will repeat this process until the ani-
mation reaches the end of the Timeline. 

Add a Backdrop (42:28)

The car is moving along nicely now, so it’s time to add a background. The first el-
ement of the background will be the road. We’ll activate the Rectangular Shape 
Tool and make sure that it’s set to create a Shape Layer and not a pixel layer. This 
setting can be found on the left side of the Options Bar. We’ll make sure that the 
Foreground color is set to black, because that will be the color of the road. The 
Foreground and Background color swatches can be found at the bottom of the 
Toolbar on the left side of the interface. Then, we’ll use the tool to drag out a long 
rectangle along the bottom of the document, so that it meets the car tires. 

We’re dragging out a rectangle to select multiple  
diamond markers.
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The new Shape Layer will appear in both the Layers Panel and in the Timeline. If it 
does not extend across the entirety of the Timeline, we can simply drag the edges 
of the bar until it does take up the entire Timeline. 

Next, we’ll insert a scene into the background. I have a long panorama image that 
we’re going to use as the background so that the car can drive across the long 
scene. We’ll drag the pano image into the Photoshop document and size the im-
age so that it’s as tall as the document. Then, we’ll drag this layer so that it’s below 
all of the layers that make up the car, just above the Background layer. 

The Rectangular 
Shape Tool is  
being used to 
create a road on 
the bottom of the 
frame.

The Rectangle 
Shape Layer did 
not extend to the 
end of the Time-
line, so we are 
dragging the right 
edge to the end of 
the Timeline.

The panorama  
layer is being 
sized so that it’s 
as tall as the  
document frame.
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We’ll now use the Move Tool to position the left edge of the panorama with the 
left edge of the document window. This is where the car will start its journey. In 
the Timeline, we’ll drag the edges of the panorama bar so that it extends across 
the entire animation. Then, we’ll click on the little triangle to the left of the layer 
name to expand the layer. In the video example, the pano image was moved into 
the document as a Smart Object, which means that we have the ability to track any 
transformations made to the layer. If, instead, you moved the image into the docu-
ment as a regular layer, you could convert the layer into a Smart Object by clicking 
on the Layer menu and choosing Smart Objects > Convert to Smart Object. We’ll 
make sure that the Playhead is all the way on the left side of the Timeline (at the 
0 mark) and we’ll click on the little watch icon to the left of the word “Transform.” 
This will tell the animation to keep track of any transformations made to the layer. 

Next, we will move the Playhead to the very end of the animation. We’ll use the 
Move Tool to reposition the pano layer so that the right side of the panorama aligns 
with the right side of the document frame. 

We can now move the Playhead to the beginning of the Timeline and hit the Play 
button to view the animation. If it goes very slowly the first time you play the an-
imation, it just means that it’s taking some time to render all of the frames. It can 
take especially long if any of the images included in the file are very large. 

At the start of the 
Timeline, we posi-
tioned the left edge 
of the panorama to 
align with the left 
edge of the frame. At 
the end of the Time-
line, we positioned 
the right edge of the 
panorama to align 
with the right edge 
of the frame. The 
animation will move 
the pano across the 
frame.
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Add Audio (49:12) 

In the Timeline Panel, below all 
of the layer names, you will find 
an “Audio Track” option. If you’d 
like the animation to include 
audio, you could click on the 
little down-pointing arrow to 
the right of the audio icon and 
choose “Add Audio” from the 
pop-up menu. This will open a 
Finder window and prompt you 
to navigate to the desired audio 
file on your hard drive. In the vid-
eo example, we used a track that 
was downloaded from a creative 
commons website. 

The track will appear as a green bar in the Timeline. If you want to cut or split the 
track so that it can begin in a certain location, move the Playhead to the location 
where you’d like to split the clip, click on the little menu in the top right corner of 
the panel and choose “Split at Playhead.” Then, you can click on one of the pieces 
to make it active and tap the Delete key to remove it. 

Saving and Exporting (52:32)

To export the animation so that you can view it outside of Photoshop or give it to 
someone else, click on the File menu and choose “Render Video.” 

NOTE: In the video, it is mentioned that you can save the file in the GIF format in 
order to get a looping animation. Upon exploring this option further, I discovered 
that this option doesn’t actually work, so we’re sorry for that error! 

We are clicking on the little down-pointing arrow to 
the right of the audio icon to access this menu.
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Convert Car into Smart Object for Simpler Future Use (53:28)

One last thing we could do is simplify the document so that the animated car can 
easily be used on other backgrounds, without the complexity of all the layers. We’ll 
select all of the layers that make up the car (the body layer, the wheel layers and 
the wheel well layers). Then, we’ll click on the Layer menu and choose Smart Ob-
jects > Convert to Smart Object. This will combine all of those layers into one tidy 
package as a Smart Object. All of the animation for the car will also be contained 
in this Smart Object, so it will simplify the Timeline as well. 

We could now move this Smart Object layer into another document and it will re-
tain the entire animation in that new document. 

We selected all of the layers that make up the car (left) and  
converted them into a single Smart Object (right). 


