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Blurring with Depth Maps 

In this lesson, we’re going to take a look at depth maps. A depth map will allow 
you to control how blurry a background should look in your images. It is essential-
ly a grayscale image that represents, or describes, the depth in the photograph. 
This will educate Photoshop as to what areas should look as if they were near the 
camera and what areas should look as if they were farther away from the camera. 
Then, it will blur the photograph based on this grayscale image.

With this lesson, we’re going to work with photos that already have these gray-
scale images attached to them. These were all created with an iPhone. On the iP-
hone, there is a feature in the Camera App called Portrait Mode. In this mode, you 
can tap on the screen to determine which areas should be in focus and it will at-
tempt to make the background look soft. It will automatically create this grayscale 
depth map for us. In a future lesson, we’ll take things a step further and learn how 
we can create our own depth maps for images shot on our regular, DSLR camera. 

LEFT: This is an 
example of how 
a depth map 
was applied to 
an image to  
selectively de-
termine what 
areas should 
be out of focus. 
BELOW: The  
image without 
the depth map.
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iPhone file format settings In order to get these iPhone images so we can use 
them in Photoshop, we need to make sure that they’re being captured in the cor-
rect format. On the iPhone, open the Settings App and scroll down to the Camera 
settings. Here, you will find a setting for formats. One option is called “Most Com-
patible” and this will save a JPEG image. The other option is called “High Efficien-
cy” and this is the one you’ll want to use. This will result in a HEIC file (for high 
efficiency) where the “C” stands for container, which means it can actually store 
more than one picture in one file.

Moving photos from iPhone to desktop Next, we need to be careful of how we 
send the image from the iPhone to the desktop. With most default settings, it will 
attempt to convert the images to JPEGS and that’s not what we want. We want 
to maintain that HEIC format. I find that when I AirDrop images from my phone 
to my computer, they remain in the HEIC format. If this does not work, or is not 
an option, you can instead use Bridge. Attach the phone to your computer via the 
USB cord, click on the File menu in Bridge and choose to “Import from Device.” 

At left are screen shots 
from the Settings app 
on the iPhone. Use the 
circled settings in order 
to capture images in the 
HEIC format.
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Intro to the Lens Blur Filter (Timestamp 6:07)

There are a few different blur filters available in Photoshop, but we’re going to be 
using the Lens Blur feature in order to specify what areas should be sharp and 
blurry. The Lens Blur feature allows us to use an alpha channel, or a saved se-
lection, to specify what areas should be completely blurry, what areas should be 
completely sharp and what should be in between. This alpha channel is the gray-
scale image that will serve as the depth map.

To create a very simple alpha channel, we could create a basic selection and then 
save that selection by clicking on the Select menu and choosing Save Selection. 
Then, we could open the Channels Panel and that selection can be seen as an 
alpha channel, where the selected areas are white and the un-selected areas are 
black. 

When we use that alpha 
channel, or depth map, in 
the Lens Blur window, we 
are defining the different 
planes of focus. The white 
areas will be thought of as 
having one plane of focus 
and the black areas will be 
thought of as having an-
other. We can click with-
in the image to determine 
what area should be sharp. 

In this lesson, we’re working with iPhone images that already have this depth map 
built in. We just need to make sure that the images are being loaded into Photo-
shop in such a way that we can use them.

The Depth Map 
will appear 
as a channel, 
which can be 
seen within the 
Channels Panel. 
The light parts 
of the channel 
represent the 
areas that Pho-
toshop thinks 
are farther from 
the camera.
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Filter for HEIC images in Lightroom In Lightroom, you can filter your images to 
see which were shot in the HEIC format that saves depth information. Expand 
Metadata category of the Filter Bar and click on one of the top search parameter 
menus. One of the items that you can populate the filter with is an option called 
“Depth.” Click on the “Has Depth” filter that will appear beneath the menu. This will 
show all of your HEIC images files that have depth information.

Opening HEIC files in Photoshop Note that you can’t move an image from Light-
room to Photoshop using the standard method (Photo Menu > Edit in > Edit in 
Adobe Photoshop) when working with depth maps. If you move the image this 
way, the depth map channel will not be included. Instead, right-click on the image 
and choose to “Show in Finder.” This will show you the original file on your hard 
drive. Click and manually drag this file to the Photoshop icon. Then, you can open 
the Channels panel and you will see the Depth Map channel. 

In Lightroom, the Filter Bar is being used to locate all images that have depth maps.
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Working with Depth Maps (12:55)

View the Depth Map Let’s look at the depth map. With the Channels Panel open, 
click on the depth map channel to view it in the main image window. With a depth 
map, things that are far away will be light in tone. White represents the thing that 
is farthest from the camera. Things that are closer to the camera have darker and 
darker shades assigned to them. We can use these tones to selectively blur the 
picture. In the Channels panel, click back on the RGB channel to view the image 
normally. 

The Lens Blur Filter We’ll click on the Filter menu and choose Blur > Lens Blur. The 
Lens Blur window will take over the screen. In the settings panel on the right side 
of the screen, we need to click on the Depth Map Source menu and choose the 

name of the Depth Map channel. If the image was 
shot on an iPhone, this channel will always be titled 
“Depth Map.” With this source chosen, we can click 
within the picture to determine what area should be 
the sharpest. When we click, it looks at the depth 
map, determines what shade of gray is under the 
mouse and it assigns that shade as what should be 
sharpest. The Radius slider determines how blurry 
the other areas will become. 

At left, you can 
see the image 
along with the 
Channels Panel 
containing the 
depth map.

In the Lens Blur window, the 
Source menu is being set to the 
Depth Map channel.
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ABOVE: In the Lens 
Blur filter, we select-
ed the Depth Map 
channel as the source 
and we clicked on the 
background. You can 
see that the back-
ground is in focus 
but the foreground is 
not. LEFT: Here, we 
clicked on the fore-
ground instead. The 
filter used the Depth 
Map to make the fore-
ground in focus.
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Adjust the Depth Map using Curves Notice that there is no setting that allows 
you to determine how deep the depth of field is. This makes it hard to make two 
planes of focus become sharp at the same time. It is possible, however, if we make 
changes to the grayscale depth map. To do this, we’ll need to exit the Lens Blur 
window. We’ll open the Channels Panel and we’ll click on the Depth Map channel 
in order to view it in the main image window. Here, we can take the two or more 
areas that we want to be in perfect focus  and make sure that they are the same 
shade of gray. You could use the Brush Tool to paint in the same shade of gray 
to these areas, but in the video example, we’re going to use a Curves adjustment. 
We’ll click on the Image menu and choose Adjustments > Curves. 

The Curves dialog will appear and we’ll make sure that the Targeted Adjustment 
Tool is active. (It looks like a little hand icon.) Using this tool, we can click within 
the image in order to target just the shade, or brightness level, that we click on. 
We want the back part of the food to be the same tone as the front part of the 
food so that both areas are equally in focus. We’ll click somewhere within the back 
part of the food and a point will be placed on the  curve. Then we’ll click some-
where within the front part of the food to place a second point on the curve. 

The Targeted Adjustment Tool (circled) was used to place two points on the curve. These 
represent two areas that we want to be equally in focus.
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We want these two curve points to be at the same level on the curve. This will 
ensure that they are the same brightness, and will therefore be in the same focus 
range when we use the Lens Blur filter. We’ll click on the lower of the two dots to 
make it active and we’ll use the up arrow key to nudge it upward. Then we’ll click 
on the upper dot and we’ll use the down arrow key to nudge it downward. We just 
want the two dots to be even. As we do this, the two targeted areas will become 
the same shade of gray in the Depth Map. 

The entire curve became distorted when 
we moved the two dots, so we’ll want to 
straighten out the curve so that it doesn’t 
brighten or darken the rest of the image 
quite as much. We’ll click to add two more 
points on the curve and drag them close to 
the two existing points, positioning them so 
the curve line looks to be as close to a diag-
onal line as is practical. We’ll click OK to exit 
the Curves dialog. 

The two curve 
points were 
nudged so that 
they became  
perfectly even.

Two additional points were placed on 
the curve and positioned so that the rest 
of the curve became close to diagonal.
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We’ll click on the top-most channel (RGB) to return to viewing the main image 
and we’ll try to run the filter again. We’ll click on the Filter menu and choose Blur > 
Lens Blur. In the Lens Blur window, we’ll make sure that the Source menu is set to 
the appropriate Depth Map channel and then we’ll click somewhere on the subject 
(the food) to make it in focus. Because the entire food area is the same shade of 
gray, it should remain in focus. We can move the Radius slider to try and adjust 
how blurry the rest of the image becomes. 

In the example image, the food became nice and sharp, but we can’t seem to get 
the rest of the image to be as blurry as we’d like. We moved the Radius slider up 
as high as it would go, but the background still isn’t blurry enough. There are two 
things we could do about this. First, we could click OK to exit the filter and simply 
run the Lens Blur filter a second time. The other option would be to further adjust 
the Depth Map channel. That’s what we’ll do. 

After using Curves to adjust the two areas we wanted to be in focus, we used the Lens Blur 
filter to click on one of those areas. Because the two areas are the same tone in the Depth 
Map, they are both now in focus. 
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We’ll exit the Lens Blur Filter and we’ll click on the Depth Map channel to view it 
in the image window again. If we want the background area to be much blurrier 
than the food, we’ll need Photoshop to think that the area is farther away from 
the camera. We can do that by making the area brighter. We’ll click on the Image 
menu and choose Adjustments > Curves. The Curves dialog will appear and we’ll 
again make sure that the Targeted Adjustment Tool (the hand icon) is active. Us-
ing this tool, we’ll first click on the food area in order to place a point on the curve, 
locking in the brightness of that area. Then, we’ll click in the area that we want to 
be blurry and we’ll drag upward. This will place a second point on the curve and 
move it up, lightening that targeted tonal range. This distorted the curve line quite 
a bit, so we’ll place two more points on the curve and position them so that the 
rest of the curve line is close to diagonal again. We’ll click OK to exit the Curves 
dialog. 

ABOVE: A Curves adjustment is being made to brighten 
the tone in the background. This will make Photoshop 
think that this area was farther from the camera.  
RIGHT: Additional points are being placed on the curve 
and positioned so that the rest of the curve becomes close 
to diagonal again.
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Adjust the Depth Map using the Brush We could also make changes to the Depth 
Map channel using the Brush Tool. We could paint with various shades of gray in 
order to make different parts of the image more in focus (or more out of focus). 
With the Brush Tool active, you can sample a color from within the image by hold-
ing down the Option key (Alt on Win) to temporarily access the eyedropper tool. 
Click within the image to sample a color. That color will become the foreground 
color, which is the color you’ll paint with using the Brush Tool. If we want two areas 
to be equally sharp, we could sample the color from one area and use the brush 
to paint over the other area with the same color. 

ABOVE: We 
sampled a 
color from 
one area of 
the depth 
map and are 
painting the 
same tone into 
another area. 
We want both 
of these areas 
to be equally 
sharp.

BELOW: In 
the Lens Blur 
Filter, we 
clicked on one 
of the areas to 
make it sharp. 
Because we 
adjusted the 
depth map, 
both areas  
became  
equally sharp.
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Artifacts around the Edges of Objects (27:20)

There may be instances where 
you run the Lens Blur filter using 
the Depth Map channel and end 
up with an undesirable artifact 
around the edges of objects. In 
the video example, we have an 
image of some yellow flowers. 
When looking at the image be-
fore using the filter, the edges 
look fine. We also can not see any 
artifact when looking directly at 
the depth map. When we run the 
filter, however, we end up with 
an ugly halo around parts of the 
flowers. That’s because the filter 
is trying to work quickly so that 
the sliders respond very quickly. 
In order to do that, it uses a lower 
resolution version of the channel 
so it doesn’t have the full fidelity 
of the original. 

If you don’t mind the filter ren-
dering changes a little slow-
er, turn on the “More Accurate” 
setting that’s located at the top 
of the adjustment panel on the 
right side of the Lens Blur win-
dow. This will cause the preview 
to look high quality and the arti-
fact will disappear. 

Here you can 
see a halo  
artifact around 
the edges of 
the flowers.

The Preview 
option is being 
set to “More 
Accurate.”

You can see 
that the halo 
artifact went 
away.
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Controlling the Background Highlights (29:18)

When you blur areas in the background, you will notice that the highlights become 
bigger. The blurrier the background becomes, the larger the highlights will be. 
These highlights will also have a certain shape, and you can determine what shape 
they will be within the settings panel. 

In the settings panel, there is a category called Iris. Here, there is a Shape menu 
that can be used to determine the shape of the highlights. The Rotation slider will 
rotate the shapes. The Blade Curvature slider can then be used to determine how 
soft the corners of the shape will be. If you move this slider all the way up, the 
highlights will become perfectly round. 

The Specular Highlights settings also give you more control over the out-of fo-
cus areas. Use the Brightness slider to brighten those areas, making them more 
prominent. The Threshold slider determines which of those bright shades are con-
sidered highlights and therefore how many of those shades should be brightened 
when you use the Brightness slider. 

The Shape menu can be used to change the shape of the highlights. In the center screen 
shot, the shape was set to Hexagon. In the right screen shot, the shape was set to Square. 
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The Noise slider can be used to add grain to the part of the image that is being 
blurred. This can be useful for making the amount of noise in the blurry areas 
match the amount of noise in the sharp areas. 

Fixing Gaps in the Depth Map (33:24)

The depth map created by the iP-
hone can sometimes be quite faulty. 
If the subject has gaps in it, then it 
sometimes can’t tell that the area 
within those gaps is supposed to 
be part of the background. In the 
example image with the yellow 
flowers, you can see that part of 
the greenery between the flowers is 
sharp, whereas the greenery surrounding the flowers is blurry. It should all be blur-
ry. Looking at the depth map channel, we can see that the image is gray where it 
should be white. We’ll need to adjust the mask to correct for this. 

At left, the Blade 
Curvature slid-
er was moved 
all the way up. 
This caused the 
highlights to be-
come circular. The 
Brightness slider is 
also being moved 
up, which is caus-
ing those high-
lights to become 
brighter.

The greenery viewable between the flower petals 
is not blurred as it should be.
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Because the area that’s supposed 
to be blurry is all green, we can 
start by making a selection using 
the Color Range command. With 
the RGB channel active, we’ll click 
on the Select menu and choose 
Color Range. The Color Range 
dialog will appear and we’ll start 
with the Fuzziness slider all the way down (at zero). Then we’ll use the eyedrop-
per to click within the color we want to select. This is the greenery between the 
yellow flowers. A small preview of what’s selected will appear in the Color Range 
dialog. We’ll activate the little plus eyedropper (+) and click on additional shades 
of green, expanding that selection. Because the small preview can make it hard 
to tell what’s selected, we’ll experiment with the Selection Preview menu at the 
bottom of the Color Range dialog. This will overlay the selection in the main image 
window. If we choose the Quick Mask option, then all non-selected areas will get 
a red overlay. If we choose the Black Matte option, then all the non-selected areas 
will get a black overlay. We can continue to use the eyedropper to add to the se-
lection while viewing the selection this way. 

Once we’re getting happy with 
the selection of the green areas, 
we can use the Fuzziness slider 
to expand the range of colors be-
ing selected. We’ll bring this slider 
up quite high and then we’ll back 
it down until only the green back-
ground is selected. We’ll click OK 
to exit the Color Range dialog and 
we’ll be left with a selection of the 
green areas. We’ll use this selec-
tion to fix the depth map.

The Select Color Range command is being used to 
target green colors from the background. 

The Select Color Range command was used to  
select the green color in the background.
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With the selection still active, we’ll click on the Depth Map channel to make it ac-
tive and visible in the image window. We’ll make sure the foreground color is set 
to White and we’ll activate the Brush Tool. We’ll use a large brush to paint with 
white over the part of the image that needs to be blurred. The selection will limit 
the paint strokes to the background area.

Now, we can apply the Lens Blur filter again and the background will be blurred 
between the flowers as well.

View image and depth map at the same time There may be times when you’ll 
need to be able to see the actual image while making changes to the depth map 
in the Channels Panel. You can do this by viewing the main depth map as an over-
lay on top of the picture. With the Depth Map channel active and viewable in the 
main image window, turn on the eyeball icon next to the RGB channel. (Don’t click 
on the name of the channel, as this would actually activate that channel. You just 
want it to be visible.) Now the depth map will appear as a red overlay on the pic-
ture and you can use the Brush Tool to refine the mask.  

LEFT: We are painting with white on the Depth Map channel and the selection is limiting 
the paint strokes to the background area. RIGHT: The Lens Blur filter was used and now the 
area between the petals is also blurry.  


