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Advanced Depth Maps 

A depth map is a grayscale image that defines how far away various elements 
are in the scene. The Lens Blur filter can use this image to simulate the look of an 
image with limited depth of field. Note that there are two other Masters Academy 
lessons on depth maps that you may want to visit if you haven’t already. The first, 
“Blurring with Depth Maps,” is an introduction and works with images that already 
have depth maps attached to them. The second lesson, “Creating Depth Maps,” will 
teach you how to create your own depth map for a particular image. This lesson is 
going to cover some more advanced tips and techniques relating to depth maps. 

In the previous lesson, “Creating Depth Maps,” we 
used a series of layers to create a pretty complex 
depth map. All of the layers used to create the depth 
map were placed inside a group in the Layers Panel. 
To recap, the lightest parts of the depth map image 
are the areas that are farthest from the camera and 
the darkest parts are the areas that are closest to the 
camera. 

In order to apply the depth map to the image, we 
need to get it into the Channels Panel. With the depth 
map visible in the document, we’ll click on the Se-
lect menu and choose All. This will create a selection 
around the entire image. We’ll then click on the Edit 
menu and choose Copy Merged. (It’s important that 
we choose the Copy Merged option so that the entire 
image is selected instead of just one layer.) Next, we’ll 
open the Channels Panel and click the New icon at 
the bottom of the panel. This will create a new channel. With this new channel ac-
tive, we’ll click on the Edit menu and choose Paste. This will paste the entire depth 
map into this new channel. We can now click on the top-most channel (RGB) to 
make it active and then return to the Layers Panel. Here, we no longer need the 
selection so we’ll click on the Select menu and choose Deselect. 

In a depth map, the lighter the 
shade, the farther the area was 
from the camera. 



Advanced Depth Maps © Ben Willmore, All rights reserved 3

Apply Depth Map (4:24)

Now that we’ve got the depth map in the Channels Panel, we no longer need to 
see it in the Layers Panel, so we’ll turn off the visibility of the depth map layer 
group. We’ll activate the original image layer and we’ll duplicate it by using the 
keyboard shortcut Command+J. 

With the image duplicate active, we’ll click on the Filter 
menu and choose Blur > Lens Blur. The Lens Blur win-
dow will take over the screen. We need to tell the filter 
to blur the image based on the depth map we creat-
ed, so we’ll click on the Depth Map Source menu and 
choose the name of the channel we just created. (It will 
usually be the last item in the menu.) Then, we’ll click on 
the part of the image that we want to be sharp. In the 
video example, it’s Karen’s face. This will cause Photo-
shop to look at what shade we clicked on in the depth 
map. It will make sure that all areas of that shade are 
the sharpest parts of the image. Then, we can use the 
Radius slider to control how blurry the other areas are. 

In the Lens Blur filter, we’re 
using the Source menu to 
choose the name of the 
depth map channel.

In the Lens Blur filter, 
we’re clicking on the 
part of the image that 
we want to be sharp. 
Everything of that 
shade in the depth 
map will be sharp and 
the other shades will 
become blurry.
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Adjusting the Depth Map using a Curves Adjustment Layer (5:17)

After applying a depth map to an image, you may find that the results are not op-
timal. Often times, an area is either too blurry or not blurry enough. In the video 
example image, the back of the chair looks fine, but the front of the chair is too 
blurry. When this is the case, you’ll need to cancel the Lens Blur filter and make 
changes to the depth map. You could make changes to the individual layers that 
make up the depth map, but an easier option would be to use a Curves Adjust-
ment Layer. 

In the video example, we’ll make the depth map layer group visible and we’ll ex-
pand the folder. We’ll click on the top-most layer within the folder to make it ac-
tive. Then, we’ll click on the Adjustment Layer icon at the bottom of the Layers 
Panel and choose Curves from the pop-up menu. A new Curves Adjustment Layer 
will be placed above that top depth map layer. In the Curves Properties panel, we 
need to make sure that the Targeted Adjustment Tool is active. It looks like a little 
hand icon. With this tool, we can click within the image and it will place a point on 
the curve, representing that targeted brightness level. 

We first want to make sure that 
the shade where Karen is doesn’t 
change, so we’ll click on the image 
in that    area. This will place a point 
on the curve, locking in the bright-
ness of that area so that it doesn’t 
change. Next, we’ll click on the 
area that we want to change (the 
front of the chair) and drag up. By 
clicking and dragging up, we are 
placing a point on the curve and 
moving it upwards. This lightens 
all areas that contain the shade we 
clicked on. We’ll drag up until the 
area appears almost as light as the 
area where Karen is. 

A Curves  
adjustment layer 
was created and 
we’re using  
the Targeted 
Adjustment Tool 
to click and drag 
up on the front 
of the chair. You 
can see that it’s 
getting lighter.
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While we’re at it, we’ll also lighten the back of the chair, which will make it look as 
if it is farther from the camera. We’ll use the Targeted Adjustment Tool to click and 
drag up on the back of the chair. This will place a point on the curve, representing 
that tone, and move it up. The back of the chair will become lighter. 

We’ve made changes to the depth map, so we need to update the depth map 
channel to reflect the changes. With the depth map visible in the document, we’ll 
click on the Select menu and choose All. This will create a selection around the 
entire image. We’ll then click on the Edit menu and choose Copy Merged. Next, 
we’ll open the Channels Panel and click the New icon at the bottom of the panel 
to create a new channel. With this new channel active, we’ll click on the Edit menu 
and choose Paste. This will paste the copied depth map into this new channel. It’s 
also a good idea to rename the channel so that it’s easy to recognize within the 
Lens Blur source menu. 

In this Curves  
adjustment  
layer, one point 
was placed to 
lock in the shade 
where Karen is. A 
second point was 
added to lighten 
the front of the 
chair and a third 
point was added 
to slightly lighten 
the back of the 
chair.



Advanced Depth Maps © Ben Willmore, All rights reserved 6

We’ll click on the top-most channel to make it active and then we’ll return to the 
Layers Panel. We no longer need the selection so we’ll click on the Select menu 
and choose Deselect. We’ll turn off the visibility of the depth map group and click 
on the image duplicate layer to make it active. Now we’ll run the Lens Blur filter 
again. We’ll click on the Filter menu and choose Blur > Lens Blur. The Lens Blur 
window will appear and we’ll use the Source menu to choose the name of the 
channel we just created. Finally, we’ll click on the area we want to be the sharpest, 
and that’s the area where Karen is. Now, the front of the chair is not as blurry and 
looks more natural.

After the depth map was updated, the Lens Blur Filter was run again and you can see that the 
front of the chair is not as blurry.



Advanced Depth Maps © Ben Willmore, All rights reserved 7

Adjust the Depth Map Channel with a Curves Adjustment (11:42)

 In the technique above, we adjusted the depth map by using a Curves Adjustment 
Layer within the Layers panel. We could also adjust the channel directly by using a 
Curves adjustment in the Channels Panel. With the depth map channel active, you 
would click on the Image menu and choose Adjustments > Curves. The Curves 
dialog will appear and you can use the Targeted Adjustment Tool in the same way. 

Limiting Curves Adjustment to Affect Specific shades

When we place a point on the curve and then move that point, it will cause the en-
tire curve line to change shape. This means that all shades will be affected to a cer-
tain degree. That’s usually not what we want. We usually want to alter a very spe-
cific shade (especially with depth maps) while leaving the other tones unchanged. 
We can achieve this by placing an additional point (or points) on the curve and 
positioning it in such a way that the curve line returns to its normal diagonal. This 
point will generally be placed very close to the point that is making the curve line 
go off track. We can add this point by simply clicking on the curve line in the place 
we want it to appear. Note that if you try to click too close to another point, it will 
think that you want to move that point instead of add a new one. You may have 
to click a little farther away from the point and then drag the new point so that it’s 
as close as is practical. 

LEFT: The curve 
points caused 
the entire curve 
to change shape, 
shifting all of the 
tones in the image. 
RIGHT: A point is 
placed on the curve  
and positioned so 
that it returns the 
curve to its normal 
diagonal.
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Adding Noise/Grain to Blurred Area (13:45)

If we use the Lens Blur filter on 
an image that had a lot of noise, 
the sharp area will have noise and 
the blurred area will not. This can 
cause the result to look unnatu-
ral and make it obvious that we 
added the effect in Photoshop. 

The Lens Blur filter has a setting 
for adding noise to the areas that 
were blurred. Under the Noise 
category on the right side of the 
interface, there is an Amount slid-
er. Zoom in on the image so that 
you can better see the noise and 
slowly move up this slider. A low 
setting will usually add enough 
noise to the image. Then, you will need to choose between Uniform and Gaussian 
(which will create a rougher texture). Experiment with these settings to see which 
creates noise that best matches the sharp areas in the image. 

We can also add noise in Photoshop by means of the Camera Raw filter. Camera 
Raw has the most sophisticated noise generation algorithm that I can think of. 
Before opening Camera Raw, we’ll need to create a selection that describes where 
we’ve blurred the picture. This selection will be in the form of a channel, where the 
areas that are white will have the noise applied (the blurry areas) and the black ar-
eas will not. In order to create this channel, we can duplicate the depth map chan-
nel and then modify the duplicate using a Curves adjustment. This adjustment will 
force areas that should have noise added to become white and it will force areas 
that should not have noise added to become black. 

In the Lens Blur filter, the Noise settings are being 
used to add grain into the blurry parts of the image.
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We’ll open the Channels Panel and duplicate the depth map channel by dragging 
it to the New Channel icon at the bottom of the panel. We’ll modify this channel 
so that we can use it for adding noise. We’ll click on the Image menu and choose 
Adjustments > Curves. We’ll make sure the Targeted Adjustment Tool is active and 
we’ll use it to click on the area where we DON’T want to add noise. In the video ex-
ample, that will be the area where Karen is. This area is sharp and therefore already 
has noise. This will place a point on the curve. We will drag that point all the way 
down to the bottom of the curve grid, making the area black. Remember, when we 
apply the noise, black areas will have no noise added. 

The background is blurry and therefore, it SHOULD have noise applied. In the 
channel, the background is already white, and that’s what we want (because white 
areas WILL have noise applied).

The front of the chair and the floor closest to the camera are areas that are cur-
rently blurry. They should have noise applied, but they are currently black in this 
channel. We need to lighten the areas so that the noise will be applied there. 

We’re using a 
Curves adjustment 
to modify a channel 
that will be turned 
into a selection. We 
used the Targeted 
Adjustment tool to 
click on Karen and 
this placed a point 
on the curve. We 
dragged that point 
to the bottom of 
the curve, therefore 
making the target-
ed area black.
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In the Curves dialog, the point in the bottom left corner represents the areas that 
were originally black in the image. We need to take these areas that used to be 
black and make them white. We’ll do this by dragging that bottom left point all the 
way to the top of the curve. 

We can further refine the channel by using the Targeted Adjustment Tool to click 
and drag on areas in the channel. We’ll click and drag up on areas that should have 
more noise and we’ll click and drag down on areas that should have less noise. The 
back of the chair should have SOME noise applied because it’s only partially blurry 
so we’ll click and drag up a bit on that area, making it a bit lighter. We’ll also click 
and drag up a bit on the front of the chair. Once we’re satisfied with the channel, 
we’ll click OK to exit the Curves dialog.

We now need to load this channel as a selection. When we turn a channel into a 
selection, white areas will be completely selected. Black areas will not be selected 
and gray areas will be partially selected. We’ll load the channel as a selection by 
holding down the Command key (Ctrl on Win) and clicking on the channel thumb-
nail. We’ll now click the top-most channel to get back to the main image and we’ll 
return to viewing the Layers Panel. We’ll make sure the blurred image layer is ac-
tive, we’ll click on the Filter menu and choose Camera Raw Filter. 

The point on the bottom 
left corner of the curve 
was dragged all the way 
to the top. This took all 
areas that were formerly 
black and made them 
turn white.
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Camera Raw will take over the screen and all of the settings sliders will appear on 
the right side. We’ll click on the FX icon to open the Effects panel. Here, there is 
a category of settings for Grain. We’ll use the Amount slider to add noise to the 
image and we’ll use the Size and Roughness sliders to define how that noise looks. 

NOTE: When we make changes with the Camera Raw Filter, the preview is not go-
ing to respect the selection that was active, which means that it will appear that 
the entire image is being affected. When we click the OK button, that will not be 
the case. In the final result, only the selected areas will receive the Camera Raw 
adjustments. 

To get a before-and-after view of the effect on the image, we can click on 
the little icon that looks like three sliders in the bottom right corner of the 
image window. Toggling this view will allow us to better match the noise 
we’re adding to the noise that was already existing in the sharp areas of the image. 

When we’re finished adjusting the noise settings, we’ll click OK to exit Camera Raw 
and return to the main Photoshop interface. Because we had a selection active, 
the adjustment of added noise will only be applied to the areas that were selected. 

The grain settings can be found within the Effect panel (circled) in Camera Raw.
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Use Depth Maps to Create a Miniature Look (25:39)

When we shoot something with a 
wide angle lens, it is very difficult to 
get a blurry background. In order to 
get a blurry background, we need to 
be shooting at the widest aperture 
setting and we need to magnify the 
scene, either by using a longer lens 
or by shooting very close to the sub-
ject. If you have a scene that encom-
passes a large area, it usually means 
that it was shot with a wide angle 
lens. Wide angle lenses don’t magni-
fy things, so we’re generally not go-
ing to get that shallow depth of field.

If we take a wide scene and use a 
depth map to create a narrow depth 
of field, it’s going to be a bit like a 
mind trick. Our brains will tell our 
eyes that we’re looking at something 
that’s miniature. In the video exam-
ple, we have an image of a service 
station that was shot with a wide 
angle lens. I applied a depth map to 
blur the image and the result makes 
it look as if the building is tiny, as if 
it’s part of a toy train set.  Let’s look 
at a how to tackle a few challenges 
when creating a depth map like this.

Above, you can see the original image, the depth 
map and the result of the Lens Blur filter.
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Creating the gradient from front to back With a depth map, the areas of the im-
age that are closest to the camera will be black and the areas that are farthest 
from the camera will be white. Therefore, the ground, or surface, will have a gra-
dient from black to white. We could create a selection of the ground and then 
apply a Gradient adjustment layer with a black-to-white gradient, but that will not 
account for the perspective in the scene and it will therefore not look natural. I ran 
into this challenge with the service station image. 

Here’s how we can create a more natural 
gradient. We’ll use the Rectangular Mar-
quee Tool to make a selection around 
the bottom part of the image. The top 
end of the selection will determine how 
far the gradient should extend before 
it turns white. With the selection ac-
tive, we’ll click on the Adjustment Layer 
icon at the bottom of the Layers Panel 
and choose Gradient. A dialog will ap-
pear and here, we’ll choose the black-to-
white gradient, ensuring that black is on 
the bottom, and click OK. The selection 
will automatically be applied to the layer mask attached to this gradient layer and 
the layer mask determines where the gradient starts and ends

Next, we’ll turn this layer into a Smart Object by clicking on the Layer menu and 
choosing Smart Objects > Convert to Smart Object.

Now, we want to transform this layer so that it matches the perspective lines in the 
image. We’ll click on the Edit menu and choose Transform > Perspective. Trans-
form handles will appear on the layer and we’ll drag one of the bottom corners 
outward, away from the image canvas. We’ll drag the corner outward until the 
edge of the transform box matches the perspective in the image. Then we’ll click 
Return/Enter to lock in the transformation. Now, the gradient will create a more 
natural blur effect when we apply the Lens Blur filter. 

A gradient layer was created for the ground, 
but the default black-to-white gradient does 
not account for the perspective in the scene.
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Depending on the image, you may need to alter the mask to account for any build-
ings or objects extending into the scene. In the video example, we had to alter 
the mask so that the gradient did not overlap the buildings that were extending 
forward into the scene. These are closer to the camera and should therefore not 
receive the same blurring effect. 

The Perspective Transform command is being used to make the perspective of the gradient 
layer match the perspective of the image.

We adjusted the layer mask for the gradient layer so that the gradient did not overlap the 
building on the left.
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Layer buildup (38:10)

Several layers were used to create the depth map for this service station image. 
Let’s look at the build-up of layers to see how the depth map was created.

1: A Gradient layer was created for the ground. 
2: A Gradient layer was created for the building on the right. 
3: A Gradient layer was created for the building on the left.

7: A Solid Color layer was created for the service station building. 
8: A Solid Color layer was created for the windows in the buildings. I wanted to blur the area 
where you could see through the windows, so these areas were assigned a very light shade. 
9: A Curves Adjustment Layer was used to fine-tune the results. 

4: A Solid Color layer was created for the front face of the building on the left. 
5: A Solid Color layer was created for the tank and pumps. The shade was chosen based on 
the shade of the underlying gradient in the area where the tank meets the ground. 
6: A Solid Color layer was created for the gas pumps. The shade was chosen based on the 
color of the underlying gradient where the pumps touched the ground.
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Clean up Jagged Artifact (46:00)

After creating a depth map made up of several layers, it’s not uncommon to end 
up with a jagged artifact along the edges between layers. That happened around 
the edges of the gas pumps in the video example. 

We can fix this after copying the depth map layers and pasting them into the 
Channels Panel. In the Channels Panel, we’ll make sure the depth map channel is 
active and we’ll activate the Brush Tool. We want to sample the shade that is sur-
rounding the object with the jagged edge (the gas pump). With the Brush Tool 
active, we’ll hold down the Option key (Alt on Win) to temporarily access the 
Eyedropper. Holding down this key, we’ll click to sample the shade just outside the 
pump. This will become the foreground color, which is what we’ll be painting with.

Now we will get a little tricky. In the Options Bar above the image window, we’ll 
use the Mode menu to change the blending mode of the brush to Darken. With 
Darken mode, the brush will only be able to darken the image. It will not be able to 
lighten the dark gas pump as we paint over it. We’ll use the Brush to paint over the 
edge of the pumps and the jagged edge will be filled in and therefore disappear. 

LEFT: We’re sampling the shade surrounding the gas pumps. RIGHT: We’re using the Brush 
Tool, set to Darken Mode, to paint with the sampled color around the edge of the pumps. 
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Adjusting the Depth Map with the Gradient Editor

After creating all of the individual depth map layers, you’ll want to inspect the fi-
nal result for issues. These can often turn up when one object is a different shade 
from another object that it’s touching. If the objects are touching, they should be 
the same distance from the camera and therefore the same shade. This happened 
with the example image of Karen doing a handstand. The layer for Karen was 
one shade of gray, but the concrete where her hands were touching was another 
shade. 

To correct this, I adjusted the gradient layer for the curved sidewalk. I double-clicked 
on the gradient thumbnail in the Layers Panel to call up the Gradient Map dialog. 
Here, I clicked within the gradient bar and this opened the Gradient Editor. The 
gradient bar has little markers beneath it, representing the colors in the gradient. 
Between these two markers is a little diamond slider that represents the midpoint 
of the transition. I dragged this slider back and forth, watching the result on the 
gradient. I ended up positioning this slider so that the part of the gradient where 
Karen’s hands are matched the shade of gray that she was. 

LEFT: The original image. RIGHT: You can see that the sidewalk layer and Karen’s hands are 
different shades of gray.
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LEFT: In the Gradient Editor, 
the slider representing the 
transition midpoint (circled) 
is being adjusted so the gra-
dient matches Karen’s hands. 
BELOW: Here, you can see 
the result of the Lens Blur 
filter.


