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PS/LR Layout Automation 

In this lesson, we’re going to 
use a variety of techniques to 
create a Photoshop action that 
we can use in a Lightroom ex-
port preset to automate the 
creation of a special photo lay-
out. 

Even if you don’t need to cre-
ate a photo layout (or tem-
plate) like this, the lesson will 
give you a good idea of how I 
use many Photoshop features 
for more than one purpose.

Create an Export Preset in Lightroom (Timestamp 1:47)

We’re going to start in Lightroom and learn how to best save a set of images so 
that Photoshop will be able to utilize them layer. We’ll create an Export Preset for 
that. We’ll click on the File menu and choose Export. The Export dialog will appear 
and this is where we’ll create a new Export Preset. This dialog contains several 
categories of settings and here are the one we’ll use:

Export Location: This is the hard drive location where the files will be saved after 
they’ve been exported. We’ll choose a location that is obvious and easy to remem-
ber. (In the video example, I used the Desktop.) We’ll turn on the “Put in Subfolder” 
check box and give the Subfolder a name. You can also specify what happens to 
the files that are already located in the specified location and I will set this “Exist-
ing Files” menu to Overwrite Without Warning. I am using this option because I 
want to create a “Best of the Week” layout and I am fine with the previous week’s 
images being discarded. 

We’re going to create an action that will automate the 
creation of a layout like this.
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File Naming: In this category, we do not want to use the original file names. We 
want to specify a new name because the action that we’re going to create in Pho-
toshop is going to use the name of the file. If the file names are not consistent, 
the action will not work. We’ll click on the “Rename To” menu and choose Edit. A 
Filename Template Editor box will appear and here we can customize the names. 

We’ll delete any existing file name 
parameters from the text field and 
we’ll type in the custom name. In the 
video, I am naming the files “Best 
of the Week “. Then, we’ll want to 
have sequence numbers at the end 
of each file name, so we’ll set the 
Sequence menu to “Sequence # 
(1)” and then click the Insert button. 
You’ll see this sequence parameter 
added to the file name field. 

NOTE: I chose “Sequence # (1)” be-
cause I know that I’m only using 
six images. Therefore, I only need 
single digits. If you are using more 
images, you will need to use a se-
quence option that will allow for 
the appropriate amount of digits. 
We’ll click the Done button to re-
turn to the main Export dialog. 

In the Export Dialog, 
we chose to Export 
To the Desktop. We 
turned on the “Put In 
Subfolder” check box 
and are naming the 
new subfolder “Best of 
the Week.”

Here, we are editing the file names of the exported 
images. They MUST be specific and in sequential 
order.
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File Settings: We’ll set the Image format to JPEG with a Quality setting of 100. The 
Color Space is a personal preference. I am using Adobe RGB. 

Image Sizing: This is where I’m going to use some special settings. When I travel, I 
don’t always have the hard drive that contains my images with me. Therefore, I use 
Smart Previews. Lightroom allows you to export Smart Previews up to a particular 
size, even when the hard drive that contains the pictures is not connected to the 
computer. That size is 2,560 pixels in width and height. We’ll enter this number 
into both the Width and Height fields and make sure the units menu is set to Pix-
els. The Resolution setting doesn’t matter as much, but we’ll use 240 pixels per 
inch here. 

Output Sharpening: This will depend on whether the image layout is going to be 
something you print or use online. 

Post-Processing: I’ll make sure the “After Export” menu is set to Do Nothing.

Now we need to save these settings as 
a new Export Preset. We’ll click on the 
Add button at the bottom of the preset 
list on the left side of the dialog. We’ll 
be prompted to name the preset and 
then click Create. In the video example, I 
named the preset “Best of the Week.” 

Now that we’ve created the preset, we can actually click the Cancel or Done but-
ton at the bottom of the dialog. This will not undo the preset creation. It just 
means that we don’t want to export any images at this time.

We’re limiting 
the Image Size 
to 2,560 pixels 
in width and 
height.

We’re saving the export settings as a new 
preset.
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Export Images (9:03)

Next, we’re going to export some images using that preset. We’ll select our imag-
es in Lightroom’s Library Module (In the video, we chose six.), we’ll click on the File 
menu and choose Export with Preset. A preset menu will appear and we’ll choose 
the preset we just created. In the video example, that’s the “Best of the Week” pre-
set. The exported images will automatically appear in the hard drive location that 
was specified in the preset. In the video example, that’s the desktop, so we end up 
with our “Best of the Week” folder of six images on the desktop. 

Create Photoshop Action (9:46)

Now we’re going to move on to Photoshop. Here, we’re going to create an action 
that creates a brand new file and then populates that file with the pictures we 
just exported. We’ll go to Photoshop’s main interface with no document open. If 
the Actions panel is not already visible on the interface, we’ll click on the Window 
menu and choose Actions. I like to organize my actions in folders, so I’ll click on the 
New Folder icon at the bottom of the 
Actions panel to create a new folder 
and name it “Best of the Week.” With 
that folder active, we’ll create a new 
action inside that folder by clicking 
on the New icon at the bottom of the 
Actions panel. The New Action dialog 
box will appear and here we’ll name 
the folder (I named mine “Best of the 
Week”) and then click the Record but-
ton. You will see that the red Record 
icon will light up at the bottom of the 
Actions panel to indicate that we’re recording.

In the Actions Panel, we created a folder in 
which to place the action. Now, we are clicking 
on the New icon in order to create a new action 
within that folder.
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Create new document At this point, we need to be very careful because every-
thing we do that has the potential of changing an image will be recorded in this 
action. We’ll click on the File menu and choose “New” to create a new document. 
When the New Document window appears, do NOT simply use the last-used set-
tings and click ok. You’ll need to manually tell Photoshop what the document size 
should be so that it’s recorded in the action. In the video example, I clicked on 
the Photo preset category and chose the preset that sizes the document at 7 x 5 
inches @300 ppi. Then click the Create button and the new document will appear. 

Create pattern background We’re 
going to create a background 
for our photo layout by clicking 
on the Adjustment Layer icon at 
the bottom of the Layers Panel 
and choosing “Pattern” from the 
pop-up menu. A new Pattern Fill 
layer will appear and the Pattern 
Fill dialog will open. Here, we can 
use the menu to choose a pattern 
that we’d like to use as the back-
ground. Note that you can use 
the little side menu of the pattern 
picker to access more categories 
of patterns. In the video exam-
ple, we choose a tree pattern and 
then clicked OK. 

Optimize Layers Panel Whenever I create actions, I always like to optimize my 
Layers Panel. Since I know that I’m not going to need the layer mask that is at-
tached to the Pattern Fill layer, I will click and drag that mask to the trash can icon 
at the bottom of the panel in order to discard it. We also don’t need the back-
ground layer so I’ll drag that to the trash as well. Now I only have the Pattern Fill 
layer. I’ll double-click on its name and rename it to “Pattern Background.”

A Pattern Fill layer is being created to serve as the 
background for the image layout.
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Blur the background At this point, I think 
that the chosen pattern has too much detail 
as a background and it will distract the at-
tention away from the images. We want to 
lessen that detail a bit. We’ll first click on the 
Filter menu and choose “Convert for Smart 
Filters.” By applying a filter as a Smart Filter 
(to a Smart Object layer), we will be able to 
go back and change the filter settings at a 
later time. 

We’ll click back on the Filter menu and choose 
Blur > Motion Blur. The Motion Blur dialog will 
appear, containing some settings. We’ll move 
the Distance slider up until the background 
looks more simplified and we can’t really tell 
that it’s trees. We’ll click OK to apply the fil-
ter. The Motion Blur Smart Filter will appear 
beneath the Pattern Background layer in the 
Layers Panel. Again, I will simplify the Layers 
Panel by dragging the filter’s layer mask into 
the trash. (I know I’m not going to use it later.)

Create the layout Now we’re going to create the layout in which the photos will be 
placed. In the video example, I am creating the layout in which to place six images, 
so I will create six boxes. We don’t want to simply drag out shapes, however. We 
want the shapes to be evenly sized and spaced. To accomplish that, we’ll click on 
the View menu at the top of the screen and we’ll choose “New Guide Layout.” The 
New Guide Layout dialog box will appear and some default settings will be ap-
plied. We’re going to use the settings to set up the guides to create three images 
horizontally and two images vertically (to create six image frames). 

The pattern layer was converted to a 
Smart Object and we are now applying 
the Motion Blur filter to this layer. 

The Motion Blur was applied to the layer 
as a Smart Filter and we discarded the 
layer mask because we don’t need it.
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We’ll enter 3 for the number of columns and 2 for the number of rows. We’ll make 
sure the Margin check box is turned on so that we have access to the margin set-
tings. These are the settings that will give us space around the four edges of the 
frame. To use these settings, type in a number to serve as a starting point and then 
use the up and down arrow keys to make the numbers larger or smaller. You can 
also hold the Shift key to move the numbers in higher increments. You can visually 
see the effect on the guides in the document window.

I want the top of the document to contain some room for text, so I’ll enter a high-
er number for the Top margin. In the video example, I used 230 px. I set the Left, 
Right and Bottom margins to 60 px. 

We’ll use the Gutter settings to determine how much space should appear be-
tween the rows and columns. Again, you can type in a number as a starting point 
and then use the arrow keys to change the number while you visually watch the 
effect on the guides. In the video, I set the gutters to 60 and clicked OK to exit the 
New Guide Layout dialog. 

The New Guide Layout command is being used to create very specific guides that will define 
the layout.
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Add Frames We now need to define the areas where the images should appear. 
We’ll do that with the Frame Tool, which can be found in the Toolbar on the left 
side of the interface. The Frame Tool allows us to insert placeholder rectangles. 
With the Frame Tool active, we’ll drag out six frames within the rectangles that we 
created with the guides. The tool will snap to the edges of the guides, helping us 
create perfectly even rectangles. 

Insert Images It’s time to place images inside the frames, but we need to be care-
ful when doing this, because we’re still recording the action. The action needs to 
know which frame should be active. We’ll click on Frame 1 within the Layers Panel 
to make that first frame active. Then we’ll go to the location where we exported 
the images from Lightroom. In the video, that’s a folder that was created on the 
desktop. We’ll open the folder and drag the first image directly into that first frame 
in Photoshop. The image will scale down automatically so that the width or height 
is sized to perfectly fit the frame.

The Frame Tool 
is being used 
to drag out 
boxes inside 
the guides.
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We’ll click on the second frame in the Layers Panel to make it active. We’ll go back 
to the image folder and drag the second image into this second frame. We’ll re-
peat this process with all six images, making sure to go in order and to activate 
each frame before dragging the image into it.

After all images have been placed, we can remove the guides by clicking on the 
View menu and choosing Clear Guides.

We clicked on 
the first frame 
to make it 
active and you 
can see that it 
was recorded 
in the action.

The images are being dragged from the folder on the hard drive, directly into the photo 
frames.
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Create layer group and add a Drop Shadow We can 
create a drop shadow behind the images to create a 
little more separation from the background, but we’ll 
need to do this in a special way because layer styles 
do not work properly on frame layers. To get around 
this, we’ll select all of the frame layers in the Layers 
Panel and we’ll click on the Folder icon at the bot-
tom of the panel. This will place all of the layers into a 
folder, or group. With the group active, you can apply 
a layer style and it will collectively apply the style to 
everything that’s inside the folder. 

We’ll make sure the group is active and we’ll click on 
the FX icon at the bottom of the Layers Panel and 
choose Drop Shadow from the pop-up menu. We’ll 
use the Drop Shadow settings to adjust the size, opac-
ity and distance of the shadow, looking at the preview 
in the main image window. When we’re happy with 
the result, we’ll click OK to exit the Layer Style dialog. 

Add Text Now we’re going to add some text to the layout. Before adding a new 
layer, we’re going to click on the Select menu and choose Deselect Layers. (Be-
cause we’re recording an action, it’s best to create a new layer when there are no 
layers active already.) 

We’ll activate the Text Tool, which can be found 
in the Toolbar on the left side of the screen. The 
Text Tool is going to apply the foreground color 
to the text and it’s important that we manually 
set the foreground color so that it’s recorded 
in the action. If we didn’t do this, the action will 
use whatever foreground color is active at the 
time. We’ll click on the foreground color swatch 
and use the Color Picker to select a color. We’ll 
click OK to close the Color Picker.

All of the layers are selected 
and we are clicking the New 
Folder icon to place them 
inside a layer group.

The foreground color is being set to 
determine the color of the text.
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We’ll make sure that the center justification icon is active in the Options Bar and 
we’ll click in the top center area of the image. This will insert some highlighted 
placeholder text. We’ll type in our new next and we’ll use the font and size settings 
in the Options Bar to specify what the text should look like. It’s important to man-
ually use these settings so that the font, style, size etc. is recorded in the action.

The text should be centered in the document so we’ll activate the Move Tool. Be-
cause only one layer is active, the alignment icons in the Options Bar are grayed 
out. We can get around this by clicking on the Select menu and choosing All. This 
will create a selection of the entire document. Whenever there 
is a selection active, the alignment icons will appear and they 
will align the current layer with the selection. We’ll click the align 
center icon to center the text. We’ll click on the Select menu 
again and choose Deselect. 

I like to add a drop shadow to the text as well, so with the Type layer active, we’ll 
click on the FX icon at the bottom of the Layers Panel and choose Drop Shadow 
from the pop-up menu. The Layer Style dialog will appear and we’ll set the drop 
shadow settings and then click OK. 

The Text Tool is being 
used to add text and 
we’re using the settings in 
the Options Bar to specify 
the size, font, etc. All of 
these things will be re-
corded in the action.

The Align Centers 
icon
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Stop recording and test action We’ll now open the Actions Panel again and click 
on the Stop button at the bottom of the panel. This will stop recording the action. 
We could test the action by first closing the document (because the action start-
ed with no active document), then opening the Actions Panel in Photoshop’s main 
interface, clicking on the name of the action and then clicking the Play button. 

Adjusting the Results (29:01)

The action was created so that the background pattern is a smart object. This 
means that we can change it after running the action if we’d like the background 
to be different. We would double-click on the Pattern Background layer and it will 
open in a separate Photoshop document window (because it’s a Smart Object). 
Here, we could click on the thumbnail in the Layers Panel to call up the pattern 
picker, choose a different pattern and then click ok. When we save and close this 
document, the smart object layer will update in the original layout document. The 
smart filter will be reapplied so that the motion blur is applied to the new pattern.

We can also use the Move Tool to re-
position the images within their indi-
vidual frames. If the Auto-Select set-
ting (in the Options Bar) is turned off, 
you can hold down the Command key 
(Ctrl on Win) and click on one of the 
image boxes to make it active. We’ll 
double-click on the image to make it 
active. We can then reposition the con-
tent. (If you did not double-click to first 
make the image active, then the frame 
would move along with the image and 
that’s not what we want.) With the Move Tool active, we activated the 

frame layer and double-clicked on the image 
so that we could drag it around inside the 
frame.
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Using the Action (31:50)

After using the action to create a layout, you can discard that resulting file, as well 
as the folder of images that was exported from Lightroom, because the action will 
not need any of that in order to work again. 

The next time you want to create a layout, select the images in Lightroom’s Library 
Module and export them using the Export preset we created early in the lesson. 
This will place the new folder of images on your hard drive. Then, open Photoshop 
and run the action. It will automatically find the folder and use the included imag-
es to create the layout. 

  


