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Gallery Wraps & Actions

In this lesson, we’re going to cover two topics: gallery wraps and the actions we 
can use to set a file up for a gallery wrap. When we say “gallery wrap,” we’re refer-
ring to the type of print where canvas is wrapped around a wood frame. We need 
to decide what content is contained around the edge of the image document in 
the part of the canvas that is wrapping around the wood. There are a few options 
for what we can do in this area. We could reflect the image on to the edge of the 
wrap. We could fill the area with a solid color, etc. After we learn how to incor-
porate the wrap area into our image files, I will show you how you can turn that 
process into a Photoshop action. 

Manually Turn Image into a Canvas Wrap (Timestamp 4:20)

Let’s look at how we can manually take an image and prepare it for a canvas gal-
lery wrap. In this example, we’ll create a 1-inch wrap. This means that we’ll need 
to select a one-inch strip from the left edge of the picture, copy it, flip it horizon-
tally, then make the document one inch larger and move the copied strip into the 
newly created space. This will need to happen for the other three edges of the 
image as well. 

A gallery wrap refers to the type of print where a canvas is wrapped around a wood frame. We 
need to take extra care in setting our images up for this type of printing because we need to 
control what appears on the part of the canvas that is wrapped around the wood.
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We’ll start by activating the Rectangular Marquee Tool. When this tool is active, 
some settings will appear in the Options Bar above the main image window, in-
cluding measurements for the Width and Height of the selection. For the Width, 
we’ll enter in one inch. Since we’re not sure how tall this document is, we’ll just en-
ter in something super large for the height, like 99 inches. With these Width and 
Height fields, it’s important to know that the measurement system isn’t always 
going to be consistent. The unit type is going to be based on what the document 
rulers are set to. If the rulers are set to pixels, then these fields will read pixels 
instead. If that’s the case, you can force the units to measure in inches by typing 
“in” after the Width and Height numbers. 

Now we can click within the document and the rectangular selection will appear. 
Instead of just clicking, however, we will click and drag left so that the selection 
aligns with the left edge of the image. Next, we’ll click on the Layer menu and 
choose New > Layer via Copy. Alternatively, we could use the keyboard shortcut 
Command+J (Ctrl+J on Win). This will create a new layer that contains a copy of 
the selection contents. 

With the Rectangular 
Marquee active, we set 
the Style menu (in the 
Options Bar) to Fixed 
size and then entered 
1 inch for the Width 
and 99 inches for 
the Height. Then, we 
clicked within the  
document and 
dragged the cursor 
to the left side of the 
image. This created a 
1-inch wide selection 
of the left edge of the 
image.
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Now we need to flip this new layer horizontally. We can do that by clicking on the 
Edit menu and choosing Transform > Flip Horizontal. We’ll then use the Move Tool 
to drag this layer to the left until the right edge of the layer aligns with the left edge 
of the document. While doing this, we can hold down the Shift key to make sure 
that we’re only moving the layer directly to the left and not up or down at all. We 
won’t be able to see the layer because it is outside of the document bounds, but 
the smart guides should help us to snap the layer to perfectly align with the edge. 

We need to extend the canvas out so that it includes this mirrored layer and we 
can do that by clicking on the Image menu and choosing Reveal All. This com-
mand will reveal any part of the document that extends beyond the canvas that 
we currently have. Now we have two layers: the original image layer and the copy 
that we made of the left edge of the document. We’ll merge those two existing 
layers by clicking on the Layer menu and choosing Merge Down or Flatten Image. 

ABOVE: After making a selection of the left 
edge of the image, we copied that selection 

to its own layer. RIGHT: The new layer was 
flipped horizontally, moved left so that the 

right edge lined up with the left edge of the 
document and then we expanded the canvas 

to include the layer.
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The next steps will be to repeat this 
process for the other three edges 
of the document. For the top and 
bottom edges, we’ll need to swap 
the Width and Height numbers 
when making the initial selections. 
With the Rectangular Marquee tool 
active, we’ll want the Width field (in 
the Options Bar) to read 99 inches 
and the Height field to read 1 inch. 
Then, after duplicating the selec-
tion to its own layer, we’ll need to 
flip the layer vertically by clicking 
on the Edit menu and choosing 
Transform > Flip Vertical. 

Creating a Gallery Wrap Action (10:06)

We just learned the process for preparing an image to print as a gallery wrap. 
If this is something you need to do all the time, it can be convenient (and more 
efficient) if you had a Photoshop action that sped up the process. While the 
steps may have seemed pretty straightforward, it’s going to become more diffi-
cult when we try to automate the process. 

There are lots of problems that can arise when creating an action that will need to 
be universally applicable to any picture. First of all, when we create the first selec-
tion of the image’s left edge, it’s going to record that selection based on what the 
rulers are currently set to. If the rulers happen to be set to pixels, the action step 
will be recorded in pixels and that is going to be a problem because the action is 
going to be run on images of all kinds of different resolutions. We need to make 
sure that the action is recorded in inches. 

This is what the 
document looks 
like after all 
four edges were 
duplicated and 
flipped to create 
the gallery wrap.



Gallery Wraps & Actions © Ben Willmore, All rights reserved 6

The other problem is that the action is going to record the height of the selection 
based on the height of the document. Every image is going to have a different 
height, so we’re going to need to get around this obstacle as well. We’ll need a 
selection that is one inch wide and as tall as the document height, regardless of 
how tall that document is. In order to achieve this, we’re going to use more than 
one document while recording the action so that we can apply some tricks. 

We’ll start with a regular image document and we’ll create that 1-inch wide selec-
tion on the left side of the image (using the Rectangular Marquee with the tech-
nique detailed above). We are not recording an action at this point.

We’ll start recording the action in a new, stand-in document that will allow us to 
get around some of the obstacles. We’ll click on the File menu and choose New. 
The New Document dialog will appear and we’ll need to set up the dimensions on 
the right side of this dialog. We’ll set the Width to 1 inch, the height to 200 inches 
and the resolution to 1 pixel/inch. It doesn’t matter that it’s specifically 200 inch-
es. What’s important is that it’s larger than the largest document you would ever 
open. We’ll click the Create button and the new, odd-shaped skinny document 
will appear in Photoshop. 

We’ll make sure that the Actions panel 
is open in Photoshop. If it’s not open, 
we can access it by clicking on the Win-
dow menu and choosing Actions. We’re 
going to create more than one gallery 
wrap action, so we’ll first create a fold-
er in which to place these actions. We’ll 
click on the Folder icon at the bottom of 
the Actions panel and a dialog will ap-
pear, prompting us to name the folder. 
We’ll type in “Gallery Wraps” and then 
click OK. The new folder will appear at 
the bottom of the Actions panel. 

We opened the Actions panel and created a 
new folder in which to place the gallery wrap 
actions. Create a new folder by clicking the 
folder icon (circled).
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With this folder active, we’ll now click 
on the New icon ( [+] ) at the bottom 
of the Actions panel in order to start 
recording a new action. The New Ac-
tion dialog will appear, prompting 
us to name the action. We’re going 
to create an action that creates a 1” 
wrap so we’ll enter the name ‘1” Gal-
lery Wraps’ and then click the Record 
button. The record icon at the bottom of the Actions panel will turn red, which 
means that it’s recording everything we do. This means that we need to be extra 
careful in the way we go about creating the action. 

We’ll activate the Rectangular Marquee Tool and use the settings in the Options 
Bar to make sure that the Width is set to one inch and the height is set to 200 inch-
es. Then we’ll click somewhere within the top left corner of the document. (We’ll 

need to be zoomed in pretty far because of the 
odd document shape.) We’ll make sure that the 
selection lines up with the top left corner of the 
document. After making this selection, we can 
see the action step that was recorded. The ac-
tion says to create a selection that starts in the 
top left corner of the document and that the 
selection is 1 inch wide by 200 inches tall. No 
document will really be this tall, but it ensures 
that the selection will extend to the bottom of 
any document we open. 

Now that we have the selection step recorded, we can move back to the regular 
image document in order to continue recording the action. Before doing this, 
however, we’ll tap the Stop icon at the bottom of the Actions panel. This will stop 
recording the action so that the document switch does not become a step. 

We clicked the New icon at the bottom of the 
Actions panel in order to create a new action 
that we’re naming 1” Gallery Wraps.

You can see how the first step in 
the action was recorded to create a 
selection that starts in the top left 
corner and extends one inch to the 
right and 200 inches to the bottom.
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With the image document open, the 1-inch wide selection should still be active. 
We’ll tap the Record button again so that we can proceed with recording the ac-
tion.

We’ll duplicate the contents of the selection 
by clicking on the Layer menu and choosing 
New > New Layer Via Copy. Then we’ll flip 
that new layer by clicking on the Edit menu 
and choosing Transform > Flip Horizontal.

At this point, there should be three steps 
in the 1” Gallery Wrap action. The first step 
creates the selection. The second step du-
plicates the contents of the selection onto a 
new layer and the third step flips that new 
layer horizontally. We now need to take that 
new layer and move it to the left, outside 
of the canvas area. We’ll activate the Move 
Tool and then click and drag left on the layer 
until it snaps to the edge of the document. 

We need the canvas to expand to include 
this new layer so we’ll click on the Image 
menu and choose Reveal All. Then, we’ll 
click on the Layer menu and choose Merge 
Down. This will merge the current layer with 
the underlying image layer so that the doc-
ument contains just one layer. 

This is what the action looks like after 
we completed the gallery wrap for the 
left side of the image. We created a 
selection, duplicated that selection onto 
a new layer, flipped that new layer hor-
izontally, moved it over, extended the 
canvas and then flattened the document.
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Next, we need to select a one-inch wide 
area from the right edge of the document, 
but we need it to select the area regardless 
of what size the document is. Because of 
this challenge, we’ll need to go about mak-
ing the selection in a special way. When we 
started making this action, the very first step 
created a selection that was one inch wide 
and 200 inches high (knowing that no fu-
ture document will ever be 200 inches tall). 
We can copy this step to create another se-
lection of the same dimensions. To copy the 
action, we first need to stop recording the 
action. You can’t copy a step while still re-
cording. We’ll hold down the Option key (Alt 
on Win) and drag that step to the bottom, 
below the Merge Layers step. (We need to 
hold down the Option key so that we copy 
the step instead of move the step.) 

At this point, the action should have created 
another selection on the left side of the doc-
ument, so we need to make that selection 
active before we continue recording the ac-
tion. We’ll make sure the Rectangular Marquee Tool is active and that the Options 
Bar dimensions are set to one inch wide and 200 inches high. We’ll click and drag 
to the top left corner of the document so that the selection appears on the left 
edge. 

Now we can start recording the action again by clicking the Record icon at the 
bottom of the Actions panel. It should turn red to indicate that it’s recording. 

In order to create the second selection 
(that will eventually contain the right 
inch of the document), we started by du-
plicating the step that created the first 
1-inch wide selection.



Gallery Wraps & Actions © Ben Willmore, All rights reserved 10

We really want that selection on the other side of the document, so this is how 
we’ll go about it. We’ll tap the Q key to enter Quick Mask Mode. In this mode, the 
areas that are not selected are covered in red so we will see red in all areas except 
for that left edge where we had the selection. 

Photoshop treats Quick Mask Mode as if it’s just a picture, so we can flip it hori-
zontally in a similar way to how we would flip an image layer. We’ll first click on 
the Select menu and choose All. The “marching ants” selection will appear around 
the entire document. Then we’ll click the Edit menu and choose Transform > Flip 
Horizontal. The Quick Mask will flip so that now the right inch of the document is 
the area that’s selected. We’ll tap the Q key to exit Quick Mask Mode and we’re 
left with the active selection. 

LEFT: We started with a 1-inch selection of the left side of the document. We tapped the Q 
key to enter Quick Mask Mode, which created the red overlay. Then we clicked on the Select 
menu and chose All. This selected the entire Quick Mask. CENTER: With the entire Quick Mask 
selected, we clicked on the Edit menu and chose Transform > Flip Horizontal. RIGHT: We 
tapped the Q key again to exit Quick Mask Mode and you can see that the 1-inch selection was 
flipped to the right side of the document. 
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We want to copy the contents of this selection to its own layer so we’ll use the 
keyboard shortcut Command+J (Ctrl+J on Win). Then we’ll flip this new layer by 
clicking on the Edit menu and choosing Transform > Flip Horizontal. We’ll acti-
vate the Move Tool so that we can click and drag the layer toward the right until 
the left edge of the layer snaps to the right edge of the document. Then, we’ll 
click on the Image menu and choose Reveal All so that the canvas expands to 
include this layer. Finally, we’ll click on the Layer menu and choose Merge Down. 
This will flatten the Photoshop document. 

In the next step of the action, we need to make a 
selection across the top of the document that is one 
inch tall and that is wider than any image we could 
possibly plan on printing. This just ensures that the 
selection will span the entire top of any document. 
The problem is that the action is going to record the 
selection width as the width of the current, active 
document. If we were to use the action on a wider 
document in the future, it wouldn’t work. Again, this 
is where we’ll need to create a separate document 
in which to record this particular action step. We’ll 
tap the Stop icon at the bottom of the Actions pan-
el to stop recording the action. Then, we’ll click on 
the File menu and choose New. The New Document 
dialog will open and we’ll enter in some dimensions 
on the right side of the window. We just want the di-
mensions to be larger than any practical document 
we would possibly open to ensure that the selec-
tion will take up the entire width of any document 
we might use. We’ll enter in 200x200 inches for the 
width and height, we’ll set the resolution to 1 and 
we’ll click the Create button. 

We are creating a new docu-
ment to help us create the next 
step in the action, which will 
select the top inch of the docu-
ment. We’re setting the dimen-
sions at 200x200 inches and 
the resolution at 1 Pixel/inch. 
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The new document will appear and we can click the Record button at the bottom 
of the Actions panel so that we can continue recording the action. 

We’ll activate the Rectangular Marquee Tool and use the settings in the Options 
Bar to specify that the selection be one inch high and 2000 inches wide. (It 
doesn’t need to be 2000 specifically. It just needs to be wider than this active 
document.) We’ll click within the document and drag to the top so that the se-
lection is aligned with the top edge of the document. We’ll hit the Stop button to 
stop recording the action again. 

Now that we recorded the selection step, we can close this document and return 
to the image document. Before we start recording again, we need to get that ac-
tive selection because that’s what was created by the last action step recorded. 
With the Rectangular Marquee Tool active and set to create a selection that is 
one inch tall by 2000 inches wide, we’ll click and drag up to the to the top of the 
image. This will place the inch-tall selection across the top of the document. 

We can click the Record button to start recording the action again. We’ll copy 
the contents of the selection onto its own layer by using the keyboard shortcut 
Command+J (Ctrl+J on Win). Then we’ll flip the new layer by clicking on the Edit 
menu and choosing Transform > Flip Vertical. We’ll activate the Move Tool so that 
we can click and drag this new layer upward and out of the frame, so that the bot-
tom edge of the layer aligns with the top edge of the document. We’ll expand the 
canvas by clicking on the Image menu and choosing Reveal All. Finally, we’ll click 
on the Layer menu and choose Merge Down. This will again flatten the image. 

With the Rectangular Marquee Tool active, we used the Options bar settings to specify that 
the selection be one inch tall and 2000 inches wide (wider than we’d ever need). Then we 
clicked within the document and dragged to the top of the image to place the selection.
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Now we need to do the same thing with the bottom edge of the image, starting 
with making a one-inch tall selection of that bottom edge. We already know that 
it’s not going to be straightforward because the selection will have to work on 
any size document we may run the action on, but we already tackled this prob-
lem when we made the selection of the top edge. Just like we copied an action 
step to create the selection of the right edge, we can again copy an earlier ac-
tion step in order to help us make this bottom-edge selection. We’ll tap the Stop 
icon to stop recording the action so that we can duplicate a step. Then, we’ll hold 
down the Option key (Alt on Win) and drag the last “Set Selection” step to the 
bottom of the list of steps, just below the “Merge Layers” step. We’ll double-click 
on that step in the Actions panel in order to apply that step and create the 1-inch 
tall selection at the top of the document. 

Here, we complet-
ed all of the action 
steps needed to 
create the gallery 
wrap across the top 
of the image. The 
top inch was cop-
ied, flipped, moved, 
and the canvas was 
extended to include 
the new layer. Then 
we flattened the 
document. You can 
see that the last 
action step so far is 
“Merge Layers.”
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We can now continue to record the action. We’ll make sure that the last step of 
the action is active so that in continues to record from that step. We can make 
sure that the step is active by clicking on it so that it becomes highlighted. We’ll 
then click on the Record button so that it turns red. 

We’ll tap the Q key to enter Quick Mask Mode. This gives us the red overlay in 
all areas of the image that are NOT selected. The overlay should fill everything 
except for the top inch of the image. We need the bottom edge selected so we 
need to flip this Quick Mask view. We’ll click on the Select menu and choose All 
so that the “marching ants” selection appears around the entire document. Then, 
we’ll click the Edit menu and choose Transform > Flip Vertical. We’ll tap Q to exit 
Quick Mask Mode and we’ll be left with an active selection of the bottom inch. 

We created a 1-inch 
selection at the top 
of the document. 
Then, we entered 
Quick Mask Mode 
and transformed 
the mask, flipping 
it vertically. This 
moved the selec-
tion to the bottom. 
Then, we turned off 
Quick Mask Mode 
to remove the red 
overlay.
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We’ll copy the contents of this selection to its own layer by using the keyboard 
shortcut Command+J (Ctrl+J on Win). We’ll flip this new layer by clicking on the 
Edit menu and choosing Transform > Flip Vertical. With the Move Tool active, we’ll 
click and drag down on the new layer so that the top edge of the layer aligns 
with the bottom edge of the document. The layer will now be completely out of 
view. To expand the canvas to include the layer, we’ll click on the Image menu 
and choose Reveal All. Finally, we’ll flatten the image by clicking the Layer menu 
and choosing Merge Down. We’ll click the Stop icon at the bottom of the Actions 
panel to stop recording the action. 

Troubleshooting Actions (37:45)

After creating an action, you’ll of course want 
to test it to make sure that it works on other 
images. If something goes wrong during test-
ing, you’ll need to troubleshoot to find which 
step (or steps) contains the error. To make 
this troubleshooting process easier, you can 
change the action playback options so that it 
plays step by step instead of all at once. This 
will show you where the problem occurred. To 
set this up, click on the little menu in the top right corner of the Actions panel 
and choose Playback Options. A dialog will appear, allowing you to choose how 
fast the action should play. By default, this is set to “Accelerated,” which means it 
will play the action as fast as possible. Choose the “Step by Step” option and then 
click OK. This will tell the actions to play slowly, one step at a time. 

Click on the name of the action, hit the Play button and the action will start to 
play slowly, one step at a time. When you see which step caused the problem, 
you can simply tap the Stop button at the bottom of the panel to stop recording 
the action. 

Play actions very slowly, in a step-by-
step manner, by clicking on the menu 
in the top right corner of the panel and 
choosing Playback Options.
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Making the Action Even More Universally Applicable (49:35)

The action we created above will work well on a flat document, meaning one that 
includes only one single image layer. If we try to run this action on a multi-layer 
document, however, we’re going to run into problems. Let’s look at how we could 
make the action even more useful so that it works on multi-layer documents. 

We’ll click on the first step of the action because we want to add a step at the 
very beginning. Then we’ll click the Record button at the bottom of the Actions 
panel. Next, we’ll click on the Image 
menu and choose Duplicate. This will 
create a brand new document that is 
identical to the active document. A di-
alog box will appear, prompting us to 
give the new document a name. We’ll 
type in “Canvas Wrap.” We’ll turn on the 
“Duplicate Merged Layers Only” check 
box and then click OK. By turning on 
that check box, it duplicates the docu-
ment as a flat image, with just one im-
age layer. We’ll click the Stop button 
at the bottom of the Actions panel to 
stop recording the action.

Now we have a step that creates a new, 
flat version of the document. We’ll 
drag that step up so that it becomes 
the very first step in the action. Now 
this action will work on both flat and 
layered documents. 

While recording the action, we clicked on the 
Image menu and chose Duplicate. This dialog 
appears and we’ll make sure the “Duplicate 
Merged Layers Only” check box is turned on.

We moved the Duplicate Image step to the 
top of the action. When the action plays, the 
very first thing it does will be to duplicate the 
document as a new, flattened image. 
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Adding a Step for Sizing the Canvas in Advance (52:20)

We now have an action that can take any image and create a gallery wrap from it. 
Let’s take things a step further by adding a feature to this action that allows us to 
determine what size the final print should be. For example, if we know that we’d 
like our canvas to be 16” x 20”, it would be important that we size the image at 
16” x 20” BEFORE we create the gallery wrap. Here’s how we can add that step. 

We’ll click on the first step in the action 
(Duplicate First Document) and then 
we’ll click on the little menu in the top 
right corner of the Actions panel and 
choose “Insert Menu Item.” A box will 
appear, prompting us to manually select 
the menu item. We’ll click on the Image 
menu and choose Image Size. Then we’ll 
click the OK button within the box. 

The Image Size step will appear in the list of steps for the action and we’ll make 
sure that it’s the second step, immediately after the “Duplicate first document” 
step. We’ll also make sure that the little box to the left of the step name is high-

lighted. It should be highlighted (and not 
grayed out) by default. This tells the action 
to ask us for information before proceed-
ing with the action. In this case, the action 
will call up the Image Size dialog and ask us 
to enter in the desired image dimensions. 
When we click OK, the action will continue 
and add the gallery wrap to the document. 

We clicked on the menu in the top right cor-
ner of the Actions panel and chose to Insert 
Menu Item. This box appears, prompting us 
to choose which menu item we’d like to add. 
Here, we clicked on the Image menu and 
chose Image Size. 

The Image Size menu item was added to 
the action and the box to the left of the 
step name is highlighted (see circled). 
This means that the action will stop and 
ask us to enter information at this point. 


