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Tree Masking

In this lesson, we’re going to learn how to mask trees. When it comes to trees, 
you’ll need to use some special techniques because the standard selection tools 
will usually fail you. 

Select Similar (Timestamp 2:17)

Trees are complicated subjects, but the backgrounds behind them are often times 
simple. When you are selecting a tree for the purpose of replacing a sky, the sky 
behind it will likely be a simple expanse of blues and grays. Most trees will not 
have any blues, so we could instead make a selection of the background and then 
invert the selection to get the opposite. Let’s look at a few ways of doing this.

With the first technique, we’ll create a very 
simple selection and then tell Photoshop to 
auto-select everything that’s similar to what’s 
contained within the selection. In the example 
image, we’ll select the sky in three different ar-
eas: an area where it’s light, an area where it’s 
dark, and an in-between area. (You can select 
more than one area by holding down the Shift 
key.) This selection tells Photoshop what kind 
of content we ultimately want selected. Then 
we’ll click on the Select menu and choose 
“Similar.” Photoshop will look across the entire 
picture to find areas that are similar to those 
that are selected. In this example, the sky is 
the only area that contains those blues, so the 
resulting selection should contain most of the 
sky and nothing else.

A selection was created that  
includes sky colors and tones.

The Select Similar command was 
used to expand the selection to 
include more of the sky.
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If there are parts of the sky that did not get 
selected, we can supplement another tool 
such as the Magic Wand Tool, which works in 
a similar way to the Select Similar command. 
With the Magic Wand Tool, we’ll hold down 
the Shift key (so that we’re adding to the se-
lection) and then click within the areas that 
still need to be selected. 

After the sky has been successfully selected, 
we’ll click on the Select menu and choose In-
verse. This will create an opposite of the se-
lection so that we instead have the tree se-
lected. 

We can check the selection by adding a layer mask. When we create a layer mask 
while there is an active selection, the selection will be applied to the mask so that 
the selected areas remain visible while the areas that were not selected are hid-
den by the mask. We’ll click on the Layer Mask icon at the bottom of the Layers 
panel and the sky area will become hidden. This will show us the isolated tree so 
that we can inspect the selection/mask. 

The Magic Wand Tool is being used to 
include sky areas that still need to be 
selected.

A layer mask 
was added and 
a new sky lay-
er was placed 
beneath the 
tree layer. This 
allows us to 
better evaluate 
the mask to see 
where it needs 
to be refined.
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Select Color Range (5:33) 

When there is nothing in the image that 
contains a color similar to that of the sky, 
we can use the Select Color Range fea-
ture. We’ll click on the Select menu and 
choose Color Range. A dialog will appear 
and it will remember the settings you last 
used. There are three eyedroppers on the 
right side of the dialog. Make sure that the 
left-most eyedropper is active and click 
somewhere within the blue sky you want 
selected. This tells Photoshop what color 
you want selected and a preview of that 
selection will appear in the Color Range 
dialog. The dialog contains a Fuzziness 
slider and if this slider is positioned all the 
way to the left, then it’s going to select 
only the exact color that you clicked on. 
As you move the Fuzziness slider to the 
right, it gradually expands the range of 
color being selected, deviating more and 
more from the color you clicked on. It’s 
best not to drag this slider too far as it can 
produce a less-than-optimal result. 

Another way to expand the color range being selected is by using the eyedrop-
per with the plus sign (+) next to it. Activate this eyedropper and then click on 
more colors that you want selected. You will see that more and more of the pre-
view window becomes white, indicating what area is selected. Another way of 
accessing the “add to selection” feature is to hold down the Shift key while using 
the regular, left-most eyedropper. This will tell the tool to add to the selection 
instead of starting a new selection. If you click and drag on the image using the 
eyedropper, it will select every color that falls under your cursor as you drag. 

The left eyedropper (circled) in the Color 
Range dialog was used to click within the 
sky. Because the Fuzziness slider is all the 
way to the left, it only selected the exact 
color we clicked on.
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The small black and white preview can make it hard to tell how accurate the se-
lection is compared to the image. The Selection Preview menu (at the bottom of 
the Color Range dialog) gives us several more options for viewing the selection. 
We’ll change this menu to Black Matte and it will place a black overlay on the 
image in all areas that are not selected. We can turn on the “Invert” check box 
in order to get the opposite of the selection, where everything that used to be 
covered in black looks normal and the opposite area becomes covered in black. 
In the example image, this gives us a much better idea of what areas still need 
to be selected. Note that this doesn’t just invert the preview. It inverts the actual 
selection so that we’re getting the opposite of what we had before. 

After using the eyedroppers to get a good selection, we can fine-tune it using 
the Fuzziness slider. We need to be careful here, because moving this slider too 
far to the right will start to remove some of the tiny branches from the selection. 

The Shift key is 
being held down 
as we use the eye-
dropper to click in 
more areas of the 
sky. Because the 
Shift key is held 
down, we’re add-
ing to the selec-
tion, expanding 
the color range 
being selected. 
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I’ll usually move this slider up until the blue sky halo surrounding the branches is 
no larger than two pixels in size. We’ll click OK to exit the Color Range dialog and 
we’ll be left with a selection of the tree and other foreground elements. (Note 
that we have a selection of the tree because turned on the “Invert” check box 
after selecting the sky.) 

We’ll now use this selection to add a layer 
mask. We’ll click on the Layer Mask icon at 
the bottom of the Layers panel and only the 
areas that are selected will remain visible. The 
areas that are not selected will become hid-
den. In the example image, we have a differ-
ent sky layer below the layer we just masked 
so we can now see this new sky appear be-
hind the tree. 

The Selection Preview menu is set to Black Matte, which shows a black overlay in areas that 
are not selected. The Invert check box is turned on, selecting the opposite of what we origi-
nally selected. 

A layer mask 
was added 
and a new 
sky is placed 
beneath the 
tree layer. 
You can see 
a halo of the 
original sky 
in the result.
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We’ll zoom in on the image and we can see a residual border of the old sky sur-
rounding the tree branches. This is the area that we couldn’t perfectly fix using 
the Color Range command. 

Select & Mask (11:57) 

The Select & Mask feature can be useful for instances where we need to refine a 
current selection. With the selection or mask active (mask in this case), we’ll click 
on the Select menu and choose Select & Mask. A new window will appear in place 
of the regular Photoshop interface. In the Select & Mask window, the settings ap-
pear in a panel on the left side of the interface and we’re going to pay attention 
to the Radius slider. As we move this slider up, we’ll be giving Photoshop more 
and more control over the edges of the selection. If we set this slider to a radius of 
one, Photoshop will have control over a 1-pixel radius around the selection edges. 
I try to set this slider to the lowest setting that gives me an acceptable result. In 
selecting trees like this, the setting is usually between one and three. 

In the Select & Mask 
window, we are 
setting the Radius 
slider (circled) to 
the lowest setting 
that still removes 
the halo of the 
original background 
from the edges of 
the tree.
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Note: In the video example, we have the View menu set to “On Layers,” which 
shows the selected layer on top of the underlying layer in the Layers panel. If this 
menu were set to a different option, the selection preview would appear as an 
overlay. In an example like this, the “On Layers” view is best for viewing the re-
sulting selection.

As we zoom in and scroll around the image, we can see that there is a colored 
halo effect around some of the smaller tree branches. The “Decontaminate Col-
ors” check box (under the Output Settings category) can help to correct this. 
This setting will attempt to eliminate any of the residual color from the original 
background. The Decontaminate Colors setting has an amount slider beneath it 
and this controls how aggressive the effect is. I usually set this slider to the lowest 
setting that still gives me an acceptable result. 

We’ll click OK to exit the Select & Mask window. 
Whenever you turn on the Decontaminate Colors 
check box, it’s going to duplicate your original 
layer and create a layer mask so we will see that 
second layer appear in the Layers panel.  If we’re 
happy with the results of the mask/selection, we 
could discard the original layer. 

LEFT: There is still a halo from the original background surrounding some of the smaller 
branches. CENTER: The “Decontaminate Colors” check box can be found under the Output 
Settings category in the Select & Mask window. RIGHT: After turning on that check box, the 
halo goes away.

After using the 
Decontaminate 
Colors setting, a 
new layer is  
created. The 
original layer is 
still there, with 
its visibility 
turned off.
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We can view the contents of a layer mask by holding down the Option key (Alt 
on Win) and clicking on the mask’s thumbnail in the Layers panel. When we do 
this, the image will change to show us the black and white mask so we can zoom 
in and scroll around on it. This will give us a better idea of whether there are un-
wanted gaps or other problems with the mask. 

More Select & Mask Tips (25:51)

Let’s look at some additional ways of refining a mask or selection within the Se-
lect & Mask window. We mentioned before that there are various preview options 
and you can switch between them using the View menu. The Overlay option will 
place a red overlay on the image and it is similar to what you would see when 
working in Quick Mask Mode. Everything that is selected will look normal and 
everything that is not selected will have a red overlay. It can be useful to view the 
selection with this View mode because you’ll often times find that there is a red 
overlay covering up some areas that it shouldn’t. That would mean that those 
areas are not selected and will therefore be transparent when the selection is 
converted into a mask. 

In the Select & Mask window, the View menu is being used to change the preview to Overlay, 
which places a red overlay in all areas that are not selected.
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If we have areas that are not selected (therefore covered with a red overlay) but 
should be, we can manually add them to the selection by using the third brush in 
the toolbar on the left side of the Select & Mask window. This brush allows us to 
paint over any areas that should be selected. As we paint, the red overlay will be 
removed. 

The third brush tool (circled) can be used to manually select areas. Using the Overlay view, we 
can see if there is any red overlay covering areas that should be selected. Here, we’re painting 
over those areas to ensure they are selected.
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We already learned that the Radius slider gives Photoshop control over a speci-
fied amount of the selection edge. We can also give Photoshop control over the 
selection by using the second brush in the toolbar on the left side of the interface. 
Using this brush, we can paint over parts of the selection edge that still show 
remnants of the original background, changing the brush size as needed. Any-
where we paint with this tool, we are giving Photoshop control over the selection 
edge and it usually does a good job of locating the edges and masking out the 
old background.

There is a check box near the top of the 
settings panel called “Show Original.” 
Turning this on will show you what the 
selection looked like before you applied 
the Select & Mask settings. The “High 
Quality Preview” check box will help 
you to see the fine details of the mask 
when you’re zoomed in on the image. 
The problem with turning this setting on 
is that it slows down the performance 
of the brush tools. 

The Background Eraser (28:13)

Now let’s look at another tool that can be used 
for isolating trees off their backgrounds. With a 
tree image open, we’ll duplicate the image lay-
er so that we can keep the original for compari-
son purposes later. Then, we’ll activate the Back-
ground Eraser Tool, which is bundled with the 
regular Eraser Tool in the Toolbar on the left side 
of the Photoshop interface. 

In the Select & Mask window, turn on the 
“Show Original” check box to see what the 
selection looked like before using the Select & 
Mask settings.

The Background Eraser Tool is 
grouped with the regular Eraser 
Tool.
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With the Background Eraser Tool active, we’ll first specify some settings in the 
Options Bar above the main image window. We’ll set the brush to a large, soft-
edged brush. To the right of the brush settings are three icons. We want to make 
sure the center icon is active and this tells the tool to sample once. 

We’ll set the Limits menu to Discontiguous, which will allow the tool to erase the 
sky from the little areas between branches. If we were to choose the Contiguous 
option, it would only be able to delete pixels in one connected chunk. Finally, we’ll 
set the Tolerance to 40%. 

When the Background Eraser is active, the cursor will look like a brush with a 
crosshair in the middle. You can change the size and softness of the brush in the 
same way that you would with the regular Brush Tool. When we click the mouse 
button, it’s going to look at the color that is directly beneath the crosshair and 
delete everything of that color from within the circular brush tip. 

When using the Background Eraser to isolate trees, the above settings work well. The second 
sample icon is used. The Limits menu is set to Discontiguous and the Tolerance is set to 40%. 

The Background 
Eraser is being used 
to remove the sky. 
The tool erases 
whatever color is 
beneath the  
crosshair when you 
click to paint.
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The Tolerance setting determines how much the tool can deviate from the color 
that’s beneath the crosshair. The higher the Tolerance setting, the more it can 
erase colors that are brighter and darker than the color that’s under the crosshair. 
I have found that a 40% Tolerance setting works pretty well for trees. 

We specified that the tool should sample once (by selecting the center icon), 
which means that, as we click and drag, it will only erase the color that was un-
derneath the crosshair when we initially clicked using the Background Eraser. 
If we did not use this setting, then it would constantly change the color being 
erased as we moved the brush over different parts of the image. By using the 
“once” setting, we can click and drag to paint directly over the trees. As long as 
we initially clicked in an area where the crosshair was touching sky, the trees will 
not be erased. 

If the Tolerance setting is too high, 
you’ll find that you might end up 
deleting too much. This is appar-
ent when you see the transparent 
checkerboard showing through in 
areas that should not have been 
erased. You can protect a particu-
lar color from being erased by us-
ing the “Protect Foreground Color” 
setting, which can be found in the 
Options Bar. To use this setting, we 
will first hold down the Option key 
(Alt on Win) to temporarily access 
the Eyedropper Tool and then click 
on the color we want to protect. In 
the example image, we’ll click to 
sample a color on a tree trunk. This will set that color as the Foreground Color. 
Then, we’ll turn on the “Protect Foreground Color” check box. Now, as we paint, 
the tool will be unable to erase anything of that particular color. 

If the Tolerance setting is too high, the Back-
ground Eraser may erase more than the back-
ground. Here, you can see that it erased part of 
the tree trunk.
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After the sky has been removed using 
the Background Eraser Tool, we’ll place 
a new sky beneath this layer so that we 
can see how natural it looks. In the ex-
ample image, we can still see a hint of 
the old background color around the 
edges of some branches. We’ll fix this 
by combining the results we got using 
the Background Eraser with the results 
we got by using the Select Color Range 
and Select & Mask features. I had previ-
ously applied those techniques to this 
image and the result is in a layer that 
currently has its visibility turned off. 

We currently have a sky layer visible 
at the bottom of the layer stack and 
we have the layer whose sky was just 
removed using the Background Eraser 
visible at the top of the layer stack. We 
want to take this top layer and act like 
we’re printing this image on top of the 
background as if we’re using ink. To ac-
complish that, we’ll change the blending 
mode of this layer to Multiply. 

Next, we’ll drag this layer just below the other version of the image that was 
masked using the Select Color Range feature. We’ll turn on the visibility of that 
layer. In this version, the masking technique ended up removing some of the tiny 
branches around the edges of the trees. By placing the other version of the im-
age beneath this layer in Multiply mode, we are allowing the underlying layer to 
show up only in the areas where the top layer’s tree branches were too thin. 

We have the layer where the Background 
Eraser was used to remove the sky on top of 
the layer stack. A new sky layer was placed at 
the bottom of the layer stack. The layer with 
the mask is the one that had its sky hidden 
using Select & Mask. 
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The effect is too strong at first (the branches are too dark) so we’ll set the opac-
ity of the underlying layer to zero and then we’ll slowly bring up the opacity to 
introduce a hint of those missing branches.

Channel Masks/Luminosity Masks (36:20)

The next technique works well for subjects 
(trees, in this case) that are in silhouette. 
We’re going to use channel masks, or lumi-
nosity masks. These two terms refer to the 
same thing. With a tree silhouette image 
open, we’ll open the Channels panel. (It’s 
usually grouped with the Layers panel.) This 
panels shows what the image is made up of 
behind the scenes. If it’s an RGB image, it’s 
made up of red, green and blue light. There 
will be a channel for each of these colors. 

LEFT: The layer that had its sky removed using the Background Eraser was set to the Multiply 
blending mode and was placed beneath the layer that had its sky removed using a layer mask.  
This filled in the thinning branches but did so to an extreme level. RIGHT: The opacity of the 
underlying layer was lowered, making the tree look more natural. 

The Channels panel shows the individual 
color components of the image.
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We’ll click through each of the three channels to view them individually in the 
main image window. We want to find the one that has the greatest amount of 
contrast between the tree and the sky. In the example image, the red channel 
shows the greatest contrast because the sky is brightest. We want to copy the 
information from this red channel and place it into a layer mask. We’ll then be able 
to manipulate the mask in order to isolate the tree. 

We first need to load this red channel as a selection and we can do that by hold-
ing down the Command key (Ctrl on Win) and clicking on the thumbnail for the 
red channel. A “marching ants” selection will appear on the image. Then, we’ll 
return to the full-color image by clicking on the name of the top, RGB Channel.

LEFT: We clicked through the channels to find the one that showed the most contrast be-
tween the tree and the sky. That is the red channel. We are loading that channel as a selec-
tion by holding down the Command key (Ctrl on Win) and clicking on the channel thumbnail. 
RIGHT: Back in the Layers panel, you can see the resulting “marching ants” selection.
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We’ll return to the Layers panel and, with the tree layer still active, we’ll click on 
the Layer Mask icon at the bottom of the panel. This will turn the active selection 
(which was a copy of the red channel) into a layer mask, essentially pasting the 
contents of the red channel into the mask. We want to view the mask in the main 
image window so that we can adjust it. We’ll hold down the Option key (Alt on 
Win) and click on the thumbnail for the mask so that we can view it in the image 
window. Next, we’ll click on the Image menu and choose Adjustments > Levels. 
In the Levels dialog, there are three Eyedropper tools and we want to make sure 
that the right one (the white one) is active. We’ll use this eyedropper to click in 
the darkest area that is directly surrounding the tree. When we click, it will force 
the area we click on, as well as anything that’s brighter than that area, to become 
solid white. Next, we’ll activate the black eyedropper and use it to click on the 
tree to ensure that it is solid black. We’ll click OK to exit the Levels dialog.  

Now, all we need to do is clean up the rest of the mask. We’ll activate the Brush 
Tool and set the foreground color to white so that we’ll be painting with white. 
We’ll paint over any parts of the sky that are not currently white. 

LEFT: We are viewing and adjusting the layer mask in the main image window. Here, you can 
see the original mask before adjustments. RIGHT: We used the white eyedropper to click on 
the darkest area surrounding the tree, therefore forcing that area to white. 
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The entire sky area is now white and the tree is 
black. Because black hides things in a mask and 
white reveals things, we need the opposite of 
what we have. We can quickly invert the mask by 
clicking on the Image menu and choosing Ad-
justments > Invert. 

We’re still viewing the mask in the main image 
window and we can now turn off this view. We’ll 
hold down the Option key (Alt on Win) and click 
on the mask thumbnail in order to go back to 
viewing the actual image layer. With this view, 
we can see some colors from the original sky 
surrounding the tree branches. To fix this, we’ll 
click on the Select menu and choose Select & 
Mask. The Select & Mask window will appear and 
we’ll turn on the “Decontaminate Colors” check 
box. This will try and eliminate any residual back-
ground color from the original image. We’ll drag 
the Amount slider to the left and then gradu-
ally increase it, finding the lowest setting that 
still removes the residual background. If this still 
doesn’t quite do the trick, we can always move 
the Radius slider up to one or two pixels, giving 
Photoshop control over the edges of the mask. 
When we’re satisfied with the mask, we’ll click 
OK to exit the Select & Mask window. 

We are still viewing the mask in the 
main image window. We are clean-
ing up the mask (so that only the 
tree is isolated) by painting over 
the sky area with white.

The mask was inverted so that only 
the tree area is white. White parts 
of the mask represent the areas 
that are visible.
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When to use the original layer from “Decontaminate Colors” (42:11)

We mentioned earlier that, whenever the “Decontaminate Colors” check box is 
turned on, the Select & Mask result will be placed on a new layer. The original lay-
er can still be found in the Layers panel, with its visibility turned off.  You usually 
won’t need to use this original image layer, but there is one instance where I find 
that it can be useful. That is when you would like to see the original, unmasked 
layer in certain areas of the image. The sky will still remain masked, but it will 
bring back any colors that were hidden from within the tree[s]. 

LEFT: After isolating the tree using a channel 
mask, you can still see some residual halo from 
the original sky. BELOW: In the Select & Mask 
window, the “Decontaminate Colors” setting is 
turned on in order to remove the halo from the 
original sky.
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To achieve this, make sure the original, unmasked layer is active and positioned 
above the masked layer. Click on the Layer menu and choose to Create Clipping 
Mask. When you create a clipping mask with a layer, it means that the layer will 
only show up in areas where the underlying layer is visible. If the underlying lay-
er has a mask, that mask will also hide parts of the clipped layer. You can tell 
that a layer is clipped because it becomes indented in the Layers panel and a 
down-pointing arrow shows up to the left of the layer thumbnail. 

After clipping the layer, you can further control where the layer is visible by add-
ing a layer mask. I like to invert the layer mask by clicking on the Image menu and 
choosing Adjustments > Invert. This will make the entire mask black so that it’s 
hiding everything in the layer. Then, I can use a white brush to manually paint in 
the areas where I want this original tree layer to be visible. 

The original, unmasked layer was placed at the top of the layer stack and it was clipped to the 
masked layer beneath it. A layer mask was added to this layer so that we can selectively paint 
in the areas where we want it to be visible.


