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Image Blending

In this lesson, we’re going to look at an image blending technique that can be 
useful for really challenging images. There are some images that are difficult to 
perfect as a whole using Lightroom’s adjustment sliders. In instances like this, 
you can take the same image and process it multiple times, optimizing a different 
area in each version. Then, you can blend all of those versions together, using only 
the enhanced area from each version. 

The example image Our video example image was shot mid-day, outside in a 
vineyard. When shooting the image, I made sure that the histogram on my cam-
era did not show a huge spike on the far right side. This would have indicated that 
the brightest area (the sky) was blown out to white. On a mirrorless camera, you 
can also turn on the zebra stripes feature, which will overlay those stripes over 
any areas that will have a loss in detail.  Know that this preview that your camera 
shows you is based on a jpeg version of the picture. The end result that is loaded 
onto the computer should be raw (presuming that you are shooting in the raw 
format). Because I made sure that the sky was not blown out to white, we will 
later be able to retrieve detail from that bright area.

The subject in this image is very dark. Her pants are close to solid black and it’s 
hard to see her face because it is also dark. 

Above, you can see before-and-after versions of the video example image. 
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We are going to process this image multiple times, focusing on a different area 
in each version. The file that you received with the course downloads contains 
some Snapshots so that you can see how I processed the image for all the differ-
ent areas. You can find these within the Snapshots panel in Lightroom’s Develop 
Module. Here, I am going to describe my mindset when processing each version 
and then we’ll move on to blend all of the versions together in Photoshop. 

Optimize the vines 

In the first pass, we’ll adjust the image to optimize the vines. Once the vines look 
ideal, we’ll want to open the image in Photoshop, but we need to do that in a 
special way. Whenever we’re going to use this blending technique, where we cre-
ate multiple versions of the same image, we need to open the image as a smart 
object in Photoshop. With the image active, we’ll click on the Photo menu and 
choose  Edit In > Open as Smart Object in Photoshop. The image will open as a 
layer in Photoshop. The bottom right corner of the image thumbnail in the Layers 
panel will include a little icon, indicating that the layer is a smart object. 

Here, we initially adjusted the image in Lightroom to optimize the vines. On the left side, you 
can see that the Snapshots panel contains a snapshot for each of the different elements in 
the image. You will have access to this in the practice file. 
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Optimize the sky

Now we need to create a duplicate of that layer in order to optimize the image for 
another area. We can not, however, use the standard method of duplicating a lay-
er. This would simply create a second instance of the same smart object, where 
any changes made to one instance will automatically be applied to the other. 
We want to be able to edit the individual layers independently of one another. 
To achieve this, we’ll duplicate the smart object by clicking on the Layer menu 
and choosing Smart Objects > New Smart Object via Copy. The key word here is 
“new.” A new layer will appear in the Layers panel and this is a new, independent 
layer that we can change without affecting the original layer. 

We now want to process the new layer using different settings that will optimize 
a different area. We’ll double-click on the layer thumbnail and the image will open 
in Adobe Camera Raw (ACR). Here, we can optimize the adjustment settings and 
this time we’re going to optimize for the sky. 

Here, we are adjusting the image to optimize the sky in Camera Raw.
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This lesson is focused on image blending and not optimization via the adjustment 
sliders, so we’re not going to go into detail on what sliders were moved to fix the 
sky here. If you are following along with the image file included with the lesson, 
know that you can click on the Snapshots panel (It’s the far right icon in ACR’s 
adjustment settings.) to see the different settings used for each version of the 
image. After adjusting the image to optimize the sky, we’ll click OK to exit the 
ACR window. 

Now we’re going to end up with two versions of the picture stacked on top of 
each other. The top version is the one where the sky looks good. To merge this 
layer with the one beneath it, we will use a layer mask to hide everything except 
for the sky area. We’ll start by making a selection around the sky and mountain 
area, but we’ll actually do this by using the bottom layer, because it’s lighter and 
the selection tools will have an easier time. We’ll turn off the eyeball icon for the 
top layer and click on the bottom layer so that it’s active. We’ll then click on the 
Quick Selection Tool (within the Toolbar) to make it active. We’ll use the tool to 
click and drag over the area containing the sky and mountains. When we release 
the mouse button, we’ll have a selection of that area. 

The Quick Selection Tool (circled) is being used to make a selection of the sky and moun-
tains. This selection will be used to create a layer mask, hiding the layer in all areas except the 
sky and mountains.
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We’ll zoom in on the image to inspect 
the selection and we can see that we 
need to fine tune it in some areas. To 
deselect an area that was accidentally 
selected, use the settings in the Op-
tions Bar above the main image win-
dow to choose the tool icon with the 
minus sign next to it. This tells the tool 
to remove from the selection instead of 
add to it. You can change the size of the 
brush by using the left and right bracket 
keys ( [  ] ). In this instance, we need a 
very small brush to paint over Karen’s 
arm, which was accidentally selected. We’ll switch between the add and subtract 
settings for the Quick Selection Tool in order to fine tune the selection as much 
as possible. 

With the Quick Selection Tool active, these 
settings (located in the Options Bar) can be 
used to tell the tool what to do. When we 
choose the icon with the minus sign, the tool 
will subtract from the selection instead of 
add to it.

The Quick Selection 
Tool is set to subtract 
from the selection 
and we’re using it to 
remove the selection 
from the subject’s 
arm.
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We can get an alternative view to evaluate the selection by tapping the Q key to 
enter Quick Mask Mode. This will place a red overlay on the image in the areas 
that are NOT selected. While in this view, we can zoom in on the image and see 
that there are parts along the edge of the selection that are not quite precise. 
These areas are too small and detailed for the Quick Selection Tool, so we’ll need 
to use another technique. 

We’ll tap the Q key again to exit Quick Mask Mode and then we’ll access a dif-
ferent feature by clicking on the Select menu and choosing Select & Mask.  Note 
that this Select & Mask feature is best used for subjects that are furry, fuzzy, hairy 
or overly complex. The Select & Mask window will open and all of the options ap-
pear on the left side of the interface.

We tapped the Q key to enter Quick Mask Mode, which places a red overlay on the areas that 
are not selected. 
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We’ll use the View menu to choose the option called Overlay, which gives us a 
red overlay similar to the one you see in Quick Mask Mode. With this view, we can 
paint on the image to add or remove from the selection. 

We’ll zoom in on the image and activate the Refine 
Edge Tool, which is the second tool down in the 
Toolbar. This tool allows us to paint on the image 
to determine what is selected. Using a small brush, 
we’ll paint over the areas where the red transition 
does not look appropriate. This will give Photoshop 
permission to refine that area. There is a way to give 
Photoshop control over the entire selection edge 
and that is by using the Radius slider. It can some-
times be useful to move this slider up just a small 
amount so that the selection edges are smooth. 
We’ll set the slider to three, giving Photoshop con-
trol over a 3-pixel radius around the entire selection.

In the Select & Mask window, we’re using the View menu to choose the Overlay option, which 
places a red overlay over the non-selected areas. 

The Refine Edge Tool is being 
used to paint over the edge of 
the selection, giving Photoshop 
control over the selection in the 
areas where we paint.
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We’ll continue to paint along the 
rough edges with the Refine Edge 
Tool, cleaning up the area where the 
leaves meet the sky. Once we’re fin-
ished, there is another problem that 
we’ll need to tackle because there 
are gaps in the leaves where the sky 
shows through. We’ll need to include 
these gaps in the selection so we’ll 
use a small brush and start to paint 
over the gaps, giving Photoshop more 
control over the selection there. 

The red overlay can make it difficult to see where the gaps in the leaves are, so 
we’ll change the view menu to an option other than Overlay. The “Onion Skin” 
option will make the non-selected areas partially transparent and you can control 
the transparency level using a slider. Another great option is “On Layers,” which 
overlays the selected area onto the underlying layers in the Layers panel. Just 
know that the underlying layer needs to have its visibility turned on in order for 
this view to work. 

We’ll continue to paint over the gaps in the leaves and any other edges that need 
a cleaner selection. When we’re satisfied with the result, we’ll click the OK button 
to exit the Select & Mask window. This will bring us back to Photoshop’s main 
interface and we can see the new “marching ants” selection around the sky area. 
We’re going to use this selection to limit where that top layer is showing up so 
we’ll make sure the sky layer is active and then we’ll click on the Layer Mask icon 
at the bottom of the Layers panel. This will apply the selection to the layer mask, 
hiding all parts of the layer except for the area that was selected (the sky). 

Now we can zoom in on the image and inspect the mask. The mask edges look 
smooth in most places, but there are a few problem areas where the transition 
looks off. One of these areas is around the subject’s hand. There is a way to view 
the mask in the same way that we would view a selection in Quick Mask Mode, 

There are gaps in the leaves, revealing the 
bright sky, so we’ll need to include these gaps 
in the selection.
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and this can help us to see and fix the problem. We will tap on the backslash key  
( \ ) and a red overlay will cover the image in the areas that are NOT selected. This 
view of the mask will make any problems more obvious. 

With this red overlay visible, we can use the Brush Tool to fine tune the mask. 
Painting with black will hide areas (adding the red overlay) and painting with 
white will reveal areas (removing the red overlay). We just need to make sure that 
we’re painting on the mask instead of the layer itself. Looking at the thumbnails 
in the Layers panel, the mask thumbnail should have little white brackets around 
it. This means that the mask is active. If the layer thumbnail contains the brackets 
instead, we can click back on the mask thumbnail to make it active. 

We’ll use a small, relatively hard brush and 
paint with black over the part of the hand that 
was not masked correctly. We’ll scroll around 
the image, looking for any other areas where 
the mask needs touching up and we’ll use the 
brush to paint on those areas, refining the 
mask as much as possible. 

The selection of the sky was converted into a layer mask, so only the sky area is visible in the 
layer. You can see the mask in the Layers panel on the right.

In Quick Mask Mode, we’re touching 
up the selection using the Brush Tool. 
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There are some parts of the mask that have a transition that is too abrupt. For ex-
ample, the area where the soft, blurred greenery meets the sky is a hard line, but 
it should be a soft transition because this area is slightly out of focus. To adjust 
this part of the mask, we’ll activate the Blur Tool, which looks like a water drop 
icon in the Toolbar. We’ll use this tool to paint over the hard edge to blur the mask 
in this area. If it’s not becoming blurry enough, we can increase the Strength set-
ting in the Options Bar above the main image window.  

Optimize the shirt

Now that we have the sky layer optimized and masked, let’s create another ver-
sion of the image and use it to optimize the subject’s shirt. We’ll activate the bot-
tom layer (because it doesn’t already contain a layer mask), click on the Layer 
menu and choose Smart Objects > New Smart Object Via Copy. This will create 
a new smart object layer that can be adjusted independently of the other layers. 

ABOVE LEFT: The edge of the selection is too hard.  
LEFT: The Blur Tool is being activated in the Toolbar.  
ABOVE RIGHT: The Blur Tool is being used (painting on the 
layer mask) to soften the transition.
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We’ll double-click on this new layer 
to open the image in Adobe Camera 
Raw. Here, we’ll use the sliders to ad-
just the shirt, ignoring all other parts 
of the image. When the shirt is op-
timized, we’ll click OK to close ACR 
and go back to Photoshop’s main in-
terface. Now we only want the shirt to 
be visible in this layer, so we need to 
make a selection of the shirt and then 
add a layer mask. We’ll activate the 
Quick Selection Tool and we’ll turn on 
the Auto Enhance setting in the Op-
tions Bar. This will give us a smooth-
er selection. Then, we’ll use the Quick 
Selection Tool, set to a small brush, to 
paint over the shirt. Once we have a 
decent selection, we’ll tap the Q key 
to enter Quick Mask Mode. This will 
place the red overlay on the image 
in areas that are not selected and we 
can use the Brush Tool to refine the 
selection in this mode. We’ll zoom 
in on the shirt and use a very small 
brush to fine tune the selection. Re-
member, painting with black will add 
the red overlay, therefore deselecting the area. Painting with white will remove the 
red overlay, therefore adding to the selection. If the foreground and background 
colors are set to black and white, you can easily switch between the two by tap-
ping the X key. This shortcut swaps the foreground and background colors. Once 
the selection is refined, we’ll tap the Q key again to exit Quick Mask Mode. 

After processing a copy of the image to  
optimize the shirt., the Quick Selection Tool is 
being used to make a selection of the shirt area.

In Quick Mask Mode, we’re using the Brush Tool 
to refine the selection.



Image Blending © Ben Willmore, All rights reserved 13

With the selection active, we’ll add a layer mask by clicking on the Layer Mask 
icon at the bottom of the Layers panel. This will convert the selection into a mask, 
where the entire mask is black except for the area where the shirt is. This part of 
the mask is white and is therefore the only part of the layer that is visible.  

Optimize the pants

We will now create yet another version of the image that is optimized for the 
subject’s pants. To create another version, we need to copy one of the layers, and 
we can choose any of the layers to copy. We’ll copy the bottom layer because it 
doesn’t already have a layer mask attached to it. We’ll activate that bottom layer, 
click on the Layer menu and choose Smart Object > New Smart Object Via Copy. 
The new layer will appear and we’ll double-click on the layer thumbnail to open 
the image in ACR. Here, we’ll adjust the image to optimize the pants and we’ll 
ignore the rest of the image while doing so. Once the pants look good, we’ll click 
OK to return to Photoshop’s 
main interface. The pants 
look good, but the rest of the 
layer is now too bright, so 
we need to mask the layer so 
that only the pants are visi-
ble. Just like in previous lay-
ers, we’ll first create a selec-
tion around the pants. Again, 
we’ll use the Quick Selection 
Tool to do this. Using a small 
brush, we’ll paint with the 
Quick Selection Tool so that 
the pants are completely se-
lected. 

The Quick Selection Tool is being used to make an initial 
selection of the pants. 
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The challenging part is where her boots meet the grass. This is a complex edge, 
and would therefore be more suited for the Select & Mask feature that we used 
earlier to mask the leaves against the sky. We’ll click on the Select menu and 
choose Select & Mask. When the Select & Mask window opens, we’ll set the view 
menu to Overlay and this will give us the red overlay in the areas that are not se-
lected. We’ll activate the Refine Edge Tool, which is the second tool in the Toolbar 
on the left, and we’ll use it to paint over the area where the boots meet the grass. 
We might also bring up the Radius slider to maybe a setting of 4, which will give 
Photoshop control over a 4-pixel radius around the entire selection. When we’re 
done with the Select & Mask settings, we’ll click OK to go back to Photoshop’s 
main interface. 

The Select & Mask window is open and we’re using the Refine Edge Tool to paint over the 
area where the boots meet the grass. This is giving Photoshop control over the selection in 
this area.
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To inspect the mask, we’ll turn on Quick Mask Mode by tapping the Q key. In 
Quick Mask Mode, we can use the Brush Tool to fine-tune the mask if need be. 
When we’re sure the mask looks good, we’ll tap the Q key again to exit Quick 
Mask Mode. This leaves us with the marching ants selection, and we will convert 
that selection into a layer mask by tapping the Layer Mask icon at the bottom of 
the Layers panel. 

Optimize the skin

We’re going to repeat the process to optimize the skin. We’ll duplicate one of the 
existing layers by clicking on the Layer menu and choosing Smart Objects > New 
Smart Object via Copy. We’ll double-click on the thumbnail for the new layer to 
open the image in Camera Raw. We’ll use the adjustment sliders to optimize her 
skin, ignoring everything else in the image. When the skin looks good, we’ll click 
OK to exit Camera Raw and go back to Photoshop’s main interface. 

Now, we need to make a 
selection of the skin areas 
so that we can convert 
that selection into a mask 
that hides all other parts 
of the layer.  At this point, 
we’ve already created 
many layer masks, includ-
ing masks that surround 
the skin area. If we turn off 
the visibility of all layers 
that do not contain layer 
masks, we’ll see the indi-
vidual masked areas that 
are making up the image. 
Looking at these, we can 

The visibility is turned off for all layers that do not contain 
a layer mask. You can see that the masked layers help us 
to mask the face. The Lasso Tool is being used to make a 
rough selection around the skin.
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see that the other masked 
layers completely surround 
the skin area. Because these 
other masked layers are po-
sitioned above the skin lay-
er in the Layers panel, the 
mask for the skin layer does 
not need to be perfect, as 
the other layers are going to 
obscure the edges. We can 
simply use the Lasso Tool to 
make a very rough selection 
around the skin and then 
click the Layer Mask icon to 
convert that selection into a 
layer mask. 

Refine the image as a whole

Now we have five different versions of the picture that have been blended to-
gether into one document. If we want to refine the result as a whole, we can place 
the layers into a folder, or group, and then create retouching and adjustment lay-
ers on top of that group. To place all of the layers into a group, we’ll select all of 
the layers in the Layers panel and then click on the Folder icon at the bottom of 
the Layers panel. This will create a new group with all of the layers placed inside 
of it. We can double-click on the group name and rename it to “Image Blending” 
so that we remember the purpose of the group later. 

Next, we’ll click on the New Layer icon at the bottom of the Layers panel. This will 
create a new, empty layer at the top of the layer stack. We can rename this layer 
to indicate that it’s the retouching layer. Now, we can use the retouching tools 

The visibility of the masked skin layer is turned on. 
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(the Spot Healing Brush, Clone Stamp Tool, etc.) to clean up any areas of the 
image that need some cleaning up. With the retouching tool active, we’ll need to 
make sure that the Sample All Layers settings is turned on and that can be found 
within the Options Bar above the main image window.  We’ll use the Spot Healing 
Brush to remove any distracting elements in the foreground of the image.

Next, we can use adjustment layers to further refine the image. Any adjustment 
layers should go at the top of the layer stack. 

The first adjustment layer will be 
used to desaturate the distract-
ing blue objects that appear near 
the subject’s legs. We’ll click on 
the Adjustment Layer icon at 
the bottom of the Layers panel 
and choose Hue/Saturation. The 
Properties panel for the Hue/
Saturation adjustment layer will 
appear. We’ll make sure that the 
Targeted Adjustment Tool is ac-
tive. It looks like the little hand icon near the top left side of the panel. We can use 
this tool to click on one of the blue objects. When we do this, Photoshop will look 
at the color of the object and automatically set the color menu to the appropriate 
color. Now we can use the sliders to adjust the targeted color. We’ll drag the Sat-
uration slider all the way down and we can see that those blue objects turn more 
of a muted gray color. The problem is that the blue sky was also affected. We’ll 
need to use the mask that is attached to the adjustment layer to hide the adjust-
ment in the sky area. Using a really large brush, we’ll make sure the foreground 
color is set to black and we’ll paint over the entire sky area, hiding the adjustment 
in that part of the image. 

A Hue/Saturation Adjustment Layer will be used to 
desaturate these blue objects.
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The second adjustment lay-
er will be used to lighten up 
the part of the mountain area 
that looks darker than the rest 
of the mountains. We’ll use a 
Curves Adjustment Layer to 
achieve this. We’ll click on the 
Adjustment Layer icon at the 
bottom of the Layers panel 
and choose Curves from the 
pop-up menu. The Curves 
Properties panel will appear. 
We’ll again make sure that the 
Targeted Adjustment Tool (the 
little hand icon) is active and 
then we’ll simply hover the cursor over the area of 
the mountains that already looks ideal and look at 
the Curve chart. There will be a little circle on the 
curve that represents the area where the cursor is. 
We just want to remember the height of that little 
circle, because this is the height where the bright-
ness of the mountains looks ideal. 

Then, we’ll click on the area of the mountains 
we want to correct. This will place a dot on the 
curve. We want to take that dot and move it to 
the height of the ideal brightness that we made a 
mental note of. We can move it by simply clicking 
and dragging the dot. 

Now we want to limit where this adjustment shows up because it’s currently 
applying to the entire document. To prevent it from applying to the entire docu-
ment, we’ll start by filling the entire mask with black. To do this, we’ll click on the 
Image menu and choose Adjustments > Invert. 

With the Targeted Adjustment Tool active, we’re hover-
ing the cursor over the ideal part of the mountain and 
noting the position of the circle on the chart.

We placed a dot on the curve for 
the part of the mountain we want 
to fix. The dot is being dragged 
up to brighten the area.
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We’ll use the Quick Selection Tool to make a rough selection of the mountains. 
This selection will contain a rough edge, and the edges of the mountains are soft, 
so we’ll need to soften up the selection. We’ll click on the Select menu and choose 
Select & Mask. Here, we can use the Radius slider to give Photoshop control over 
the edges of the selection. We’ll set the Radius relatively high, to a setting of 19, 
and then click OK to exit the Select & Mask window. Now we have an active se-
lection around the mountains. We don’t want to fill the entire selection, but we 

can use the Brush Tool to 
paint with white over the 
area where we want the 
adjustment to be visible 
and the selection will pre-
vent us from getting paint 
overspill into the sky area. 
We’ll use a large, soft 
brush and paint over the 
part of the mountain that 
needed some lightening. 
This will reveal the Curves 
Adjustment in the area 
where we paint. 

In conclusion, with this lesson, we learned how to interpret an image with more 
than one set of adjustment settings and we were able to do that by opening the 
image as a smart object (because it contains a copy of the original raw file), cre-
ating new copies of that smart object with different adjustment settings applied 
and then masking the individual layers. 

We are painting with white on the layer mask to reveal the 
lightening effect from the Curves Adjustment Layer. The se-
lection is limiting the paint stroke to the mountain area.


