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Photoshop Video Keyframes

In this lesson, we’re going to dive deeper into video editing with Photoshop. Note 
that there is a separate lesson that covers the basics, so you may want to visit 
that one before working through this one. 

Here, I am going to introduce the concept of keyframes. Keyframes allow us to 
change a certain quality of a layer over time. This can be the opacity of the layer, 
the position of the layer, or a transformation that you’ve made to a layer.

Getting Videos into Photoshop

Let’s start by getting the videos and other media we want to work with into 
Photoshop. We’ll open the folder containing the media in Adobe Bridge. When 
I first viewed my video files in Bridge, I only saw the Quicktime icon instead of a 
video preview thumbnail. To fix this, I went to the Tools menu and chose “Man-
age Cache.” A dialog appeared and I clicked on the top option, “Build and export 
cache folder *folder name* and all enclosed folders.” I then clicked OK and all of 
the thumbnails displayed images instead of Quicktime icons. 

You can preview a video in Bridge by first clicking on 
the thumbnail to make it active. The video will appear 
in the Preview panel with a play slider beneath it. Click 
on the Play button and then use the slider to scroll back 
and forth through the video. (Note that you have to first 
click the Play button in order for the slider to work.) 

I also renamed my video files before moving them into 
Photoshop. This just helps you remember what kind 
of action is happening in each video layer. Select all of 
the video files within Bridge, go to the Tools menu and 
choose Photoshop > Load Files into Photoshop Layers. 
When it’s done, a new Photoshop document will open 
and there will be one layer for each video file. The layers 
will be named based on the file names. 

A series of video files were 
selected in Bridge and 
then loaded as layers into 
one Photoshop document.
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The Timeline Panel

The video layers will also appear within the Timeline panel, which runs along the 
bottom of the interface and is where you’ll be doing much of your video editing. I 
like to expand the Timeline panel so that I can see all of the video layers and then 
resize the main image so that I can see the entire thing within the main image 
window. Use the little slider at the bottom of the Timeline panel to zoom in and 
out. This is like zooming in and out on a map. You’re not changing the length of 
any of the videos. You’re just changing the view of them. 

If you ever want to get rid of the Timeline panel, you can either click on the Win-
dow menu and choose Timeline (to remove the check box next to its name) or 
you can click on the Window menu, choose Workspace and then choose a work-
space that’s not the Motion workspace. 

Organize the layers by changing their order within the Layers panel, based on the 
order in which you’d like them to play in your video. When you change the order 
of layers in the Layers panel, the order will also change within the Timeline panel. 

The playhead is positioned, by default, on the left side of the Timeline. Click and 
drag to the right in order to preview the video, knowing that the top video layer 
will hide your view of the layers beneath it. The length of the video will be dis-
played at the bottom of the Timeline, beneath the list of video layers.

The Timeline panel is shown above. It shows all of the layers and how they will appear over a 
specified time frame. 
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Splitting clips and removing pieces of clips

You may not want to use the entirety of a video clip in your project. If that’s the 
case, you could either split the clip in two pieces and remove the unwanted piece, 
or you could trim the clip from the beginning or from the end. 

To split a clip into two pieces, first position the playhead over the area where you 
want to split the clip and then click the little Scissors icon in the top left side of 
the Timeline panel. This will split the clip into two pieces, with each piece on a 
different layer. You can then delete the layer that you don’t want.

To trim a clip, first position the playhead over the area that you want to trim to. 
Then hover your cursor over the beginning or ending edge of the clip. When the 
cursor changes into a bracket with two arrows, click and drag on the edge of 
the clip until it meets the location where you positioned the playhead.  You can 
then click and drag on the clip in order to position it where you want it to appear 
within the Timeline. In the video example, we trimmed the clip to remove the first 
half and then we dragged it to the left side of the Timeline so that it would start 
playing at the beginning of the video. 

The top clip is being trimmed by clicking and dragging on one of the edges of the clip within 
the Timeline panel. 
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Grouping video layers

If you know that you’re not going to have more than 
one video clip playing at the same time (where one 
video overlays another), you can simplify your Time-
line panel by placing the video layers sequentially 
on a single horizontal bar. This is a simple drag-and-
drop process. When you place more than one video 
on a single horizontal bar, those video layers will 
be placed into a layer group, and you will see that 
reflected in the Layers panel. You can change the 
name of the layer group within the Layers panel. 

In the video example, we placed a series of video 
clips on the top bar in the Timeline panel and then 
dragged on the edges of each clip to trim the be-
ginning and ends, ensuring we weren’t including any 
video footage that we didn’t want. When you trim 
clips that are grouped on the same horizontal bar, 
it’s going to automatically snug the clips together 
so that there are no gaps between them. 

Here, we are dragging multiple video clips onto the same horizontal video bar so that they 
will play in a sequential order. 

When multiple clips are moved 
to the same horizontal bar int 
he Timeline, they will be placed 
in a group within the Layers 
panel. Here, we renamed the 
group “Main Storyline.”
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Adding Still Photographs

A video can also contain still photographs and there are a few ways of adding ad-
ditional media to the document. The easiest way is to drag and drop. Position the 
Photoshop and Bridge windows so that you can see both on your screen at the 
same time. Then, simply use Bridge to find the image you want and then drag the 
image directly into the Photoshop image window. Whenever you add an image 
like this, Photoshop is going to add it as a smart object and it is automatically go-
ing to scale down the image 
so that it fits within the doc-
ument bounds. The trans-
form handles will be active 
so that you can manually ad-
just the image’s size and po-
sition. In the video example, 
the image we added did not 
fill the document frame on 
the left and right sides so we 
actually used the transform 
handles to scale the image 
up so that it filled the frame 
completely. 

When you drag an image from Bridge into Photoshop, that image is going to be 
placed on a layer that is directly above the layer that was previously active. In 
our example, the active layer was inside of a layer group, so the new image was 
placed inside of that group as well. Remember, any time that layers are placed in-
side of a single video group, they will be located on the same horizontal bar in the 
Timeline and they will all appear in sequential order within the video. In our case, 
we want the new image to appear on a separate horizontal bar in the Timeline 
because we’re going to make the image appear as the same time as the video. To 
achieve this, we simply dragged the layer thumbnail outside of the layer group in 
the Layers panel. 

This photo was dragged from the Bridge window directly 
into the Photoshop window. When you drag an image into 
Photoshop like this, it’s added as a smart object. 
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Picture in picture You can make one picture (or video) appear at the same time 
as another video inside a smaller picture window. Place the playhead in the lo-
cation where you’d like the picture to overlay on the video and then drag the 
photo clip to that spot. It should click in place to the location you set the play-
head. By default, the picture will take up the entire frame, hiding any video layers 
beneath it. To create more of a picture-in-picture effect, click on the Edit menu 
and choose Transform > Scale. Transform handles will appear around the layer 
and you can use them to scale and reposition the image so that it appears in an 
appropriate place above the video layers. Press the Return/Enter key to lock in 
the transformation. To control how long that image should play within the video, 
drag the edge of the clip within the Timeline to make it wider (to play longer) or 
narrower (to play for a shorter time). 

ABOVE: The image layer was positioned so that it overlapped 
the video layers in the Timeline. The Transform command is 
being used to scale the image down so that it only appears 
in a small window above the video. LEFT: The edges of the 
image clip are being dragged to specify the length of time the 
image will appear in the video.
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Keyframes: Make an image zoom over time

One of the things we can do with the images in our videos is make them zoom in 
or out over time. Note that to make an image zoom in, it needs to start in a state 
that is already scaled down so that we don’t bring it to a resolution that is larger 
than 100%, as this would cause the quality to go down. 

When we make the image zoom, we don’t want to change the size of the image 
frame. We instead want the contents of the image to get bigger within the im-
age’s frame, and this will make things a bit more complicated. 

Make sure that the image layer that you want to zoom is active in the Layers 
panel. Then, hold down the Command key (Ctrl on Win) and click on the layer 
thumbnail. This will create a selection around the contents of the layer. Next, add 
a layer mask by clicking on the Layer Mask icon at the bottom of the Layers panel. 
This will create a mask that hides everything that’s outside of the active selection. 
The layer has no content outside of the active selection but it will after we start 
scaling the layer up. 

Now if you were to scale the layer as is, Pho-
toshop will assume that the layer mask should 
scale with it, and you don’t want that. You 
need to tell the layer mask to stay in place 
while the contents of the layer changes. To do 
this, click on the little link icon between the 
layer thumbnail and the mask thumbnail. This 
will unlink the layer from the mask so that they 
can move independently of one another. 

The Transform Keyframe  Now the image layer is set up such that it can be scaled 
within its frame. In the Timeline, make sure that the image clip is active and that 
the playhead is positioned at the beginning of the clip. Then click on the little 
triangle to the left of the layer name for the image layer. This will expand a list of 
keyframe options. To create the scaling effect, you’ll want to use the keyframe 
called Transform. 

A layer mask was added to the im-
age layer and we unlinked the layer 
and the mask so they can move inde-
pendently of one another.
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Click on the little stopwatch icon and Photoshop will start keeping track of any 
transformations made to the layer. A little yellow diamond will appear beneath 
the image layer, indicating that Photoshop just recorded the size and position 
of the layer at that point in time. Whenever the playhead reaches that particular 
point, the image layer will look as it does right now. 

Now, drag the playhead to the end of the image clip in the Timeline. Click on the 
Edit menu and choose Transform > Scale. Transform handles will appear around 
the layer and you can use them to scale the image up to the size that you want 
it to ultimately zoom to. Because the layer is unlinked from the mask, the image 
frame will not change size, just the image inside of it. When you’re done scaling 
the image, hit the Return/Enter key to lock in the transformation. Another key-
frame will automatically be added at the point on the Timeline where you made 
the transformation. 

LEFT: Click on the little triangle to the left of the layer name (circled) to expand the list of 
keyframes. RIGHT: After clicking on the stopwatch icon to the left of the Transform keyframe, 
a yellow diamond will appear, marking the keyframe position.

LEFT: The image layer is 
being scaled after creating 
a keyframe. ABOVE: After 
scaling the image, a sec-
ond keyframe was added.
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If you want to change the length of the image clip, you can do so by dragging 
the edges of the clip, but know that the keyframe will not move with it. If you 
want to move the keyframe as well, you will need to manually by drag it sepa-
rately. You can also add multiple transformations to a single image. 

In the example, we scaled the image up. If we were to move the playhead and 
then make another transformation (perhaps we rotate the image), then anoth-
er keyframe would automatically be added for that transformation. You can 
manually add more keyframes by clicking 
the little diamond icon to the left of the 
Transform keyframe category on the left 
side of the Timeline.

To copy the function of one keyframe 
and apply it to another, right-click on the 
keyframe that you want to copy. A pop-
up menu will appear and you can choose 
Copy. Then, right-click on the keyframe 
that you want to change and choose Paste 
from the pop-up menu. You can delete a 
keyframe by right-clicking on it and choos-
ing Delete from the pop-up menu. 

Keyframes: Make an Image Fade over time

The Opacity Keyframe  Now let’s look at some of the other types of key-
frames. The Opacity keyframe can be used to make an image fade out or fade 
in over time. To make an image fade out, position the playhead at the location 
where you would like the image to start fading out and then click on the little 
stopwatch icon to the left of the word “Opacity” on the left side of the Time-
line. This will set the first keyframe, locking in the opacity of the image at the 
specified point in time. Then, position the playhead at the location where you 

Right-click on a keyframe to copy or 
paste its functionality.
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would like the fade-out to end. Use the Opacity setting at the top of the Layers 
panel to change the opacity from 100% to 0%. At 0%, the layer will be completely 
invisible. When you change the opacity setting, another keyframe will automat-
ically be added, marking that change. Now, if you drag your playhead over the 
image clip, you will see that it starts at full opacity and then begins to fade after it 
passes the first keyframe. It will be completely transparent by the time it reaches 
the second keyframe. 

Adding Text

Text can be added to your video projects just like you would add it to a regular 
Photoshop document. Activate the layer on top of which you’d like the text to 
appear. In addition, position the playhead in the location you’d like the text to 
appear in the Timeline. In the video example, we moved the playhead to the be-
ginning of the Timeline because we want the text to start at the beginning of the 
video and serve as an introduction. We also activated the top layer so that the 
text layer would be placed above it, at the top of the Layers panel. 

Activate the Text Tool, click within your document to place the cursor and start 
typing in your text. This will create a new type layer that will appear within your 
document. You will need to drag the edges of this clip within the Timeline in order 
to specify how long the text should appear in the video. 

In the video example, we decided that we wanted the text to fade in at the be-
ginning of the video. We set the playhead to the very beginning of the Timeline 
and then created an Opacity keyframe. (Remember that you need to click the 
little arrow to the left of the layer name in order to expand the keyframe list.) We 
set the opacity of the layer to 0% so that the keyframe marks the layer as being 
invisible in this location. We then moved the playhead to the right by the number 
of frames we want it to take for the text to fade in. We then set the opacity to 
100% and when we did this, a new keyframe was automatically added. 
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To take things further, we added some Transform keyframes to the text layer so 
that, in addition to the fading effect, the layer also got larger as it moved out of 
the frame. To accomplish this, we positioned the playhead at the location where 
we wanted the text to start moving and then clicked the stopwatch icon to add 
a Transform keyframe. We then moved the playhead to the location where we 
wanted the transformation to end and we used the Transform command to repo-
sition and resize the text layer. When we did this, a second keyframe was auto-
matically added to log that change. 

Keyframes: Adding Styles

The type of keyframe named Styles is going to allow you to add the types of ef-
fects that you would find under the FX menu or the Layer Styles dialog and then 
cause these effects to change over time. This type of keyframe can be applied in 
the same way as the Opacity and Transform keyframes. 

In the video example, we’re going to use Style keyframes on another text layer 
that we want to appear at the end of the video. We’ll add the text layer in the same 
way we did the previous one, this time positioning the playhead near the end of 
the video Timeline. We want this text to look like it’s hovering above the ground 
and then coming to a land. We can achieve this effect by using drop shadows. If 
you move a sun-lit object closer and closer to the ground, its shadow will become 
darker and less feathered, so that’s what we’ll make the drop shadow do.

At left, the Opacity 
keyframe was used 
to make the select-
ed text fade in over 
a short period. At 
the first keyframe, 
the text is at 0% 
opacity. At the sec-
ond keyframe, it’s 
at 100%. 
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With this effect, we’ll start by determining how it should look when it’s done, 
so we’ll position the playhead at the very end of the video, where we want the 
change to stop happening. We’ll move the text so it’s in the ideal ending position 
and then we’ll click the FX icon at the bottom of the Layers panel and choose 
Drop Shadow from the pop-up menu. The Layer Style dialog will appear and the 
Drop Shadow settings will be at the forefront. We’ll use our mouse to manually 
position the drop shadow so that it’s very close to the text itself. We’ll also make 
sure that the opacity is at a relatively high setting so that the shadow is dark, and 
then we’ll click OK. 

Here, we are defining what the text layer should look like at the end of the video. A Drop 
Shadow layer style is being added. At the end of the video, we want the shadow to be dark 
and close to the text. 
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Now we want it to keep track of the settings that we use for that layer over time, 
so we’ll click on the arrow to the left of the layer name to expand the list of Key-
frame types. We’ll then click on the stopwatch icons for the Opacity keyframe, 
the Transform keyframe AND the Style keyframe. We want Photoshop to keep 
track of all these things put together.

Next, we’ll position the playhead at the location where the text clip begins in the 
Timeline. We want the text to start off very large and move from outside of the 
screen so we’ll use the Transform command (Edit > Transform) to scale the text 
size up quite a bit and position it almost outside of the top edge of the frame. 
We’ll click Return/Enter to lock in the transformation. A keyframe will automati-
cally be added to mark this change in the Timeline. 

Then, we’ll click on the FX icon at the bottom of the Layers panel and again choose 
Drop Shadow from the pop-up menu. We’ll use the drop shadow settings to po-
sition the shadow very far from the text and set the opacity very low. We’ll also 
move the Size slider far to the right so that the shadow is very soft and spread 
out. We’ll click OK and, again, another keyframe will automatically be added to log 
the change. We’ll also lower the opacity to about 50% so that the text starts off 
partially visible. A keyframe is automatically added to mark that opacity change. 

Here, we are de-
fining what the 
text layer should 
look like when 
it first appears 
in the video. A 
drop shadow 
is being added 
that is very soft, 
light and far 
from the text.
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In the end, when we drag the playhead across the text clip, we will see it start off 
very large, with a soft drop shadow. As we drag the playhead to the right, the text 
gets smaller and moves into the frame, while the drop shadow gets harder, darker 
and closer to the text. 

Keyframes: Warping text

The final type of keyframe that you’ll see in the Timeline panel is the Text Warp 
keyframe. This type will only show up when you’re working with a text layer. 

To warp text, place the playhead over the area where you don’t want the text to 
be warped and add a Text Warp keyframe. Then, position the playhead over the 
place in the Timeline where you DO want the text warped. Go to the Edit menu 
and choose Transform > Warp.  A warp grid will appear over the text and you can 
use the Warp menu in the Options Bar above the image window to choose what 
type of warp you want. Then you can adjust the severity of the warp by using 
the additional settings in the Options Bar. Click Return/Enter when you’re done. 
A new keyframe will automatically be added and the warp effect will gradually 
occur in the time period between the two keyframes. 

Above, you can see the starting and ending state of the text. It moves from one state to the 
other as the playhead moves over the text clip in the Timeline. The text bulge effect you see 
at the starting point was created using the Warp command.
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A trick for using keyframes with video layers

A lot of cameras can capture 4K video, which is twice the width as HD video., 
though it’s rare to need 4K video for a project. But, if you set your camera to 
record in 4K video, you’ll have twice the width and twice the height that you’d 
actually need. This will allow you to zoom into your video clips without a loss in 
quality. You would do this using the Transform keyframe and you can scale up to 
twice the height and width of a normal HD video. 

If you open a 4K video in Photoshop but only need HD video, here is what you 
can do so that you can use the zoom technique. Activate the Marquee Tool and, 
in the Options Bar, set the Style menu to Fixed Size. Type in the width and height 
in pixels for the document size that you need. If your goal is HD video, type in the 
dimensions of 1920 x 1080. Click within your image and you will get a rectangu-
lar selection of that size. Next, switch to the Crop Tool and the crop handles will 
automatically snap to the size of the selection. Before hitting Return/Enter, make 
sure that the “Delete Cropped Pixels” check box in the Options Bar is turned off. 
Hit the Return/Enter key and the canvas will crop to the chosen size, but the rest 
of the video content will still be there, outside of the frame edges. This will enable 
you to zoom out and in while retaining the image quality. 

This 4K video file 
is being cropped 
to the size of HD 
video. The “Delete 
Cropped Pix-
els” check box is 
turned off so that 
we still retain all 
of the video con-
tent outside of the 
frame edges.


