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Image Size Calculations 

In this lesson, we’re going to learn how to use the Image Size dialog box to do some 
useful calculations. In one example, we’re going to open a floor plan in Photoshop 
and use the Image Size settings to correctly scale furniture so that it accurately fits 
into the plan. In another example, we’re going to take three different images (of 
me) and scale an object (my head) within each individual document so that it is the 
same size in all documents. 

Sizing furniture to fit in a floor plan

Open the floor plan PDF in Photoshop Let’s start with the floor plan example. The 
floor plan document is a PDF file and we can open that in Photoshop simply by 
dragging it to the Photoshop icon. Alternatively, we could right-click on the file 
within Bridge and choose Open With > Adobe Photoshop CC from the pop-up 
menu. Photoshop will come to the forefront and the Import PDF dialog will appear. 

There are two different types of PDFs: raster and vector. A raster image is made out 
of pixels and a vector image is made out of paths. You can tell which type of PDF 
file it is by clicking on the Image check box in the top left corner of the Import PDF 
dialog. If nothing shows up in the 
window below, it’s a vector PDF. 
If individual images show up, it’s 
a raster PDF. If it’s a vector PDF, 
as we have here, it means that it 
can be scaled to any size without 
reducing quality. 

I’ll click back on the “Pages” 
check box so that I can see the 
floor plan icon again. On the 
right side, we can specify how 
large we’d like the floor plan to 
be. We’ll turn on the “Constrain 

The Import PDF dialog appears when opening a PDF 
file in Photoshop. Here, we are using the Width field to 
open the file at 5000 pixels wide.
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Proportions” check box so that the image does not become distorted when we 
change the dimensions. I want to make the floor plan huge, so I’ll set the Width field 
to 5000 pixels and then click OK. 

Fill transparent background with white The PDF will open in Photoshop and the 
first thing we’ll notice is that there is a lot of transparency. The only parts of the im-
age that don’t have the transparency checkerboard are the areas where the black 
lines of the plans are. We want to be able to see this a little better so we’re going 
to fill the transparent areas with white. We’ll click on the Adjustment Layer icon at 
the bottom of the Layers panel and choose Solid Color from the pop-up menu. The 
Color Picker will appear, we’ll choose white and then click OK. The Color Fill layer 
will appear at the top of the layer stack, so we’ll drag it beneath the layer that con-
tains the floor plan. 

We’ll zoom in on the document and inspect the lines. Here, we can see a small 
amount of anti-aliasing on the edges. This is where there are some partially trans-
parent pixels to try and make things look smoother. We only have a little of that 
here, but depending on what software created the document, you might experi-
ence much more of that. It may help the document, or it might be a problem. If it’s 
a problem, you can correct it and make all the lines look solid. To do this, duplicate 

The floor plan 
had a transpar-
ent background, 
so we created a 
white solid color 
layer and placed it 
beneath the floor 
plan layer.
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the layer multiple times, until all of the lines look solid when viewed closely. Then, 
flatten the image so there is a single layer containing the floor plan with a white 
background. That’s what we’ll do here. 

Sizing the image  Now we want to find an area of the floor plan that we know the 
correct size for. I know that the length of one of the rooms is 12’10”. (I know that 
because I measured it with a tape measure.) We want to make it so that if I make 

a selection of the area in Photoshop, that selection will 
numerically tell me the correct dimensions (12’10”). We 
can achieve that by using the Info panel and the Image 
Size dialog. If the Info panel is not open in your interface, 
you can access it by going to the Window menu and 
choosing Info. The Info panel is going to be set to the 
same units that the rulers are set to. We want the units 
to be set to inches. If they are not already reading inches, 
we can click on the crosshair in the lower left corner of 
the panel to access the units menu. Here, we can set the 
units to inches. 

We’ll make a selection of the length of the room that we know is 12’10”. In our doc-
ument, it’s going to read as the height because of the orientation of the floor plan. 
Looking at the Info panel, we can see that the Height readout is 20.444 inches. We 
want the Info panel to think that it’s 12’10” so that it accurately reflects the actual 
size. To do this, we need to tell it how big the pixels are that make up the document. 
In other words, we need to change the resolution, which is how large the pixels are 
when printed. We want to adjust this so that if we printed the document, the room 
would be 12’10”. 

With the selection of the room active, we’ll go to the Image menu and choose Crop. 
This will crop the document to the size of the selection. Then, we’ll go to the Image 
menu and choose Image Size. In the Image Size dialog, we’ll set the unit menus to 
Inches and the Width and Height readouts show that the size of the selected area 
in the document was about 5” x 20”. 

To change the units to 
inches, we are using the 
menu in the bottom left 
corner of the Info panel.
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We’ll first turn off the Resample check box because we don’t want to change the 
amount of information that’s in the file. We just want to change how big Photoshop 
thinks the pixels are. To do this, we need to calculate the resolution. The lower the 
Resolution number, the fewer the number of pixels that fit in an inch. 

I know that 12’10” is 154” so we’ll type 154 into the Height field. When we do this, the 
Resolution number changes to 9.558 and this is the number we need. (Remember 
that the Resample check box MUST be turned off in order to get an accurate result 
here.) Now we just used the Image Size dialog to calculate that resolution number, 
so we’ll simply hit the Cancel button to exit the dialog. Then, we’ll go to the Edit 
menu and choose Undo Crop. (We had only cropped so that we could make that 
calculation.) 

We know the area defined by this cropped document is 12’10” tall, which is 154” tall, so we en-
tered 154 inches into the Height field. This gave us a resolution of 9.558. This is the number we 
must remember so that we can use it later. 
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Now, working on the uncropped version of the picture, we’ll go back to the Image 
menu and, again, choose Image Size. Once again, we’ll make sure that the Resam-
ple check box is turned off and we will enter in the resolution we just calculated: 
9.558. We’ll click OK to exit the dialog. The picture will not LOOK like it changed, 
but if we make the same selection and then look at the Info panel, the Height read-
out is going to read out 154”, which is the correct size of the room. Now, anything 
we measure in the document should be the correct size. I’ll make a selection of the 
garage and then look at the Info panel. The Width and Height readouts will now 
display the accurate dimensions for the space. 

Now that we have the document sized to the 
same size as the house, we can easily place fur-
niture of specific sizes to see how it would look 
in the space. Let’s say that I want to see what a 
specific desk would look like in my office. We’ll 
activate the Shape Tool and make sure that the 
menu in the Options Bar (above the image win-
dow) is set to Shape. 

Now that the 
document is 
sized correctly, 
we can make a 
selection of a 
space and look  
at the Info panel 
to get the precise 
dimensions of  
the area.

When using the Shape Tool to 
place furniture, we want to make 
sure the tool is set to create a 
Shape (not a path or pixels).
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Then, instead of clicking and dragging to define a shape, we’ll 
hold the Shift key and click once within the document. This 
will bring up the Create Rectangle dialog where we can en-
ter in specific dimensions for the shape. The desk that I want 
to place is 24” x 84” so I will enter those dimensions into the 
Width and Height fields, making sure to type “in” after each 
number to specify that it’s inches. We’ll then click OK and the 
shape layer will appear in the document. We’ll use the Move 
Tool to position the shape of the desk into the correct spot in 
the floor plan. This will give me a good idea of how large the 
desk will look in the space. We can create as many shape layers as we’d like to 
place furniture of specific sizes into the space. Again, the Marquee Tool can also be 
used to measure specific areas. We’d simply make the selection and then look at 
the Info panel to see the dimensions. 

With the Shape Tool, 
we held the Shift key 
and clicked in the 
document. This al-
lows us to enter the 
width and height.

A shape layer was created to represent a desk. It was set to a specific size so that I could see 
how it fit into my office space in the floor plan. 
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Scale an object to the same size in multiple images

Measure the height in pixels  Now let’s use the Image Size dialog to calculate the 
height of an object in pixels. In this example, we want to take the same object in 
three different documents and make it the same size in pixels across all the docu-
ments. The object in question here is my head. 

First, let’s look at all three images and find the one where my head appears the 
smallest. We will scale the other images down to this size. We’re choosing this way 
because we don’t want to scale anything up due to the loss in quality. 

In Bridge, we’ll select all three images and then 
double-click on one. This will open all of the 
images as separate Photoshop documents. 
We’ll start on the image where my head is the 
smallest and we’ll use the Rectangular Marquee 
Tool to create a selection that is the height of 
my head. Just as in the previous example, we’ll 
now crop the document to the size of this se-
lection by going to the Image menu and choos-
ing Crop. 

We’ll click on the Image menu and choose Image Size. We’ll again use the Image 
Size dialog as a calculator. We want to set the units menus to Pixels, but in order 
to do this, we need to make sure that the Resample check box is turned ON. (If the 
Resample check box is turned off, the Pixels option will be grayed out in the units 
menu.) Once set to pixels, we’ll simply make a note of the height in pixels, which is 
357 in this case. This is the size we want my head to appear in the other two doc-
uments. 

We only used the Image Size dialog to get that readout, so we’ll click the Cancel 
button to exit the dialog. We’ll also undo the crop by going to the Edit menu and 
choosing Undo Crop. 

A selection is being made of the ob-
ject (my head) so that we can see the 
height of the object in pixels.
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We’ll now open one of the other documents and we want to resize it so that my 
head is the same size in pixels as it appears in the first image. We’ll use the Rectan-
gular Marquee Tool to make a selection of the area we want to work with (my head) 
and then we’ll click on the Image menu and choose Crop. We’ll then go back to 
the Image Size dialog (Image menu > Image Size) and we DO want to turn ON the 
Resample check box. This means that we want to change the amount of informa-
tion that we have. We’ll change the unit menus to display pixels and we’ll change 
the number in the Height field to match the number that we recorded in the other 
document (357). We want to use this to scale the document. 

Now we just want to click away from the height field by clicking on another field so 
that the Height is no longer highlighted. Then, we will change the unit menu on the 
Height field to read out the Percent. This will tell us the percentage that it scaled 
the image down in order to make it the height shown. In this case, it’s 42.2%. We’ll 
remember this number because it tells us how much we need to scale the entire 
document down. 

Again, we’ll click the Cancel button to exit the Image Size dialog and then we want 
to undo the crop so we’ll click on the Edit menu and choose Undo Crop. 

LEFT: The same object is being selected in the second image. RIGHT: The Image Size dialog is 
being used to enter the height in pixels and then convert the units to percent so that we know 
what percentage to use when scaling the entire document.
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With the full image, we’ll go back to the Image Size dialog and make sure that the 
Resample check box is turned on. We’ll change the unit menus to Percent and we’ll 
enter in 42.2, which is the percentage that we previously made a note of. We’ll click 
OK and the image will resize. We can check our work by making a selection around 
my head and then looking at the dimensions in the Info panel to see that the height 
matches the height of my head in the first image. The same steps can be used to 
scale the third image, and then my head will be the same number of pixels tall in 
each image. 

This technique can be used any time you want to make an object the same size 
across multiple documents. 


