
Multi-Processed Raw



Multi-Processed Raw © Ben Willmore, All rights reserved 2

Multi-Processed Raw 

In this lesson, we’re going to look at how I take many of the features that we’ve 
covered in previous lessons and combine them to work an image. In the process, I 
think you’ll learn a lot.

The image was shot for HDR & is made up of three exposures The image I’m go-
ing to work with is made up of three exposures that were captured by using the 
auto-bracketing feature on my camera. They were captured at two stops apart. 
The really bright shot ensures that I will have detail in the shadows and the really 
dark exposure ensures that I will have detail in the highlights (the sky area). In or-
der to combine them for HDR, I selected  them all in Lightroom, then clicked on 
the Photo menu and chose Photo Merge > HDR. This brought up the HDR dialog 
where I could adjust a few settings (if necessary) and then send the result back to 
Lightroom’s main interface. 

The three exposures above 
were shot at two stops apart. 
At left, you can see the HDR 
image created by merging 
the three exposures.
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Compare the merged HDR with a single exposure  

Whenever I shoot for HDR, I will compare the HDR version to an individual expo-
sure to see if it’s truly better. Sometimes, it turns out that one of the single expo-
sure looks better to me than the merged HDR. In order to make this comparison, I 
need to get the single exposure to be the same brightness as the merged HDR. I’ll 
choose the single exposure that I think has the best tonality (In this case, it’s the 
middle exposure) and I will open that image within Lightroom’s Develop Module 
(or Adobe Camera Raw). In order to make the single exposure as close in tonality 
to the merged HDR image, I would like to view the images side-by-side. On the left 
side of the tool bar (beneath the image window), there are some alternative view 
icons. I’ll click the one that contains the letters R and A. This will split the image 
window in half, placing the current image (the single exposure) on the right side. 
I can now find the merged HDR image in the Filmstrip that runs along the bottom 
of the interface and drag it into the left window. This will serve as the Reference 
photo. 

Here, I am using the [R|A] view to compare the merged HDR image (on the left) with one of 
the single exposures (on the right). This will allow me to determine whether the HDR image is 
truly the better version. 
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I now have both images side-by-side. The version on the left is just the reference 
photo. The version on the right is the active image and it is the one that will change 
when I move the sliders. I will work with the sliders and try to get the brightness 
to match the brightness in the reference photo. When the cursor is hovered some-
where over the image, a series of numbers will appear beneath the Histogram and 
these can serve as tools when matching the brightness of the two images. By de-
fault, however, these numbers represent the RGB values (meaning the red, green 
and blue values) and I’ll need to change that. I’ll right-click within the histogram 
to get a little pop-up menu and I will choose “Show LAB Color Values” from that 
menu. Now, there are numeric values for L, A and B appearing beneath the Histo-
gram. The L value represents the brightness of the area where the cursor is hover-
ing. Knowing this, I can hover the cursor over an area on the reference image and 
make note of the L value. Then, I can hover the cursor over the SAME area on the 
active image and then look at the L value so I can compare how close they are in 
brightness. This number will also give me guidance as to how I should adjust the 
sliders to get the brightness of both images to match. 

While in the [R|A] 
view, I am using 
the adjustment 
sliders to try and 
make the bright-
ness of the image 
on the right (the 
active photo) 
match the bright-
ness of the image 
on the left (the 
reference photo). 
I set the Histo-
gram to read out 
LAB values (cir-
cled). The L value 
represents the 
brightness of the 
area under the 
cursor. 
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After adjusting the brightness, I also like to expand the Lens Corrections tab and 
turn on the check box to “Remove Chromatic Aberration,” which removes any arti-
fact represented as pink and green lines that sometimes appear around the edges 
of things. I’ll also turn on the “Enable Profile Corrections” check box, which corrects 
for any distortion caused by the lens. After making adjustments in the Develop 
Module, I’ll move back to Lightroom’s Library Module.

Looking at the images in the Grid View within the Library Module, I now want to 
compare the two images and decide which is better. (The reason I didn’t make this 
comparison in the Develop Module is that you can’t zoom in on both images at the 
same time while in that module.) I’ll select both images and then think about which 
one I THINK is going to be better. That’s the one that should be most selected. You 
can determine which image should be most selected by clicking on it once. It will 
have a brighter highlight than the other selected image[s]. In this case, I think that 
the HDR image is going to be better so I’ll make sure that one is the most selected. 
Then, I’ll click the Compare View icon (  [X|Y] ) on the left side of the Toolbar in or-
der to get the images side by side. The merged HDR image was the most selected 
so it will be positioned on the left, as the “Select.” The single exposure will go on 
the right, as the “Candidate.” 

What’s special about this view is that I 
can zoom in and move around within 
an image, and both images will zoom 
and move in the same way. This truly 
allows for a good comparison. When 
I click once on the image, it will zoom 
to a 1:1 view by default. If you’d like 
to change the zoom ratio, open the 
Navigator panel and either choose 
from the zoom options at the top, 
or click on the little side menu to get 
even more zoom options. 

Change the zoom ratio in Lightroom’s Develop 
Module by using the options at the top of the  
Navigator panel.
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Now I will zoom in to a 1:1 view and start scrolling around the image, comparing the 
different areas side by side. One of the things that I notice is that there is a problem 
with the trees in the merged HDR image. There was some motion in the branches 
at the time the images were shot, and this resulted in a ghosting artifact when the 
images were merged for HDR. I also notice a bit of a double edge in the sign area 
of the merged HDR image and this could be the result of shooting hand-held, and 
then having poor alignment when merging the images. 

Looking at the overall crispness of the images side-by-side, the single exposure is 
much sharper overall, and this is the one I am going to use when I move forward 
to process the photograph. I’ll click back on the Grid View icon below the image 
window to get out of this comparison view. 

Here, I am using the Compare View to look at the images side by side. When I zoom in on 
one side, the other side zooms as well, which makes it easier to compare images. Here, I can 
see that there is some ghosting artifact in the HDR image (on the left) and I can see that the 
image on the right (the single exposure) is sharper overall. 
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Process the image to optimize the building 

Now I’m going to use the single exposure and interpret it multiple ways inside of 
the Develop Module. I’ll create multiple versions of the image, each processed to 
optimize a specific area. In the end, the images will be blended together to com-
bine all of the optimized areas. 

I’ll open the image in the Develop Module and use the various tonal and color slid-
ers to first make the building look good. I’m going to ignore everything else except 
the building. I will also expand the Lens Corrections panel and make sure that the 
following check boxes are turned on: “Remove Chromatic Aberration” and “Enable 
Profile Corrections.” 

Under the Detail panel, I’ll work with the Masking slider to control what areas get 
sharpened. By holding down the Option key (Alt on Win) while dragging the Mask-
ing slider, I’ll get a different view of the image that shows what areas are being 
sharpened. Anything that is white is being sharpened and anything that is black 
will not be sharpened. I will drag this slider until anything with no usable detail 
turns black. This will ensure that I’m not sharpening areas that just contain noise. 

In Lightroom’s Develop Module, I am using the Masking slider (within the Detail panel) to 
control what areas are being sharpened. I’m holding down the Option key (Alt on Win) to get 
this special view where white represents areas that will be sharpened. 
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The last thing I will do is reset any cropping that was done to the image. I do this 
whenever I know I am going to combine multiple versions of the same image. To 
reset the crop, I’ll activate the Crop Tool (located above the adjustment panels in 
Lightroom) and click the Reset button. 

Open the first processed version in Photoshop

After I’m finished working on this version of the image, I will open it in Photoshop 
as a smart object. To do that, I’ll click on the Photo menu and choose Edit In > Open 
as Smart Object in Photoshop. This will create a special layer where the entire raw 
file is embedded directly in the layer. What’s nice about a smart object layer is that 
you can double-click on the layer thumbnail to edit the original image. In the case 
of a raw file, double-clicking on the layer thumbnail will open the image in Camera 
Raw so that I could further refine the settings. 

 

Process the image to optimize the sky

Now it’s time to create the next version of the image. With the first version, I pro-
cessed the image to make the building look good. In this next version, I’ll process 
to make the sky look good. 

I want to duplicate the first smart object layer, but I need to do that in a special 
way. If you duplicate a smart object layer in the standard way (using the shortcut 
Command+J / Ctrl+J), then it’s going to create a second instance of the same 

The first processed image was opened in  
Photoshop as a smart object. At left, you can 
see the layer thumbnail in the Layers panel. 
The icon in the bottom right corner of the 
thumbnail means that the layer is a smart  
object.
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smart object. Any changes you make to it will affect ALL instances of that smart 
object. I don’t want this. I instead want to be able to adjust this second copy inde-
pendently of the first. In order to copy a smart object as a separate, independent 
smart object, I’ll have to go to the Layer menu and choose Smart Objects > New 
Smart Object via copy. 

Now I have a second smart object layer in the layers panel. I will double-click on 
the layer thumbnail to open the image in Camera Raw. Here, I’ll adjust the image 
to optimize the sky. Note that we’re not going into detail about how I make these 
adjustments, as those techniques are covered in other Masters Academy lessons. 
I will use the Basic panel sliders to darken the sky, bringing out more detail in the 
clouds, and then click OK to go back to Photoshop. 

The smart object image layer was copied as a new smart object in Photoshop.  
I double-clicked on this new smart object layer to open it in Camera Raw. Here,  
I am adjusting this version to optimize the sky. 
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Use a layer mask to combine the two processed versions

In this Photoshop document, there is now one layer where the building looks good 
and another layer where the sky looks good. I’m going to use a layer mask to blend 
the two together. With the top layer active (the one where the sky looks good), I’ll 
click on the Layer Mask icon at the bottom of the Layers panel. This adds a white 
layer mask to the layer. When a layer mask is all white, it means that the entire layer 
is visible. I will use the Brush Tool along with some selection tools in order to add 
black to the mask in the area where I don’t want this layer to be visible, and this is 
going to be the area containing the building and the sign. By hiding the building 
and the sign in this layer, I’m allowing the underlying layer to show through, and 
this is the layer where the building and the sign have been optimized.  

At left, you can see that a layer mask 
was added to the sky layer and black 
was added to the mask in order to hide 
the building and the sign. Above, you 
can see a view of the layer mask itself. It 
was created by using the Brush Tool as 
well as some selection tools. 
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Use the blending sliders to fine-tune the mixing of layers

The building and sky are both looking 
good now, but I don’t like the darken-
ing effect on the trees in the center of 
the image. This is happening because 
the trees are located on the sky layer, 
which has been darkened. We can fix 
this by using a special technique in-
volving the blending sliders. With the 
sky layer active (this should be the 
top layer), I’ll click on the FX icon at the bottom of the Layers panel and choose 
Blending Options from the pop-up menu. This will call up the Layer Style dialog 
box, and the blending sliders will appear in the bottom half of this dialog. 

We’re working on the top layer that is also the darker layer. What we want to do 
is allow the brighter, underlying layer to break through in the area where the trees 
are.  Because we want the underlying layer to break through, we’re going to use 
the sliders attached to the “Underlying Layer” gradient within the blending sliders. 
We’ll drag the black slider (on the left) over to the right until we can see the tree 
start to change. It will become brighter and brighter the more we drag this slider 
because it is allowing the underlying layer to break through in the darker areas. 

The only problem is that the transition is choppy. It has a hard edge as if I used an 
exacto knife to cut through the layer. In order to create a softer transition, I need to 
break this little black slider in half. Breaking the slider in half will create a smooth 
transition and the farther apart I drag the two halves, the softer the transition will 
be. I’ll split the slider by holding the Option key (Alt on Win) and pulling on one half 
of the slider. After they’ve separated, the two halves can be moved independently 
of one another. 

I don’t like how dark the trees are at this stage, 
so I’m going to use the blending sliders to fix 
this darkening effect. 
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Process the image to optimize the details

The building and the sky are both looking good now, so I’ll look around the image 
to see if there’s anything else that needs to be optimized. I notice that the air pump 
in front of the building is very dark and should be lightened. I’ll create a third pro-
cessed version of the image to accomplish that.

I’ll use the original image layer to base this copy on because it has no layer mask 
or blending slider adjustments applied. I’ll activate that bottom layer, click on the 
Layer menu and choose Smart Objects > New Smart Object via Copy. Remember, 
by duplicating the smart object this way, I’m creating a new, independent layer that 
I can adjust separately from the other smart objects. 

I will move this new layer to the top of the layer stack and then double-click on the 
thumbnail to bring it back into Camera Raw. Here, I will zoom in on the air pump 
and use the adjustment sliders to optimize just this object. I’ll ignore what’s hap-
pening in the rest of the image. To optimize the pump, I will use the Exposure and 
Shadows sliders to make it brighter, and I will also apply some noise reduction and 
sharpening. When I’m happy with the way it looks, I’ll click OK to get back into 
Photoshop. 

I am using the blending sliders within the Layer Style dialog to hide the darkening effect on 
the trees. I used the Underlying Layer slider because I want the underlying layer (the bright-
er layer) to break through in the area where the trees are. I split the slider in half to create a 
smooth transition. 
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Now I need to mask this layer so the brightening effect is only visible on the air 
pump. This will require a mask that is black in all areas except for the air pump, so 
it’s going to be easier to start off with a black mask instead of a white one. When 
you click on the Layer Mask icon to add a mask, that mask will be white by default. 
To create a layer mask that is completely black, hold down the Option key (Alt on 
Win) while clicking on the Layer Mask icon at the bottom of the Layers panel. I’ll 
now use a small, fairly hard-edged brush and paint on the mask with white in the 
areas where the pump is. This will reveal the contents of the layer in just the areas 
where I paint. 

Looking at the image, there are a few other details that I would like to lighten, and I 
can use this same layer to lighten those areas. I’ll simply adjust the layer mask in the 
areas I want lightened. One such area is the blue elements in the “Pure” sign. This is 
a pretty detailed area, so it would be difficult to get the precision I need by painting 
on the mask with the Brush Tool. Instead, I’ll need to make a selection around the 
area I want lightened, and then I’ll fill that selection. 

Here, I am processing another version of the image in Camera Raw. This time, I’m using the 
adjustment sliders to optimize the air pump by lightening it up. 
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There is a way to create a selection based on the brightness in the image and that 
can be done by using the Channels panel. This technique will create a selection 
where all white areas are completely selected and all black areas are not selected 
at all. Anything in between will be partially selected. To get this selection, I’ll first 
open the Channels panel, which is usually docked along with the Layers panel in 
the Photoshop interface. I’ll hold down the Command key (Ctrl on Win) and click 
on the thumbnail for the top-most channel, labeled RGB. This will create a selec-
tion of all the bright information in the image. This selection will vary a lot, because 
there are many different brightness levels in the image. I want to adjust this selec-
tion to control what areas are selected. I’ll enter Quick Mask mode by tapping the 
Q key. This mode shows the selection in the main image window and it is shown 
as a red overlay. While viewing the selection like this, I can adjust the selection by 
using regular adjustments like Levels. I’ll click on the Image menu and choose Ad-
justments > Levels. 

Within the Levels dialog, I will use the eyedropper tools to adjust the selection. The 
white eyedropper will force an area to white so I will use this to click on the white 
part of the sign. The black eyedropper will force areas to black, so I will use this to 
click on the dark part of the sign (part of the blue text or graphics). I’ll click OK. 
Now the white part of the sign should be completely selected and the dark part of 
the sign should be completely deselected.

I am adjusting a selection of the Pure sign while in Quick Mask Mode. The Levels eyedropper 
tools are being used to fine-tune the selection.
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Now the only area that I real-
ly want to select is within the 
sign, so I will make sure the rest 
of the image is deselected. I’ll 
use the Lasso Tool to draw out 
a circular selection around the 
sign. Then, I will get the oppo-
site of that selection by going 
to the Select menu and choos-
ing Inverse. Now there is a se-
lection of everything EXCEPT 
the sign. I’ll go to the Edit menu 
and choose Fill. When the Fill 
dialog appears, I’ll choose to fill 
with White and then click OK. 
Now, the only area that con-
tains any of the Quick Mask 
overlay is in the sign. I’ll go to 
the Edit menu and choose de-
select to get rid of the selec-
tion created by the Lasso Tool. 
I’ll also use the Brush Tool and 
paint with white to clean up 
the mask. I’ll paint away the 
red overlay in any areas where 
it appears outside of the blue 
text and graphics of the sign. 

The red overlay now covers ONLY the blue area of the sign. Because the overlay 
represents the area that is NOT selected, I’ll need to get the opposite. After all, I 
need the selection around the blue area of the sign in order to apply it to the layer 

I have isolated a brightness range while in Quick Mask 
Mode. I then made a selection around the sign, inverted 
that selection and then filled the selection with White. 
This makes it so that ONLY the dark parts of the sign 
have the red overlay.

I’m still in Quick Mask Mode and am painting with white 
to clean up the mask.
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mask. I’ll go to the Image menu and choose Adjustments > Invert. Then, I’ll tap the 
Q key to exit Quick Mask Mode. This will remove the red overlay so that I can only 
see the “marching ants” selection around the blue part of the sign. Since this se-
lection took a while to create, I’ll save it by going to the Select menu and choosing 
Save Selection. 

I’m now going to do a similar thing with a different part of the image. There are 
a few other details that I would like to adjust and make a little brighter, including 
some of the details on the fuel pumps in the image. These details are much darker 
than their surroundings and therefore, I can select them by using the same tech-
nique that was used to select the detail in the sign. I’ll open the Channels panel, 
hold down the Command key (Ctrl on Win) and click on the thumbnail for the top-
most channel, named “RGB.” This will create a selection based on brightness. I’ll tap 
the Q key to enter Quick Mask Mode. Now this mode can sometimes be confus-
ing because you’re seeing both the red overlay AND the underlying image at the 
same time. While Quick Mask Mode is active, there will be an extra channel at the 
bottom of the Channels panel and this channel will represent the Quick Mask. I can 
activate this channel and then turn off the visibility of all the other channels so that 
I’m viewing the mask in the main image window. It will look like a black and white 
version of the image. The white areas are the parts of the image that are selected. 

I made a selection based on the brightness of the image and then entered Quick Mask Mode 
to view that selection as a red overlay. While in Quick Mask Mode, I opened the Channels 
panel, where there is a temporary channel for the Quick Mask. We’re viewing that here. 
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I would like to adjust the text that’s on the gas pumps, and this text is dark, so I 
will need to invert the mask so that the text becomes light, and therefore will be 
selected. To Invert the mask, I’ll click on the Image menu and choose Adjustments 
> Invert. 

I’ll now use a Levels adjustment to further refine the mask and force more areas 
to black and white (instead of a shade of gray). I’ll again use the eyedroppers to 
do this. With the black eyedropper active, I’ll click on part of the pump that is dark 
gray. That will force the targeted tone to become black. Then I’ll activate the white 
eyedropper and click on part of the text that I want to be completely selected. This 
will force that area to be completely white. I’ll click OK to exit the Levels dialog. 

The Levels adjustment is being used to force more areas of the mask to solid white and more 
areas of the mask to solid black.
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Now I have the text and other details on the pumps selected. I just need to make 
sure those are the ONLY areas selected, so I need to make sure that the rest of the 
mask is completely black. I’ll make a selection around those pumps, invert the se-
lection so that everything ELSE is selected, and then Fill the selection with black. I 
can now deselect. I’ll use the Brush Tool to fine-tune the mask, painting with black 
in any additional areas I don’t want selected. 

Remember, I’m still in Quick Mask Mode. I’m just viewing it in the channels panel to 
get a black and white view of it. To go back to viewing the red overlay, I’ll simply 
turn on the visibility of the other channels in the Channels panel. I’ll then tap the Q 
key to exit Quick Mask Mode. 

To apply this selection to the mask, I’ll activate the layer mask that’s attached to the 
bright layer and then fill the selection with white (Edit menu > Fill). Now the details 
on the pumps will get the same brightening effect as the blue water pump. The 
problem is that I think they’re a little TOO bright. That’s OK though. I can just alter 

LEFT: I made a selection around the pumps, inverted the selection (so that the rest of the im-
age was selected) and then filled the selection with black. RIGHT: I am cleaning up the mask 
by painting with black in any additional areas that I don’t want selected. 
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the mask so that only 50% of the bright layer is allowed to show through. With the 
mask active, I’ll set the Brush Tool to paint with black, but I will change the Opacity 
setting (in the Options Bar) to 50%. Then, I’ll paint over the parts of the pumps that 
I think are too bright. This will make the pump details half as bright. 

Now if you look at my Layers panel, you will see three different interpretations of 
the same image. Each is a raw file with different settings applied. One is adjusted 
to optimize the sky. Another is adjusted to optimize the building and the third is 
adjusted to optimize the details. I will take these three layers and place them in a 
folder titled “main image blend.” Now I can apply any necessary retouching to an 
empty layer above this folder. 

How to keep track of what needs to be done to the image

I might close this image and come back to it layer, so how can I remind myself of 
what needs to be done to the document? The following is my system for keeping 
track of where an image is in the editing process and what still needs to be done. I’ll 
create a Solid Color layer by clicking on the Adjustment Layer icon at the bottom of 
the Layers panel and choosing Solid Color from the pop-up menu. The Color Picker 
will appear and I’ll set it to bright red and then click OK. I want to be able to see 
through this layer to the image so I will set the opacity of the layer to 50%. 

Now I will add a layer mask to this solid color layer, and I want the mask to start 
out completely black. Remember, you can get a black mask by holding down the 
Option key (Alt on Win) while clicking the Layer Mask icon at the bottom of the 
Layers panel. This will hide the entirety of the red layer. I will now use a hard-edged 
brush and paint with white on the mask in the areas that need to be retouched. This 
will reveal the red layer in these areas. I’ll name this solid color layer “Retouching 
Needed” so that I know what still needs work. As I complete this retouch work, I’ll 
paint with black on the mask in the areas that are completed, therefore removing 
the red overlay. 
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Image refinements

After retouching the image, I like to do all of my refinements using a series of 
adjustment layers. All of these adjustment layers will go into a folder (or group) 
named “Refinements.” We have discussed these adjustments in other lessons, so 
I wont go into detail about them here. Instead, here is the list of adjustments that 
were used to further refine this image:

• Curves adjustment layer to bring out detail in the pavement

• Hue/Saturation adjustment layer to desaturate the green grass

• Curves adjustment layer to darken the highlights in small areas (distracting 
bright areas in the windows)

• Curves adjustment layer to remove a blue color cast from the sign.

• Hue/Saturation adjustment layer to make the blues pop out more

• Curves adjustment layer to remove the yellow cast on the inside of the lights

• Curves adjustment layer to add contrast to the sign that’s mounted on the wall 
of the building

At left, a Solid Color layer is 
being used as a visual remind-
er as to what areas still need 
retouching. As I complete the 
retouching tasks, I’ll remove 
the red overlay from the com-
pleted areas.
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Finishing Touches

The last thing that I’ll do to the image is a small series of finishing touches. These 
will also be placed inside a separate folder (or group), titled “Finishing Touches.” 
One of these finishing touches layers will designate how I’d like to crop the image. 
I won’t actually crop the image in Photoshop, but I will use a shape layer to place 
black bars on the image, showing what the ideal crop would be. I will also create a 
Curves Adjustment layer to add a vignette, darkening the edges of the image and 
therefore drawing the viewer’s eye toward the subject. 

A Shape Layer was used as a visual guide as to what the ideal crop is. A Curves Adjustment 
layer was also used to vignette the image.
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Retouching Trick

Before wrapping up the lesson, I want to share a retouching trick I used to remove a 
sign that was on the window behind the air pump. If I tried to use the Spot Healing 
Brush to paint over the sign, it would mess up because it merges with the pump. 
Here’s a quick way to get around that. 

I’ll create a new, empty layer to apply this retouching on and I’ll instead retouch 
out both the sign AND the pump using a combination of the Clone Stamp Tool 
and the Spot Healing Brush. Then, I will add a black layer mask to this retouching 
layer. Remember, to add a mask that is filled with black, hold down the Option key 
(Alt on Win) while clicking the Layer Mask icon at the bottom of the Layers panel. 
This will completely hide the retouching layer, making both the pump and the sign 
visible again. Then, I’ll make sure I’m zoomed in on the area and I will paint on the 
mask with white in the area where the undesirable sign is. This method gives me a 
lot more control in retouching out the sign. 

 
ABOVE LEFT: I want to remove the sign 
that’s behind the air pump. ABOVE RIGHT: 
The retouching tools are being used to 
remove both the sign AND the pump. LEFT: 
I am painting with white on the layer mask 
to remove just the sign, while keeping the 
pump intact.


