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Looping Animations 

In this lesson, we’re going to learn how to transform photographs into looping an-
imations. This will introduce some motion into your photo and can be fun to use 
online. 

In order to create something like this, you will need to take a fairly quick succession 
of photos while keeping the camera as still as possible. It is ideal to use a tripod, but 
you can also get away with hand-holding the camera. 

Load files to Photoshop layers After loading the images on your computer, you’ll 
need to get the series of photos into a single Photoshop document. In Bridge, se-
lect all of the photos you would like to use in the animation, click on the Tools menu 
and choose Photoshop > Load Files into Photoshop Layers. (If you are using Light-
room, you would click on the Photo menu and choose Edit In > Open as Layers in 
Photoshop.) Photoshop will open and all of the images will be loaded as separate 
layers in a single document. 

Making the file size smaller In the video example, we loaded raw files into the doc-
ument. This is going to make for a huge document and will make things run slower 
when trying to turn the images into an animation. We will also need a small file size 
for uploading to the Internet. To make the image smaller, click on the Image menu 
and choose Image Size. When the Image Size dialog appears, make sure the unit 
menu is set to Pixels, change the size to 720 pixels by 1080 pixels (or something 
similar) and click OK. 

With all of the 
images selected in 
Bridge, we are  
using the Tools 
menu to Load the 
selected files as 
separate layers in 
a single Photoshop 
document.
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Aligning the layers  If you shot the series of images using a tripod, this step will not 
be necessary. If you shot hand-held, however, you’ll want to make sure that all of 
the images are perfectly aligned. To align all of the layers, first make sure that they 
are all selected. You can select all of the layers by clicking on the Select menu and 
choosing All Layers. Next, click on the Edit menu and choose Auto-Align Layers. 
A dialog box will appear, you can leave all of the settings at their default positions 
and then click OK. Now, Photoshop will align all of the layers based on the contents 
of each one. After Photoshop is done aligning the layers, there will likely be some 
transparent areas around the edges of the frame and you will need to use the Crop 
Tool to crop out those areas. 

View the Timeline  When making animations, you will need to have the Timeline 
visible on your screen. You can open it by clicking on the Window menu and choos-
ing Timeline. It will likely appear along the bottom of the interface. The Timeline can 
create a frame animation, which is basically a sped-up slideshow, or it can create 
an actual video. Here, you will be using it to create a frame animation. Click on the 
little menu in the middle of the Timeline and choose Create Frame Animation. Then 
click the Create Frame Animation button. This will create the first frame in your 
animation and you will see it on the left side of the Timeline. 

Access the 
Image Size 
dialog via the 
Image menu. 
Here, you can 
change the size 
of your docu-
ment. We are 
scaling down 
the document 
so that the file 
size becomes 
smaller.



Looping Animations © Ben Willmore, All rights reserved 4

The animation will be created by playing a slideshow of all the layers, so you’ll need 
each layer to be added as a separate frame. Click on the little menu in the top right 
corner of the Timeline panel and choose to “Make Frames from Layers.” You will 
see all of the frames appear within the Timeline. Click the Play button at the bot-
tom of the Timeline to view the animation and then hit the Stop button to stop the 
animation. With default settings, the animation is usually too fast. You can see how 
long the animation will pause before moving to the next frame by looking at the 
number at the bottom of each frame. By default, it will say 0 seconds. This means 
that there will be no pause before moving to the next frame. Click on the number 
and a pop-up menu will appear, allowing you to choose how much time the slide 
will play for. In an animation like this, you’ll want every frame to have the same time 
setting, so select all of the frames by clicking on the little menu in the top right 
corner of the Timeline and choosing to “Select All Frames.” With all the frames se-
lected, click on the bottom of any one of the frames to change the amount of time. 
This will change the time for all of the selected frames. In the video example, we set 
the time to 0.1 seconds. Click Play to view the results. You may have to experiment 
with different times in order to decide which looks best to you. If the time setting 
you want is not available in the little menu, choose “Other” and you will be allowed 
to manually enter in the desired time. 

The Timeline panel is shown above and we are clicking on the menu in the middle and choos-
ing to ”Create Frame Animation.”

To get all of the layers loaded as individual animation frames, we clicked on the little side 
menu (circled) and chose to “Make Frames from Layers.”
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The more frames that you have in your animation, the larger the file size will be. If 
you have a lot of frames, you may want to assess the individual frames and decide 
whether there are any that don’t add to the animation. You could then remove 
those by clicking on them to make them active and then clicking the little trash can 
icon at the bottom of the Timeline panel. 

If your animation appears to be playing backwards, there is a way to reverse it. This 
happened with the video example of the animation of the waterfall. In our case, the 
mist seemed to be moving up instead of down. To reverse the frames, they must 
first all be selected. Then, click on the little menu in the top right corner of the 
Timeline panel and choose to “Reverse Frames.” 

Limiting the animation to part of the image  You may have a series of images that 
you would like to turn into an animation, but you only want part of the image to be 
animated. In the video example, we have an animation of a leopard drinking water. 
We want the head and tongue to be animated, but we don’t want the water or the 
rest of the cat’s body to move. Let’s look at how we can achieve that. 

First, create the animation in the Timeline using the method we detailed above. 
Then, go to the Layers panel and turn on the visibility of one layer at a time, decid-
ing which frame you like the most and would like to use as your “base image.” Move 
this layer to the bottom of the layer stack in the Layers panel. Next, you’ll need to 
add layer masks to the other layers, hiding the parts of the layers that you don’t 

Change the duration of each frame by clicking on the little menu at the bottom of the frame 
thumbnail. 
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want to move. In our example, we painted with black on the layer masks, hiding the 
water, the tail and the body of the cat. If you’d like to take a layer mask and apply 
that same mask to another layer, hold down the Option key (Alt on Win) while 
dragging the mask to the other layer. (If you don’t hold down the Option key, you 
will simply move the mask, removing it from the original layer. You want to make 
sure that you copy the mask instead, so that the same mask is applied on both 
layers.) 

Now you’ll need to update the frames in the Timeline. Turn off the visibility of all 
layers except for the bottom layer. Then click on the first frame in the Timeline. The 
first frame should display the bottom layer, which is the layer that does NOT have 
a layer mask. Click on the second frame in the Timeline and turn on the visibility of 
one of the other layers. This frame will contain one masked layer and the bottom 
layer serving as the background, or “base” layer. Then click on the third frame in the 
timeline, turn off the visibility of the layer that was used to create the second frame 
and turn on the visibility of the next masked layer. Continue this process until you 
have worked your way across the entire timeline, making sure that each frame has 
the visibility of the bottom layer plus one masked layer. In our video example, we 
only had three layers, so our three frames contained the following:

Frame 1: Bottom layer only visible

Frame 2: Bottom layer plus middle layer visible

Frame 3: Bottom layer plus top layer visible 

At left, you can see the Timeline, which consists of three 
frames that make up the animation. We used layer masks to 
hide the motion in all but one area of the image. Above, you 
can see the layer visibility for each of the three frames.
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Setting the image to only animate periodically When putting an animation online 
(like on your website), it can be fun to make it look like a regular image but then 
have it animate only periodically. In order to do this, we would choose the one 
frame we want it to display for most of the time and then use the little time menu 
at the bottom of the frame to make the duration much longer. Remember, you can 
choose the “Other” option from this menu and manually type in a custom duration. 
In our video example, we chose the frame where the cat’s tongue is not out, we 
clicked on the little duration menu and set the time to 20 seconds. As a result, the 
cat will be still for 20 seconds and then it will look like it quickly takes a drink of 
water. 

We clicked on the duration menu at the bottom of the animation frame (circled) and chose 
“Other” from the menu. This brought up the Set Frame Delay dialog, where we can enter in a 
custom time duration.
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Specify how long the image animation should continue You can specify that the 
image should animate for a certain period of time and then stop. To do this, click on 
the little menu on the bottom left side of the Timeline. By default, this menu is set 
to Forever, which will make is so 
the animation never stops. When 
you click on the menu, you’ll also 
have the options of Once (mean-
ing it will only animate one time), 
3 times or Other. If you choose 
Other, you can manually specify 
how many times the animation 
should loop before coming to a 
stop. 

Evaluating your layers When creating animations, you will sometimes want to eval-
uate each layer, one at a time. Here’s a fast way of doing that. Turn off the visibility 
of all layers except for one. Make sure that visible layer is the active layer. Then, you 
can use a keyboard shortcut to quickly cycle through the layers. Hold down the 
Option Key (Alt on Win) and then tap the square bracket keys ( [ ] ) to cycle up 
and down through the layer stack. 

Using guides to track motion When 
viewing your layers one by one, you 
might want to make a note of how 
far the motion extends to the edge of 
the frame. This way, you know where 
it is safe to crop the image without 
cutting off part of the animation. In 
the video example, we have an ani-
mation of an elephant swinging his 
trunk around. We cycled through all 
of the images, looking for the far-

The menu in the bottom left corner of the Timeline 
allows you to determine how many times the anima-
tion should loop.

We placed 
guides in the 
document 
showing where 
the trunk ex-
tends toward 
the edge of the 
frame.
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thest point where the trunk extends in all directions. When looking through your 
images like this, it can be a good idea to place guides that show you the farthest 
points where the motion extends. To place a guide in your document, hover your 
cursor over one of the rulers surrounding the document window, then click and 
drag into your document. When you click and drag from the horizontal ruler above 
the image, you will be placing a horizontal guide. When you click and drag from 
the vertical ruler on the left side of the image window, you will be placing a ver-
tical guide. Note that if the rulers are not visible in your interface, you can access 
them by using the keyboard shortcut Command+R (Ctrl+R on Win). To remove the 
guides, click on the View menu and choose Clear Canvas Guides. 

Exporting the animation After creating the animation in Photoshop, you will need 
to export it in the gif file format because this format supports looping animation. 
Click on the File menu and choose Export > Save for Web. In the Save for Web 
dialog, use the file type menu in the top right and choose GIF. Make sure the third 
menu down is set to the Diffusion option and then use the Colors menu to choose 
the lowest number that makes the image look acceptable. (You will see a preview 
of the results in the main part of the dialog box.) Know that the higher the number 
of colors, the longer the animation will take to load. 

Near the bottom of the Save for Web dialog, there are a few Animation settings 
and this is where you can specify how many times the animation will loop. You can 
also view the individual frames of the animation by using the forward and backward 
buttons at the bottom of the dialog. When you’re done specifying the settings, hit 
the Save button in the bottom right corner of the dialog.

Reversing an animation Sometimes, you may want the animation to be able to 
repeat AND reverse. (In certain apps, like Instagram, this movement is called “boo-
merang.”) To create this effect, first follow all of the steps listed above for put-
ting your initial animation together. Then, select all but the very first and very last 
frames in the Timeline. Click on the little menu in the top right corner of the Time-
line panel and choose “Copy Frames.” Then, click on the little menu again and this 
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time choose to “Paste Frames.” A dialog box will appear, allowing us to specify a 
“Paste Method.” Make sure the “Paste After Selection” option is selected and click 
OK. The copied frames will then appear after the original frames in the Timeline. 
Before you deselect the new frames, go back to the little side menu and this time 
choose to “Reverse Frames.” Now, when you hit the Play button, the animation will 
look as if the motion is going back and forth. 

ABOVE: We copied all but the first and 
last frames. Then we clicked on the little 
side menu and chose to Paste Frames. 
Here, we are specifying that the frames be 
pasted after the selection.

LEFT: With the pasted frames still select-
ed, we are choosing to Reverse Frames.


