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Lightroom Image Overlays 

In this lesson, we’re going to cover a feature in Lightroom that will allow you to 
overlay one picture on top of another. It can be useful when trying to figure out 
which picture to use in a layout design. 

Magazine Cover Example

Let’s say that you had to choose an image that will be featured on a magazine 
cover. This would be a good example of where the image overlay feature would be 
useful because it will allow you to see what different images look like on the cover 
template. 

Removing the background to create a template  You may have a template for the 
cover of the publication, where you have the title and supporting text, along with 
any other standard graphics, set on a transparent background. If that’s the case, 
you won’t need to do this first step.

I was given a pdf of one of the covers for the magazine I would be providing an 
image for. It’s just one solid image with text and images. I would like to remove the 
background image so that the background is transparent. This way, I can place my 
own images on the cover to see how they look.

To start, I’ll open the pdf in Photoshop. Whenever you open a pdf in Photoshop, 
a dialog box will pop up where you can choose which pages to open (if there are 
more than one), what resolution to use, etc. There is also a setting in the top left 
corner of the box where you can choose between opening Pages or Images. I’m 
going to make sure this is set to Pages so that the entire cover opens and not just 
individual images on the cover. I’ll click OK to bring the cover into Photoshop.

Now I need to remove the background image so that I can plug in my own im-
age[s]. In the example image, I’m going to use the Magic Wand Tool, which is hid-
den beneath the Quick Selection Tool in the Toolbar on the left side of the interface. 
I want to use the Magic Want to select the text, but there is a setting I’m going to 
change first. In the Options Bar, above the image window, there is a “Contiguous” 
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check box, which is turned on by default. When this setting is on, it means that 
the tool will make a selection of a single chunk of color when the mouse is clicked 
within the image. For example, if I clicked within the green letter C, it would select 
the entire letter C and nothing else. When the “Contiguous” setting is turned off, it 
means that it can select multiple areas of the same color and tone. For example, if 
I used the tool to click within the green C, it would select ALL the letters that are 
the same color and tone within the document. Because of this, I’ll turn this check 
box OFF. 

ABOVE: The Magic Wand Tool was used to create a 
selection of all the text and graphical elements on 
this magazine cover. LEFT: The Contiguous setting 
is turned off so the Magic Wand Tool can select mul-
tiple areas at once. 
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I’ll use the Magic Wand Tool to click within the text, and I’ll hold the Shift key to 
add to the selection, clicking in other areas of text until I have everything selected. 
This also selected the white logo in the bottom and the open address area, which 
is good. These are all elements that should be in the template overlay. I’m going to 
now add a layer mask, which will hide everything that is not currently selected. To 
add the mask, I’ll click on the Layer Mask icon at the bottom of the Layers panel. 

After the mask is added, I can see that I need to clean it up a bit, because there are 
some remaining areas of the underlying photograph that i want to hide. To make 
it easier to see what areas need to be cleaned up, I’ll view the mask directly in the 
image window. You can get this view by holding down the Option key (Alt on Win) 
and clicking on the mask thumbnail in the Layers panel. The black and white view 
of the mask will fill the image window and, in this view, I can paint with black and 
white to adjust the mask. I’ll paint with black in any places where I can see leftover 
white from the photograph. 

After a selection was made around the text and graphics, a layer mask was added. The mask is 
hiding all areas of the layer that were not selected.
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Now that I have the mask the way I want it, I’ll hide the mask view by holding down 
the Option key (Alt on Win) and clicking on the mask thumbnail in the Layers panel. 

At this point, there is a lot of transparency in the document so it’s hard to tell how 
accurate the mask is because I’m seeing that checkerboard view. If I really wanted 
to inspect the layer to see how good the mask is, I could create a solid color layer 
and place it beneath the image layer in the Layers panel. You can create a solid 
color layer by clicking on the Adjustment Layer icon at the bottom of the Layers 
panel and choosing Solid Color from the pop-up menu. I’ll be sure to choose a col-
or that really contrasts with the image layer so it’s easy to see the difference. This 
view shows me that the layer mask is accurate, so I can now discard the solid color 
adjustment layer. 

I need to save this image in a file format that supports transparency so that I can 
overlay it on top of other images. I’ll choose the Save As command (from the File 
menu) and use the Format menu to choose PNG. I’ll then click the Save button. A 
small dialog box will appear with some saving options. I like to choose the top op-
tion that will save the document with the largest file size. 

FAR LEFT: I am viewing 
the mask in the image 
window and painting 
with black to clean it 
up. DIRECTLY LEFT & 
ABOVE: I placed a solid 
color layer beneath the 
image layer to better 
inspect the mask.
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Overlaying the image in Lightroom Now it’s time to 
move this image into Lightroom so that I can overlay 
it on top of my other images. I will open Lightroom’s 
Library Module and find the image that I would like 
to use as the underlying image. It’s important that I 
open the image in the Loupe View, which is the view 
that shows a single large image in the main image 
window. Click on the Loupe View icon below the im-
age window in order to move the active image into 
Loupe View. 

I’ll now click on the View menu at the top of the screen and choose Loupe Overlay 
> Layout Image. A dialog will pop up, asking me to navigate to the hard drive lo-
cation where I saved the PNG file. I’ll navigate to the file and then click the Choose 
button. This will place that PNG file over the picture I have open in the Loupe View. 

If I hold down the Command key 
(Ctrl on Win), some handles will ap-
pear around the corners so that I can 
scale the overlying image, and some 
settings will appear at the bottom of 
the document. We’ll discuss those 
shortly.

The purpose of creating this maga-
zine cover layout was to see what im-
age looked best as the background. 
To do this, I’ll need to view it with dif-
ferent background images. I can eas-
ily do this by using the left and right 
arrow keys on the keyboard in order 
to cycle through the images in the 
selected folder, or the active selec-
tion of images. In the video example, 

Click this icon to move the  
selected photo[s] into the 
Loupe view.

The Command key (Ctrl on Win) is held down in 
order to access the scale handles and Opacity/
Matte settings while viewing the image overlay.
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I had selected a series of bus photos and then moved into Loupe View. When I use 
my left and right arrow keys, it cycles me through all of the images I had selected. 

As I mentioned before, holding 
down the Command key (Ctrl 
on Win) will bring up some set-
tings at the bottom of the doc-
ument. One of these settings is 
Opacity, and this can be useful 
for making the overlying image 
more or less transparent in or-
der to see what’s behind it. The 
Matte setting controls how light 
or dark the area outside of the 
image overlay is. 

To remove the overlay, go back 
to the View menu, choose Loupe 
Overlay and then turn off the 
“Show” setting. 

Facebook Cover Photo Example

Another example of when the image overlay feature might be useful is when you 
need to prepare an image to be used in some kind of online template. In the video 
example, I’m going to use the image overlay to find the best image for my Face-
book cover photo. When placing a Facebook cover photo, there will be some el-
ements overlaid on the image, including the profile picture, some text and some 
buttons. I want to make sure that I choose a photo where important subject matter 
will not be covered up by these elements. 

The left and 
right arrow keys 
can be used to 
cycle through a 
folder of imag-
es (or a selec-
tion of images) 
while keeping 
the same image 
overlay. Here, I 
found the best 
photo to use on 
this magazine 
cover.
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Removing the background image from the cover photo screen shot To start, I will 
take a screen shot of the Facebook cover image as it appears in my browser. The 
keyboard shortcut for capturing a screen shot differs between operating systems, 
so you’ll want to do a Google search for your particular OS.  I’ll capture the upper 
portion of the interface, which includes my cover photo and profile picture. 

Next, I will take this screen shot image and open it in Photoshop so that I can re-
move the background image. I’ll use the Rectangular Marquee Tool to start by cre-
ating a selection around the cover photo. I want to turn this selection into a layer 
mask, but by default, a layer mask will look at the active selection and hide every-
thing ELSE. I want the opposite, where the layer mask hides the contents of the 
selection. To get this, I’ll hold down the Option key (Alt on Win) while clicking the 
Layer Mask icon at the bottom of the Layers panel. Now the area inside the selec-
tion will be hidden, and I can see the transparent background behind it. 

I am capturing a screen shot of my Facebook cover photo in the browser.
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I need to refine the mask so that I can see the buttons, profile picture etc. When-
ever you have a mask active in the Layers panel, the Properties panel will display 
some settings relating to that mask. Here, you will find the Density slider, which 
controls how much of the mask you can see through. By default, this slider is set to 
100, which means that you can’t see through the mask at all. I will drag this slider 
down, just until I can start to see some of the underlying image. This will allow me 
to refine the mask based on the underlying content. 

I can now see the two buttons that appear 
in the bottom right corner of the cover im-
age. I’ll use the Rectangular Marquee Tool to 
make a selection around one of the buttons. 
Because the mask is active, I will use the key-
board shortcut Command+I (Ctrl+I on Win) to 
invert the contents of the selection, making 
the mask white instead of black and therefore 
revealing the underlying image in that area. I 
will do the same thing for the other button. 

With the layer mask active, the Density slider (circled) is being used to lower the visibility of 
the mask so that I can see through the mask to the layer it’s hiding.

The Rectangular Marquee Tool is being 
used to select elements in this layout 
that I don’t want to be masked.
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I will use the Elliptical Marquee Tool 
to create a selection around the 
circular profile picture. I want the 
entirety of the profile picture to be 
visible, so I will use the Fill com-
mand (Edit > Fill) to fill the selec-
tion with white. Remember, adding 
white to a layer mask will reveal 
the layer in that area. The reason I 
did not use the Invert command is 
that part of the profile picture was 
already visible (not hidden by the 
mask). Had I inverted the selection, 
the part that was previously visible 
would have become invisible. 

The last thing I need to make visible is my 
name, which appears directly to the right of 
the profile picture. For this, I will bring the 
mask’s Density setting back to 100 and then 
I will temporarily disable the mask. Disable a 

layer mask by holding the Shift key and click-
ing on the layer mask thumbnail in the Layers 

panel. When a mask is disabled, a red X will appear over the mask thumbnail. The 
mask still exists. It’s just temporarily hidden. 

I need to make a selection of my name, and to do this, I’ll use a trick that makes a 
selection based on the brightness of the image. I’ll open the Channels panel (It’s 
usually docked along with the Layers panel) and hold down the Command key 
(Ctrl on Win) while clicking on the thumbnail for the top-most channel, named 
RGB. This will give me a selection based on brightness. Everything that is com-
pletely white will be 100% selected. Anything that is completely black will not be 
selected at all. Everything in between will be partially selected. 

The Elliptical Marquee tool is being used to make a 
selection around the profile picture. I’ll then fill the 
selection with white in order to remove the layer 
mask in that area and make the picture visible.

You can tell that this layer mask has 
been disabled because it has a red X 
over the thumbnail.
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Now that I have that selected, I will return to the Layers panel and refine the selec-
tion. I will type the Q key to enter Quick Mask Mode, which gives me a red overlay 
in all areas that are not selected. I can adjust this overlay to control what areas 
are being selected. I’ll go to the Image menu and choose Adjustments > Levels. In 
the Levels dialog, I will use the eyedropper tools to refine the selection. The black 
eyedropper will forces areas to black, or in the case of a Quick Mask, to red.  I will 
activate the black eyedropper and click somewhere right outside my name. This 
ensures that this area is not selected at all. I know that my name is completely se-
lected because it was white. I’ll click OK to exit the Levels dialog. 

Now, to make sure that my name is the only thing selected, I will use the Rectan-
gular Marquee Tool to make a selection around my name and then I will go to the 
Select menu and choose Inverse in order to get the opposite (where the rest of 
the image is selected). I’ll then use the Fill command (Edit > Fill) to fill the selec-
tion with black. This will ensure that no other areas are selected. I’ll tap the Q key 
again to exit Quick Mask Mode and I can see that there is only a selection around 
my name. 

I made a selection based on brightness by holding down the Command key (Ctrl on Win) and 
clicking on the thumbnail for the top-most channel, named “RGB.” 
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I’ll reactivate the layer mask by holding the Shift key and clicking on the mask 
thumbnail again. I will make sure that the mask is active and not the layer. I want the 
contents of the selection to show up, so I will fill the selection with white. (White 
parts of the mask reveal the layer it’s attached to.)  

Now I have the document set up so that it can be overlaid on another image, so I 
will use the Save As command and save the file using the PNG file format. Remem-
ber, this is the format that supports transparency. 

Overlaying the Facebook layout on an image in Lightroom It’s now time to head 
back into Lightroom. I’ll find a folder of images I might want to use for my cover 
photo. I’ll select one and then enter the Loupe View. To get the image overlay, I’ll 
go to the View menu, choose Loupe Overlay and turn on the “Show” setting. This 
will use the previous image I chose to overlay, so from that same menu, I will select 
the “Choose Layout Image” option. I’ll be prompted to choose the PNG file from 
my hard drive. The image will be overlaid on the active image. I can hold down the 
Command key (Ctrl on Win) and drag on the overlay to reposition it on the image 
and I can also use the corner handles to scale the overlay if necessary. 

In Quick Mask Mode, I used the Rectangular Marquee to make a selection around my name and 
next I will invert the selection so that everything EXCEPT my name is selected.
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In the video example, the underlying image didn’t work so I will use the left and 
right arrow keys to cycle through different images in the folder to see how they 
look with the same overlay. I found one that would work better, so I again held 
down the Command key to reposition and scale the image to the ideal size for the 
overlay. When I’m done, I’ll go back to the View menu, choose Image Overlay and 
then turn off the “Show” setting. This will remove the overlay. 

Video Overlay example

In the next example, let’s look at how to use overlays to save an image for use in 
video. I’m not as familiar with video requirements, but I’ve been asked to send an 
image to a video editor and I need to keep the content within the “title safe area.” 
Not knowing what this was, I looked it up and found a series of guides for video 
purposes. I would love to get these guides into Lightroom so that I can choose the 
correct photo for use in the video. I will download the image file that contains the 
guides and I will open that image in Photoshop. 

I used the Facebook layout as an image overlay in Lightroom and am cycling through my im-
ages to see which would work best.
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Using the blending sliders to remove a white background The image contains size 
guides, with each guide as a separate color. The background is white, and I want 
the background to be transparent so that I can overlay this image on top of my 
photographs in Lightroom. To achieve this, I’m going to use the blending sliders, 
located within the Layer Styles dialog.

In this video example, the FX icon (for adding layer styles) at the bottom of the 
Layers panel is grayed out, indicating it’s not available. This will happen whenever 
the active layer is locked. The image layer is locked because it its also the Back-
ground layer, and the Background layer will always be locked. To unlock it, simply 
click on the Lock icon to the right of the layer thumbnail.  I did that, and the FX icon 
became available. 

I’ll click on the FX icon and choose Blending Options from the pop-up menu. This 
will bring up the Layer Style dialog and the blending sliders will be near the bot-
tom. I’m going to use the sliders labeled “This Layer” because it’s the active layer I 
want to affect. I will drag the white slider (the one on the right) to the left until all 
of the white background disappears. By moving this slider to the left, I’m hiding 

This is the guides 
image that I 
downloaded 
from the Inter-
net. I’ll need to 
remove the white 
background.
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more and more of the bright areas in the layer. To get a smooth transition between 
what parts of the layer are visible and the parts that are not visible, I can hold down 
the Option key and drag one side of the slider so that it splits in two. Splitting the 
slider will create a smoother transition. I’ll click OK to close the Layer Style dialog. 

Now I have the white background removed, so I just need to make sure this image 
is the correct size for video, which is 1920 x 1080 pixels. I’ll click on the Image menu 
and choose Image Size. When the Image Size dialog appears, I’ll change the Width 
dimension to 1920. The Height dimension automatically scales, in proportion, to 
1076, which is close enough to 1080, so I’ll click OK to resize the image. Now, to 
make sure the image is EXACTLY 1920 x 1080, I’ll click back on the Image menu 
and choose Canvas Size. In the Canvas Size dialog, I can use the Width and Height 
fields to scale the canvas size independently of the image size. The Width is al-
ready 1920, so I just need to change the Height field to 1080 and click OK. 

The white blending slider under the “This Layer” gradient is being used to hide the white 
background from the active image.



Lightroom Image Overlays © Ben Willmore, All rights reserved 16

It’s now time to save the image so I’ll use the Save As command to save the doc-
ument in the PNG format. Again, the PNG format is what I need for this purpose 
because it supports transparency. 

I’ll open Lightroom’s Library Module, choose the photo I think I’ll want to use in 
the video, and open that image in the Loupe View. I’ll click on the View menu and 
choose Loupe Overlay > Choose Layout Image. I’ll be prompted to select the image 
from my hard drive so I’ll navigate to the location where I saved the guides image 
and click the Choose button. 

The Image Size dialog (Found under the Image menu) is being used to set the size to closely 
match the size we’d want to use for video (1920 x 1080).

The guides 
image is being 
overlaid in Light-
room so that I 
can see how my 
image needs to 
be cropped for 
video purposes.
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The guides will now be positioned as an overlay on my image and I can move them 
around to see how much of the image is appropriate to use. 

InDesign 

If you create a layout using InDesign, you can use that layout as an image overlay 
in Lightroom. Simply export the layout by going to the main menu at the top of the 
interface and choosing File > Export. Make sure to choose PNG format because it 
supports transparency. Then, you can follow the same steps to overlay the layout 
image in Lightroom. 

 


