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Realistic Shadows 

In this lesson, we’re going to explore how to create realistic shadows in your imag-
es. This could come in handy when you want to remove the background on an ob-
ject and then place that object on a new background while maintaining a realistic 
look. Having a realistic-looking shadow will be key in making that object look like it 
naturally belongs in its new environment. 

Maintaining the original shadow

One of the ways we can go 
about incorporating a nat-
ural shadow after remov-
ing the background on an 
object is to maintain the 
object’s original shadow. In 
the video example, we will 
take an image of a coffee 
mug and place it on top of 
a different, textured back-
ground while maintaining 
the mug’s original shadow. 

Load files into Photoshop layers In Bridge, we’ll select the two images (the mug 
image and the background image), we’ll go to the Tools menu and choose Photo-
shop > Load Files into Photoshop Layers. This will place both images as separate 
layers in the same Photoshop document. We’ll just make sure that the mug image 
is positioned above the background image. In order to make it look like the mug is 
sitting on the new background, we’ll need to isolate the subject onto its own layer. 
That’s because we’ll be using a blending mode to make it look like the shadow is 
printing on top of the background as if it were made of ink. The blending mode that 
will achieve this look is the Multiply blending mode. Note that you can change the 
blending mode of a layer by activating the layer and then using the Blending Mode 

At left, you 
can see the 
mug image 
and the tex-
tured image 
that we will 
use as the new 
background 
for the mug.
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menu at the top of the Layers panel. The subject itself will not look appropriate in 
the Multiply blending mode, however, and that’s why we’ll need to isolate the mug 
from the background. After doing this, we’ll be able to set the blending mode of 
the mug’s shadow to Multiply while allowing the mug to remain normal. 

Isolate the subject We’ll start by duplicating the mug layer. To duplicate a layer, 
make sure the layer is active in the Layers panel and then use the keyboard short-
cut Command+J (Ctrl+J on Win). We’ll temporarily hide the visibility of the original 
image layer by turning off the eyeball icon to the left of the layer’s thumbnail. With 
the top layer active, we’ll work on isolating the mug by creating a selection around 
it. In some images, you could use the Quick Select Tool to do this, but because the 
color of the mug is so close to the color of the background, we are going to take 
a more manual approach here. We’ll activate the Elliptical Marquee Tool and use it 
to create a selection around the circular part of the mug. The Transform Selection 
command will make it easier to make a selection like this. We’ll start by creating a 
roundish selection around the mug. Then, we’ll go to the Select menu and choose 
Transform Selection. Transform handles will appear around the elliptical selection 
and we can click and drag on these handles in order to perfectly position the selec-
tion around the mug. Note that if you’re using a newer version of Photoshop (after 
the October 2018 update), you will need to hold down the Shift key while dragging 

ABOVE: The Blending Mode menu is 
located at the top of the Layers panel. 

RIGHT: The mug image is set to the 
blending mode of Multiply and you 

can see that it doesn’t look appropri-
ate. We need to make it so only the 

mug’s shadow is set to Multiply.
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these handles if you do not want the selection to be scaled proportionally. We’ll hit 
the Return/Enter key to exit the Free Transform feature. Now we’ll need to add the 
mug handle to our selection. To make this easier, we’ll tap the Q key to enter Quick 
Mask Mode. While in Quick Mask Mode, any area that is not selected will be covered 
with a red overlay and this will make it easier to visualize the selection. We’ll acti-
vate the Brush Tool and use a relatively hard-edged brush to paint with white over 
the handle of the mug. We’ll tap the Q key again to exit Quick Mask Mode. 

We now want to isolate the mug by use of a layer 
mask. With the selection active, we’ll click on the 
Layer Mask icon at the bottom of the Layers panel. 
Whenever you create a layer mask while you have an 
active selection, that selection will be applied to the 
mask. All selected areas will be white on the mask 
and this represents the area that remains visible in 
the layer. Any areas that were not selected will be 
black in the layer mask and these are the areas that 
will be hidden. This results in our coffee mug sitting 
on a transparent (checkerboard) background. 

LEFT: The Elliptical Marquee Tool was used to make a round selection around the mug and 
the Free Transform command is now being used to fine-tune the selection so that it perfectly 
matches the edges of the mug. RIGHT: We are adding the handle of the mug to the selection 
by using the Brush Tool in Quick Mask Mode. 

With the mug selection active, 
we created a layer mask and 
the selection was automatically 
applied to the mask.
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Now we’ll turn the visibility of the original image layer (the one we’ll be using to 
create the shadow of the mug) by turning on the eyeball icon to the left of the lay-
er’s thumbnail. We’ll also rename the layer to “Shadow” so that it’s obvious what its 
purpose is. We’ll name the top layer “Subject” just to be organized. 

Adjust the Shadow layer We’ll make sure that the Shadow layer is active and we’ll 
change the blending mode of this layer to Multiply. This causes the shadow layer 
to blend into the textured background layer. In this example image, we also need 
to use the Eraser Tool to remove some dark areas from the edge of the layer. (This 
mug was shot on top of a white notebook, and you can see some of the dark edges 
and spiral binding of the notebook, so we need to remove those.) 

LEFT: The shadow layer was set to the Multiply blending mode. We can see that there are 
some dark areas on the edges of that layer. RIGHT: We are using the Eraser Tool to get rid of 
those dark areas. 
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Any time you have a layer that is set to Multiply mode, it acts as if the contents is 
made out of ink. Because the paper that was sitting under the mug was not per-
fectly white, it is adding some “ink” to the image below, and that makes it so we 
can still see a slight darkening in that area. In order to fix this, we need to adjust the 
shadow layer to make the paper solid white. Once it becomes solid white, it will be 
completely invisible because anything that is solid white when set to Multiply mode 
will disappear. We’ll make sure this Shadow layer is active, we’ll click on the Image 
menu and choose Adjustments > Levels. In the Levels dialog, we’ll take the slider 
on the right side of the bar chart and drag it to the left. Moving this white slider 
to the left will force more and more areas of the layer to become solid white. We’ll 
continue moving this slider to the left until we can no longer see any of the paper. 

A Levels adjustment is being used to force the paper in the background to be solid white and 
therefore disappear when set to Multiply mode. We are dragging the white slider (circled) to 
the left, which forces more and more areas to be solid white. 
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Levels Tip: When working with Levels, it might not always be easy to tell when 
parts of your image become solid white. In the example we used, it was easy to 
tell because the layer was in Multiply mode and all white areas simply disappeared. 
That will not always be the case for you, so here is a trick for knowing exactly what 
areas are turning white. As you drag the white slider to the left, hold down the Op-
tion key (Alt on Win). This will temporarily change the view of your image to give 
you a visual representation of what areas are pure white. Colored areas represent 
parts of the image that are NOT solid white. We will drag the slider until the only 
areas that we still see in color are the areas where the mug’s shadow should be. 
We’ll then click OK and make sure the layer’s blending mode is set to Multiply. 

We are holding down the Option key (Alt on Win) while dragging the white Levels slider and 
this is giving us a different view of the image that shows what areas are solid white. The ar-
eas that are colored or black indicate areas that are NOT solid white. 
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Now we want to make sure that if we 
move the mug layer (the top layer), the 
shadow layer will move along with it. 
We’ll make sure that both of the layers 
are selected and then click the Link sym-
bol at the bottom of the Layers panel. 
This will link the two layers together so 
that when we move one of them, the oth-
er will move with it. 

Correct for color cast in the shadow In the example image, the mug’s shadow 
seems to have a brownish tint to it. We’ll correct for this by using an adjustment. 
We could either use a Hue/Saturation adjustment, dragging the Saturation slider all 
the way to the left to remove the color, or we could use the Desaturate adjustment, 
which will remove all of the color from the layer. We’ll use the Hue/Saturation ad-
justment so we can have more control. With the Shadow layer active, we’ll click on 
the Image menu and choose adjustments > Hue/Saturation. In the dialog box, we’ll 
move the Saturation slider to the left. The result is a nice, neutral shadow. 

The Link icon was used to link the two layers 
so that they will move together.

LEFT: You can see that the mug’s shadow has a brownish color cast to it. RIGHT: We used a 
Hue/Saturation adjustment to remove the color from the shadow.
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Place the object on a different background  Now that we have isolated both the 
mug and the mug’s shadow, we can place the mug onto any appropriate back-
ground/surface that we’d like. To move the mug from one document to another, 
first make sure that the second document is open in a separate Photoshop tab. 
Then make sure that one of the mug layers is active (either the mug itself or the 
shadow). Because the two layers are linked, it doesn’t matter which layer is active 
because both of them are going to move together. We’ll click on the mug with the 
Move Tool and drag it to the Photoshop tab for the document we want to place it 
in. When we hover the cursor over the tab, that document will come to the fore-
front. Keeping the mouse button held down, we’ll drag the cursor into the new 
document. When we release the mouse button, the mug (and its shadow) will 
appear in the new document. In our example, we’re placing the mug into a scene 
where two people are playing a board game. The mug is far too large for the new 
image, so we’ll use the free transform command (Edit > Free Transform) to scale 
the mug down to a size that suits the new surroundings. 

Extracting a shadow from a textured surface 

If a shadow falls on a textured surface, it might be more difficult to maintain that 
original shadow and place it onto a new background while looking natural. In our 
example image, we have a WhiBal card that is sitting on a textured surface and we 
can see the texture in the shadow. We want to place the card (and the shadow) 
onto a new surface while keeping the original shadow. 

Just like in the first image, we’ll duplicate the 
layer and isolate the subject via a layer mask. 
We’ll use a Levels adjustment to force every-
thing except the shadow to become pure white. 
Then, we’ll remove the color from the under-
lying shadow layer so that it doesn’t maintain 
that blue hue from the original background. To 
remove the color, we’ll go to the Image menu 
and choose Adjustments > Desaturate. 

We want to extract this shadow while 
making it still look realistic by  
removing the texture.
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Now, we’ll have to remove the texture from the shadow and we can do that via the 
Gaussian Blur filter. With the shadow layer active, we’ll go to the Filter menu and 
choose Blur > Gaussian Blur. Here, we’ll find the lowest setting that gets rid of all 
the texture and then click OK. Finally, we’ll set this shadow layer to Multiply mode. 

Putting the subject and shadow on one layer

Up until now, our results have included two layers: one layer for the subject and an-
other for the shadow. There may, however, be instances where you need everything 
on one layer. Maybe you need to open the image in a program that doesn’t support 
layers or doesn’t know what blending modes are. Or perhaps you need to upload 
the image for use on the Internet. Let’s look at how to do this.

There is a technique that will give you a se-
lection based on the brightness of your pic-
ture. It will select all areas that are solid white 
and as areas become darker, they will be less 
and less selected. To do this, we’ll need to 
make sure the Channels panel is visible. It is 
usually grouped with the Layers panel. We’ll 
hold down the Command key (Ctrl on Win) 
and click on the RGB thumbnail at the top 

LEFT: The Gaussian Blur filter is being applied to the shadow layer. We’re using the lowest 
setting that still removes the texture. RIGHT: The subject is placed on a different background 
and, because the texture was removed from the shadow, it still looks natural. 

We are creating 
a selection based 
on brightness by 
holding down the 
Command key 
(Ctrl on Win) and 
clicking on the 
RGB channel.
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of the panel. This will create the selection based on brightness. This is actually the 
opposite of what we want (we want the dark areas selected and the white areas 
unselected) so we will go to the Select menu and choose Inverse. Now, we’ll go 
back to viewing the Layers panel and we can actually get rid of the shadow layer 
by dragging it to the trash. 

To re-create the shadow (on a layer that doesn’t require a change of blending 
mode), we’ll click on the Adjustment Layer icon at the bottom of the Layers panel 
and choose Solid Color. The Color Picker will appear, we’ll use it to choose a black 
hue and then click OK. Because there was an active selection, that selection will 
automatically be applied to the adjustment layer’s mask. 

Now, we will select both the Color Fill layer and the lay-
er containing the subject and merge the two together 
by going to the Layer menu and choosing Merge Lay-
ers. As a result, we have a single layer that contains 
both the subject and the shadow, with the necessary 
transparency to make the shadow look realistic. 

With the selection active, we clicked on the Adjustment Layer icon and chose to create a  
Solid Color adjustment layer. Here, we are choosing black as the fill color. 

The shadow and subject are 
now contained on one layer.
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Note that when saving an image like this, we are limited to the type of file format 
we can use because many file formats do not support transparency. The PNG file 
format is a good format to use because it supports transparency and is compatible 
for use on the web. You can either go to the File menu and choose Export > Export 
As or you could choose Export > Save for Web. Either of these methods will let you 
choose the PNG file format. 

Extracting shadows for use on a printing press

When you print something on a printing press, you’re going to need to convert the 
document from RGB mode to CMYK mode, which is the color space required by 
professional printing presses. You can change the mode of the document by going 
to the Image menu and choosing Mode > CMYK.  Printing a shadow on a press can 
present a bit of a problem. 

After following the steps we used pre-
viously for separating the subject and 
shadow onto separate layers, activate 
the shadow layer and then open the 
Info panel. (If the Info panel is not al-
ready visible in your interface, you 
can access it by going to the Window 
menu and choosing Info.) We did this 
with the image of the Canon GPS re-
ceiver. Looking at the numbers for 
CMYK, we can see that the image is 
made of small percentages of Cyan, Magenta and Yellow. The problem is that with 
printing presses, it’s easy for the inks to be off a little bit so that we end up with too 
much of one certain color of ink, and this would result in a shadow that has color 
in it. This is something we don’t want so we need to do something that ensures the 
shadow won’t have an odd color to it. This technique will also use less ink because 
we’re going to reproduce the shadow using only black ink. 

Here, we’re looking at the Info panel for the 
shadow layer in a CMYK document. You can see 
small percentages of Cyan, Magenta and Yellow 
in this layer. 
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We need to make sure that the shadow 
layer is active and that it is not locked. 
We’ll click on the FX icon at the bottom 
of the Layers panel and choose Blending 
Options from the pop-up menu. The Lay-
er Style dialog will appear. In the middle 
of this dialog, there are Channel check 
boxes for C, M, Y & K. We’ll turn OFF the check boxes for Cyan, Magenta and Yel-
low. We will make sure that the black (K) check box is turned ON and click OK. 

In our example image, the shadow is there but it appears very light. That’s because 
we never changed the amount of black ink being used. We just told Photoshop not 
to use any of the other inks. We need to tell Photoshop to use the same amount of 
ink, but just do that with black ink. We’ll go to the Image menu and choose Adjust-
ments > Channel Mixer. The Channel Mixer dialog will appear and we want to make 
sure that the Output Channel menu is set to Black. Now we want to tell Photoshop 
to take whatever would usually be printed with Cyan, Magenta and Yellow and use 
Black instead. We’ll just drag these three sliders up until the shadow starts to look 

dark enough again. The three 
sliders should be set to about the 
same value but there is no precise 
algorithm. We’re just going to 
move the sliders up while looking 
to see how they are affecting the 
image. We’ll make sure the Black 
slider is set to 100 and then click 
OK. Now, we can look back at the 
Info panel and we’ll see that there 
is no Cyan, Magenta or Yellow in 
the image. The entire shadow 
layer is made up of black ink. This 
will ensure that the shadow will 
not have a color cast to it when 
printed on a printing press. 

In the Blending Options section of the Layer 
Style dialog, we turned off the check boxes 
for Cyan, Magenta and Yellow. We turned on 
the check box for black (K). 

The Channel Mixer adjustment is being applied to the 
shadow layer. We’re using the sliders to tell Photo-
shop to insert black in the areas that used to contain 
Cyan, Magenta and Yellow. 
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How to re-create a shadow

There are going to be instanc-
es where it will be impossible to 
maintain the original shadow when 
placing a subject onto its own layer 
(or layers). An example would be 
an image where the shadow falls 
on a very busy background, like the 
woodgrain in the video example. In 
this image, we tried to use the Lev-
els adjustment to force the back-
ground to white, but because there 
were dark details interspersed in 
that background, the lightening 
took the shadow along with it. In 
order to get around this, we’re go-
ing to have to re-create the shadow 
instead of maintaining the original 
shadow. 

We’ll start in the same way that 
we have done so previously. We’ll 
duplicate the background layer 
and then use a selection and layer 
mask in order to isolate the subject 
in that layer copy. 

In order to make a truly realistic shadow, the shadow will likely need to consist 
of more than one piece. In the mug image, we can see a large shadow extending 
from the right side of the mug and we can also make out a secondary shadow 
created by the handle of the mug.

It will be impossible to maintain the original 
shadow for an image like this because there is too 
much detail in the background. We’ll instead need 
to re-create the shadow.

A layer mask was used to isolate the mug.
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For the first piece, we’ll activate the bottom layer and then use the Lasso Tool to 
draw an outline around one of the shadows. In the coffee mug example, it’s the 
large, oval-shaped shadow falling on the right side of the mug. Then, we will click 
on the FX icon at the bottom of the Layers panel and choose to create a Solid 
Color adjustment layer from the pop-up menu. The Color Picker will appear and 
we can either choose a black color or we can use the eyedropper to choose a col-
or from a shadow that is already in the picture. In the video example, we’ll choose 
black and then click OK. Because there was a selection active, the selection will 
automatically be applied to the mask for the solid color layer. This leaves us with a 
black shape that sits above the background layer but below the layer containing 
the isolated mug. 

The Lasso Tool was used to create a selection in the shape of the desired shadow. This  
selection is being used to create a Solid Color layer, set to black. The Solid Color layer is  
positioned just beneath the subject layer.
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This black shape clearly does not yet look like a shadow. It is obvious that we 
must blur the shadow. To do this in a way that can be changed later (if we should 
so desire), we’ll need to make sure that the Color Fill layer is active and we will 
expand the Properties panel, which contains the settings for the layer mask. Here, 
we can drag the Feather slider to the right, softening the edge of the shadow 
until it looks appropriate. Then, we will use the Opacity setting at the top of the 
Layers panel to lower the opacity of the shadow so that it looks natural. 

Next, we’ll work on the next piece of shadow, which is created by the handle of 
the mug.  We’ll follow the same procedure as we did with the first shadow.  We’ll 
use the Lasso Tool to make a selection around the area that is darkened by the 
handle shadow. With that selection active, we’ll click on the FX menu and choose 
to create a Solid Color adjustment layer. We’ll use the Color Picker to choose a 
black color and click OK. Because there was a selection active when we creat-

To make the shadow look more natural, we opened the Properties panel for the Solid Color 
layer and dragged the Feather slider to the right, softening the shape. We are also lowering 
the opacity of the shadow. 
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ed the Solid Color adjustment layer, that selection will automatically be applied 
to the layer mask and there will be a black shape that represents this second 
shadow. It doesn’t look natural, so we’ll open the Properties panel and drag the 
Feather slider to the right until the shadow looks appropriate. Lastly, we’ll low-
er the Opacity setting so the shadow is not quite as dark. We can now turn off 
the visibility of the underlying, original image layer so that we have our mug and 
shadow sitting on a transparent background. We can easily use the Move Tool to 
place the subject onto a new background and fine-tune the opacity of the differ-
ent shadows so that they look appropriate in their new surroundings. 

The color of these shadows can also be adjusted at any time by double-clicking 
on the color swatch thumbnail for the Solid Color adjustment layer. The Color 
Picker will appear and we can use it to choose a new color from within the color 
square or use the eyedropper to sample a color within the image. 

A second shadow was added for the handle of the mug and we are viewing the result on a 
transparent background. 
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If we set the opacity to a high 
setting for one of the shad-
ows, it might start to look un-
natural because we won’t be 
able to see through it to the 
background. This would hap-
pen if the blending mode of 
the shadow layer was kept 
to Normal mode. In order for 
the textured background to 
appear through the solid col-
or fill shadow, we’d need to 
change the blending mode to 
Multiply mode. 

How to re-create a complex shadow

There are going to be instances where you won’t be able to re-create a shadow 
by simply drawing out an oval with the Lasso Tool. This will be the case when the 
shadow is a really complex shape, like the bicycle shadow in the video example. 
Let’s look at how to tackle a job like this.

We’ll work on the image that contains a shadow of a chair and we’ll start by du-
plicating the image layer. Duplicate a layer by using the shortcut Command+J 
(Ctrl+J on Win). Now, we want to try and isolate the shadow using this layer 
duplicate. We will try to use a Levels adjustment to force the areas surround-
ing the shadow to become solid white. We’ll go to the Image menu and choose 
Adjustment > Levels. In the Levels dialog, we’ll move the white slider to the left, 
forcing more and more areas to become white. We’ll hold down the Option key 
(Alt on Win) while we drag this slider so that we can get that special view of the 
image that shows us what areas are becoming solid white. Once we have forced 
as much of the surrounding area as possible to white, we’ll click OK. 

This shadow is set at a high opacity setting and you an 
see that it’s starting to look unnatural because you can 
no longer see the background texture. To fix this, we can 
set the shadow blending mode to Multiply.
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More of the surrounding area is now 
white, but we still have patches of 
color surrounding the shadow. We’ll 
use the Brush Tool to paint with 
white in the areas directly around 
the shadow. We won’t worry about 
any spots that are distanced from 
the shadow because we’ll fill those 
with white after making a selection. 
We’ll use the Lasso Tool to make a 
loose selection around the shadow 
and then go to the Select menu and 
choose Inverse. This will make it so 
everything EXCEPT the shadow is selected. We’ll fill this selection with white 
by going to the Edit menu and choosing Fill. When the Fill dialog appears, we’ll 
choose to fill with white and then click OK. 

A Levels adjustment is being used to force the area surrounding the shadow to white.

A selection was made around the shadow. That  
selection was inverted and then filled with white. 
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Now we have our shadow isolated, but there is still texture to the shadow. To fix 
this, we’ll go back to the Levels adjustment (Image > Adjustments > Levels) and 
use the black slider to force more areas to black. We’ll drag that black slider to 
the right, forcing as much of the shadow to black as possible, and then click OK. 
The result looks good, but we have a small amount of cleanup to do. We’ll use 
the Brush Tool to paint with white in any areas outside of the shadow that are not 
white already. We’ll paint with black inside of the shadow in any areas that were 
not perfectly black. 

The shadow of the chair is now isolated in this layer. The shadow is black and 
everything else is white. We will now make a selection of this shadow and we 
can do that by using the technique that allows us to create a selection based on 
brightness. We’ll open the Channels panel, hold down the Command key (Ctrl on 
Win) and click on the top-most channel (named RGB). This will make a selection 
where all white areas are 100% selected and all black areas are 0% selected. 

A Levels adjustment is being used to force as much of the shadow as possible to become 
solid black. 
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This is, of course, the opposite of what we want so we’ll go to the Select menu 
and choose Inverse. Now we have the shadow perfectly selected and we can go 
back to viewing the Layers panel. The only reason we duplicated the image layer 
was to create the selection of the shadow. Now that we have that selection, we 
can drag that layer to the trash can icon at the bottom of the Layers panel. 

With the selection active, we’ll click on the FX icon at the bottom of the Layers 
panel and choose Solid Color from the pop-up menu. The Color Picker will appear 
and we’ll use it to choose black and then click OK. Because there was a selection 
active at the time we created the Solid Color layer, that selection will automatical-
ly be applied to the adjustment layer’s mask and we will be left with a color layer 
in the shape of our shadow. We can then adjust the Opacity of the shadow or we 
can soften the edges by opening the Properties panel and dragging the Feather 
slider. 

LEFT: We now have a selection of the chair’s shadow. RIGHT: The shadow is isolated on its 
own layer. 
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Create a custom shadow

There are also going to be times 
when the original shadow will not 
work on a different background. 
This means that we can’t use that 
original shadow and we can’t use it 
as a guide to create a new shadow. 
The video example image shows a 
model on a white backdrop, but the 
shape of the backdrop is influenc-
ing the shape of the shadow. This 
makes it so that if we were to place 
the shadow on a different back-
ground, it would not look appro-
priate. Let’s look at how to create a 
new shadow for her.

We’ll start by placing the subject on her 
own layer by the use of a selection. For 
this image of the model, we’ll go to the 
Select menu and choose Subject. This 
may or may not work correctly. It will 
depend on the subject of your image. In 
our example, it actually did a pretty de-
cent job. We could further refine the se-
lection using the Select & Mask feature, 
but that is the subject of a different les-
son. Plus, we’re going to be creating a 
shadow from this selection, so it’s not 
going to matter if all of the fine hairs 
and other details are selected proper-
ly because the shadow is going to be 
blurred significantly. We will, however, 

The shadow in this image would not be appropri-
ate on a different background, so we’re going to 
create a new shadow. 

The selection of the model was created by 
going to the Select menu and choosing  
Subject.
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refine the selection around the 
shoes because this part might 
be more noticeable in the re-
sult. We’ll tap the Q key to enter 
Quick Mask Mode and then use 
the Brush Tool to refine the se-
lection around the shoes, making 
sure that there is no red overlay 
on the shoes and that there IS a 
red overlay in the area surround-
ing the shoes. We’ll tap the Q key 
again to exit Quick Mask Mode. 

Now, we’ll isolate the subject by 
adding a layer mask (the layer 
mask icon is at the bottom of 
the Layers panel). Because there 
was a selection active, the selec-
tion will automatically be applied 
to the mask so the model is visi-
ble but the background is not. 

Let’s create a Solid Color layer based on a selection of the subject. We will then 
be able to use that layer as the shadow. We already have the subject isolated 
using a layer mask. You can turn a mask into a selection by holding down the 
Command key (Ctrl on Win) and clicking on the layer mask thumbnail. With that 
selection active, we’ll click on the FX icon at the bottom of the Layers panel and 
choose to create a Solid Color layer. The Color Picker will appear, we’ll use it to 
choose black and then click OK. 

Now we have a black Solid Color layer in the shape of the subject. It’s on the top 
of the layer stack, so we’ll need to drag it beneath the image layer in order for 
the model to show up on top. We can now modify the Solid Color layer so that it 
looks like a shadow. 

The selection is 
being refined in 
the area around 
the shoes by using 
the Brush Tool in 
Quick Mask Mode.

The subject was isolated by taking the selection and 
turning it into a layer mask.
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With the Solid Color layer active, we’ll go to the Edit menu and choose Transform 
> Distort. Transform handles will appear on a rectangular box and we can use 
these handles to distort the layer. If you’re using a newer version of Photoshop 
(updated after October 2018), you will need to hold down the Shift key while 
dragging these handles. This will allow you to apply the transformation without 
constraints. Keeping the Shift key held down, we’ll drag the handles individually 
so that they extend in the way that the shadow would extend (see screen shot). 
Note that it will be difficult to get the shoes to look right. That can be remedied 
using the Puppet Warp feature, and there is a separate Masters Academy lesson 
that covers that topic. 

With the selection of the subject active, we are creating a Solid Color layer and choosing 
black for the fill color.
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To make the shadow look more realistic, it will need to be blurred. Just like we did 
in previous examples, we’ll open the Properties panel and drag the Feather slider 
up until the shadow looks more appropriate. Shadows tend to be more crisp in 
the area close to the subject and they get softer and softer as they extend away 
from the subject. To achieve this, we’ll need to start by rasterizing the layer. With 
the Solid Color layer active, we’ll click on the Layer menu and choose Rasterize 
> Layer. This will take it from being a special, Solid Color layer to being a regular 

layer that is filled with black and 
has a layer mask applied. Next, 
we’ll drag the layer mask to the 
trash can icon and a dialog box 
will appear, asking us wheth-
er we’d like to apply the mask. 
We’ll click Apply. This will delete 
all the areas hidden by the lay-
er mask, leaving us with a black 
shape of the subject. 

The Free Transform 
command is  
being used (with 
the Distort setting) 
in order to warp 
the shadow into the 
correct position.

The Color Fill layer was rasterized and the layer mask 
was applied. This leaves us with a normal layer con-
taining the shape of the subject.
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Now we can more easily blur the shadow. We’ll click on the Filter menu and 
choose Blur Gallery > Field Blur. The Filter Gallery window will appear and the 
Field Blur circle will be positioned over the image. We will drag this circle to the 
subject’s feet and then drag the ring, determining how blurry that area should be. 
Since this part of the shadow is close to the subject, we don’t want it too blurry. 
Then we will click on the head part of the shadow, adding another Field Blur ring. 
We can use the slider on the ring to determine how blurry this area should be. 
This part of the shadow is farthest from the subject, so it should be much more 
blurry. When we’re satisfied, we’ll click OK. 

The next issue is opacity. Look at a photo that includes a natural shadow and 
you will see that the shadow is very opaque when it’s close to the subject and it 
gradually fades out as it gets farther from the subject. We’ll need to mimic this 
in order for our shadow to look natural. This can be achieved by adding a layer 

The Color Fill layer was rasterized and the layer mask was applied. This leaves us with a nor-
mal layer containing the shape of the subject.
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mask and using the Gradient Tool. With the shadow layer active, we’ll click on 
the Layer Mask icon at the bottom of the Layers panel. This will add a white layer 
mask. When a layer mask is entirely white, it means that the entire layer is visible. 
We’ll activate the Gradient Tool and make sure that the foreground color is set to 
black. We’ll use the gradient menu in the Options bar to choose the Foreground 
to Transparent gradient. Then, we’ll make sure the layer mask is active and then 
drag out the gradient. We’ll start where the “head” of the shadow is and drag out 
the gradient line to the “feet” of the shadow and then release the mouse button. 
This will place a lot of black into the mask near the head and then add less and 
less black as it gets closer to the feet. As a result, the area near the feet will be 
pretty opaque and the shadow will become more and more transparent as it 
moves toward the head. 

A layer mask was 
added to the 
shadow layer and 
then the Gradient 
Tool was used on 
the layer mask. 
We used a fore-
ground (black) to 
transparent gradi-
ent and dragged 
from the head of 
the shadow to the 
feet of the shad-
ow. This hid the 
layer more near 
the head and less 
near the feet. 
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Shadows falling across objects

We have talked about how we can cast shadows onto different backgrounds. But 
what if that background includes other objects? Let’s look at how we can create 
a shadow and make it look realistic when falling over another object. We’ll work 
on the Photoshop document that contains a ruler layer positioned over a clamp 
layer. We want the ruler to cast a shadow down on the clamp. 

We don’t have any shadow to go from, so we’ll create one using the Drop Shadow 
Layer style. With the ruler layer active, we’ll click on the FX icon at the bottom 
of the Layers panel and choose Drop Shadow from the pop-up menu. The Layer 
Style dialog will appear and the drop shadow settings will be at the forefront. 
We’ll adjust the size and opacity settings so that the shadow looks like it is cast-
ing a decent distance from the backdrop. We’ll click OK. 

A Drop Shadow layer style is being added to the ruler layer so that it looks like it is sitting a 
good distance from the backdrop.
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Now, the shadow is casting onto the backdrop and the clamp equally, and this 
doesn’t look totally natural. We need to remove the current shadow from the 
clamp and create a new, different, shadow JUST in the area where the ruler over-
laps the clamp. To do this, we first need to turn the drop shadow layer style into 
its own layer. We’ll click on the Layer menu and choose Layer Style > Create 
Layer. This will remove the drop shadow from the ruler layer and place it onto its 
own layer, directly below the ruler layer. We’ll drag this shadow layer down in the 
Layers panel so that it is positioned under the clamp layer. This will remove the 
shadow from the clamp. 

Now we’ll create a new shadow to fall on the clamp. We’ll activate the ruler layer 
and we’ll again add a drop shadow layer style. This shadow needs to make it look 
as if the clamp is just below the ruler, so it will be a harder shadow that has a high-
er opacity setting. The Size slider will also have a lower setting. Once we create a 
realistic look here, we’ll click OK.

LEFT: The drop shadow is being applied as a layer style to the ruler layer. RIGHT: The drop 
shadow was separated from the ruler layer and placed onto its own layer. 

A new drop shadow 
is being added to the 
ruler. This time, it’s a 
harder shadow that has 
a smaller Size setting. 
This makes it look as if 
it is positioned closer 
to the clamp.
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Now we only want this new shadow to fall on the clamp, so we will again need to 
take the drop shadow and put it on its own layer. We’ll click on the Layer menu 
and choose Layer Style > Create Layer. This will again take the drop shadow, re-
move it from the ruler layer and place it on its own layer, just beneath the ruler 
layer. In order to make it so the shadow only appears in the area where the clamp 
is, we’ll create a clipping mask. With the shadow layer active, we’ll go to the Layer 
menu and choose Create Clipping Mask. This will take the shadow layer and only 

allow it to be visible where there is 
content in the underlying layer (the 
clamp layer). You can tell that a lay-
er is “clipped” to the layer beneath 
it because it will be slightly indent-
ed in the Layers panel and it will how 
a down-pointing arrow to the left of 
the layer thumbnail.

The shadow layer is clipped to the clamp layer. 
This causes the shadow to only appear in the 
area where there is content in the underlying 
layer (the clamp). 

Above, you can see the resulting image. There is one shadow designed to cast on the back-
drop and another designed to cast onto the clamp. 


