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Challenge Images: Building Distortion & Spiderweb 

In this lesson, we’re going to work on two challenge images submitted by Masters 
Academy members. I will take these images and show you the step-by-step pro-
cess I would use to tackle the problems. 

Building image: Distortion correction

The first image is of a building that 
appears distorted due to the cam-
era angle. Let’s look at what we can 
do to correct for some of the distor-
tion. The image is a raw file so we 
will double-click on it (from within 
Bridge) to open it in Adobe Cam-
era Raw. In Camera Raw, we’ll first 
try to get rid of any distortion that 
may have been caused by the lens. 
We’ll click on the Lens Corrections 
tab on the right side of the inter-
face. The icons for the different tabs 
can be found directly beneath the 
histogram. Within the Lens Correc-
tions panel, it’s always a good idea 
to turn on the “Remove Chromat-
ic Aberration” check box, as this 
will remove any artifact that looks 
like a colored fringe running along 
contrasting edges in the image. We 
will also turn on the “Enable Profile 
Corrections” check box, which will 
straighten out any curvature that’s 
in the building. 

Some of the distortion in this image is due to the 
extreme angle at which it was shot. We will use a 
few different techniques to correct for it. 

In the Lens  
Corrections 
tab (the icon is 
circled at left), 
we are turning 
on the “Remove 
Chromatic Aber-
ration” check box 
and the “Enable 
Profile Correc-
tions” check box.



Challenge Images: Building Distortion & Spiderweb © Ben Willmore, All rights reserved 3

At this point, we can click back on the Basic tab (it’s the icon on the far left) and 
make any tonal adjustments that are necessary. 

Next, we’ll activate the Transform Tool by clicking on its icon in the Toolbar that 
runs along the top of the interface. With the Transform Tool active, a different 
group of settings will appear on the right side of the interface. (Note that in Light-
room, the same settings can be found under the Transform panel on the right side 
of the Develop Module.) There are a series of icons that run horizontally along the 
top of the tab and these are the Upright settings. The icon that looks like a square 
with a horizontal line through the center will try to make horizontal lines in the im-
age become straight. The icon that looks like a square with vertical lines inside of it 
will try to make vertical lines become straight. The icon that looks like a grid will try 
to straighten both horizontal and vertical lines. The icon with an A on it is the Auto 
setting and this will try on its own to determine which settings are needed. When 
an image has this much distortion, however, these icons will likely not be enough. 
In a case like this, the Guided Upright tool is a better bet, and this is the icon on the 
far right side. 

We activated the Transform Tool (circled at top) and the Transform settings appear on the 
right side of the interface. We’re going to use the Guided Upright feature (circled at right).
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We’ll click on the Guided Upright icon in order to activate the tool. Then, we’ll find 
a line in the image that should be horizontal. We’ll hover the cursor over one end 
of the line and then click and drag our cursor over to the other end of the line. A 
guide will appear where we dragged out the line. This, by itself, will not do anything 
because it requires at least two lines to be defined in order to straighten things. 
Knowing this, we’ll find another line in the image that should be horizontal and we’ll 
do the same thing. Note that in order to get the most precision, it’s best to choose 
lines that are far apart from each other. In the challenge image, we dragged out 
one line along the railing at the bottom of the image and we dragged out a second 
line on a horizontal rim near the top of the building. When we release the mouse 
button, it’s going to make its corrections based on the horizontal lines we defined. 

We’ll now do the same thing with vertical lines. We’ll click and drag out guides 
along two vertical lines in the image (preferably ones that are far apart from each 
other). In the end, we have corrected the distortion created by the tilting of the 
lens. 

Using the Guided Upright setting (circled at left), we dragged out 
two lines that define surfaces that should be horizontal. Photoshop 
used those lines as guides for correcting the distortion (right). 
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Whenever we make a drastic transformation like this, it might look as if the build-
ing is squished in one direction. To compensate for this, we can adjust the Aspect 
setting, which is located within the Transform sliders. 

LEFT: We used the Guided Upright setting to drag two vertical lines on the image.  
RIGHT: When we released the mouse button after drawing the second line, Photoshop used 
the lines to correct for the vertical distortion.

After applying an extreme transformation, the image may look as if it is squished in one di-
rection or another. Here, we are using the Aspect slider to correct for that.
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Now me might think about cropping the image, and there is an important setting to 
consider, given that the transformation has resulted in transparent areas of canvas 
on the left and right sides of the image. The Crop Tool is located in the Toolbar on 
the top of the Camera Raw interface. If we click and hold the mouse button on the 
tool’s icon, a menu will appear and one of the menu items is “Constrain to Image.” 
If this option has a check mark next to it, that means that the setting is turned on 
and when we go to crop the image, it will not allow us to include any transparent 
areas. If we turn the setting off, then the Crop Tool will allow us to include transpar-
ent areas of canvas. If we plan on using Photoshop to fill in the transparent areas, 
we would keep this setting turned off. 

We will allow for some transparent areas and we will click the Open Image button 
in the lower right corner of the interface. This will open the image in Photoshop so 
that we can attempt to fill in those transparent areas. We’re going to try and let 
Photoshop fill in the empty areas but we first need a selection. We’ll activate the 
Magic Wand Tool and click in one of the transparent areas. We’ll hold down the 
Shift key and click on the other transparent area so that both areas are selected. 

LEFT: We are clicking and holding on the Crop Tool icon to access this menu. RIGHT: When 
the Constrain to Image setting is turned on, the Crop Tool will not allow us to include trans-
parency when we crop the image. 
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Now, in order for the Content-Aware Fill feature to work properly, the selection will 
need to overlap the image by just a tiny amount. We’ll go to the Select menu and 
choose Modify > Expand. In the Expand dialog, we’ll tell it to expand by just one 
pixel and then click OK. 

Now there are a couple of ways that we could fill this selection. In the past, I would 
go to the Edit menu and choose Fill. The Fill dialog would appear, I’d make sure 
the Contents menu was set to Content-Aware and then click OK. Photoshop would 
then look at the areas of the image surrounding the selection and try to fill in the 
selection based on those areas.

There is now another, smarter method for using the Content-Aware Fill feature. 
With the selection[s] active, we’ll click on the Edit menu and choose Content-Aware 
Fill. (This feature was added in October of 2018.) When we choose this option, the 
Content-Aware Fill interface will appear and there will be two image windows. The 
window on the left shows the selection as well as a colored overlay. The colored 
overlay represents the areas that Photoshop can copy from in order to fill in the 
selection area. The window on the right shows a preview of the result, with the se-
lection filled in. 

With active selections 
around the transpar-
ent areas, we went 
to the Edit menu and 
chose Fill. In the Fill 
dialog, we are using 
the Content-Aware 
setting. This is the 
older method for  
applying the  
Content-Aware Fill 
settings.
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We can specify where we would like Photoshop to sample the content from by 
adding or subtracting from the colored overlay. With the Brush Tool active (in the 
Toolbar on the left), we will make sure that the Plus icon ( + ) is highlighted in the 
Options Bar at the top of the image window. This will allow us to add to the colored 
overlay and we’ll paint over part of the image that we WANT Photoshop to copy 
from in order to fill in the selection. 

Here, we are adding the colored overlay in the area we want Photoshop to copy from in order 
to fill in the retouch area. To add the colored overlay, we need to make sure the brush tool is 
set to the plus icon (+), which is circled above. 
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Then we will click on the minus icon ( - ) and use the brush to paint away the overlay 
in places where we do NOT want Photoshop to copy from. Looking at the preview 
on the right, we can see that it’s starting to fill the selection with more appropriate 
content. In order for Photoshop to fill this selection most effectively, we’re going 
to need to give it more control. If we turn on the Mirror and Scale check boxes un-
der the Fill Settings category, Photoshop will be able to take the sample content 
and flip it or scale it to best fill the selection. We can also change the setting in the 
Rotation Adaptation menu, which determines how much Photoshop is allowed to 
rotate the sampled content. We’ll set this to Low for this image, but it’s something 
you’ll need to experiment for each image/selection you are trying to fill. Once we 
are happy with the result, we’ll click OK.

Here, we set the brush to the subtract setting (-) and are painting to remove the colored 
overlay in the window on the left. At right, we can see a preview of the result. It’s not perfect, 
but it’s getting closer.
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In this challenge photo, we were unable to perfectly fill in the selection using the 
Content-Aware Fill feature. If this ever happens, you will need to use Photoshop’s 
retouching tools in order to fill the area. We would find a sample area that could 
best be used to fill in the retouch area and then we would copy that sample area 
using the Clone Stamp Tool or the Healing Brush. Then, we would use the Clone 
Source panel to scale and rotate that sampled content so that we can perfectly 
paste it into the retouch area.

Spiderweb image: Removing the background

The next challenge image features a spi-
derweb and we want to try and remove 
the background. In order to do this, we’ll 
need to make a selection and isolate the 
web.

Making a selection based on brightness  
One way of making a selection is to make 
the selection based on brightness. To 
do this, we would first duplicate the im-
age layer and then try to take the back-
ground on the top half (the part that’s 
almost white) and force it to solid white. 
Then, there is a way to make a selection 
of that background where all the white 
areas would become selected. 

We will make sure the image layer is active and then we’ll use the keyboard short-
cut Command+J (Ctrl+J on Win). This will duplicate the layer. With the image dupli-
cate layer active, we’ll click on the Image menu and choose Adjustments > Levels. 
In the Levels dialog, the slider in the upper right will force areas to become white. 
If we hold down the Option key (Alt on Win) while dragging this slider, we’ll get 
a different view of the image that shows us what areas are becoming solid white. 

With this  
image, we 
are going 
to try to 
remove 
the back-
ground and 
isolate the  
spiderweb. 
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We’ll drag this as far as we can before parts of the spiderweb start disappearing. 
Because the bottom part of the spiderweb image is almost black, we will try to 
force those areas to black by dragging the left slider (the black one) over to the 
right as far as we can before the top part of the web starts to get too thick. (see 
screen shot) We’ll click OK. 

The Levels adjustment is being used to force all the bright parts of the background to solid 
white. We are holding down the Option key (Alt on Win) to get this view of the image that 
shows what parts are being forced to become solid white. We also moved the black slider in 
to force the dark parts of the background to become solid black. 
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We have forced a large part of 
the image to solid black and 
solid white so we can now 
make that selection based 
on brightness. We’ll open 
the Channels panel and hold 
down the Command key (Ctrl 
on Win) while clicking on the 
thumbnail for the top-most 
channel (RGB). This will give 
us a selection where all white 
areas are completely selected 
and all black areas are not se-
lected at all. The white areas 
represent the background, 
and we want the opposite, so 
we’ll click on the Select menu 
and choose Inverse. Now, the 
top half of the spiderweb will 
be selected. 

To see how accurate the selection is, we’ll cre-
ate a new, empty layer and then fill the selection 
with black by going to the Edit menu, choos-
ing Fill and then setting the Contents menu to 
Black. In our example image, we placed a dif-
ferent photo at the bottom of the layer stack 
so that we could see what the content looked 
like on a different background. We’ll deselect 
the selection and then zoom in to see the re-
sults. We ended up getting a good portion of 
the spiderweb but I’d like to maintain more of 
the highlights that were in the original image. 

With the Channels panel open, we held down the Com-
mand key (Ctrl on Win) and clicked on the top channel 
thumbnail in order to get a selection based on brightness.

Working on an empty layer, we filled 
the selection with black and then 
placed it on a different background  
so we could see the results.
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To get the rest of the spiderweb selected, we’ll need to take the selection process 
we just used and repeat it several times. First, however, we’ll mask out the part of 
this new layer that is not useful. We want to keep the part of the spiderweb that is 
isolated on a transparent background. That’s the top part of the layer. We’ll mask 
out the bottom part by adding a layer mask and then painting with black on the 
bottom part of the mask. Then, we would repeat the selection process a few more 
times, each time targeting an additional portion of the web.

If we wanted to make a selection that includes the bright highlights within each 
droplet on the web, we would use Levels to isolate the absolute brightest parts of 
the image, which should be the specular highlights within the droplets. We’ll use 
the keyboard shortcut Command+J (Ctrl+J on Win) to duplicate the image layer 
and then go to the Image menu and choose Adjustments > Levels. We will use the 
black slider to try to force everything to black except for the little highlights on the 
water drops. We’ll also drag the white slider in just a bit in order to brighten those 
highlights and then we’ll click OK. 

We only need the top part of this new layer, so we added a layer mask and we’re painting on 
the mask with black in order to hide the bottom half of the layer.
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We’ll open the Channels panel, hold down the Command key (Ctrl on Win) and 
click on the thumbnail for the top channel. This will make a selection based on 
brightness, so all the white areas will be selected. Back in the Layers panel, we’ll 
create a new, empty layer and then fill the selection with white. This layer now con-
tains the highlights on the bubbles. We’ll also turn on the last layer that we created, 
containing the dark part of the web. Looking at this result with the other image as 
the background, we can see the progress that we have made in isolating the web. 
Again, we would need to repeat the selection process a few more times, each time 
isolating a different part of the web. 

A Levels adjustment is being used to isolate just the highlights within the water drops.

LEFT: We’re looking at the layer that was created for the specular highlights on the web. 
RIGHT: We are viewing the highlight layer as well as the web layer on a different background 
image.
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The Background Eraser Now, let’s try a completely different technique for remov-
ing the background on the spiderweb. We’ll place the spiderweb image as a sepa-
rate layer on top of another image, just so that we can better see the results. Then 
we’ll activate the Background Eraser, which is hidden behind the Eraser Tool in the 
Toolbar on the left side of the interface. We’ll click and hold the mouse button on 
the Eraser Tool in order to get the menu that gives us access to the Background 
Eraser. With this image, we’ll set the Background Eraser to paint with a huge, soft-
edged brush. (The settings can be found in the Options Bar above the main image 
window.) We’ll also make sure that the Limits menu is set to Contiguous. 

With the Background Eraser, you will notice that there is a little crosshair in the 
middle of the brush tip. We want to position this crosshair over part of the back-
ground color. When we click, it’s going to try and erase ONLY the color that is 
directly beneath the crosshair and it will do so across the entire diameter of the 
brush. We’ll click and then zoom in to examine the results. 

We activated the Background Eraser (circled) and, using a very large brush, we are position-
ing the center crosshair over part of the background color.
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The tool did erase the background of the 
spiderweb, but it ended up taking part 
of the web with it. We’ll use the Undo 
command, change a setting and then try 
again. We want to make sure that the Tol-
erance setting (also located in the Op-
tions Bar) is as low as is workable. The 
Tolerance setting determines how much 
the eraser can vary from the color we click 
on. We’ll set the Tolerance to 10% and try 
again. This time, it did a pretty good job! 
This setting will vary from image to image, so when trying to remove a background 
using the Background Eraser, you will need to experiment with the Tolerance in or-
der to find the right setting for your particular image. 

We’ll continue to click around the image using the Background Eraser, making sure 
to position the crosshair in the background area between the strands of the web, 
until the entire background has been removed. 

We attempted to remove the background 
on the spiderweb using the Background 
Eraser. It removed the background but un-
fortunately took part of the web with it.

Here, we set 
the Background 
Eraser’s Tolerance 
setting to 10% 
(circled) and then 
tried to remove 
the background. 
This time, it did 
a good job, re-
moving the back-
ground while 
leaving the web 
intact. 


