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Undo & History 

In this lesson, we’re going to learn about using undo’s and the History panel. Here, 
we will cover the basics, and in a different lesson, we’ll work on a more advanced 
level. 

The undo command The standard keyboard shortcut for undoing the last thing 
you did [in any program] is Command+Z (Ctrl+Z on Win). In Photoshop, you can 
also go to the Edit menu and choose Undo. If the very last thing you did was undo 
something, then this menu will show “Redo” instead. This is because Photoshop 
will only allow you to undo one step.  

Multiple undo’s We mentioned above that you can 
only use the undo command once. (If you try to 
use it a second time, it will redo the step.) If you 
would like to have multiple undo’s, you will need 
to use the History panel. If the History panel is not 
already visible in your Photoshop interface, you 
can access it by going to the Window menu and 
choosing History. 

The History panel will display a list of everything 
you’ve done to the image since you opened it in 
Photoshop. At the very top of the list will be the 
word “Open” and that’s because the first thing you 
did to the image was open it. The step at the bot-
tom of the list will be the very last thing you did to 
the picture. You can click on any of these steps to 
revert the image to the stage it was in when you 
made that step. Clicking on the item that is one up 
from the bottom of the list would be the equivalent 
to using the undo command, because it will undo 
the last thing you did. If you would like to undo mul-
tiple steps, simply click on one of the steps in the 
list to undo every step taken after it. 

Photoshop’s History panel lists 
everything you’ve done to the 
image.
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By default, the History panel can only record a certain number of steps, but you 
can change that within Photoshop’s preferences. Go to the Photoshop menu and 
choose Preferences > Performance. (If you are using Windows, the Preferences 
will be located under the Window menu.) The Performance section of the Prefer-
ences dialog will appear and there will be a “History States” setting on the right. 
Here, you can type in anything from 1 to 1000 and this will determine how many 
steps the History panel can record. You might be wondering why you shouldn’t 
just type in 1000. Well, Photoshop records all of the history steps on your com-
puter’s scratch disk. When working on a complex image, you might get an error 
that says your scratch disk is full. This basically means that the file that keeps track 
of all the steps you’ve taken with your image is full and can’t get any bigger. You 
would then no longer be able to make any more changes to your image. The num-
ber you type into the History States field will depend on how big your hard drive is 
and some other variables, but personally, I find that 500 is a good number to use. 
Click OK to save the change and exit the Preferences dialog. 

You can change how many steps Photoshop will record in the History panel by changing the 
“History States” setting within the Performance section of the Preferences dialog. 
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Keyboard shortcuts for the History panel I sometimes find that the History pan-
el takes up too much room on my screen and I would prefer to navigate up and 
down the list by using keyboard shortcuts. The shortcuts would be for the “step 
backward” and “step forward” commands. The step backward command will take 
you back a step in your Photoshop process and, unlike the undo command, you 
can use it over and over again (until you get back to the stage where you opened 
the document). The step forward command can be used after you used the step 
backward command and realized you wanted to redo some of those steps. You 
can find these menu commands by clicking on the little menu in the top right cor-
ner of the History panel or by clicking on the Edit menu at the top of Photoshop’s 
interface. However, it’s much easier to use keyboard shortcuts. 

Step backward: Option+Command+Z (Alt+Ctrl+Z on Win)

Step forward: Shift+Command+Z (Shift+Ctrl+Z on Win)

When you step backward a few times, all 
of the steps beneath the current state of 
your document (the ones you undid) will 
be grayed out in the History panel. It’s im-
portant to know that if you should do any-
thing in your document at this point, those 
grayed out steps will disappear and you will 
no longer be able to “redo” them. 

What is recorded in the History There are 
some things that will not be recorded in 
your Photoshop history and will therefore 
not be undoable. These are things that 
would not have the potential of changing 
the look of your document. For example, if 
you change the foreground or background 
color, or if you change the zoom view of the 
document, it will not show up as a state in 
the History panel. 

Here, we “stepped backward” four steps 
and you can see that the steps we “un-
did” became grayed out. If we were to 
do anything to our image at this point, 
these grayed-out steps would disappear 
and we would no longer be able to redo 
them.
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When you close a document, all of the saved history states and snapshots will be 
thrown away. It doesn’t matter if you save the file or not. This is because all of the 
history is stored in a temporary scratch disk file that will be deleted the moment 
the document is closed.  

Positioning the History panel By default, the History panel is docked with your 
other Photoshop panels. To minimize it down to an icon, click on the word History 
at the top of the panel or click on the little arrow at the top of the panel. Click on 
the History panel icon to expand the panel again. You can undock the panel so 
that it becomes a floating panel that you can position anywhere you’d like in your 
interface. To do this, click on the name of the tab and drag it away from the bar 
of docked panels. Then, you can position the panel by clicking and dragging on 
that tab that displays the name, “History.” To re-dock the panel with the other pan-
els, click and drag the tab back to the bar of panels. A blue highlight will appear, 
showing you where the panel will be docked when you release the mouse button. 
If you’d like it docked next to the other panels, release the mouse button when 
the vertical blue line appears. If you’d like it docked WITH the other panels (in the 

LEFT: The History panel icon. ABOVE LEFT: The tab is being dragged away from the 
panel bar so it can be a free-floating panel. ABOVE RIGHT: Click the little arrow icon 
to expand and condense the panels horizontally.
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same list), position it between the other panel icons and release the mouse button 
when a horizontal blue line appears. If the panels appear as icons and you would 
like to see them expanded horizontally, click on the icon that looks like two little 
arrows at the very top of the panel list. If the panels are expanded and you would 
like to condense them back down into icons, click on that little arrow icon again. 

Snapshots Snapshots allow you to save a 
particular state of your document so that 
you can go back to it at any time. Let’s say 
that you adjusted your image and you’re 
happy with the result, but you would like 
to see what the image would look like with 
additional effects applied. You could create 
a snapshot of the current state (that you 
know you like) and then continue working 
on the image. If it turns out that you don’t 
like the additional effects that you applied, 
you could click on that snapshot to easily 
return to that state in which you liked the 
image. To create a snapshot of the current 
state of your image, click on the little cam-
era icon at the bottom of the History panel. 
The snapshot will appear near the top of 
the History panel and it will have the de-
fault name of “Snapshot 1.” You can change 
the name by double-clicking on the text 
and typing in a new one. To return to the 
state of your image (captured in that snap-
shot) at any later time, simply click on the 
snapshot’s thumbnail in the History panel. 

Click the camera icon to create a snap-
shot. Snapshots will appear at the top of 
the History panel.
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Photoshop automatically creates a snapshot when a document is opened. It is 
located at the very top of the History panel and has the same name as the image 
file. Clicking on this snapshot will bring you back to what your image original-
ly looked like. It will revert the document to the exact state it was in when you 
opened the file. 

There are other things you can do to have Photoshop automatically create snap-
shots. If you click on the little menu icon in the top right corner of the History pan-
el, a menu will appear and one of the choices is History Options. Choose this and 
a dialog will appear, containing a list of check boxes. The first item, “Automatically 
Create First Snapshot,” is turned on by default. You may also want to turn on the 
second check box, “Automatically Create New Snapshot when Saving.” This will 
create a new snapshot every time you save your document. The name of the snap-
shot will be the date/time when you saved. 

Non-Linear History Another setting within the History Options dialog is the “Allow 
Linear History” check box. If you turn this on, the History panel will behave a little 
differently. By default, when you step backward in your history for a document, 
the steps that you undid will become grayed out in the History panel and if you did 
something else to your image at that point, all of those grayed-out steps would 
be deleted. However, if you turn on the “Allow Linear History” check box and then 
step backward in your history, those steps that would previously be grayed out 

The History Options allow 
you to specify that  
Photoshop create a new 
snapshot every time you  
save the document.
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will NOT be grayed out. If you did something else to your image at this point, the 
step would be inserted at the bottom of the History list, leaving all of the other 
steps intact. No steps are deleted. This can be somewhat confusing, though, due 
to things getting out of order. For example. Let’s say you retouched out an object 
soon after opening the document and then applied a series of changes after that. 
In the video example image, we retouched out some stickers from a bus wind-
shield. Then, several steps later, you clicked back on the step where the object was 
still present and applied a filter. The filter step will be added at the bottom of the 
history list, but the object will be back, and that’s because the filter was applied to 
that earlier version of the image. Because this can get confusing, I usually keep the 
Non-Linear History check box off. I will instead rely on snapshots to save a certain 
state of my image. 

Make Layer Visibility Changes Undoable  By default, 
Photoshop will not record a change in layer visibility as 
a history step. When working with a document that has 
many, many layers, however, you might WANT Photo-
shop to record when layers were turned off and on, as 
layer visibility can change the look of your image. You 
can specify that changes in layer visibility be recorded 
by turning on the “Make Layer Visibility Changes Undo-
able” within the History Options dialog. (Remember, you 
get to the History Options dialog by clicking on the little 
menu in the top right corner of the History panel.)

If, however, you are not using layer visibility to change the 
look of your image, you might want to keep the setting 
turned off so that it is not adding lots of extra steps to 
the History panel. For example, I often times will create 
a layer or adjustment layer to use as a guide for what’s 
going on in my image. In the video example, I created a 
Curves adjustment layer and used it to brighten up the 
image a LOT. This allowed me to better see where I had 
painted with black on an underlying layer. I toggled the 

Use the History Options 
to specify that the History 
panel record changes in 
layer visibility.
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visibility of this adjustment layer many times as I worked on darkening the under-
lying layer. If Photoshop were to be recording the changes in layer visibility, my 
history list would be unnecessarily long, so for an instance like this, I would keel the 
“Make Layer Visibility Changes Undoable” check box turned off. 

Show new snapshot dialog by default  We mentioned above that you can change 
the name of a snapshot by double-clicking on the text and then typing in a new 
name.  If you know that you are going to change the name of the snapshot when 
you create it, you can hold down the Option key (Alt on Win) while clicking on the 
little camera icon. This will cause Photoshop to present you with a New Snapshot 
dialog, in which you can specify the name and then click OK. Now let’s say that 
you ALWAYS rename your snapshots. If this is the case, I’d recommend turning on 
the “Show New Snapshot Dialog by Default” check box within the History Options 
dialog. With this setting turned on, Photoshop will bring up the New Snapshot 
dialog every time you click the camera icon to create a new snapshot. This allows 
you to easily specify a name for the snapshot and then click OK. 

Clear History Once you are completely finished making changes to your image, 
you have the option to clear the history. This will remove all of the history states 
listed in the History panel but it will not delete your snapshots. Clear history by 
clicking on the little menu in the top right corner of the History panel and choos-
ing Clear History.  To delete a snapshot, simply click and drag the snapshot to the 
trash can icon at the bottom of the History panel. 

Save out a snapshot as a separate document You can save out a snapshot as a 
separate file, giving you another version of your image file. To do this, click on the 
snapshot to make it active and then click the little plus (+) icon at the bottom of 
the History panel. This is the button to “Create new document from current state.” 
The new file will open in a separate Photoshop window. 

Fill and paint with history The History panel is not just about undos and returning 
to previous states of your document. You can also fill with and paint with these 
different versions. To fill or paint with a previous state of your image, you’ll first 
need to specify which state you’d like to fill or paint with. Looking at the History 
panel, you’ll notice that there is a little paint brush icon that is to the left of the top 
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snapshot by default. This means that if you 
fill or paint with a state in history, it will use 
this snapshot to fill or paint with. If you’d 
like to change which history state is being 
used, simply click on the little square to the 
left of the name of the history state in or-
der to place the little paint brush icon in 
that square. This is the version of your im-
age that will be used when you fill or paint 
with history.

If you would like to fill your document (or a selected area) with a previous state 
of the image, go to the Edit menu and choose Fill. In the Fill dialog, the Contents 
menu can be used to specify what you’re filling with and one of the options is His-
tory. When you use this option, Photoshop will fill the layer (or selection) with the 
history state you specified. 

This brush icon indicates what history 
state will be used when you fill with  
history or use the History Brush.

Here, we’re using the Fill command to fill the document with the specified history state.
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You can also paint with an earlier version of your 
image using the History Brush, which can be found 
in the Tool Bar on the left side of the interface. The 
History Brush is going to paint with whichever version of your picture that has the 
History Brush icon next to it. This is nice because you have many of the settings 
that you’d have with the Brush Tool (opacity, blending modes, etc.). Note that the 
History Brush is covered in more detail in the lesson that covers advanced history 
and undo techniques.  

The History Brush can 
be found in the Tool Bar.

The History Brush is being used to paint in the specified history state.


