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Layer Style Essentials 

In this lesson, we’re going to explore the basics of lay-
er styles. The Layer Styles menu can be found at the 
bottom of the Layers panel and is represented by an 
FX icon. If you click on the top-most option, Blend-
ing Options, the Layer Style dialog will appear, but no 
styles will be applied yet. You will see the list of layer 
styles again on the left side of this dialog and you can 
move between them here. Note that in Photoshop, you 
will see the terms “Layer Styles” and “Layer Effects.” 
The Layer Effects are how we refer to the individual 
effects (Stroke, Inner Glow, etc.). The Layer Styles are 
how we refer to the collective sum of the effects ap-
plied to a layer. In general, however, the two terms can 
be used interchangeably. 

The layer styles menu, at the 
bottom of the Layers panel.

The Layer Style dialog contains a list of all the effects on the left side. You can apply as many 
as you want while remaining inside this dialog.
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When covering this topic, we’re really going to be focusing on three things, as 
these three things are often times used together:

Layer Styles     •     The Shape Tool     •     Defining Patterns

The Stroke effect

The first effect that we’ll talk about is the Stroke effect. In the video example, we’ll 
apply this effect to a text layer. We’ll make sure the layer is active, we’ll click on the 
FX icon at the bottom of the Layers panel and we’ll choose Stroke from the pop-
up menu. This will open the Layer Style dialog and it will automatically activate the 
Stroke effect and show us the settings relating to it. 

A Stroke is basically going to take the layer you’re currently working on and draw a 
line around all of the layer’s solid pixels. As you work with the Stroke settings, you’ll 
see a preview of what the effect looks like in the main image window behind the 
Layer Style dialog. (You might need to reposition the Layer Style dialog in order to 
see the layer you’re affecting beneath it.) 

The Size slider will determine how large, or thick, the stroke is. The Position menu 
will determine how the stroke is placed on the layer. The Inside option will cause 
the stroke to encroach into the shape of the layer, applying it on the inside edge 
of the layer’s solid pixels. The Outside option will make the layer appear larger be-
cause it will add the stroke to the outside of the layer’s solid pixels. The Center op-
tion will cause the stroke to be centered right on the edge of the layer so it partially 
overlaps the layer’s pixels and partially extends outside of them. 

The Position menu determines where the stroke will sit on the 
edge of the layer: the Inside, Outside or Center. Examples above, 
from left: No stroke, Inside stroke, Outside stroke, Center stroke. 
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The Stroke effect also has a Blending Mode menu and this will determine how the 
stroke will interact with the rest of the layer, but you’ll find that the blending mode 
option will be more useful with some of the other layer effects we have available. I 
never personally change the blending mode of a layer’s stroke. 

The Opacity slider will allow you to make the stroke partially transparent and the 
Overprint setting will make it so that you can still see the layer beneath the stroke 
line when the stroke opacity is lowered. 

The Color setting determines what color the stroke is. Click on the color swatch 
and the Color Picker will appear. Here, you can choose the desired color and click 
OK. The Fill Type menu is automatically set to the Color option, and this will simply 
create a solid color stroke based on the color you chose from the Color Picker. You 
can also set this menu to Gradient or Pattern so that the stroke line contains some-
thing other than a solid color. When you choose one of these options, the settings 
relating to it will appear below. Know that we will cover the settings for applying 
patterns and gradients later on in this lesson. 

For the Stroke layer effect, the most important three settings are the Size, Position 
and Color. These are the three you will likely be working with the most. 

To choose 
the color of 
the stroke, 
click on the 
Color swatch 
to access the 
Color Picker. 
Here, we are 
using the Col-
or Picker to 
create a black 
stroke. 
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Layer Styles & the Layers panel

Once you’ve added a layer style to a 
layer, you will see the FX icon appear 
to the right of the layer name in the 
Layers panel. All of the added effects 
will also be listed below the layer in the 
Layers panel. If you would like to hide 
this list, click on the little disclosure tri-
angle to the right of the FX icon. This 
will collapse the list of layer styles. Click 
the FX icon again to expand the list. 

You can also go back and change the settings to any layer effect you have applied. 
To access the settings for an effect, double-click on the name of the effect in the 
Layers panel. This will open the Layer Style dialog with the settings for the chosen 
effect visible. You can then further adjust the settings and click OK. Alternatively, 
you can click on the FX icon at the bottom of the Layers panel again and re-choose 
the effect you want to continue to adjust. 

You can add as many layer effects as you’d like while you are inside the Layer Style 
dialog. Simply click between the different effects on the left side of the dialog and 
change the settings for each effect. If you have already exited the Layer Style di-
alog and you’d like to add another effect, there are a few ways to do this. You can 
click on the FX icon at the bottom of the Layers panel and choose the effect you’d 
like to add. The same Layer Style dialog box will appear. You could also access the 
Layer Style dialog by double-clicking on the layer thumbnail. 

Within the Layer Style dialog, you can add additional effects by turning on the 
check boxes to the left of each effect’s name. Note that turning the check box on 
will add the effect to the layer, but it will not show you the settings for the effect 
on the right side of the dialog. If you want to see, and work with, the settings for 
the effect, you need to click on the name of the effect itself so that it becomes 
highlighted. The highlighted effect is the one whose settings appear on the right. 

After adding a layer style (or styles), it will 
appear indented below the layer in the Layers 
panel. Use the eyeball icons to the left of each 
effect name to toggle the visibility of the  
effects, or layer styles.
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Drop Shadow

Another one of the layer effects you can apply is a Drop Shadow. Click on the Drop 
Shadow option within the Layer Effects menu and the Drop Shadow settings will 
appear. Within these options, the Angle and Distance settings will determine the 
position of the drop shadow, but know that there is a much easier way to control 
this. With the Drop Shadow settings visible in the Layer Style dialog, move your 
mouse into your image window and click and drag to position the drop shadow. 
As you do this, the Angle and Distance settings will update to reflect the change. 
The Size slider is also an important setting because it determines how soft the 
edge of the drop shadow will be. If this slider is set to 0, you will have a perfectly 
crisp-edged drop shadow. As you drag the slider to the right, the edge of the drop 
shadow becomes softer and softer. 

To add a layer effect, turn on the check 
box to the left of the effect name in the 
Layer Style dialog. If you want to work 
with the settings for the effect, you 
will need to click on the name so that 
it becomes highlighted. The highlight-
ed effect is the one whose settings are 
visible on the right.

Here, we have the Drop Shadow settings visible within the Layer Style dialog and we are 
clicking and dragging within our image window to position the shadow. This is changing the 
Angle and Distance settings. 
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The Opacity setting will determine how dark the drop shadow is. If this slider is 
moved all the way to the left, the drop shadow will be invisible. As you move it to 
the right, the shadow becomes darker and darker. 

The Spread slider will make the drop shadow thicker, or denser, by expanding the 
solid portion of the shadow. This can be useful when working with a layer that has 
thin areas, such as fine text. When the Spread slider is at a low setting, the drop 
shadow may be hard to see on a layer like this. Moving the Spread slider up will 
make the shadow thicker and therefore easier to see. We don’t usually bring the 
Spread slider up TOO far, however, because it can get more difficult to control 
the size. 

At the top of the Drop Shadow settings are the Blend Mode menu and the color 
option. These two settings work together in a way. The Color setting determines 
the color of the shadow and the Blend Mode menu determines how the shadow 
will interact with the layers beneath it. Usually, we will leave these options at their 
default settings when adding drop shadows. The color of the shadow is set to black 
and the Blend Mode is set to Multiply, which acts like ink. If we were to change the 
color setting to white, however, the drop shadow will seem to disappear, and that’s 
because a printer would not use white ink. To create white, a printer would use an 
absence of ink, so the Multiply blending mode will cause anything white to disap-
pear. If we wanted a white “shadow,” we’d need to change the blending mode to 

When creating a drop shadow layer style, the Spread slider will determine how thick the 
shadow will be. On the left, the Spread setting is at 0. On the right, we bumped it up to 21, 
making the shadow easier to see.
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either Normal or to one of the modes that is designed to brighten (Screen, Lighten, 
etc.). Note there is a separate Masters Academy lesson on what each of the Blend-
ing Modes do. 

Copying layer styles from one layer to another 

After you have created a layer style for one of your layers, you might decide that 
you want the same treatment on one or more of your other layers. There are a 
couple of ways to achieve this and the easiest is the drag-and-drop method. If you 
would like to copy all of the effects that were applied to one layer and paste them 
onto another layer, hold down the Option key (Alt on Win), click on the word “Ef-
fects” under the layer thumbnail and then drag them to the layer where you would 
like them applied. It’s important to hold down the Option key (Alt on Win) here. If 
you were just to click and drag, you would be moving the styles from one layer to 
another. They would be removed from their original layer and then placed on the 
target layer. In the video example, we added a stroke and a drop shadow to a layer 
containing a photograph. We wanted the same styles applied to another photo 
layer so we held down the Option key and then dragged the word Effects from one 
layer to the other. 

You can also use menus to copy styles 
from one layer to another. Make sure 
that the layer with the styles you 
want to copy is active. Then go to 
the Layer menu and choose Layer 
Style > Copy Layer Style. Next, select 
the layer or layers that you would like 
the same styles applied to. Go back 
to the Layer menu and choose Layer 
Style > Paste Layer Style. 

Another way of accessing this menu 
option is by right-clicking on the 
name of the layer in the Layers panel 

We are copying 
all of the layer 
styles attached 
to a layer by 
right-clicking on 
the layer in the 
Layers panel and 
choosing Copy 
Layer Styles 
from the pop-up 
menu.
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and choosing Copy Layer Style from the pop-up menu. Then, select all of the layers 
that you would like the styles applied to, right-click again on one of the layer names 
and choose Paste Layer Style from the pop-up menu. 

Layer Styles, Layer Masks & Clipping Masks

Layer Masks If you apply layer styles to a layer that has a mask applied to it, the 
effects will apply to the visible areas of the image. In other words, it will apply the 
layer mask first and then apply the effects to only the areas that the mask has left 
visible. These would be the white parts of the layer mask. 

Clipping Masks You can “clip” one layer so 
that it only appears within the shape of the 
layer that’s directly beneath it. For exam-
ple, if we place an image layer above a text 
layer, we can clip that image layer to the 
text layer so that it looks like the image is 
appearing inside the text. To clip a layer to 
the layer beneath it, make sure the layer is 
active, go to the Layer menu and choose 
Create Clipping Mask. The clipped layer will 
become indented in the Layers panel and it will have a down-pointing arrow to the 
left of its thumbnail, indicating that it is clipped to the layer beneath it. If there are 
any layer styles applied to the underlying layer, it will first combine the two layers 
together and then apply the layer styles. In other words, the layer styles will be ap-
plied to the result of the two layers merging together. 

The ability to combine layer masks and clipping masks with layer styles enables us 
to have a lot more versatility when creating templates. You could use the Shape 
Tool to create boxes or shapes in which you can later place pictures. These shapes 
can be styled before hand using layer styles. When you’re ready to add images, 
place the image on top of the box it should appear inside of and then create a clip-
ping mask.  

When a layer is clipped to the layer be-
neath it, a down-pointing arrow will 
appear next to its thumbnail and it will 
become indented in the Layers panel.
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Inner Shadow

The only difference between an Inner Shadow and a Drop Shadow is where the 
shadow appears. The drop shadow appears on the outside edge of the layer and 
the inner shadow appears on the inside edge of the layer. This layer style will make 
it look as if the layer is somewhat indented. When applying it to a photo layer on a 
white background, it will make it look like there is a hole in the white paper and the 
photo is placed behind it. The white paper will look like it’s casting a shadow on the 
photo, as if it were matted in a frame. 

Again, when we choose the Inner Shadow layer effect, all of the settings relating 
to it will appear inside of the Layer Style dialog box. Just like with the drop shad-
ow style, we can click and drag within the image window in order to position the 
shadow. When we do this, the Angle and Distance settings will update to reflect 

Left: A template was created using a series of shape layers. Right: The template was quickly 
populated by clipping image layers to the pre-made shape layers.
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the changes. These two settings collectively determine the position of the inner 
shadow. The Size slider will determine how soft the edge of the shadow is and the 
Opacity slider will determine how dark the shadow is. 

Here, we’re working with the settings for the Inner Shadow layer style. With the settings visi-
ble, we are clicking and dragging within the image window to position the shadow. By doing 
this, we are changing the Angle and Distance settings. 
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Global Light

There is one setting within the Layer Style dialog that will change the settings of 
all the relevant layer effects used in your document. This is the Global Light check 
box, working in conjunction with the Angle setting. When you change the Angle 
setting in one of your layer styles, it will automatically change the Angle setting of 
all the layer effects in your document (all of the effects that have an Angle setting, 
that is). This is because the Global Light check box is turned on by default. The 
Global Light setting is going to make it look as if the light is coming from the same 
direction in all layers in your document. When the light appears to be coming from 
the same direction across all layers, the shadows will look more natural and real-
istic. If, however, you would like for the Angle setting to differ in one of the layers, 
turn off the Global Light check box and then adjust the Angle setting. 

The Angle setting is used in many of the available layer effects, including Drop 
Shadows, Inner Shadows and Bevel & Emboss. 

When the Global Light setting (circled) is turned on, the Angle setting will be the same 
across all layer styles. Here, you can see that the drop shadows for all of the layers have the 
same angle applied to them.
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Using the Shape Tool and layer styles together

You can create a lot of interesting effects by using only the Shape Tool and Layer 
Styles. When we apply layer styles to a shape that was created using the Shape 
Tool, it will be special in that we will be able to scale the shape up and down 
without losing any quality. That’s because shapes (created with vectors) and layer 
styles are infinitely scalable. 

Let’s walk through the process of creating an in-
teresting effect using the Shape Tool and Lay-
er Styles. First, we’ll activate the Shape Tool and 
make sure that the menu on the left side of the 
Options Bar (above the main image window) 
is set to Shape. It will not be scalable later if we 
were to choose the Pixels option here. We’ll set 
the Shape Tool to create an Ellipse and we’ll click 
and drag out a circular shape in our document. 
We now want to fill this shape and we’ll do that 
using effects. Using layer effects, we could fill the 
shape with a Color Overlay (a solid color), a Gra-
dient Overlay or a Pattern Overlay. We’ll make 
sure that the shape layer is active, we’ll click on 
the FX icon at the bottom of the Layers panel 
and we will choose Gradient Overlay from the 
pop-up menu. The Layer Style dialog will appear 
and the Gradient Overlay settings will be visible. The first thing we’ll need to deter-
mine is what colors should be on the gradient. We’ll click on the Gradient menu to 
get a series of presets. We’ll choose the black to white gradient here. We’ll adjust 
the angle so that the light looks as if it’s coming from the upper left. This will place 
the white end of the gradient in the upper left and the black end of the gradient in 
the lower right. The Scale slider will allow us to scale the gradient up or down with-
in the shape and the Opacity slider will allow us to make the gradient somewhat 
transparent so that we can see through it to the original color underneath. 

In order for a shape layer to be 
scalable (without losing quality), 
the menu in the Options Bar must 
be set to Shape.

We’re clicking and holding the 
mouse button on the Shape Tool in 
order to choose the Ellipse Tool.
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Now we want to make it look as if our shape has a three-dimensional quality to it. 
We can achieve this with the Bevel & Emboss layer effect so we will click on the 
name “Bevel & Emboss” on the left side of the Layer Style dialog. This will automat-
ically apply a bit of a beveled look to the shape, but we need to work with the set-
tings in order to get the kind of 3D quality that we want. The Size slider determine 
how far the bevel extends into the middle of the shape. Bringing this slider up really 
high will make it look like the curve is smooth all the way into the middle of the 
shape. Because our shape is a circle, moving the Size slider up really high will make 

Above: With the shape layer active, we’re clicking 
on the FX icon at the bottom of the Layers panel 

and choosing Gradient Overlay from the list of 
layer styles. Right: We clicked on the Gradient 
menu to get a list of gradient presets and are 

choosing the black-to-white gradient.
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the circle look more like an orb. We don’t want a look that’s quite so rounded, so we 
will move the slider up until just the edges of the shape are rounded. This will make 
it look more like the head of a metal bolt.  The Depth slider will control the differ-
ence between the highlights and the shadows, giving the shape more contrast. 

The settings on the bottom half of the dialog give us separate control over the 
highlights and the shadows. If we want the highlights to be brighter, we’ll use a 
higher Opacity setting for the highlights. If we want the shadows to be darker, we’ll 
use a higher opacity setting for the shadows. We’ll fine-tune these settings and 
then click OK.

Now we’re going to create another shape. We’ll click and hold on the Shape Tool in 
order to access the drop-down menu and choose the Polygon Tool. (We’re trying 
to create a metal bolt, and the Polygon Tool will create the shape of the hole that 
an alan wrench would fit into.) With the Polygon Tool active, you can specify how 
many sides the shape should have within the Option Bar. We’ll set the number of 
sides to five. We will click and drag in our document to create a shape that will 
become the hole in our bolt. After creating the shape, we’ll need to make sure that 
it’s perfectly centered on the circle shape we created previously. To align two lay-
ers, make sure they are both selected in the Layers panel and that the Move Tool is 

Here, the Bevel 
& Emboss layer 
style is being ap-
plied to the shape 
layer and the Size 
slider is being 
moved to deter-
mine how far the 
bevel extends 
into the middle of 
the shape.
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active. This will cause the alignment icons 
to appear in the Options Bar above the 
image window. We will click on the icon 
to align the layers vertically and then we’ll 
click on the icon to align the layers hori-
zontally. We can now click back on the lay-
er with the polygon shape so that it’s the 
only one that is active. We want to make it 
look as if this shape is indented (like the hole of a bolt) so we will choose the Inner 
Shadow layer effect, which will create the shadow on the inside edge of the layer. 
Looking at how the sliders are affecting the shape, we will fine-tune the Distance 
slider to make the “hole” appear as deep as it should be and we’ll adjust the Size 
slider to make sure there is a little softness to the edge of the shadow. 

In order to make the hole look indented, we’ll click on the Bevel & Emboss effect 
on the left side of the Layer Style dialog. By default, it will make the shape look like 
it is rising up, and that’s the opposite of what we want. We’ll change the Direction 
setting from Up to Down, and this will make the shape look like it is indented. The 
Size slider will determine how recessed the shape should look, and we’ll keep this 
at a low setting. 

We selected two layers and are using the 
alignment icons to align the two objects 
vertically and horizontally.

An Inner Bevel layer style is being added to the polygon shape, making it look indented.
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The “hole” of the bolt is recessed and it should therefore be darker, having more 
shadows cast into the hole. We’ll use the gradient effect to achieve this, clicking on 
the Gradient Overlay effect on the left side of the dialog to access the settings that 
go along with it. The “white to black” gradient will work, and we can use the Style 
menu to determine how the gradient will behave. We’ll choose the Radial style, so 
the gradient extends out in a circle (instead of in a line). By default, this made the 
inside of the shape dark and the outside light. This is the opposite of what we want, 
so we’ll turn on the “Reverse” check box to the right of the gradient setting. The 
Reverse setting will basically flip the colors of the gradient. 

A Gradient Overlay layer style is being applied to the polygon shape. The Style is set to  
Radial so the gradient extends outward in a circular fashion. The Reverse check box was also 
turned on so the gradient extends outward from white to black (instead of black to white).



Layer Style Essentials © Ben Willmore, All rights reserved 18

We have the gradient set from white to black, and these are the colors that are ap-
pearing in the polygon shape. We’d like to see the color that was there before, so 
we’ll change the blending mode of the gradient to Multiply. Changing the blending 
mode will determine how the gradient is interacting with the contents of the layer. 

The two shapes combined are now starting to look more like a bolt, but we can 
make it look even more realistic by adding a pattern overlay. We’ll activate the lay-
er containing the circular shape, click on the FX icon at the bottom of the Layers 
panel and choose Pattern Overlay from the pop-up menu. The pattern settings will 
appear in the Layer Style dialog and the first thing we’ll need to choose is what 
kind of pattern to use. We’ll click on the Pattern box (the one that displays the pat-
tern preview) and a menu will appear that presents us with our available pattern 
presets. Note that the patterns you see in the video example may differ from what’s 
in your version of Photoshop, depending on what patterns you have loaded. We’re 
going to choose the pattern that looks like brushed metal and then we’ll use the 
Scale slider to fine-tune how large the pattern should look. After clicking OK, our 
result looks very much like a realistic bolt. 

Because we used the Shape Tool combined with layer styles, we can now scale this 
graphic down and up as much as we want without losing any quality. 

A Pattern Overlay 
layer style is be-
ing applied to the 
round shape. We 
used the Pattern 
menu (circled) 
to add a brushed 
metal pattern.



Layer Style Essentials © Ben Willmore, All rights reserved 19

Creating a brushed metal pattern

Using filters to create a brushed metal look When creating our own graphics (like 
the one we just created), it can be useful to know how to create a brushed metal 
look. Let’s look at how we can achieve that and then turn the brushed metal look 
into a pattern that we can use within a layer style. With a new, empty document, 
we’ll go to the Filter menu and choose Noise > Add Noise. The Add Noise dialog 
will appear and we will drag the Amount slider up very high, creating a LOT of 
speckled noise. We will also turn on the “Monochromatic” check box so that the 
noise does not contain any color and then we’ll click OK. The entire document will 
now be filled with black and white noise. To make this look like brushed metal, we 
will apply a second filter. We’ll click on the Filter menu and choose Blur > Motion 
Blur. We’ll make sure the Angle slider is set to zero and drag the Distance slider up 
quite far, until the result looks like brushed metal, and then click OK. The problem 
with the result is that the left and right edges are not blurred in the way that we 
want, and that’s because the filter runs out of content to blur on the edges of the 
frame. To fix this problem, we’ll simply use the Crop Tool to crop out the far left and 
right sides of the document. 

Left: The Add Noise filter is being applied, using a high Amount setting, to create a speckled 
look. Right: The Motion Blur filter is being applied to the noise.
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How to make sure a future pattern will be seamless Now, we want to take this 
brushed metal document and turn it into a seamless pattern that we can use later. 
Before creating the pattern, we need to see if the left and right edges are going 
to look seamless when placed against each other in a tiled fashion. That is how a 
pattern works, after all. To check how things line up, we’ll go to the Filter menu and 
choose Other > Offset. All this filter does is move the image. We’ll use the Horizon-
tal slider to push the contents of the document over to the right, about half-way 
across the canvas. We’ll set the “Undefined Areas” option to “Wrap Around,” which 
will take the contents of the image that got pushed off the right side of the canvas 
and it will place it on the left side, so that it’s acting like a conveyor belt. We’ll click 
OK and then look to see if we can find a seam. In this instance, there is a seam. It’s 
subtle, but we can see it. To fix this, we’ll use a retouching tool (the Clone Stamp 
Tool, in this example) and retouch out the seam. Now, there should be no seam and 
we can turn this image into a pattern. (Note that because this is brushed metal, 
there will be no vertical seam. If we were creating another type of pattern, we’d 
need to check to make sure that there is no vertical seam as well.)

Defining the pattern We will now define the pattern from the brushed metal doc-
ument we created. We’ll go to the Edit menu and choose Define Pattern. A dialog 
will appear, asking us to name the pattern and then click OK. Now, this pattern can 
be used in a layer style or it can simply be used to fill a layer or a selection. 

Left: The Offset filter is being used to check 
if the pattern will be seamless. The Horizon-
tal Offset slider is moved to the right and the 
Wrap Around setting is used. 

Above: We clicked on the Edit menu and 
chose Define Pattern and are now giving the 
pattern a name so it can be saved for later use.
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Here, you can see that several layer styles were used to create the effect on the right. The 
style was used by using a combination of the Bevel & Emboss, Gradient Overlay, Pattern 
Overlay and Drop Shadow layer effects.

This circular brushed metal look was created in a similar way to the horizontal brushed metal 
we created earlier. The difference was that we used the Radial Blur instead of the Motion Blur.

Here, you can see that a wide variety of effects were used to 
create this style.
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Layer Style Presets

Once you have created a lay-
er style that you like, you can 
save it as a preset so that it’s 
easy to reproduce later. To 
save a layer style, first make 
sure that the layer containing 
the style is active. Then you 
will need to open the Styles 
panel. If it is not already open 
in your Photoshop interface, 
go to the Window menu and 
choose Styles. At the bottom 
of the Styles panel, click on 
the “New” icon. A dialog box 
will appear where you can 
type in a name for the style. 
You will also need to turn on 
the “Include Layer Effects” 
check box before clicking OK. 
The new style will then appear 
at the bottom of the Styles list. 
To apply the style to a layer in 
the future, simply activate the 
layer that you want to have 
the style and then click on the 
style icon within the Styles 
panel. 

We clicked on the New icon (circled) at the bottom of 
the Styles panel to save the current style as a preset.


