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Advanced History Techniques 

In this lesson, we’re going to look at intermediate and advanced uses for the His-
tory panel. Note that there is another Masters Academy video on Undos & History 
panel basics. If you have not already visited that lesson, you might want to do so 
before moving on to this one, as it provides much of the foundational knowledge 
you’ll need to work with the Undo command, multiple Undos and the History panel. 

Quick Basics Recap

The History panel  If the History panel is not already visible in your interface, you 
can access it by going to the Window menu and choosing History. The History 
panel will list everything that you have done to your picture since you opened it in 
Photoshop. The first step in the list will be “Open.” At the top of the panel is where 
you will find any snapshots. By default, there will be one snapshot that is automat-
ically created every time you open a document and it will have the same name as 
the document. If you do NOT see this snapshot, it means that some settings were 
changed within the History Options 
dialog. Click on the little menu in 
the upper right corner of the Histo-
ry panel and choose “History Op-
tions” to access this dialog. Here, 
you will see that the top check box 
reads “Automatically Create First 
Snapshot.” Make sure that this is 
turned on so that the initial snap-
shot will automatically be created. 

Undo & Step Backward  To undo the last step you did, use the keyboard shortcut 
Command+Z (Ctrl+Z on Win). In Photoshop, you can also go to the Edit menu and 
choose Undo. If the very last thing you did was undo something, then this menu 
will show “Redo” instead. This is because Photoshop will only allow you to undo 
one step.

The History Options dialog is shown above. When 
the top check box is turned on, Photoshop will 
automatically create a snapshot that contains the 
original version of the document.  
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To go back multiple steps, either click on the step you want to go back to (within 
the History panel) or use the keyboard shortcut to step backward:

Step backward: Option+Command+Z (Alt+Ctrl+Z on Win)

If you’d like to go the other direction in the History panel, and redo the steps 
you’ve undone, you can use the step forward shortcut:

Step forward: Shift+Command+Z (Shift+Ctrl+Z on Win)

Paint & Fill with History  You can also paint 
or fill an area with a previous version of your 
image. To fill the document or a selected 
area with history, go to the Edit menu and 
choose Fill. In the Fill dialog, use the Con-
tents menu to choose History, make sure 
the Mode is set to Normal and the Opaci-
ty is set to 100, and then click OK. By de-
fault, this is going to fill the document or 
selected area with what your image looked 
like at the time you opened it. You can also 
choose to change which history state is 
being used. Looking at the History panel, 
you’ll see a little brush icon to the left of the 
top snapshot. This means that when you fill 
or paint with History, this snapshot (which 
is the original image) will be used to fill the 
area. If you’d like to change this, click on the 
little square to the left of a snapshot name 
or a history state and this will place that lit-
tle brush icon there, designating that as the 
state in history that should be used when 
you paint or fill with history. 

To Fill with the contents of a snapshot or 
specified history state, choose the Histo-
ry option within the Fill dialog (Accessed 
via the Edit menu).

The snapshot or history state with the 
History Brush icon next to it is the one 
that will be used when you fill or paint 
with history. 
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You can also use a brush to paint in a previous state of your image. First, make 
sure that the brush icon is pointing at the state in history you’d like to paint with 
in the History panel. Then, activate the History Brush (located in the Tool Bar on 
the left side of the interface) and use it to paint on the image. This is nice because 
you have many of the same brush settings that you’d have with the regular Brush 
Tool (size, opacity, blending mode, etc.) and they can be found in the Options Bar 
above the main image window.

Clear History You can clear out the History panel by clicking on the little menu 
in the top right corner of the panel and then choosing Clear History. This will not 
undo any of the steps. It will just remove them from the panel and you will no lon-
ger be able to undo them. Note that when you clear the history, it will still keep the 
one step that the History Brush icon was pointing to. 

Using the History tools to work smarter and correct mistakes

The History panel can be used for much more than simply undoing things you did 
in Photoshop. It can be used to isolate a mistake you made several steps ago and 
then make it as though it never happened (while keeping the changes you DID 
want intact). Let’s say you did something to a layer many steps ago and now de-
cide that you didn’t want that change. In our example image, we accidentally paint-
ed with black on the layer with the green swirl. The problem is that we did many 
things afterwards that we DO like. If we simply used the step backward command 
enough times to remove the error, we would also erase all those changes that we 
did want. Here’s how we can use the History features to fix that one isolated step. 
We’ll activate the layer that contains the problem (In our case, it’s the layer with 
the green swirl.) and make sure that the History Brush icon is to the left of the top 
snapshot in the History panel. This will ensure that we’re filling the area with what 
the document looked like at the time that it was opened. Then, we’ll go to the Edit 
menu and choose Fill. We’ll set the Contents menu to History and make sure that 
the Mode is set to Normal and the Opacity is 100%. We’ll click OK. Because this is a 
multi-layered document, Photoshop knows what was in the active layer at the time 
the document was opened, so it will use that information to fill the layer. 
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If you need to fill the layer with a history state other than the version of the doc-
ument at the time that it was opened, find that step in which things look the way 
you want and click the little square to the left of the step’s name in the History 
panel in order to position the History Brush icon there. (After the brush has been 
placed, be sure to click back on the last step in the History panel to make it ac-
tive again.) Then, follow the same step. Go to the Edit menu, choose Fill and then 
choose to Fill with History. Alternatively, you could use the History Brush to paint 

Here, we accidentally added black paint to the layer with the green swirl. To fix that (without 
affecting all the steps taken after it), we are filling with history, using the snapshot that was 
created when the document was opened. You can see that the History Brush icon is posi-
tioned to the left of that snapshot, which is telling Photoshop what to use when we fill with 
history. 
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in that selected history state in only the areas you want. If you only wanted to 
reduce an effect, you could use the History Brush and paint with a lower opacity 
so that you’re not completely hiding the content that’s currently there. You’re just 
lessening its effect. The Opacity setting can be found in the Options Bar above 
the main image window (The brush needs to be active in order to for the Opacity 
setting to be available.) 

The History Brush is being used to paint in a previous state in history (designated by the His-
tory Brush icon placement in the History panel). 
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Different types of snapshots As we mentioned in the basics video, you can create 
a snapshot by clicking on the camera icon at the bottom of the History panel. This 
method will use default settings. If you hold down the Option key (Alt on Win) 
while clicking on the camera icon, the New Snapshot dialog will appear. Here, you 
can specify a name for the snapshot and use the “From” menu to determine what 
type of snapshot you’d like to create. The choices are Full Document, Merged Lay-
ers or the Current Layer. 

The default option is Full Document and this will remember everything in the doc-
ument at the time you create the snapshot. When you use this snapshot to paint 
with history, it will look at the layer you are working on and paint in the contents 
of that layer at the time the snapshot was created. Note that if you try to use this 
snapshot to paint on a layer that did not exist at the time you created the snap-
shot, you will likely get an error. Also, its not based on the name of the layer or the 
stacking order of the layer. You can change either of these things and the History 
Brush will still know which layer it should use. 

The Merged Layers option will take all of the layers and combine them all together 
so it’s seen as one piece. If you use this snapshot to fill or paint with history, it will 
use the contents of the entire merged document (and not just the contents of the 
active layer) to fill the layer. You can use this type of snapshot to paint with the 
History Brush on a new layer.

Hold down the Option Key (Alt 
on Win) while clicking the New 
Snapshot icon and you will get 
the New Snapshot dialog, where 
you can use the From menu to 
choose between three different 
types of snapshots.



Advanced History Techniques © Ben Willmore, All rights reserved 8

The Current Layer option will 
create the snapshot contain-
ing only the information in the 
active layer (the layer active at 
the time you create the snap-
shot). If you use this snap-
shot to paint with history, it 
will only paint in the contents 
of that single layer (the layer 
used to create the snapshot). 

Here, we created a snapshot using the Merged Layers option and we are using the History 
Brush to paint with that snapshot. It’s easier to see in the layer thumbnail (circled) that we 
are painting the contents of the entire merged document.

With the green lay-
er active, we creat-
ed a Current Layer 
snapshot. Now, we 
have the red lay-
er active and are 
painting with histo-
ry, using that Cur-
rent Layer snapshot. 
You can see that it’s 
painting the green 
layer into the active 
layer.
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Restoring parts of the original document 

Let’s say that you completely changed your image and there is no layer contain-
ing the content you want to restore. In the video example image, it is the original 
colored background in the document. Click back through the steps in the History 
panel until you find the step where the content was still there. With that step ac-
tive, select the layer that contains the content you want and turn off the visibility 
of all the other layers. Then, hold down the Option key (Alt on Win) and click on 
the snapshot icon (the camera) at the bottom of the History panel. The New Snap-
shot dialog will appear and you’ll want to choose the Current Layer option from 
the “From” menu. It’s also a good idea to give the snapshot a name that indicates 
what it is. Click OK. 

We wanted to bring back the look of our bottom layer from an earlier stage in the editing 
process. We stepped backward in the History panel until the layer contained the content we 
wanted, we made sure that bottom layer was active and then we turned off the visibility of all 
the other layers. Now, we are creating a new snapshot, using the Current Layer setting. 
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Now, you can click back on the last step in the History panel to get all of your other 
work back. Activate the layer where you want that saved content to appear (in the 
video example, we created a new, empty layer.). Then, click the little square to the 
left of the icon for the new snapshot you just created in order to place the History 
Brush icon there. Finally, go to the Edit menu, choose Fill, select the History op-
tion within the Fill dialog and then click OK. This will fill the active layer with the 
contents of the snapshot. 

When the History tools can fail 

Let’s look at an instance where 
the History tools can mess up a 
bit. This can happen when you 
apply some retouching to the 
image and then change the di-
mensions or the mode (RGB, 
CMYK, etc.) of the document. If 
you try to use the History Brush 
after cropping the image or 
changing the mode, you will get an error message. To get around this, you’ll either 
need to change the document back to its original dimensions or you will have to 
get tricky. 

In the video example image, we have a photo of a sculpture in the sand and we 
used some retouching tools to remove some tourists. Then, we used the Crop Tool 
to crop out the bottom half of the image so that we could focus in on the subject. 
If we were to try and use the History Brush after cropping, the error message will 
appear. Here’s how we can get around this. We’ll click back through the History 
panel until we find the step where the image was at its original size. Then, we’ll 
go to the Image menu, choose Image Size and then note the dimensions. We’ll 

This is the error message you’ll get if you try to use the 
History brush after cropping/resizing your document.
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copy down the numbers for both the width and height dimensions and then click 
Cancel. Now we’ll click back to the last step in the History panel so that the image 
goes back to its current state. We’ll go back to the image menu and choose Can-
vas Size. Within the Canvas Size dialog, we’ll enter in the dimensions of the original 
image (that we copied down). We’ll also set the anchor point to the top so that 
the extra canvas size is added at the bottom (this is the half that we had cropped 
out) and we’ll click OK. The canvas will expand back to its original size and we can 
now use the History Brush to paint in a previous state of our image. 

If the History tools are not working because we changed the mode of the image, 
we’d simply change the mode back to what it originally was. 

Here, we clicked back through the history steps until we reached the step prior to cropping. 
Then we went to the Image menu and chose Image Size to call up this dialog. We are simply 
taking note of the width and height dimensions so that we can change the document back to 
its original size later. 
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Creative uses for the History tools

Now that we’ve talked about how the History 
tools can be used to correct things, let’s look at 
some more creative uses. If you click and hold 
your mouse button down on the History Brush 
Tool in the Tool Bar, you will get a little pop-up 
menu that also gives you access to the Art His-
tory Brush Tool. With this tool active, different 
settings will appear in the Options Bar (above 
the main image window) that will allow us to create more unique effects in our 
images. One of those settings is a Style menu and this gives us different options 
for what kind of effect will be created when we paint. In the video example image, 
we’ll set this menu to Dab. When we paint, it’s going to look at whichever snapshot 
or history state that the History Brush icon is set to and it’s going to use that to 
determine which color to paint with. The Dab setting is going to create a style that 
looks like we’re dabbing the canvas with a paint brush. If we were to choose one of 
the Curl settings, it will create more of a spiral brush effect and we can determine 
how large the effect will expand from the brush tip by using the Area setting in 
the Options Bar. You can also click on the Brush Settings icon to access all of the 
settings that will allow you to come up with a much more creative brush effect. 

The Art History Brush is hidden  
behind the History Brush in the  
Tool Bar.

The Art History Brush is active, we set the style to Dab (left) and are using the brush to paint 
in a specified history state. In this case, it’s the original image. 
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Keeping snapshots after closing a document

When you close a document, the History panel will be cleared and you will lose any 
snapshots that you have saved there. To get around this, you can save out your 
snapshots as separate documents and then use these to reconstruct the contents 
of the panel after you re-open the document. Let’s look at how to do that. 

First, click on the snapshot that contains the state of your image you want to be 
used when you reopen the it and save the document in this state. Then, click on 
the next snapshot to make it active and click on the little plus icon at the bottom 
of the History panel to create a new document out of this snapshot. (Alternatively, 
you can go to the File menu and choose Save As.) You’ll be prompted to name 
the new document and determine where it should be saved on your hard drive. Do 
this with any additional snapshots in the document (that you want to save) and 
then close the document. As we mentioned before, closing the document will dis-
card any snapshots that were saved in the History panel. Re-open the document 
and you will see that the History panel is empty (except for the snapshot that is 
automatically created when you open the document). Now, open up the other file 
that was created from the snapshot that you saved from the original document. 

Position this document so 
that it is in a floating window 
where you can see both doc-
uments at once and make 
sure that the History pan-
el is open. Click and drag on 
the thumbnail for the single 
snapshot, drag it into the im-
age window for the original 
document and then release 
the mouse button. This will 
add the new document as a 
snapshot within the original 
document. 

We are dragging the snapshot icon from one document 
into the image window for the original document. This 
will place the snapshot that we’re dragging as a new 
snapshot within the original document.
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The History Log

Photoshop gives us a way to save out our History list as a text file. Go to the Pho-
toshop menu (the Edit menu in Windows) and choose Preferences > History Log. 
Turn on the History Log check box and some options will become available. If we 
choose the Metadata option, it means that it will save the history as a text file that 
is attached to the image itself. In order to see that info later, you’d have to open 
the image, go to the File menu and choose File Info. The screen that appears will 
contain the saved history information. If you choose the Text File option, you’ll be 
prompted to name the file and determine where it should be saved on your hard 
drive. The Both option will save the information as a text file as well as within the 
file’s metadata. 

The Edit Log Items menu will allow you to determine how much detail should be 
saved when it comes to the history list. The Sessions Only option will save only 
the name of the file and how long the file was open. This can be useful when you 
need to log hours when billing to a client. The Concise option will save the same 
list that you see within the History panel, but it will not record the settings used 
for each individual step. The Detailed option will record enough info required to 
be able to reproduce each step (or record an action) so it will include the settings 
for each individual step. 

Above are the History Log settings within Photoshop’s Preferences dialog.


