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The Path Blur & Spin Blur Filters

In this lesson, we’re going to explore 
two Photoshop filters that will allow 
us to add motion blur to an image. 

In the past versions of Photoshop, we 
would go to the Filter menu, choose 
Blur and then either select Motion 
Blur or Radial Blur. One problem with 
these filters is that there is no inter-
action between the motion blur dia-
log and the image itself. In more cur-
rent versions of Photoshop, there is 
now a filter category called the Blur 
Gallery, and this is what we’ll use to 
create the motion blur. The Blur Gal-
lery can also be found under the Fil-
ter menu and we will be focusing on 
the Path Blur and the Spin Blur.

The Path Blur allows us to draw a line, 
or path, across the image and it will 
blur the image as if the camera were 
moving across that path. The Spin 
Blur will create a look that resembles something spinning really fast, and we’ll use 
this on the wheels of the car, to make it look as if the car is moving fast. 

Before using these filters, it’s a good idea to convert 
the image layer into a smart object and you can do 
that by going to the Filter menu and choosing Con-
vert for Smart Filters. This will allow us to apply any 
filters in a way that will enable us to go back at a later 
time and make changes to the filter settings or dis-
able the filter entirely.  

This is the kind of motion blur effect that can 
be achieved by using a combination of the Path 
Blur and Spin Blur filters. 

This is the image we’re going to work with in 
this lesson, adding the Path Blur to the back-
ground and the Spin blur to the wheels.

When a layer is converted into 
a smart object, an icon will 
appear in the lower corner of 
the thumbnail. 
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The Path Blur Filter

After we convert the image layer into a smart object, let’s apply the Path Blur filter. 
We’ll go to the Filter menu and choose Blur Gallery > Path Blur. When we choose 
any of the Blur Gallery options, the large Blur Gallery Window will take over the 
interface. All of the Blur Gallery choices will be listed on the right, and the settings 
for the chosen blur type will be expanded. If you’d like to apply more than one 
type of blur, you can turn on the check box for the additional blur type here. Click-
ing the disclosure triangle to the left of each blur name will also activate that blur 
and expand the settings for it. 

After we activate the Path Blur, there will be a blue line on the image with a white 
dot on either end. We can click and drag on the white dots  to determine the di-
rection of the blur. Then, we can use the Speed slider on the right side of the inter-
face to determine how extreme the blur will be. In the example image of the car, 

Above, you can see the Blur Gallery dialog with the settings for the Path Blur active. A blue 
line appears on the image and you can drag the white dots on the line to determine the di-
rection of the blur. 
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you’ll see that the car is blurring as well. That’s ok, because we’re going to isolate 
the car later and make it so the extreme effect is not blurring it. 

Within the Path Blur settings, there is a “Centered Blur” check box and this deter-
mines whether it should blur in both directions or only one. With this setting off, 
the blur will primarily go in one direction. With the check box on, the blur will go in 
both directions. To achieve a simulated motion blur, like we’re trying to do in this 
example, we’ll keep this setting turned off.  The Taper slider will lessen the blur as 
it gets toward the end of the blue line. 

You can have a different speed setting for the beginning, the middle and the end 
of the blue line. When you click on one of the three white dots, a little black dot 
will appear in the middle of the white dot, indicating that it is active. When a dot 
is active, you can use the End Point Speed slider (within the Path Blur settings) to 
determine the speed setting near that point. 

You can delete the blue line entirely, removing the blur, by clicking on one of the 
end dots and then hitting the Delete key. 

If you click on one of the white dots that run along the blue line, a black dot will appear in 
the middle of the white dot. You can then use the End Point Speed slider to determine the 
speed setting for that area on the line.
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To add a Path Blur, click on 
the image once where you 
want the path to start and 
again where you want it to 
end. Photoshop will think 
that you’ll want to continue 
the path, so it will try to con-
tinue the blue line beyond 
the second click. If you don’t 
want this, simply hit the Es-
cape key. Click and drag on 
the center dot in order to add some curvature to the path line. 

There is also an “Edit Blur Shapes” check box and if we turn this on, a red line will 
appear at the end of our blue line. If we click and drag on the dots of this line, it will 
change the shape of the blur to make it look as if we not only panned the camera 
left or right, but also moved the camera up, down, or in rotation. 

Remember that any of these settings can be changed at a later time, so we don’t 
need to commit to them in the beginning editing stages. 

After we’re done creating the blur, we will 
click on the OK button at the top of the Blur 
Gallery interface. Back in the main Photoshop 
interface, a Smart Filter icon will appear be-
low the Smart Object layer in the Layers pan-
el and this represents the Blur Gallery filter 
we just applied. We can click on the eyeball 
icon to toggle the visibility of the filter effect, 
or we can double-click on the filter name in 
order to go back to the filter settings so we 
can make changes to them. 

When creating a new Path Blur line, Photoshop will try to 
extend the line beyond the second point, as you can see 
above. If you don’t want this, hit the Escape key.

After adding a filter to a smart object, 
it will appear below the smart object 
layer in the Layers panel. 
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When working with smart filters, each filter automatically has a mask attached 
to it. If we click on the mask to activate it, we can add black paint to the mask in 
order to hide the filter effect in specific areas. In the video example image, we can 
paint with black over the car in order to hide the blur effect, making the car sharp 
again. While the Brush Tool will hide the effect, it’s hard to be really precise with 
this tool. We will instead create a selection around the car and then fill that selec-
tion with black. It will be easier to make a selection if we can see the image with-
out any blur effect, so we’ll click on the eyeball icon to the left of the Blur Gallery 
name in the Layers panel to turn off the visibility of the filter. 

To make a selection of the car in the example image, we’ll start by creating a gen-
eral selection using the Quick Selection Tool. Next, we’ll tap the Q key to enter 
Quick Mask Mode, which will give us a red overlay on the image in all areas where 
the car is not selected. The car will appear normal in all areas where it IS selected. 
This will better help us to visualize the selection. 

In Quick Mask Mode, everything that is NOT selected has a red overlay and everything that 
IS selected appears normal. 
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Now we’ll zoom in on the im-
age and refine the selection, 
using the red overlay as the 
guide. We’ll use a small, rela-
tively hard-edged brush and 
paint with black in all areas that 
were not selected but should 
be. This will add the red over-
lay to those areas. We’ll also 
paint with black on the shad-
ow under that car because that 
should appear blurred as well. 
If we accidentally add the red 
overlay in an area that should be selected, we can simply switch to a white brush 
and paint in that area to remove the overlay (therefore adding to the selection). 

Tip for using the Brush Tool in Quick Mask Mode: If you click in one place, hold the 
Shift key and then click in another place, it will create a perfectly straight brush 
stroke between the two points. 

After we’re finished refining the selection, we’ll tap the Q key again to exit Quick 
Mask Mode. We’ll also click the eyeball icon to the left of the Blur Gallery filter name 
in the Layers panel to turn on the visibility of the blur. We want to fill the selected 
area (on the layer mask) with black in order to hide the blur effect in that area and 
we can do that by going to the Edit menu, choosing Fill and then selecting to fill 
with black. We can now deselect by going to the Select menu and choosing Dese-
lect or by using the keyboard shortcut Command+D (Ctrl+D on Win). 

Now that the selection is gone, we can see that there is a problem, and that is the 
motion blur that is extending off of the back of the car. This isn’t what you’d get 
if you actually shot motion blur with your camera so it takes away from the effect 
we’re trying to create. We can also see crisp trees through the window of the car, 
and these will need some motion blur as well. 

Here, we are refining the selection while in Quick Mask 
Mode by using the Brush Tool to paint on areas that 
should not be selected.
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To fix the unwanted blur in the back of the car, we’re going to have to modify the 
image layer so it looks as if there was no car there. To do this, we’ll work on a du-
plicate of the image layer.

When you duplicate a smart object, it basically creates another instance of that 
same smart object, where any changes you make to one instance will affect every 
instance of the smart object. We want to be able to make changes to one inde-
pendently of the other, so we will need to duplicate the smart object in a special 
way. We’ll go to the Layer menu and choose Smart Objects > New Smart Object 
via Copy. Now we can make changes to one of the smart objects where those 
changes will NOT affect the other smart object. We’ll work on the top, duplicate 
layer and double-click on the image thumbnail in order to open the smart object 
in a separate Photoshop window. Here, we’ll see the original contents of the layer 
before the blurring filter was applied. 

We need to retouch out the back portion of the car, replacing the area with the 
grass and fence. This will make it so the blur filter will affect this extra grass/fence 
area instead of the back of the car. 

To retouch out the back of the car, 
we’ll use the Clone Stamp Tool so that 
we can have precise control over the 
edges and lines of the fence, grass, 
etc. When using the Clone Stamp 
Tool, we’ll hold down the Option key 
(Alt on Win) and click on the area 
that we want to copy (the area we’ll 
use to fill in the retouch area) and 
then we’ll click and drag to “paint” 
that copied area over the car. When 
we do this, we’ll see a preview of the 
content we’re about to paste within 

the round tool tip. We’ll continue Option+clicking on areas to copy and then paint-
ing over the areas we want to cover up until the back of the car is gone. 

Here, we opened the smart object and we’re 
retouching out the back of the car so it doesn’t 
create an undesirable blur.
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Now, we can simply close this window. Photoshop will ask us if we’d like to save 
the changes and we’ll click Save. Back in the original document, the smart object 
layer will automatically be updated with these changes. We have two layers. The 
top layer has part of the car retouched out and the bottom layer has the car intact. 
We want to put an intact version on the top of the layer stack and then use the 
layer mask to hide the area behind the car that has the undesirable car blur. To do 
this, we’ll duplicate the bottom layer (Command+J; Ctrl+J) and drag this duplicate 
to the top of the layer stack. With this new top layer active, we’ll click the Layer 
Mask icon at the bottom of the Layers panel to add a layer mask to this layer. With 
this mask, we want the opposite of what’s in the smart filter layer masks. We want 
the entire mask to be black except in the area where the car is. This will hide the 
entire layer except the car area. 

To get this, we’ll start by copying the contents of one of the smart filter masks. 
We’ll hold down the Option key (Alt on Win) and click on the smart filter mask’s 
thumbnail in the Layers panel. This will make it so we’re viewing the mask in the 
main image window. Then, we’ll go to the Select menu and choose All and then 
click on the Edit menu and choose Copy. Next, we’ll click back on the layer mask 

We held down the Option key (Alt on Win) and clicking on the smart filter layer mask in 
order to view the mask in the main image window. We are copying this mask so that we can 
paste it into a new layer mask.
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for the top layer. We’ll again hold down the Option key (Alt on Win) and click on 
the mask in order to view the mask in the main image window. We’ll go to the Edit 
menu and choose paste. Option+click on the mask thumbnail again to turn off 
that view. 

Now, we can throw away the smart filter for this top layer because we don’t want 
any blurring to be visible here. As we mentioned before, the layer mask contains 
the opposite of what we want, so with the mask active, we’ll go to the Image menu 
and choose Adjustments > Invert. This will give us the sharp car visible in that layer. 

In the end, we have three layers. The top layer contains only the sharp car. The 
bottom layer contains the version of the image with normal motion blur applied, 
where we can see the duplication of the car coming out of the back. The middle 
layer is the version where we retouched out the back part of the car, hiding the 
undesirable car blur in the back. 

We pasted the contents of the smart filter layer mask into the layer mask for the top car 
layer. Then, we inverted the mask so that only the sharp car was visible on the blurred back-
ground. 
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There are some ways that we could make this process easier in the future, if we 
knew we were going to be isolating a car or object so that it is sharp against a 
blurred background, we could begin by isolating the car with a selection and then 
copying it onto its own layer that would stay at the top of the document. Then, we 
could again duplicate the bottom layer and apply the blur to it, retouching in any 
areas where it’s necessary. 

There are still a few problems with 
this image. Looking in the car 
windows, we can still see some 
trees in the background that are 
not blurred, and they should be. 
We’ll need to paint on a few lay-
er masks in order to achieve this. 
In the layer mask for the top layer, 
we’ll use the Brush Tool and paint 
with black, using a small brush, in 
the area where the window shows 
sharp trees. We won’t see any 
change and that’s because we’ll 
also need to paint on the mask 
for the middle layer’s smart filter. 
We’ll paint on the smart filter lay-
er mask, this time using white to 
reveal the blur effect. 

Another problem with the blur result is that the wheel on the bottom left shows 
motion blur coming out from behind it, and this wouldn’t happen had we panned 
with the camera to get this motion blur effect. I can also see that the selection was 
a little bit off around the edges of the front two tires. 

Looking through the car window, we can see some 
sharp trees that need the motion blur applied.

Here, we’re painting on the smart filter’s layer mask, 
revealing the blur effect in the window.
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To fix the blur on the tire, we’ll work with the middle layer, which is the one that 
has the back part of the car retouched out. We’ll double click on the layer thumb-
nail in order to open the smart object in a separate image window. We’ll then use 
the Clone Stamp Tool to retouch out the back part of the tire so the motion blur 
doesn’t cause it to extend too far back. Now we can close the window, and when 
asked whether we want to save, we’ll click the Save button. This will take us back 
to the original Photoshop document and the smart object will be updated so we 
no longer see the undesirable blur extending off the back of that tire. 

The Spin Blur Filter

Now let’s look at how we can use the Spin Blur filter to make the wheels of the 
car look like they’re spinning. We’ll activate the top layer, which contains the sharp 
version of the car, we’ll click on the Filter menu and choose Blur Gallery > Spin 
Blur. The Blur Gallery window will appear and there will be a circle over the image. 
We need to drag the circle so the center point lines up with the place where we 
want the center of the rotation to be. In this case, it’s the center of the front wheel. 
Then, we’ll resize the circle by dragging the little dots on the edge of the circle so 
that it matches the shape of the wheel. 

When the Spin 
Blur settings 
appear, there will 
be a circle on 
the image. Here, 
we’re positioning 
that circle over 
the area we want 
to have the Spin 
Blur applied.
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Zooming in on the Spin Blur circle, 
you can see that there are four sets 
of circles, an inner, larger dot and 
an outer, smaller dot. The inner dot 
indicates where the blur effect will 
start to fade out and the smaller 
dot (the one on the curve) is where 
the effect will end completely. You 
can click and drag on these dots to 
move them in and out, determining 
where the filter transition will hap-
pen and how quickly it will happen.

It can sometimes be tricky to get 
the four dots of the circle in the 
right position while keeping the 
center point in the desired location. 
If this ever happens, know that you 
can hold down the Option key (Alt 
on Win) and drag the center point 
so that it moves independently of the the outer circle. This will allow us to position 
the point in an off-center location, which is sometimes necessary. 

On the right side of the Blur 
Gallery interface, there is 
a setting that allows us to 
specify the angle of the ac-
tive blur. You can also set 
the blur angle by clicking 

and dragging on the ring 
that surrounds the center 
dot of the blur filter circle. 
This does the same thing as 
moving the Blur Angle slider. 

The white dots inside of the Spin Blur line indicate 
where the effect will start to fade out. The little 
dots on the circle are where the effect will end 
completely.

You can specify the angle 
of the blur by either using 
the Spin Blur slider or by 
dragging the circle outside 
of the center point in the 
Spin Blur circle.
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Hide Guides If you find the Spin Blur circle to be distracting, you can hold down 
the H key on your keyboard. As long as you have the H key held down, all of the 
guides will temporarily be hidden so you can get a cleaner view of the image. 

Before & After View If you’d like to compare what your image looked like before 
the blur to after the blur, you can toggle the Preview check box in the upper bar 
of the Blur Gallery interface. Alternatively, you can tap the P key on your keyboard 
in order to toggle the preview off and on. 

Now we want to create an equal Spin Blur on the back wheel. Instead of drawing 
out a completely new blur circle, we’re going to copy the one from the front wheel 
to use on the back wheel. We’ll hold down the Option and Command keys (Alt and 
Ctrl on Win) and then click and drag the center dot of the original blur circle to 
drag out a second, identical blur circle. We’ll position this second blur circle over 
the back wheel and then reposition the dots so that it fits the wheel properly. 

Other settings  There are some additional settings for the Spin Blur filter under 
the Motion Effects tab on the right side of the Blur Gallery interface. These will try 
to simulate the look you would get if you used a strobe (or strobes) while shoot-
ing with motion blur. You will get a few more little frozen areas in the image and 
you can control how many there are by using the Strobe Flashes slider. There also 
some settings under the Noise tab that will be available when using the Spin blur 
and the Path Blur. These settings can be used to match the noise in the blur area 
to the noise in the chart area. If there is noise in the sharp area and no noise in 
the blur area, the effect won’t look natural. Zoom in on the sharp portion of the 
image to see how much noise there is. Then drag the Amount slider (under the 
Noise tab) up until the noise in the blurred area matches the amount of noise in 
the sharp area. Then, adjust the Size and Roughness sliders as needed to make it 
visually match. 

Now that we have our wheels blurred to the degree that we like, we are almost 
ready to take the image back to the main Photoshop interface. Before doing that, 
however, we’ll turn on the “High Quality” check box, which can be found in the bar 
at the top of the Blur Gallery interface. This will make the processing time take 
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longer, but it will pro-
duce a higher quality 
result. We can now 
click the OK button 
to close the Blur Gal-
lery window and head 
back to the original 
Photoshop document. 

Additional Fixes After applying both blur filters, there are still a few ways in which 
we can improve this car image. We can see that the far left side of the frame doesn’t 
have as much of the blur effect and that’s because the blur goes from left to right, 
and on the left side of the frame, there’s no content to use in which to create the 
blur. If we wanted the blur to truly start on the far left side of the frame, there 
are two things we could do. We could use the Crop Tool to crop a short way into 

the frame so that the non-
blurred edges is not visible. 
If we did not want to crop 
into the frame, however, we 
could use the Crop Tool to 
extend the frame out a bit 
in all directions. We would 
then use our retouching 
tools to add content around 
the edge of the frame. After 
doing this, we could again 
use the Crop Tool to crop 
in again because we would 
have removed the undesir-
able, less-blurred area.   

Turning on the High Quality check box will lend to a longer pro-
cessing time, but will create a better result.

Here, we’re using the Crop Tool to extend the canvas. We 
will then use our retouching tools to add content around 
the edges of the frame.
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We can also adjust the Path Blur filter so that the angle of the blur where the car 
is varies slightly from the angle of the blur at the top or bottom of the image.  To 
do this, we’ll double-click on the Smart Filter “Blur Gallery” name for the center 
layer, which is the one displaying the blur. This will cause the Blur Gallery interface 
to appear, with the current Path Blur settings visible. We need to add an additional 
Path Blur line to tweak the direction of the blur. We’ll click and drag on the image, 
moving from the front tire of the car to the back tire. The angle of the line will be 
different from the initial blur line and it will control what’s happening in how the 
direction of the blur is moving in the image. (Note that if the tool tries to continue 
on after you create the line, simply hit the Escape key to limit the line to where 
you just dragged.) We can add as many Path Blur lines as is necessary to control 
the direction of the blur, clicking the OK button at the top of the interface when 
we’re done. 

Here, we’re adding a second Path Blur line in order to tweak the direction of the blur.
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In the next example image, we want to apply the Spin Blur again to the wheels of 
a car, but we’ll need part of the area where the effect is being applied to remain 
sharp. There is a disc brake in the wheel and the red part of the disc brake would 
not actually be in motion, so we need to make sure this area somehow remains 
sharp while the rest of the wheel becomes blurred. 

We’ll start by converting the image layer into 
a smart object (Filter > Convert for Smart Fil-
ters). Then, we’ll go to the Filter menu and 
choose Blur Gallery > Spin Blur. We’ll posi-
tion the blur circle so that it matches the front 
wheel of the car and then move the Blur Angle 
slider until it looks like there is an appropriate 
amount of blur. We’ll click OK to go back to 
Photoshop’s main interface. We now need to 
make it look as if the brake caliper is somehow 
still stationary while the rest of the wheel is 
spinning around it. We could paint on the layer 

These are the before and after versions of using the Spin Blur filter to make the wheel look 
like it’s in motion while the brake caliper looks to be stationary.

The Spin Blur circle is being posi-
tioned around the front wheel
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mask for the Spin Blur smart filter, but that wouldn’t enable us to see the red brake 
caliper behind the spoke of the wheel, which is what we’d see if we had actually 
shot the image with motion blur. 

Instead, we’ll go to the Layer menu and choose Smart Object > New Smart Ob-
ject via Copy. This will duplicate the smart object layer so that it is detached from 
the original layer. This way, we can make changes to one without those changes 

affecting the other. We’ll dou-
ble-click on the thumbnail for 
that copy so that we can work 
on the actual contents of the 
smart object (in a separate 
Photoshop window). Then, 
we’ll add a layer mask and 
paint on the mask with black 
to hide all of the inner work-
ings behind the wheel, leav-
ing the actual wheel spokes 
visible. We’ll then close the 
window and, when prompt-
ed, choose to Save. This will 
take us back to the original 
document. 

We now have a layer with the wheel spokes on top and a layer with the entire 
image on the bottom. We need to get the crisp brake caliper so we will duplicate 
the bottom layer by going to the Layer menu and choosing Smart Objects > New 
Smart Object via Copy. I don’t want this layer to be blurred at all so we’ll drag the 
Blur Gallery smart filter to the trash, discarding it. We’ll add a layer mask to this 
layer and will want the entire mask to be black except for the area where the brake 
caliper is. To achieve this, we’ll make a selection around the brake caliper, invert 
the selection by going to the Select menu and choosing Inverse. Then, we’ll fill that 

Here, we’re painting on a layer mask in order to hide the 
inner workings of the wheel.
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selection with Black, hiding the layer in all areas except for that area. We’ll make 
sure the layer is active (and not the mask) and retouch the spoke of the wheel out. 

Now we can turn on all of the layers. The bottom layer will have the blurred image. 
The middle layer will have the sharp brake caliper. The top layer will place the blur-
ry wheel on top of the brake caliper, so it looks as if it’s spinning while the brake 
caliper is staying in place. 

In the final result, we 
have the bottom layer 
displaying the image with 
the blur. The middle layer 
contains only the sharp 
brake caliper. The top 
layer contains the blurry 
wheel, masked so that 
you can see the sharp 
brake caliper behind it.


