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Intermediate Panoramas

In this lesson, we’re going to cover some intermediate panorama stitching tech-
niques. Note that there is a previous Masters Academy lesson on merging pan-
oramas and HDR images that covers the basics. Now we’re going to take things a 
step further. 

The best way to stitch a panorama is from Lightroom or Adobe Camera Raw and 
that’s because the end result will be a raw file. Therefore, you can adjust the image 
after you stitch it instead of needing to adjust the individual images before hand. 
To merge a panorama from Lightroom, select all of the images and then click on 
the Photo menu and choose Photo Merge > Panorama. In the video example, we’re 
going to use Camera Raw. To merge a panorama in Camera Raw, we’ll select all of 
the images in Bridge, then click on the File menu and choose to Open in Camera 
Raw. All of the images will be displayed as thumbnails in a Filmstrip on the left side 
of the screen. We want all of the images selected so we’ll click on the little menu 
above the Filmstrip and choose Select All. Then we’ll click on that same menu and 
choose Merge to Panorama. 

If all goes well, Camera Raw 
will process the images for a 
few moments and then pres-
ent you with a merged pano. 
However, things don’t always 
go as planned, so let’s look 
at what could go wrong and 
how to handle it. In the video 
example, we got an error box 
that said “Selected images 
are not compatible with each 
other for merging.” There 
are a few things that could 
cause this. If you were shoot-
ing hand-held and the lens 

In Camera Raw, we selected all of the images and 
clicked on the menu to choose Merge to Panorama.
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zoomed in or out a little 
while you were shooting 
the pano, it could cause 
this error. You can tell if 
this happened by looking 
at the camera settings 
for each image. They will 
be listed beneath the His-
togram in Camera Raw.

Another instance where you might get this error is if you were not in manual mode 
for your exposure of if you were not using the auto exposure lock (AEL) setting.

To get around this, we will 
need to merge the pano in 
Photoshop instead of Cam-
era Raw or Lightroom. From 
Bridge, we will again select 
all of the images, we’ll go to 
the Tools menu and choose 
Photoshop > Photomerge. 
The Photomerge dialog will 
appear. We’ll leave the de-
fault settings and then click 
OK. A few status bars will 
appear and then Photo-
shop will present us with 
the end result, which is a 
series of layers (one for 
each image) containing lay-
er masks, which have been 
implemented to blend the 
images into a final pano. 

One of the errors you might get when merging a pano is “Se-
lected Images are not compatible...”

The Photomerge dialog in Photoshop.
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It’s important to know that this end result is not a raw file. This means that we’ll be 
limited in how we can adjust the pano after merging. We can’t recover highlight  or 
shadow detail like we could with a raw file, and if we attempt to adjust the white 
balance, it’s not going to look as good as if we had done it ahead of time. 

With some problematic panos, you might get an error with 
Photoshop’s Photomerge as well as the Lightroom/Bridge 
pano merge feature. If that happens, don’t give up just yet! 
In an instance like this, we can follow the same steps that 
Photoshop does automatically in merging a pano. We will 
just do them manually (while still getting a little help from 
Photoshop), in three steps. First, we will select all of the im-
ages in Bridge and then go to the Tools menu and choose 
Photoshop > Load Files into Photoshop Layers. This will 
create a single Photoshop document with each image as a 
separate layer. This is the first step that Photoshop would 
take when using the Photomerge command. 

The result of merging a panorama using Photoshop’s Photomerge feature.

After “Loading into 
Photoshop Layers,” 
we’ll get one document 
with each image as a 
separate layer.
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Next, we want to get some 
working space around the 
image so we’ll go to the 
Image menu and choose 
Canvas Size. This will let 
us see and adjust the 
width and height of the 
document. We’re going 
to set the measurement 
unit menu to percent, set 
the width to 1200 percent 
(this is a really wide pano) 
and then click OK. 

Now, if Photoshop were doing this automatically, this is the stage in which it would 
use the Auto-Align Layers command, but this is the command that is causing the 
error. For this reason, we’re going to align the images manually. We need to choose 
a base image to start with and we’ll choose the image containing the most import-
ant part of the scene. In the video example, it’s the image containing the sun and 
the contrasting mountains. We’ll turn off the visibility of all other layers. Then, we 
will turn on the visibility of the layer containing the adjacent part of the image and 
use the Move Tool to manually align the layers. It will be difficult to achieve perfect 
alignment by doing this visually, so we’ll use a trick. We’ll set the blending mode of 
the overlying layer to Difference. With Difference mode, any area where the active 
layer matches the underlying layer will display black. Anywhere it doesn’t match, 
it will display various colors. This will allow us to move the layer around, trying to 
get the entire layer to display black (meaning everything is perfectly aligned). We 
can also use the arrow keys to move the layer in tiny amounts. After the two layers 
are lined up as closely as possible, we will set the blending mode back to Normal. 

Next, we’re just going to repeat that process, turning on the next layer and lining it 
up using the same method. We will need to make sure that the layer we’re moving 
around is positioned above the other visible layers in the Layers panel. We’ll con-
tinue this process for all of the other layers in the document. 

We’re add-
ing space 
on the left 
and right 
sizes of the 
canvas via 
the Canvas 
Size dialog.
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All of the layers should now be aligned, but we still don’t have a seamless panora-
ma because the layers are not blending into one another. To make the layers blend 
seamlessly, we’ll go to the Edit menu and choose Auto-Blend Layers. A dialog will 
appear where we can choose between Panorama and Stack Images. We’ll make 
sure it’s set to Panorama and make sure the “Seamless Tones and Colors” check 
box is turned on before clicking OK. Photoshop will merge the images together, 
creating and implementing a mask for each layer. At first, it may look as if there 
are seams in the panorama, but know that these are not actually in your file. If you 
zoom in to view the image at 100%, you will see that they are no longer visible. 
They will also disappear if you flatten the image. 

When we set a layer to Difference mode, it will appear black in all areas where the active 
layer is the same as the underlying layer. We’ll see colors in the areas where the two layers 
differ.

The layers are aligned but they are not blending into each other and we can see the seams 
between each image.
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8-bit vs. 16 bit When an image is opened in 16-bit, Photoshop uses thousands and 
thousands of brightness levels when it blends the images together. This creates 
a much smoother panorama than one that was merged in 8-bit (with only 256 
brightness levels). This is especially noticeable in smooth areas like skies. Before 
merging a pano, I will make sure that the images are being opened in 16-bit. After 
merging the pano, we can switch the image back to 8-bit without a loss of quality. 

To set the bit depth setting in Lightroom, open Lightroom’s Preferences and click 
on the External Editing tab at the top. Here, there will be a bit depth setting and 
this is where you choose whether your images should open in 8-bit or 16-bit when 
they are sent to Photoshop

In Camera Raw, click on the line of text at the bottom of the screen and it will tell 
you if the image will be opened in 8-bit or 16-bit. If you’d like to change it, click on 
the line of text and the Workflow Options dialog will appear. Here, you can specify 
whether the image should be opened in 8-bit or 16-bit. 

Left: In the Auto-Blend Layers dialog, we are 
choosing the Panorama option and making 
sure that the “Seamless Tones and Colors” 
check box is turned on. Above: After blending 
the layers, you might see seams between each 
layer, but these are not actually in the file and 
will not be visible when viewed at 100% or 
after flattening the document.
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Fisheye panoramas: Technique 1 Panos that are shot with a fisheye lens can pres-
ent their challenges because of the large amount of distortion. In the video ex-
ample, we got an error that read “Some images were unable to be merged” when 
we chose to merge from Camera Raw. When we chose OK, the Panorama Merge 
Preview dialog opened and we attempted to choose different Projection options, 
but none of them seemed to work out better. Here is another option. We’ll select 
all of the individual images in Bridge and we’ll go to the Tools menu and choose 
Photoshop > Photomerge. In the Photomerge dialog, we’ll make sure that the Lay-
out option is set to Auto and we’ll turn on the following three check boxes: 

• Blend Images Together

• Vignette Removal

• Geometric Distortion Correction

Then we’ll click OK. The combination of settings chosen will likely do a better job 
at merging a fisheye panorama. After merging, there are further techniques that 
we can use to straighten things out and correct for distortion. 

Here are two sets of panoramas that were shot with a fisheye lens. The distortion is going to 
create problems when merging that we will need to compensate for. 
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Fisheye panoramas: Technique 2 There is another route 
that we can take when merging a fisheye panorama and 
that is correcting for distortion before merging the in-
dividual images. We’ll select the individual images and 
open them in Camera Raw. With the images selected, 
we’ll open the Lens Corrections panel on the right side 
of the interface. We’ll make sure the Profile tab is se-
lected and then we’ll turn on the “Enable Profile Cor-
rections” check box. This will straighten out the fisheye 
image, but the problem is that part of the content gets 
cut off on either side. We need to try to correct for this. 
We’ll activate the Crop Tool (at the top of the ACR in-
terface), click on the crop ratio menu and make sure the 

Above is the result of merging a fisheye panorama with Auto setting selected and the top 
three check boxes turned on. 

In the Lens Corrections 
panel, we are turning on 
the “Enable Profile Correc-
tions” check box.
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Constrain to Image setting is turned OFF. Note that in Lightroom, this setting will 
be located on the right side of the interface when the Crop Tool is active. If this 
setting were turned on, we’d never be able to see anything beyond the edges of 
the image, where there might be some empty space. 

We will then go to the Transform settings and drag the Scale slider to the left until 
all of the important content in the image becomes visible again. We will also get 
some empty space and that’s ok. We’ll click the Open Images button in the bot-

Left: The original image. Right: The same image with the Profile Corrections setting on. 

In the Transform settings, the Scale slider is being moved to the left until all important con-
tent comes back into the frame.
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tom right corner of Camera Raw. This will open the images as separate Photoshop 
documents, and we want them all in one document. We’ll drag the layers, one by 
one, into a single document. We will use the Move Tool to best align the layers, 
using the Difference blending mode to get a better idea of when they are lined up 
perfectly. After lining up the images, we have areas in the layers that are extend-
ing beyond the boundaries of the document frame. We’ll expand the canvas to 
include those areas by going to the Image menu and choosing Reveal All. This will 
expand the canvas to include anything that’s extending beyond the edge. 

Choosing an area to use when auto-blending Now in this example with the cars 
at Cadillac Ranch, one of the layers shows the cars extending outward and an-
other layer shows the cars pushing inward. This is just a difference in distortion 
because of the way the lens was angled in the two shots. It won’t be uncommon 
that you will have an area of one image that you like better than that same area 

The top layer is set to Difference mode so that we can best see when the layers are lined up 
accurately. 
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in a different image and you will need to spec-
ify which image Photoshop should use to fill in 
that area. In our example, we went to the Edit 
menu, chose Auto-Blend layers and then end-
ed up with the cars pushing inward. I actually 
wanted the opposite, which is the cars extend-
ing outward. Here is how to specify that you 
don’t want an area in a particular layer to be 
included in the final merge. Turn off the visibil-
ity of all other layers. Then add a layer mask to 
the layer with the undesirable area and paint 
over that area (on the layer mask) in black. This 
will completely hide the area. In our case, we’re 
going to paint with black over the area that in-
cludes the cars leaning inward. Then we’ll turn 
on the visibility of the other layer[s] and try the 
merge command again. We’ll go to the Edit menu and choose Auto-Blend Layers. 
Now, because the undesirable area was hidden, Photoshop could not use it in the 
merge. Note that this technique can be useful for any panorama merge, not just 
fisheye panoramas. 

Finally, we will use the Crop Tool to crop 
out any transparent areas around the 
edges of the image. With the Cop Tool 
active, there will be a “Delete Cropped 
Pixels” check box in the Options Bar 
above the main image window. If you 
turn this check box on, any content out-
side of the crop rectangle will be dis-
carded. If you keep this setting off, you 
will be able to go back later and “un-
crop,” bringing back any areas that were 
outside of the crop rectangle.

A layer mask was used to hide the 
undesirable area, making sure that 
Photoshop does not include it when 
auto-blending the layers.

The Crop Tool is being used to crop out any 
transparent areas. 
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Fixing distortion caused by stitching a panorama  Sometimes, you’ll shoot a pan-
orama and the individual images look fine, but the final merge has some distortion. 
To demonstrate this, we’ll use a panorama shot at a temple complex. We merged 
the images in Camera Raw and experimented with the Projection settings to see 
which looked best. (In this case, it was the Cylindrical setting.) The Boundary 
Warp slider will bend the picture based on the shape of its edge, making it closer 
and closer to a rectangular document. Because we’re going to bend the picture to 
correct for distortion, we’ll leave the Boundary Warp slider at zero and then click 
the Merge button. We’ll be prompted to name the new panorama and then click 
Save. Then the merged pano will open in Camera Raw. 

We want to open the image in Photoshop to make further adjustments, but if we 
simply click the Open Image button, the image will lose the quality of a raw file. 
Instead, we’ll hold down the Shift key so the Open Image button turns into the 
Open Object button. We’ll click this so the image opens as a Smart Object in Pho-
toshop. (To do this in Lightroom, go to the Photo menu and choose Edit In > Open 
as Smart Object in Photoshop.) In Photoshop, the layer thumbnail with have a little 
icon on top of it, indicating that it is a Smart Object. We could double-click on the 

All of the individual images in this panorama are undistorted. After merging, however, we 
ended up with distortion.
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Smart Object to open the image back in Camera Raw so that we can make further 
adjustments while still retaining the quality of a raw file. 

To correct for the distortion, we’ll go to the Filter menu and choose Adaptive Wide 
Angle. The Adaptive Wide Angle window will take over the interface and it will 
automatically try to correct for some of the distortion. We can also guide the tool 
to correct things in the way that we want. Toggle the Preview check box at the 
bottom of the screen to see a before and after view of the distortion correction. 
Because this is a filter, it can’t change the dimensions of your picture, so it can’t 
make it wider or taller. We CAN use the Scale slider to scale the entire image down 
so that it all fits within the document frame. 

Now we can work on correcting specific areas that are distorted. In the example 
image, some of the lines of the buildings are curved where they should be straight. 
The Constraint Tool is the top most tool on the left side of the interface and it is 
usually active by default. This is the tool that we’ll use. We’re going to click and 
drag on a surface that should be a straight line and you’ll see that the line will bend 
to match the photograph. When we release the mouse button, Photoshop will at-
tempt to straighten that part of the photograph and everything else around it. We 
can repeat this with other areas of the image that are distorted. 

Using the Constraint 
Tool (active by de-
fault), we drew out a 
line over an edge that 
was curved (but sup-
posed to be straight). 
When we released the 
mouse button, Pho-
toshop straighted out 
the edge and sur-
rounding areas. 
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After merging a pano, you might also 
get lines that are supposed to be ver-
tical but are actually curved or bow-
ing outward or inward. We can cor-
rect for this within the Adaptive Wide 
Angle window as well. We’ll use that 
same Constraint Tool, clicking and 
dragging up a surface/edge that is 
supposed to be perfectly vertical. 
Before we release the mouse button, 
however, we will hold down the Shift 
key, which will change the color of the 
guide line. When we release the Shift 
key and the mouse button, the tar-
geted surface will become perfectly 
vertical. (This also works for horizon-
tal surfaces.)

After we switch a surface 
from curved to straight, the 
angle may not be perfectly 
to our liking. To fix this, we 
can click and drag on one 
of the white dots along the 
line in order to rotate the 
angle. After drawing out 
a guide line, you can also 
right click on the line to get 
a little menu. Here, we can 
choose what kind of line it 
should be: Horizontal, Ver-
tical or Arbitrary.

If you hold down the Shift key while using the 
Constraint Tool, you can drag out a line on a 
surface you want to be perfectly vertical (or 
horizontal). 

After straightening out a surface using the Constraint Tool, 
you can drag the circular handles to change the angle.
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When you are creating guide lines in the Adaptive Wide Angle filter, it’s basically 
creating a mesh behind the scenes. To see how the image is being distorted (or 
undistorted), turn on the Show Mesh check box at the bottom of the screen. We’ll 
make as many changes as needed and then click OK. 

Note that the Adaptive Wide Angle filter is more geared toward correcting distor-
tion in panoramas and not single-shot images. For a regular image, I’d recommend 
using the Lens Corrections settings in Lightroom or Camera Raw.

Because this is a raw file, we can always come back and make changes to the filter 
settings by double-clicking on the name of the filter under the layer thumbnail in 
the layers panel.

You can view the way the image is being distorted by turning on the Show Mesh check box 
at the bottom of the Adaptive Wide Angle dialog.


