
Wish I Knew: Creative



Wish I Knew: Creative © Ben Willmore, All rights reserved 2

Wish I Knew: Creative

The “Wish I Knew” lessons are full of tips and techniques that I wish I had known 
when I was starting out with Photoshop. This lesson will cover the essential con-
cepts I wish I had known related to doing creative things in the program. 

Blending Modes

Change blending mode of several layers at once 
The blending mode menu can be found at the top 
of the Layers panel. It used to be that you could only 
change the blending mode of one layer at a time. 
Now, you can select multiple layers and change 
their blending modes all at once. If you would like 
to change the blending mode of all the layers in the 
document, go to the Select menu at the top of the 
screen and choose All Layers. Then, you can use 
the Blending Mode menu to change the mode for 
all of them. 

Quickly cycle through blending modes If you’re 
not sure what blending mode you want to use, you 
can quickly cycle through them to see which works 
best. To do this, make sure the Move Tool is active 
and then hold down the Shift key while using the 
plus or minus keys ( + - ) to move through the blend-
ing modes. The plus key will move up the Blending 
Mode menu and the minus key will move down in 
the menu. For Windows, the method is different. If 
you are using Windows, click on the pop-up menu 
and, while it’s activated, you can use the up and 
down arrow keys to move through the menu. 

The Blending Mode menu can 
be found at the top of the 
Layers panel (circled). Here, 
we selected several layers and 
then used the menu to change 
the blending mode of all of the 
selected layers at once. 
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Blending modes & layer groups When you have layers with overlapping content 
and you change the blending mode of them all, the overlapping areas will look dif-
ferent than the non-overlapping areas. This may or may not be what you want. If 
you would like the layers to act as one piece when you change the blending mode, 
select all of the layers and place them inside a layer group by clicking the New 
Group icon at the bottom of the Layers panel (It looks like a little folder). Now, 
change the blending mode of the group (instead of changing the blending mode 
of the individual layers). When you do this, Photoshop will think of everything in-
side the group as one piece. As another option, you could select all of the layers 
and convert them into a smart object. Then, you could change the blending mode 
of the smart object. 

In the top screen 
shot, each bar is a 
separate layer and 
we changed the 
blending mode of all 
the bar layers to Mul-
tiply. As you can see, 
they look different in 
the areas where the 
layers overlap. In the 
bottom screen shot, 
we placed all of the 
bar layers inside a 
layer group and then 
changed the blend-
ing mode of the 
group to Multiply. 
This caused layers to 
to act as one piece 
so they interact with 
the background but 
not with each other. 
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Pass Through vs. Normal The blending mode for 
a layer usually controls the way the layer interacts 
with all of the layers underneath it. In some cases, 
you might want to change the way the layer in-
teracts with some underlying layers, but not all of 
them. If that is ever the case, take all of the layers 
that you want to be affected by the blending mode 
and place them inside of a layer group. Click on the 
name of the group and you will see that the default 
blending mode setting for the group is a choice 
called Pass Through. This means that the effect of 
any blending modes will pass through all the way 
to the bottom of the layer stack. If you click on the 
Blending Mode menu and change the setting to 
Normal, then any blending will stay contained with 
what’s inside the folder. The blending modes will not 
change the way the layers inside the folder interact 
with what is beneath the folder. 

Filters

Applying filters on multiple layers at once In general, filters can not be applied 
to more than one layer at a time. If you select multiple layers and then click on 
the Filter menu, you will notice that the filters are grayed out, meaning they are 
unavailable. To get around this, we can convert multiple layers into a smart object 
and then apply the filter to that smart object. To do this, go to the main menu and 
choose Layer > Smart Objects > Convert to Smart Object. Alternatively, you can 
choose Filter > Convert for Smart Filters. The command is exactly the same. All 
of the selected layers will now appear as one single layer in the Layers panel. The 
little icon in the bottom right of the thumbnail indicates that the layer is a smart 
object. Now, when we select the smart object layer in the Layers panel, we can 
go back to the filter menu and see that all of the filters are now available.  We 
can always access the individual layers that make up the smart object and make 

Here, we are changing the 
blending mode of a group from 
Pass through to Normal.
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changes to them by double-clicking on the smart object thumbnail in the Layers 
panel. This will cause a separate Photoshop document to open, containing all of 
the layers that make up the smart object. We can make changes to the document, 
save and close it, and the updates will be reflected in the original document. 

Smart Filters  When we apply a filter to a smart 
object, it will be applied as a smart filter. This 
means that the effect is simply an accessory 
that is attached to the layer. It is not perma-
nent, so we can go back and change the set-
tings or remove the filter at any time. In the 
Layers panel, the smart filters will appear as 
a separate thumbnail, indented beneath the 
smart object layer. Every filter applied will be 
listed here and we can turn off or on the eyeball 

Left: Several layers were used to create a graph-
ic in the document. We want to apply a filter 
to the graphic, but we can not apply a filter to 
multiple layers. Above: The layers that make up 
the graphic were converted into a smart object, 
so we can now apply a filter to this smart object 
layer. 

When a filter is applied to a smart 
object, it will be a smart filter and 
appear as an indented thumbnail 
beneath the smart object.
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icon to the left of the filter names in order to disable and re-enable the filter. We 
can also double-click on the name of the filter to access the filter’s settings so that 
we can make changes to them. We can stack as many filters as we’d like, and can 
change the order in which the filters are applied by dragging them up and down 
in the list. To the right of the name of a filter is a little icon that looks like sliders. If 
we double-click on this icon, 
a dialog will appear, allowing 
us to change the blending 
mode and opacity of that 
individual filter. When filters 
are applied to smart objects, 
the smart filters “layer” in the 
Layers panel will automat-
ically have a layer mask at-
tached to it and we can use 
this mask to hide the effect 
in parts of the document. 

Using filters on selections & masks We can also use filters to modify the look of 
selections and masks. In order to do this, we will need to take an active selection 
and then view it in Quick Mask Mode, which will give us a red overlay depicting 

the selection. You can quick-
ly enter (and exit) Quick 
Mask Mode by tapping the 
Q key on your keyboard. As 
long as Quick Mask Mode is 
active, we can go to the Fil-
ter menu and have access to 
all of our standard filters. In 
the video example, we cre-
ated a rectangular selection 
that framed the center of the 

If we double-click on the icon to the right of the filter 
name (circled), we can change the blending mode and 
opacity of the filter effect. 

We started with a selection that frames the center of the 
document.
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document and then applied the Ripple filter (while in Quick Mask Mode) in order 
to make the selection wavy. We hit the Q key again to exit Quick Mask Mode. Note 
that the same technique can be used when working with layer masks. 

We hit the Q key to enter 
Quick Mask Mode, which 
shows our selection as a 
red overlay.

With Quick Mask Mode 
active, we applied the 
Ripple filter to the selec-
tion.
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The Filter Gallery The Filter Gallery can be accessed from the Filter menu and it 
contains many different filters that are grouped into categories (Artistic, Distort, 
Texture, etc.). I would like these filters to appear in the regular filter menu so that 
I don’t need to enter the Filter Gallery in order to access them. We can set this up 
in Photoshop’s preferences, which can be accessed by clicking on the Photoshop 
menu and choosing Preferences > Plug-Ins. In Windows, the Preferences can be 
found under the Edit menu. In the Preferences dialog, we’ll turn on the check box 
that reads “Show All Filter Gallery Groups and Names.” Now, all of the Filter Gal-
lery filters can now be found in the regular Filter menu at the top of the screen. 

If you’d like all of the Filter Gallery filters to appear within the Filter menu, turn on the 
“Show All Filter Gallery groups and names” check box within the Plug-Ins section of the 
Preferences dialog.
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Layer Styles 

Layer styles, or layer effects, are settings that are attached to a layer and can be 
removed or changed at any time. You can learn how to create complex looks using 
a series of layer styles. Add a layer style by clicking the FX icon at the bottom of 
the Layers panel and choosing the desired effect from the pop-up menu. 

Drop shadows When adding a drop shadow, there are several different settings 
within the Layer Styles dialog box. The Distance slider determines how far away 
the shadow will sit from the object[s] in the layer and the Angle setting deter-
mines which direction the shadow should be casting. There is a better way of de-
termining the distance and direction, and that is by clicking and dragging on the 
image itself. When you move the shadow around with your mouse, the distance 
and angle settings will automatically move. The Size slider controls how soft the 
edge of the drop shadow is and the Opacity slider controls how dark it is. 

Here, we are controlling the position of the drop shadow by manually dragging it around 
with the mouse. When we do this, the drop shadow settings automatically change within the 
Layer Style dialog.



Wish I Knew: Creative © Ben Willmore, All rights reserved 10

Layer styles and blending modes  Every layer style has a blending mode menu in 
the settings, and there is a default blending mode for each one. For the drop shad-
ow effect, the default blending mode is Multiply, which is only capable of darken-
ing things. There is also a color swatch you can click on to access the color picker 
so you can choose what color the drop shadow should be. Let’s say that we want 
to use this layer style to create a glowing, brightening effect instead of a darken-
ing effect. To do this, we can use the color picker to choose a light color and then 
change the blending mode to something that will lighten instead of darken. In the 
video example, we chose a yellow color and set the blending mode to Screen. 
In general, pay attention to the blending mode menu when working with a layer 
style. You may be able to use it to create a different, more unique effect. 

Layer styles on multiple layers After creating a layer style, the name of the effect 
will appear below the name of the layer in the Layers panel. You can move the 
style from one layer to another by clicking and dragging on the name of the lay-
er style from one layer to another within the Layers panel. You can copy a layer 

Here, the drop shadow style is being used to create a bright, glowing effect. This was done 
by changing the color to a bright yellow and then setting the blending mode to Screen.
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style from one layer to another by holding down the Option key (Alt on Win) and 
dragging the layer style from one layer to another. You can also right-click on the 
layer style and choose Copy Layer Style from the menu that appears. Then, you 
can select one or many layers in the Layers panel, right-click on them and choose 
Paste Layer Style from the menu that pops up. Note that you need to right-click 
to the right of the layer thumbnail in the layers panel. This second method will be 
more useful when you need to copy a style to many layers at once. 

If you’d rather use Photoshop’s menu, you can go to the main menu and choose 
Layer > Layer Style > Copy Layer Style and then Paste Layer Style. 

When you apply the same layer style to multiple layers, it will treat each layer as 
a single entity. If you’d like the style to be applied as if all of the layers were one 
combined unit, first place all of the layers into a group and add that layer style to 
the group (instead of the individual layers inside it). 

We copied a the drop shadow layer style from one layer and pasted it onto the rest of the 
layers.
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Layer styles, opacity and fill  At the top of the Layers panel, you’ll see that there 
are settings for Opacity and Fill. At first glance, these sliders seem to do the same 
thing. It’s when you have a layer style applied that they will act differently. When you 

lower the Opacity setting, 
it will lessen the visibility 
of the layer itself AND the 
effect of any layer styles 
that have been applied to 
it. When you lower the Fill 
setting, the contents of the 
layer itself becomes trans-
parent but the effects ap-
plied via the layers styles 
remain at full strength. 

Direction of light/Global Light Some of the layer styles have settings relating to 
the direction of light. The drop shadow is one example of this. When the direction 
of light is coming from the upper left, the angle of the drop shadow will be to the 
lower right. If you have multiple layers that have drop shadows applied to them, 
Photoshop will try to keep the direction of light the same. When you change the 
angle settings for one of the layer’s drop shadows, the angle setting will change for 
all of the layers, and you will see that all of the drop shadows change position. You 
may or may not want this to happen. If you would like to change the angle of the 

drop shadows independently (so you 
are only affecting the direction of the 
active layer’s shadow), then turn off 
the Use Global Light check box. You 
will find this Global Light check box 
within the settings for all of the lay-
ers styles that make use of direction 
of light. These include drop shadow, 
bevel & emboss, inner glow, etc. 

At left, we are lowering the Opacity setting. At right, we 
are lowering the Fill setting.

The Global Light setting will determine wheth-
er the direction of light will be the same for all 
applicable layer styles. 
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Turn a layer style into a layer After creating an effect via a layer style, you may 
find that you want more control over that effect or you want to do something to 
it independently of the layer itself. If that’s the case, you can separate it from the 
layer so that it becomes its own layer. To do this, go to the Layer menu at the top 
of the screen and choose Layer Style > Create Layer. When you do this, the orig-
inal layer will no longer have the style applied. The results of the style will instead 
be contained on a separate layer. 

Smart objects

To convert one or more layers into a single smart 
object, select the layer or layers in the Layers panel, 
go to the Layer menu and choose Smart Objects 
> Convert to Smart Object. A little icon will appear 
over the thumbnail in the Layers panel, indicating 
that the layer is a smart object. If more than one lay-
er was used to create the smart object, they will now 
appear as a single layer in the Layers panel. 

Left: The active layer has a drop shadow layer style applied to it. Right: We used the “Create 
Layer” command to take the drop shadow layer style and turn it into its own layer.

The little icon in the bot-
tom right corner of the layer 
thumbnail indicates that the 
layer is a smart object.
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Multiple instances of a smart object If you ever take a smart object and duplicate 
it (using any method), it is just creating another instance of the exact same smart 
object. This means that they all point back to the original layer (or layers). If you 
double-click on one of the instances of the smart object in the Layers panel, it will 
open as a separate Photoshop document and you can make changes to it. When 
you save and close this document, the changes will be reflected in every single 
instance of the smart object in your original document. 

In our example document, we took the layer containing a leaf image, converted it 
into a smart object and then duplicated that smart object multiple times, creating 
a fan-style shape out of the multiple leaves. Then, we double-clicked on one of the 
leaf thumbnails in the Layers panel to open the smart object in a separate docu-
ment. We inverted the color of the leaf, making it black instead of white and then 
closed and saved the document. Back in the original document, all of the leaves 
were updated to reflect that change. We simply changed the blending modes to 
Screen in order to give them a unique look. In working with the smart object doc-
ument, we could have easily replaced the leaf with something else entirely and it 
would have still updated to that new item in every instance of the smart object. 

Left: Each leaf is a separate instance of the same smart object. We simply duplicated the 
layer and repositioned the duplicates into the fan shape. Right: We double-clicked on one of 
the smart objects to open it in a separate document so that we could make changes to it. 
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Smart objects and text  When you have a text layer, Photoshop will not allow you 
to apply certain filters on that layer. It will present you with a dialog box that says 
you must either rasterize the text layer or convert it into a smart object. The ras-
terize choice will make it so the text layer is no longer editable text. Instead, it will 
act like a picture of text. You will not be able to change the text after you rasterize 

In editing the smart object, we inverted the layer, which took the white leaf and made it 
black.  When we saved the smart object document, all instances of the leaf were inverted to 
black. We then changed the blending mode of all the leaf layers to Screen. 

If you try to apply 
a filter to a text 
layer, Photoshop 
will present you 
with the option 
to either rasterize 
the text or con-
vert it to a smart 
object. 



Wish I Knew: Creative © Ben Willmore, All rights reserved 16

it. If you instead choose to convert the text layer into a smart object, it will put that 
text layer in a protective bubble so that you can apply filters to it AND go back 
and change the text later. It will appear as a smart object in the layers panel, and 
to change the text, you would double-click on the thumbnail to open the text in a 
separate document. After changing the text, you would save and close that docu-
ment and the text will become updated in your original document and it will retain 
any filters that were applied to it. The filters will appear as smart filters indented 
below the smart object layer in the Layers panel.

Replace contents You can quickly take a smart object and completely replace 
the contents with another image of the exact same pixel dimensions. To do this, 
select the smart object in the layers panel, go to the main menu and choose Layer 
> Smart Objects > Replace Contents. You’ll be prompted to choose a file on your 
hard drive that you want to use in place of the contents of the smart object. 

Here, we converted the text layer into a smart object, so we were able to apply a filter to the 
layer. In this case, we applied the Ripple filter. 
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Protect transparency

If you have a layer that contains 
an object with a transparent back-
ground, you might want to change 
only the object in the layer and not 
the transparent areas. For exam-
ple, maybe you want to paint on 
the object in the layer but you only 
want the paint to affect the areas 
that already contain pixels (the ar-
eas that contain the object). By de-
fault, the brush tool will paint over 
everything (the object and trans-
parent areas alike). If, however, you turn on the Transparency Lock setting, you 
will only be able to add paint to areas of the layer that already contain pixels. Turn 
on the Transparency Lock setting by clicking the icon near the top of the Layers 
panel that looks like a little checkerboard. 

This protect transparency feature can also be applied when using the Fill command. 
To fill a layer with your foreground color, use the keyboard shortcut Option+Delete 
(Alt+Backspace on Win). This will fill the entire layer, regardless of whether there 
is any transparency. If you instead use the keyboard shortcut Shift+Option+Delete 
(Shift+Alt+Backspace on Win), it will only fill the areas that already contain infor-
mation. All transparent areas will remain transparent.  

 

The Lock Transparency setting (circled) will pro-
tect any transparent areas in the layer. 


