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Yoga Stitch

In this lesson, we’re going to cover some techniques that can be used to merge a 
difficult panorama. In the example image, I was photographing Karen in front of a 
mural that was located in a narrow alleyway. Because my lens wasn’t wide enough, 
I had to take multiple shots in order to capture the entire scene. The shots were 
also captured by angling the lens up, left and right, and this created a challenge 
when merging the images together. 

In the video example, we are merging the images using Bridge and Adobe Cam-
era Raw (ACR) but you can just as easily use Lightroom. From Bridge, we’ll select 
all of the images and use the keyboard shortcut Command+R  (Ctrl+R on Win) to 
open the images in ACR. The images will appear as thumbnails within the Filmstrip 

on the left side of the ACR interface. To merge 
the images into a panorama, we’ll first click on 
the little hamburger menu at the top of the 
Filmstrip and choose Select All. Then we’ll go 
back to that same menu and choose Merge to 
Panorama. (Note: In the video example, we got 
an error because one of the images was shot in 
a different orientation. We deselected that im-
age and then chose to merge the pano.) In the 
Panorama Merge Preview dialog, we’ll turn off 
the Auto-Crop check box so that we can see the 

Above are the four images that were shot to capture the entire scene.

The images are all selected in ACR 
and we are choosing to merge  
them into a panorama.



Yoga Stitch © Ben Willmore, All rights reserved 3

entire image. Because the images were shot by angling the lens a lot, the resulting 
panorama does not look all that usable so we will switch the Projection setting 
to Perspective. This option is designed to correct for distortion and it provides us 
with a good starting point. We’ll click the Merge button and a dialog will appear 
asking us to name the document, choose a location and then click Save. Back in 
ACR, the newly-merged pano appears in the Filmstrip and we can continue to 
work on it.

Merging in Lightroom: If you are using Lightroom instead of ACR, you would se-
lect all of the images, go to the Photo menu and choose Photomerge > Panorama. 
The same Panorama Merge Preview will pop up and you can follow the same steps 
that we did using ACR. 

In the Panorama Merge Preview dialog, we chose the Perspective setting, which did the best 
job at correcting for the distortion.
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Back in ACR, we’re going to select all of the images again, making sure that the 
merged pano is the one we’re viewing. We’re adjusting all of the images at once 
to ensure that all of the images will match, should we have to use one of the sup-
porting images to fill in the pano’s empty areas. Using the adjustment sliders, we’ll 
darken the highlights a bit (to bring detail back into the sky), increase contrast, 
lighten the shadows and then use the White Balance Eyedropper to ensure the 
color is correct. Then we’ll click the Done button to return to Bridge. 

From Bridge, we’ll open the merged pano into ACR. Here, we’ll try to correct for 
some distortion. We’ll activate the Transform Tool, which can be found in the Tool 
Bar at the top of the interface. (In Lightroom, the same tool can be found within 
the Transform panel in the Develop Module.) When the Transform Tool is active, 
the settings relating to it will appear on the right side of the interface. We’re going 
to choose the Guided Upright tool, which is the icon on the far right. 

We’ll use this to drag out a line over the top edge of the building. This tells ACR 
that this line should be perfectly horizontal. Nothing will happen, however, until 
we drag out a second line. We’ll drag out another line on the bottom edge of the 
building and ACR will attempt to correct the distortion based on the information 
we provided. 

Left: The Transform Tool can be found at the top of the Camera Raw interface.	 
Right: We are choosing the Guided Upright command within the Transform settings.
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The Guided Upright tool can also be used to correct for the vertical distortion, but 
in this image, I actually want to maintain some of that distortion, so I will use the 
Transform sliders instead. I’ll use the Vertical slider, dragging it to the left until the 
distortion looks a bit less drastic. 

After making this correction, part of the image started to get cut off by the edges 
of the frame. To fix this, we’ll use the Scale slider to scale the image down, making 
more of it fit in the frame. We can also use the Offset sliders to move the image 
up/down or left/right within the frame. We’ll click the Done button to get back to 
Bridge.

The merged panorama is missing a chunk of the mural at the top of the frame, 
so at this point, we want to start filling in that top edge with parts from another 
picture. We’ll select the pano picture as well as the picture that includes the top 
edge of the building, then go the Tools menu and choose Photoshop > Load Files 
into Photoshop Layers. 

The two images will open as separate layers in a single Photoshop document. 
Because of the distortion, we’re not going to be able to simply move the lay-

Left: The Guided Upright tool is being used to drag out lines on the surfaces that are sup-
posed to be horizontal. Right: ACR corrected the distortion based on the lines we created.
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ers to line them up. We’ll have to use 
other techniques. We’ll make sure the 
pano layer is on the bottom and with 
that layer active, we’ll click on the lit-
tle lock icon at the top of the Layers 
panel. This will ensure that Photo-
shop can’t scale or distort this layer.  
Then, we’ll go to the Edit menu and 
choose Auto-Align Layers. When the 
Auto-Align dialog appears, we’ll leave 
the settings at Auto and click OK. 
Photoshop will move and distort that 
top layer to best line it up with the un-
derlying, locked layer. Sometimes this 
works really well and other times, we’ll 
need to try other methods. 

If the Auto-Align command does not work, we’ll instead activate the Move Tool 
and position the top layer to generally line up with the underlying pano. We can 
change the blending mode of that top layer to the Difference mode and this will 
give us a view that shows where the two layers line up and where they differ. We’ll 
choose one area in the mural and make sure that it’s lined up with the same area 
on the underlying layer. Now we need to scale and transform the layer so we’ll ac-
tivate the Free Transform command by going to the Edit menu and choosing Free 
Transform. With the Free Transform command active, handles will appear around 
the layer and a little crosshair will appear in the middle. This crosshair represents 
the center of the layer, and we can move it in order to anchor the layer in a specific 
place. We’ll drag that crosshair to a location where the two layers line up. Then, 
we’ll hold down Shift+Option (Shift+Alt on Win) and drag the transform handles 
to better align the layer. 

We are locking the bottom layer so that it is 
not distorted when we use the Auto-Align Lay-
ers command.
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Because of the distortion, we still won’t be able to get the layers to perfectly align 
so we’ll next turn to the Distort command. We’ll go back to the Edit menu and 

choose Transform > Distort. This will 
allow us to move the four corners of 
the layer independently of one an-
other. We’ll position the corners in an 
attempt to line up the layers, placing 
extra focus on the top part of the 
wall because this is the part that 
we’ll actually be using. When we’re 
done, we’ll hit the Return/Enter key 
to lock in the transformation.  We’ll 
then change the blending mode of 
that top layer back to Normal. 

The top layer’s blending mode is set to Difference so that we can better see where the lay-
ers are lining up. We are using the Move Tool to best position the top layer so that some of 
the contents lines up with the bottom layer. 

When using the Distort command, we can move 
the four corners of the layer independently of 
one another. 
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Now, we want to use the top layer to fill in the parts that are missing from the 
bottom layer and we’ll start by making a selection around the empty areas on the 
bottom layer. We’ll hold down the Command key (Ctrl on Win) and click on the 
layer thumbnail for the bottom layer. This will make a selection around all areas in 
the layer that are not empty. Then we’ll go to the main menu and choose Select > 
Inverse. Now the empty areas are selected. We want to expand this selection just 
a small amount so we’ll go to the Select menu and choose Modify > Expand. In the 
dialog that pops up, we’ll leave the default setting of one pixel and click OK. 

With the selection active, we’ll click on the top layer to make it active and then 
add a layer mask by clicking the layer mask icon at the bottom of the Layers 
panel. Because there was an active selection, that selection was automatically 
applied to the mask. Looking at 
the result, the layers are still not 
aligned properly, so we’ll need to 
do some more work. We want to 
move the top layer, but we want 
the layer mask to stay in place, 
because we know the mask is in 
the correct position. We’ll click on 
the little link icon that appears be-
tween the layer thumbnail and the 
mask thumbnail so that we can 
move the layer independently of 
the mask. We just need to make 
sure that the layer is active, and 
not the mask. We can now use 
the Move Tool to further reposi-
tion the layer. 

After adding a layer mask, we want to move the lay-
er contents while leaving the position of the mask 
unchanged, so we clicked the link icon between the 
layer thumbnail and the mask thumbnail to unlink 
the two. 
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In order to get more control over the position of the layer, we’ll use the Puppet 
Warp command (Edit > Puppet Warp). The Puppet Warp mesh will appear over 
the layer. With Puppet Warp, we can click on parts of the image to add pins that 
lock the area in place. We’ll add a few pins in the areas we want to reposition. To 
get a clearer view of what’s going on, we’ll hide the mesh by turning off the Show 
Mesh check box in the Options Bar above the image window. We can now click 
and drag to move those anchor points we added, and we can add more if neces-

The Puppet Warp command is being used to add pins to the layer so that we can reposition 
specific areas.

The Puppet Warp pins are being repositioned in order to line up the layers. 
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sary. We are basically trying to add points and then line them up with the content 
in the underlying layer. We’ll hit Return/Enter to lock in the transformation when 
we’re done. Lastly, we’ll use a soft-edged brush to paint on the layer mask to cre-
ate a softer transition between the top layer and the underlying pano. 

Removing the telephone pole Now that we filled in the empty area in the image, 
I want to try and remove the telephone pole from the left side. To do this, we’ll 
create a new, empty layer and do the retouching on this layer. Then, we’ll activate 
the Clone Stamp Tool and make sure the Sample menu in the Options Bar is set to 
Current & Below.  We want to use the Clone Stamp Tool to copy from an area that 
does not include the pole or the pole’s shadow, so we’ll use the wall on the right 
side of the frame. We’ll hold down the Option key and click on that area to copy it. 
Then, we’ll paint over the pole area on the left. We’ll continue to sample areas to 
try and remove as much of the pole as possible. This helped in removing the pole, 
but the colors are not blended properly, so we’ll activate the Spot Healing Brush 
and use a hard-edged brush to paint over the area. 

The Clone Stamp Tool is being used to paint over the telephone pole, sampling from an area 
on the right side of the frame. 
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Tip: It can be useful to take the layer that you’ll be distorting and first turn it into 
a Smart Object. When a layer has been converted into a Smart Object, you can 
easily go back and change the adjustments made to it. For example, if you used 
Puppet Warp and then later decide you want to further adjust the warp, you can 
activate Puppet Warp and the same transform pins that you created before will 
still be there so you can further adjust them. To turn a layer into a Smart Object,  
make sure the layer is active and then go to the main menu and choose Layer > 
Smart Objects > Convert to Smart Object, 

 


