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Challenge Image: Fix Crop & Frame

In this lesson, we’re 
going to walk through 
a challenge image in 
which we’ll need to 
uncrop the image on 
one side and lighten 
up the gold frame so 
that it appears in equal 
brightness all the way 
around. In the process, 
we’ll cover how to flip 
images, work with layer 
masks and the use the 
Puppet Warp feature. 

Duplicate & Flip In the example image, the 
gold, oval frame is bright on the bottom and 
dark on the top. We’d like it to be bright all 
the way around so we’ll try to copy the bot-
tom part of the oval and flip it upside down, 
matching it up with the rest of the image. The 
first thing we’re going to do is duplicate the 
background/image layer by using the key-
board shortcut Command+J (Ctrl+J on Win). 
We want to flip this duplicate layer vertical-
ly so we’ll go to the Edit menu and choose 
Transform > Flip Vertical. 

In the challenge image above, our goal is to uncrop the left 
side of the image and lighten up the gold frame on the top.

We duplicated the image layer and 
then flipped it vertically.
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Compare with underlaying layer  Now we need to see if we can get this flipped 
version of the image to line up with the underlying, original image. When I need to 
get two layers to align, I usually will use a blending mode. With the top layer active, 
we’ll use the Blending Mode menu at the top of the Layers panel to change the 
blending mode to one of the “difference” modes (Difference, Exclusion, Subtract 
or Divide). These modes will take the active layer and compare it to the underlying 
layer. Wherever the two layers are identical, it will appear black. Wherever the two 
layers differ, there will be various shades of gray and/or colors. We’ll experiment 
with these four blending modes and find the one that allows us to best see what’s 
going on in both layers. In this example, it’s the Divide mode. 

We changed the blending mode of the top layer to one of the 
Difference modes, which allow us to see where the active layer 
differs from the underlying image. After experimenting with 
the four Difference modes, we found that the Divide mode 
worked best in this example.
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Scale to align  With the top layer set 
to the Divide blending mode, we’ll 
drag the layer around to see how 
close we can get the circular gold 
frame to match up with the layer 
beneath it. In order for the layer to 
be best aligned, it will require some 
scaling. To do this, we’ll go to the 
Edit menu and choose Free Trans-
form. Transform handles will appear 
around the layer and we can click 
and drag on these handles to scale 
the layer, trying to match the gold 
frame as best as possible with the 
gold frame in the underlying layer. 
If you ever need to drag one of the 
four corners independently of the others, as we need to do in this example, you 
can do so by holding down the Command key (Ctrl on Win) and dragging the cor-
ner. This will temporarily activate the Distort command. 

Reveal All  After flipping and 
moving the upper layer, part 
of that layer is now extending 
beyond the document edge. To 
expand the canvas to reveal the 
part that’s extending, we’ll go 
to the Image menu and choose 
Reveal All. This command will 
expand the canvas to make the 
document just large enough so 
that it includes everything that 
extended beyond the docu-
ment’s bounds. 

The Free Transform command is being used to 
scale and position the top layer so it matches the 
underlying image. We are holding down the Com-
mand key (Ctrl on Win) to move the top left cor-
ner independently of the other corners. 

The Reveal All command was used to expand the can-
vas to include all content that extended beyond the 
document bounds.
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Layer mask  Now, we only want to use the top half of the overlying layer. This is 
the part that contains the bright gold part of the frame. To hide the rest of the 
layer, we’ll use a layer mask. A layer mask can be added by clicking on the Layer 
Mask icon at the bottom of the Layers panel. (It looks like a white rectangle with a 
dark circle in the middle.) By default, the new layer mask will be completely white, 
which means the entire layer will be visible. In our case, we want the layer mask 
to start out completely black. This will hide the entire layer and we will manually 
paint in the areas we want to be revealed. To create a layer mask that starts out as 
completely black, hold down the Option key (Alt on Win) as you click the Layer 
Mask icon. After doing this, we’ll activate the Brush Tool, set the foreground color 
to white and then paint in the areas we want the layer to be visible. In our case, it’s 
the top half of the circular, gold frame. 

Merged visible duplicate  In the next stage of optimizing this image, we’ll need 
to flip a copy of the right side of the gold frame horizontally so that it fills in the 
parts that are missing from the left side of the frame. In order to do this, however, 

A black layer mask was added to the top layer, hiding the entire layer. Here, we are painting 
on the mask with white in order to reveal the top part of the layer. 



Challenge Image: Fix Crop & Frame © Ben Willmore, All rights reserved 6

we’ll need to use parts of both existing layers. To make things easier, we’ll create 
a merged visible duplicate of the two layers. A merged visible duplicate is a flat-
tened combination of all visible layers that is copied to a new, separate layer. We’ll 
hold down the Option key (Alt on Win), go to the Layer menu and choose Merge 
Visible. Alternatively, you could use the keyboard shortcut Option+Shift+Com-
mand+E (Alt+Shift+Ctrl+E on Win). We can now see a new layer at the top of the 
Layers panel that is a merged version of all the visible layers in the document. 

Repeat Duplicate/Flip The new, merged layer will now be flipped so that we can 
use the right part of the gold frame to fill in what’s missing from the frame on the 
left side. We’ll go to the main menu and choose Edit > Transform > Flip Horizontal. 
In order to line up the new, active layer with the underlying image, we’ll again use 
one of the difference blending modes, which can be accessed via the Blending 
Mode menu at the top of the Layers panel. In our case, the Divide blending mode 
seemed to work the best. Using 
this mode, we can see where the 
frame from the underlying image 
lines up with the active layer and 
we can position the active layer 
so that it aligns best. We can’t 
get the frame to perfectly line 
up simply by moving the layer, 
so we will need to transform it 
as well. We’ll go to the Edit menu 
and choose Free Transform in 
order to get the transform han-
dles to appear. Again, to move 
the individual free transform 
handles independently of one 
another, we’ll hold down the Command key (Ctrl on Win) and then drag a corner. 
We’ll then set the blending mode of that top layer back to Normal. 

The Free Transform command is being used to line 
up the left side of the gold frame. 
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Now the left side of the image is extending beyond the bounds of the document 
so we’ll again go to the Image menu and choose Reveal All. This will extend the 
canvas so that we can see the entirety of all the layers.  The top layer was added 
to fill in the left side of the gold frame and that’s the only part of this layer we want 
to be visible. We’ll hold down the Option key (Alt on Win) and click on the Layer 
Mask icon at the bottom of the Layers panel in order to add a layer mask to this 
top layer that is completely black. Again, whenever you have a black layer mask, 
the entire layer will be hidden. We’ll now need to activate the Brush Tool, set the 
foreground color to white and then paint in the area we want the gold frame to be 
visible (the left side of the document). 

Adjust Crop  Next, we need to use 
the Crop Tool to eliminate as much 
of the excess empty area surround-
ing the edges of the frame. We’ll 
drag in the crop handles in as much 
as possible without encroaching 
into the gold frame. Before hitting 
the Enter key to lock in the crop, 
we’ll look in the Options bar above 
the image window to see if the “De-
lete Cropped Pixels” check box is 
turned on. We want to make sure this is turned off so that we can come back and 
undo or readjust the crop if need be. Then we’ll hit the Enter key to make the crop 
handles go away.

Fill in edges  After cropping the image as much as possible, we still have some 
excess white space around the edges and we need to fill that in. The white space 
exists in three of the corners, but the fourth corner seems to look perfect. We’ll 
copy the content in that corner and use it to fill in the other corners. The intact 
corner is contained on the bottom layer, so we’ll start by duplicating that layer. To 
duplicate the layer, we’ll make sure it’s the active layer and then use the keyboard 
shortcut Command+J (Ctrl+J on Win). We’ll then drag this duplicate to the top of 

When cropping the image, we turned off the “De-
lete Cropped Pixels” check box so that we can go 
back and adjust the crop later if need be.
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the layer stack and then flip the layer horizontally by going to the Edit menu and 
choosing Transform > Flip Horizontal. The bottom left corner is now in the correct 
position, but we need to hide the rest of this duplicate layer. We’ll do that with a 
layer mask. Remember, to create a layer mask that starts off entirely black, we’ll 
hold down the Option key (Alt on Win) and click on the Layer Mask icon at the 
bottom of the Layers panel. Then, we’ll use the Brush Tool, with the foreground 
color set to white, and paint over the area of the layer we want to be visible (the 
bottom left corner). This will fill in the corner area and hide the empty white space. 
We’ll repeat this process for the other corners, filling in as much of the white space 
as possible. 

We duplicated and flipped the background layer so that we could use its intact corner to fill 
in the corner in the bottom left. A black layer mask was added, hiding the entire layer, and 
we are painting on the mask with white to reveal the layer and paint in the corner. 
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Touch up edges We have filled in the emp-
ty areas as best as we could, but there are 
still some white slivers along the edges of 
the frame. We’ll try to remove these with a 
retouching tool. We’ll create a new, empty 
layer at the top of the layer stack and apply 
the retouching on this layer. We’ll activate 
the Spot Healing Brush and make sure that 
the “Sample All Layers” check box is turned 
on within the Options Bar. (This will allow 
us to apply our retouching on an empty lay-
er.) Then, we’ll use the Spot Healing Brush 
to paint over the small, remaining areas of 
white. If there are any areas where the Spot 
Healing Brush doesn’t work effectively, then we’ll switch to the Clone Stamp Tool 
to manually fill in the areas. (If using the Clone Stamp Tool on an empty layer, make 
sure the Sample menu within the Options Bar is set to Current & Below.) 

Copy Merged At this point, we could call the image done, as the entire gold frame 
is now intact and of equal brightness on the top and bottom. However, the gold 
spikes on the left and right edges of the frame are slightly darker than the rest of 
the frame, so let’s look at a few more techniques that 
might help to fix this. We’re going to copy an area from 
another part of the gold frame and then warp it to fill 
in the left and right edges (the parts that are a little 
darker). To do this, we’ll first make a selection around a 
different part of the frame. The selection will be large 
enough to contain several of the gold spikes. We want 
to take this content and copy it to its own layer. The 
problem is that the selected content is made up of sev-
eral layers, so the Copy command would not be effec-
tive. Instead, we’ll go to the Edit menu and choose Copy 

The Spot Healing Brush is being used 
to touch up some of the areas along the 
edges of the frame.

A selection is made around 
part of the frame that we 
want to copy.
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Merged. Then, without deleting the se-
lection, we’ll go back to the Edit menu 
and choose Paste. This will paste the 
merged content back into the correct 
location and place it on its own layer. 
We’ll then reposition and transform 
this content so that it best aligns with 
the area we want to replace on the 
right side of the frame. 

Puppet Warp The curve of the frame that we copied is different from the curve we 
want to replace and the spikes on the frame are not angled correctly, so an addi-
tional technique will be required. We’ll set the blending mode of the top layer to 
Divide so that we can better see how it’s lining up with the underlying image. Then, 
we’ll go to the Edit menu and choose Puppet Warp. With Puppet Warp active, we’ll 
get a mesh overlay on the layer we’re warping. This mesh isn’t useful to us in this 
instance, so we’re going to hide it by turning off the “Show Mesh” check box that 
can be found in the Options Bar. Next, we’re going to click on the selected area in 

the places where we 
don’t want it to 
move. This will place 
pins, indicating that 
these points are 
locked in place. We 
can click and drag 
to reposition these 
pins before mov-
ing on to the warp 
stage. Then, we’ll 
click and drag the 
other parts of the 
layer to warp them 

The new layer 
is being repo-
sitioned over 
the part of the 
image we want 
to replace.

Left: You can turn off the Puppet Warp mesh via the setting in the 
Options Bar. Right: With Puppet Warp active, we are clicking to 
place pins in the areas we want to stay locked in place. 
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into place. When doing this, the selected area 
will warp, but the places where we added pins 
will stay locked in place. We’ll click and drag the 
gold spikes so that they line up with the gold 
spikes in the underlying image. When we’re sat-
isfied, we’ll hit the Return/Enter key to lock in the 
transformation and then set the blending mode 
of this layer back to Normal. If need be, we can 
add a layer mask to hide parts of this warped 
layer from showing up in certain areas.

Smart Objects It can often times be a good idea 
to convert a layer into a smart object before ap-
plying the Puppet Warp command. This will allow 
us to go back later and adjust the warp. To convert 
a layer into a smart object, go to the Filter menu 
and choose Convert for Smart Filters. Then, we 
can apply the Puppet Warp command and hit En-
ter/Return to lock in the transformation. Because 
the layer is a smart object, we can see a smart fil-
ter thumbnail show up below the layer thumbnail 
in the Layers panel. If we were to go back to the 
Edit menu and choose Puppet Warp, we will not 
be starting from scratch. Instead, all of the pins 
we previously positioned will be visible again and 
we can adjust the warp we currently have. If we 
hadn’t converted the layer into a smart object, we 
would be starting with a completely new warp.  

Using Puppet Warp, points are being 
added and repositioned, warping 
the selected area to match the curve 
of the frame.

When a filter is applied to a smart 
object, it appears as a smart filter 
within the Layers panel and the 
filter settings can be adjusted at 
any time.


