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Watermarking Images

In this lesson, we’re going to cover the various methods of watermarking your 
images. We’ll start in Lightroom, where we have automated ways of incorporating 
watermarks. We’ll then head to Photoshop to learn how you can have a little more 
control over the process.

Watermarking in Lightroom

When you create a watermark in Lightroom, the image itself will not change. You 
will not see the watermark on the image when you are previewing it. Instead, the 
watermark will be applied when we export the image, print the image or use it for 
other purposes.

To create a watermark, go to the Lightroom menu at the top of the screen and 
choose Edit Watermarks. (In Windows, this will be located under the Edit menu.) 
The Watermark Editor will appear on your screen. The image that was active when 
you opened the Watermark Editor will be the preview image and in the top right 
corner, you will find the setting where you can choose between a Text watermark 
or a Graphic watermark. 

The top of 
the Water-
mark Editor 
dialog is 
where you 
choose be-
tween a text 
or a graphic 
watermark.
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Creating a Text Watermark With 
the Text watermark style select-
ed in the upper right corner of the 
Watermark Editor, you can type in 
your custom watermark text. The 
settings on the right give you con-
trol over what the watermark looks 
like and when you make chang-
es to these settings, you will see 
those changes reflected in the wa-
termark preview on the image. The 
Text Options settings allow you to 
choose the font, font style, align-
ment and color. You can also add 
a drop shadow to the watermark 
text by turning on the Shadow 
check box within the Text Options. 
The sliders will give you control 
over the opacity of the drop shad-
ow, the offset (how far away from 
the text it is), the radius (how soft 
the edge of the shadow is) and the 
angle (the direction of the shadow 
in relation to the text). 

The Watermark Effects settings give you a different set of controls. The Opacity 
slider controls how transparent the watermark is. The size settings allow you to 
choose between Proportional, Fit and Fill. Choosing Proportional will allow you to 
use the coordinating slider to determine the size and then that size will be scaled 
proportionally within every image the watermark is placed on. The Fit setting will 
make the watermark fit the horizontal width of the image and the Fill setting will 
make the watermark fit the vertical height of the image. The inset sliders will de-

The text for the watermark is typed in below the 
image preview and then the Text Options are be-
ing used to specify the font and drop shadow.
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termine how far the watermark will be separated from the horizontal and vertical 
edges of the image. The Anchor setting will determine where the watermark will 
be positioned. I like to save four watermark presets, where the anchor point is lo-
cated in each of the four corners of the image. To save your watermark settings as 
a preset, click on the menu in the upper left corner of the Watermark Editor and 
choose Save Current Settings as New Preset. You’ll be prompted to give the new 
preset a name and then click Create. Then, your new preset will be available in that 
menu in the upper left. The Rotate buttons will allow you to rotate the watermark 
90 degrees in each direction. This can be useful if you would like the text to run 
vertically along one of the left or right edges. 

Creating a Graphic Watermark You may decide to use 
a graphic watermark instead of a text one. This may be 
your logo or a custom watermark you created in a dif-
ferent program. To do this, click the Graphic watermark 
style in the upper right corner of the Watermark Editor. 
You’ll be prompted to navigate your hard drive to the 

Left: The Watermark Effects settings. 
Above: We are using the Inset slid-
ers to specify how far the watermark 
should be separated from the edges 
of the image.

A graphic watermark is be-
ing used here.
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location where the graphic file is stored and click the Choose button. Note that 
the graphic must be a jpg file or a png file. After selecting your graphic, it will be 
placed on the preview image within the Watermark Editor and additional settings 
will appear on the right. The Text Options settings will be unavailable because the 
watermark is a graphic. The Watermark Effects settings will be the same as the 
settings for creating a text watermark, including settings for Opacity, Size, Inset 
and Anchor. 

Watermark presets  We men-
tioned earlier that you can 
save watermark presets by 
choosing the preset option 
within the menu in the upper 
left corner of the Watermark 
Editor. After creating presets, 
they can be accessed in many 
different areas of Lightroom. 
One of these locations is with-
in the Export dialog. 

Watermarking in the Export Dialog To export a selected image, go to the File 
menu and choose Export. The Export Dialog contains many expandable settings 
tabs and one of them is for Watermarking. When this tab is expanded, there is a 
Watermark checkbox. Turn on the checkbox to access the menu containing all of 
the watermark presets you have created. When you export the image (or imag-
es), the chosen watermark will be included. The Watermark menu also contains 
an “Edit Watermarks” option, which will bring you back to the Watermark Editor. 
There, you can edit or create new watermarks. 

Within the Export Dialog, the list on the left side of the box contains all of the export 
presets. An export preset is basically a saved group of settings that tells Lightroom 

The Preset menu in the upper left corner of the Water-
mark Editor.
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how the image should be exported. You can include a watermark within an export 
preset so the watermark is placed on the image with all of your other desired set-
tings (resolution, size, file format, etc.). To create an export preset, work through all 
of the settings tabs on the right side of the Export dialog, specifying exactly how 
the image should be exported. Then, click on the Add button at the bottom of the 
preset list on the left. You’ll be prompted to give the new preset a name and then 

The Export dialog is shown above. We are choosing to export with a watermark by turning 
on the Watermarking checkbox and using the menu to select a watermark preset.
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click the Create but-
ton. After doing this, 
the new export preset 
will be included within 
the User Presets cate-
gory in the list on the 
left side of the Export 
dialog. After saving 
some export presets, 
you don’t need to re-
turn to the Export dia-
log when exporting an 
image. Instead, select 
the image you want to 
export, go to the File 
menu and choose Ex-
port with Preset. A fly-
out menu will appear 
that includes all of the 
export presets you 
have created. 

Watermarking in the Print Module Lightroom’s Print Module can be accessed by 
clicking the Print option in the upper right portion of the interface. In the Print 
Module, all of the print settings can be found within panels on the right side of the 
interface. The Watermarking option is located within the Page panel. Turn on the 
Watermarking check box to access the menu that contains all of the watermark 
presets you have created. Just like when exporting an image, you can include a 
watermark within a print preset (known as a Template). To create a print preset, 
click on the little plus sign to the right of the Template Browser panel header on 
the left side of the interface. 

When exporting with a preset, you don’t need to open the Ex-
port dialog. Simply go to the File menu and choose Export with 
Preset. The list of export presets will appear in a menu. 
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Watermarking in the Slideshow Module 
Lightroom also allows you to display a wa-
termark on your images as you are playing 
a slideshow. The Slideshow Module can be 
accessed by clicking the Slideshow option 
in the top right portion of Lightroom’s in-
terface. Just like in the Print Module, all of 
the settings relating to the slideshow are lo-
cated within panels on the right side of the 
interface. The Watermarking option can be 
found within the Overlays panel. Once the 
Watermarking checkbox is turned on, you 
will have access to the menu that includes 
all of the watermark presets you have creat-
ed. You can save slideshow presets and in-
clude a watermark within one of those pre-
sets. To save a slideshow preset, first specify 
all of the slideshow settings (including any 
watermarks) by using the settings on the 
right side of the interface. Then click the lit-
tle plus button ( + ) to the right of the Tem-
plate Browser heading on the left side of the 
interface. 

Watermarking in the Web Module  Lightroom’s Web Module is used for creating 
web sites that display a selected set of images. Watermarks can be added to these 
images as well. In the Web Module, the watermarking settings can be found under 
the Output Settings panel and it is the same menu (containing watermark presets) 
that is found in all of the other areas mentioned above. 

In the Slideshow Module, we’re choosing 
a watermark preset within the Overlays 
panel.
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Watermarking within the Publish Services Lightroom’s publish services allow you 
to export your images directly to places like Facebook, Flickr, etc. Watermarking 
can be applied to your images when exporting using these publish services. The 
Publish Services panel can be found on the left side of the interface when in the 
Library Module. If you have a publish service set up, right-click on it and choose 
Settings from the menu that pops up. The Publish Service settings dialog will ap-
pear and it will contain settings very similar to the Export settings, including the 
Watermarking tab. Here, you can specify which watermark preset you would like 
to use for the chosen Publish Service. 

The Publish Services panel can be found on the left side of Lightroom’s interface while in the 
Library Module. Right-click on a publish service and choose settings to get this Lightroom 
Publishing Manager dialog. Here, we are selecting a watermark from the preset menu.
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Watermarking workflow  Let’s say you need to export a series of images where 
the watermark will not appear in the same location in every photo. The following 
is a workflow that could potentially streamline this process. Note that this process 
will rely on your having created different presets for placing the watermark in each 
of the four corners of an image. First, place all of the images you would like to ex-
port into a Quick Collection. (You can quickly add a selected image to the Quick 
Collection by tapping the B key.) Then, drag the images so that they are in order 
based on where the watermark should appear. For example, drag all of the images 
that should have a lower right watermark to the beginning of the Quick Collection. 
Then, drag all of the images that should have a lower left watermark so they appear 
next, and so on. You basically just want the images that should have similar water-
marks to be grouped together within the Quick Collection. Select the first series 
of images (the ones that should have watermarks in the same location) and then 
go to the File menu and choose Export with Preset. Choose the preset with the 
desired watermark location from the preset list that appears in the fly-out menu. 
Now that those images have been exported, you can remove them from the Quick 
Collection by selecting them and then tapping the B key. Next, select the next se-
ries of images that should have a watermark in the same location and follow the 
same procedure. Eventually, the entire Quick Collection will be cleared and all of 
the images will have been exported with watermarks in the appropriate locations. 

Use the watermark feature to create a border effect  Let’s look at how we can use 
Lightroom’s watermarking feature to create a border effect on your images. We’ll 
first need to create a graphic in Photoshop to use as the “watermark.” In Photo-
shop, we’ll create a new document that is a perfect square (7” x 7” for example). 
That’s because the image we want to apply this border effect to is also a square. 
Then, we’ll use the Rectangular Marquee Tool to make a selection around the cen-
ter part of the image, about a quarter of the way from the edge of the frame to 
the center of the frame. We’ll go to the Select menu and choose Inverse, which will 
give us the opposite (a selection of the edges) and then we will fill that selection 
with a color by going to the Edit menu and choosing Fill. In the video example, we 
chose to fill the selection with White and then we clicked OK. We deselected the 
frame by going to the Select menu and choosing Deselect.
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Now we want to distort the edge of the 
frame we just created in order to give it a 
textured look. We’ll go to the Filter menu 
and choose Distort > Twirl. We’ll adjust the 
Angle slider and then click OK. Note that 
you can play with the different Distort filters 
in order to get different styles for the edges 
of this frame and you can also use multiple 
filters. You basically want to create an inter-
esting frame that you’d like to place around 
your images. In the video example, we also 
used the Gaussian Blur filter in order to soft-
en the edges of the frame and we lowered 
the opacity so that it wouldn’t completely 
obscure the view of the underlying photo. 

When we’re done creating the frame, we’ll go to the File menu, choose Save As 
and then save the document as a png file. Back in Lightroom, we’ll select the 
square image that we want to apply the border effect to. Then, we’ll go to the 
Lightroom menu and choose Edit Watermarks. (In Windows, this can be found 

Left: We made a selection just inside the edges of the document. Center: we inversed the 
selection and filled it with white. Right: We are applying the Twirl filter. 

This is the frame after we applied the 
Twirl filter.
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under the Edit menu.) We’ll choose the Graphic Watermark style in the top right 
corner of the Watermark Editor and then select the frame file we just created as 
the graphic. We’ll set the Size option to Fit or Fill and tweak the Opacity slider if 
necessary. We’ll then use the menu in the upper left to save the settings as a new 
watermark preset. Finally, we can select our square image (any square image) and 
export using the new watermark preset. 

The previous technique used a set of filters to create a border effect on a square 
image. Note that you can create a border for any size image you’d like. You just 
need to know the proportions before creating the border. Additionally, you can 
use any techniques you can think of to create an interesting border effect. We just 
used the filters as a quick and easy solution. 

In the Watermark Editor, we chose the Graphic watermark style and then selected the frame 
graphic we just created. 
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Watermarking in Photoshop

A logo or graphic can be used as a watermark, but in order for that to work, the 
graphic must have no background. Any part of the document that does not con-
tain part of the graphic needs to be transparent. Let’s look at how to remove the 
background on a graphic. 

Removing the background on a black and white graphic If the logo is solid black 
on a white background, the task will be fairly easy. We’ll first need to adjust the 
image to make sure that the white area is truly white and the black area is truly 
black. We can do this by going to the Image menu and choosing Adjustments > 
Levels. If the Levels chart shows any humps or spikes that are not on the far ends 
of the chart, that means there’s a part of the image that isn’t truly white or truly 
black. If there are parts that aren’t solid white, we’ll drag the white slider (the one 
on the right below the Levels chart) to the left until those areas become solid 
white. If there are areas that are not solid black, we’ll drag the black slider (the 
one on the left below the Levels chart) to the right until those areas become per-
fectly black. Then we’ll click OK.

A Levels adjustment is being used to make sure that this document contains only solid white 
and solid black. 
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Next, we’ll want to select the entire picture by going to the Select menu and 
choosing All. Then, we’ll go to the Edit menu and choose Copy. We’ll hit the Q 
key to enter Quick Mask Mode, but there will be no visual indication that we are in 
Quick Mask Mode because the entire image is selected. If there were any areas of 
the image that were not selected, those areas would have a red overlay in Quick 
Mask Mode. We’ll go to the Edit menu and choose Paste and then we’ll tap the 
Q key again to exit Quick Mask Mode. In the end, all of the areas that are solid 
white will be selected. This is actually the opposite of what we want so we’ll go 
to the Select menu and choose Inverse. With the black part of the logo selected, 
we’ll click on the Adjustment Layer icon at the bottom of the Layers panel and 
choose a Solid Color layer. This will create a new layer for the logo and it will bring 
up the Color Picker, where we can decide what color the logo should be (we can 
always go back and change it at any time). Now we can throw away the original 

After we make a selection around the graphic, a Solid Color layer was created and we are 
using the Color Picker to choose the color for the graphic. 
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image layer because we no longer need it. This will leave us with only the logo on 
a transparent background. Lastly, we’ll go to the Image menu and choose Trim. 
This will crop the image as tightly as possible so that it only contains the graphic 
and none of the surrounding empty space. 

After removing the background on a graphic, you’ll need to save it in a file format 
that supports transparency. The png file format is good for this. Lightroom allows 
you to use watermarks in the jpg format and in the png format. If the watermark 
was created from a photograph, it’s best to use the jpg format. If the watermark 
was created from a graphic, like the one in this example, it’s best to use the png 
format. 

The original graphic layer was discarded, leaving only the solid color layer that’s being used 
to create the logo. 
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Removing the background on a multi-colored graphic  When you need to remove 
the background on a graphic that is not black and white, the process will be a lit-
tle different. Let’s look at how to remove the background a multi-colored graphic. 
We’ll start by duplicating the background layer by using the keyboard shortcut 
Command+J (Ctrl+J on Win) and then we’ll turn off the visibility for the bottom 
layer. We duplicate the layer so that we can retain the original colors of the graph-
ic. We want to remove color from that top layer, so we’ll make sure it’s active in the 
Layers panel and then we’ll go to the main menu and choose Image > Adjustments 
> Desaturate. We will now follow a similar process to the previous technique in 
order to make the image perfectly black and white, with no gray areas. We’ll go to 
the Image menu and choose Adjustments > Levels. In the Levels dialog, we’ll use 

the black and white 
sliders directly be-
neath the chart, drag-
ging them toward the 
center enough to re-
move any gray areas. 
We want the graphic 
to contain only solid 
black and solid white. 
After achieving this 
as closely as possible, 
we’ll click OK. If there 
are any dark areas left 
that are not part of the 
graphic, as we have in 
the video example, we 
can use the Brush Tool 
and paint with white 
over those areas. 

A Levels adjustment was made to ensure the image was made 
up of only solid black and solid white. You can see the before 
and after view above.
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Now that the image contains only solid black and solid white, we can follow the 
same process used in the previous technique. We’ll select the contents of the 
entire document by going to the Select menu and choosing All. We’ll then go to 
the Edit menu and choose Copy. We’ll tap the Q key to enter Quick Mask Mode 
and then go back to the Edit menu and choose Paste. We’ll exit Quick Mask Mode 
by tapping the Q key again. The white part of the document will be selected and 
that’s the opposite of what we want so we’ll go to the main menu and choose 
Select > Inverse. The graphic is now selected, but we want it to have its original 
colors. We’ll throw away the top layer by dragging it to the trash can icon at the 
bottom of the Layers panel and then we’ll turn on the visibility of the background 
layer. With the graphic selected, we’ll add a layer mask by clicking the Layer Mask 
icon at the bottom of the Layers panel. This will hide all areas of the document 
that don’t contain the graphic, so we end up with our logo on a transparent back-
ground.  

We can now go to the Image menu and choose Trim. This will be the test as to 
whether we truly made sure the entire background area was white. If Photoshop 
does not trim the document to contain just the logo, it means there are some 
non-transparent pixels out there. One way of finding them would be to view the 
layer mask in the main image window. Do this by holding down the Option key 
(Alt on Win) and clicking on the layer mask thumbnail. If you see any white spots 
(other than the logo), you can paint on them with black to clean up the mask. 

Add Outer Glow to increase separation After isolating a graphic designed to be 
a watermark, you might want to add an effect that will make the graphic separate 
from the image you place it on. In Lightroom, we had the option of adding a drop 
shadow, but there are more options when using Photoshop. Here, we’re going to 
apply an Outer Glow effect. We’ll make sure that the layer containing the logo 
is active and that the image itself is active (not the mask). You can tell whether 
the layer or the mask is active because the thumbnail will be surrounded by little 
white brackets. Then, we’ll click on the FX icon at the bottom of the Layers pan-
el and choose Outer Glow from the menu that pops up. The Layer Styles dialog 
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will appear, giving us the options for the Outer Glow effect. For the use as a wa-
termark, we’ll change the Blend Mode menu to Normal. We’ll click on the color 
swatch to call up the Color Picker and we’ll choose a yellowish color and click OK. 
Then, we’ll play with the size and opacity settings, looking at the preview to make 
sure it looks ideal. We’ll click OK. 

Now, because we cropped the image before applying this effect, we likely have 
part of this outer glow being cut off by the edges of the document. If you ever 
think this could be the case, go to the Image menu and choose Reveal All. This 
will make the document larger to include anything that’s extending beyond the 
bounds. 

An Outer Glow effect is being applied to this graphic. We accessed these settings by activa-
tion the graphic layer, clicking on the FX icon at the bottom of the Layers panel and choos-
ing Outer Glow from the menu that appeared. 
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Applying watermarks in Photoshop Photoshop’s Libraries Panel gives you a 
place to store commonly-used elements, such as graphics. If you have different 
graphics that you frequently use for watermarks, it can be convenient to store 
them here. If the Libraries Panel is not already open on your screen, go to the 
main menu and choose Window > Libraries. To add a graphical element to your 
library, simply drag it from the document window into the Library panel. It will 
remain in the Library so you have access to it when working on any image. To add 
the watermark to a photo, drag the graphic from the Libraries panel directly into 
your image. Free transform handles will appear around the graphic so that you 
can scale it down and position it where you like. Hit Return/Enter to lock in the 
transformation. 

Above: This graphic had been placed into the Library 
and was dragged from the Libraries panel into the im-
age. Initially, it’s scaled to the size of the image. Right: 
We are using the Free Transform handles to scale the 
graphic down to a watermark size. 
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Adding color to a black or white logo You can add color to a black or white 
graphic by using a Solid Color adjustment layer. With the logo layer active, we’ll 
click on the Adjustment Layer icon at the bottom of the Layers panel and choose 
Solid Color from the menu that 
pops up. We’ll use the Color 
Picker to determine what col-
or we’d like the logo to be and 
then click OK. The color will fill 
the document and we need it 
to appear only on the logo. To 
achieve this, we’ll create a clip-
ping mask, which will only al-
low the active layer to appear 
where there is content in the 
layer beneath it. With the Sol-
id Color layer active, we’ll hold 
down the Option key (Alt on 
Win) and hover our cursor over 
the line between the color lay-
er and the logo layer. When the 
cursor turns into a square with 
a down-pointing arrow next to 
it, we’ll click the mouse button. 
This will make the solid color fill 
the logo and nothing else. Just 
note that if you want to add any 
additional effects to the logo, 
the graphic layer must be active 
and not the solid color layer. 

Top: A Solid Color layer was created and we are using 
the Color Picker to choose the color of the logo. Middle: 
The Solid Color layer is being clipped to the logo layer. 
Bottom: The Solid Color layer is being used, in conjunc-
tion with a clipping mask, to change the color of the logo 
layer. 
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Adding watermarks with the Brush Tool  The Brush Tool can also be used to 
add a watermark to an image. We’ll first have to create a brush preset based on 
the logo/graphic file. To do this, we’ll 
open the logo file, go to the Edit menu 
and choose Define Brush Preset. This 
will turn the graphic into a brush that 
we can paint with. We’ll be prompt-
ed to give the Brush a name and 
then click OK. Now, we can choose 
the new brush from the Brush Preset 
menu within the Options Bar and use 
it to add the watermark to an image. 
We’ll likely need to scale the brush 
using the left and right bracket keys 
so that it is a desirable size and then 
click once to “stamp” on the logo. 

Automate the watermarking process with Actions  We can create an action 
within Photoshop in order to automate the watermarking process. If the Actions 
panel is not already viewable on your screen, you can access it via the Window 

menu. We’re going to create a folder 
in the Actions panel for all of our wa-
termark actions. To do this, we’ll click 
on the folder icon at the bottom of the 
Actions panel, we’ll name the folder 
“Watermarks” and then click OK. Now, 
because we’re going to use the Brush 
Tool to create the watermark, we need 
to click on the little side menu in the 
top right corner of the Actions pan-
el and choose “Allow Tool Recording” 
from the menu that appears. We also 
need to set our rulers to show percent-

With the graphic file open, we went to the 
Edit menu and chose Define Brush Preset. This 
dialog appeared and we are giving the brush a 
name.

We’re creating a new folder within the Actions 
panel by clicking on the folder icon and giving 
the new folder a name.
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ages and not size units. This will ensure that 
the watermark is placed in the same location 
in proportion to the size of the document it’s 
being added to. If the rulers are not already 
visible around your image window, go to the 
View menu and choose Rulers. Then, right-
click on the ruler above or to the left of your 
image and choose Percent from the menu 
that pops up. 

With the Watermarks folder active, we’ll click the New Action icon at the bottom 
of the Actions panel. We’ll name the action based on the graphic we’re going to 
use and the location in which it will be placed in the image and then we’ll click the 

Record button. Photoshop will now 
pay attention to every step we make 
so that it can apply the same steps to 
another image at a later time. We need 
to set our foreground color to the col-
or we want the watermark to be. Even 
if the foreground color is already cor-
rect, we still need to complete this 
step, clicking on the foreground color 
icon at the bottom of the Toolbar and 
selecting the appropriate color in the 
Color Picker. If we don’t complete this 
step, then the action will use whatev-
er foreground color is active when the 

action is applied and that color may vary in the future. Next, we need to select 
the appropriate Brush Preset that will be used to create the watermark. Again, we 
need to complete this step even if the watermark brush is already active. That’s 
because when the action is used in the future, Photoshop will use whatever brush 
is active at the time (if we don’t specify a brush). Then, we’ll set the size and 

We’re telling the rulers to measure by 
Percent by right-clicking on the ruler 
and choosing Percent from the menu 
that pops up.

To create a new action, we clicked the New 
Action icon at the bottom of the Actions panel, 
gave the action a name and then clicked OK. 
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opacity of the brush by using 
the settings in the Options 
Bar above the main image 
window. We can now click 
with the Brush Tool in the lo-
cation we’d like to place our 
watermark. Lastly, we’ll click 
the Stop button at the bot-
tom of the Actions panel to 
stop recording the action. 

Applying an action to several images at once To apply the watermark action to 
several images at once, we’ll start in Adobe Bridge. In Bridge, we’ll select all of the 
images we’d like to apply the watermark to and then go to the Tools menu and 
choose Photoshop > Image Processor OR Photoshop > Batch. The Batch option will 

simply apply an action to 
the image and then save 
the picture.  The Image 
Processor option will be 
able to do much more 
than that. It will not only 
apply the action, but we 
can also specify the file 
format and whether the 
image should be scaled 
as well. We’ll choose the 
Image Processor option 
and the dialog will ap-
pear, containing several 
settings. We can ignore 
the settings under step 
number one. Under step 

Above, you can 
see the steps taken 
to create the wa-
termark inside the 
Actions panel. It’s 
important that you 
include the “Set 
Foreground Col-
or” step as well as 
the “Set Current 
Brush” step.

Above, you can see the settings available within the Image 
Processor dialog.
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number two, we can decide whether we’d like the images to be saved in the same 
location or in a new location that we specify. The settings under step three allow 
us to choose the file format and decide whether we’d like the image to be scaled 
to specific pixel dimensions. Step four is where we specify the action that should 
be run on the images. We’ll first click on the left dropdown menu and choose the 
Watermarks folder we created. Then we’ll click on the right dropdown menu and 
choose the specific watermark action to use. After specifying all these settings, 
we’ll click the Run button. Photoshop will then watermark all of the selected im-
ages, scale them if applicable and save them in the location we specified.

Had we chosen the Batch command (instead of the Image Processor), we would 
get a dialog box that allows us to choose the action that should be run as well as 
the location the images should be saved in.

The Batch dialog allows you to choose an action to be applied and specify where the result-
ing files should be saved. 


