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This vs. That

There are many features in Photoshop that seem to perform similar functions and 
in this lesson, we’ll talk about the differences in these sets of functions and why 
you’d want to use one over the other when processing your images. 

Opacity vs. Flow

When you are working with a tool that uses a brush, you will find the Opacity and 
Flow settings in the Options Bar above the image window. 

When we paint with the Opacity setting turned down, we can paint over the 
same areas again and again without our “paint” building up. In order for the paint 
to build up, we’d have to release the mouse button and start painting again. 

The Flow setting is more like using spray paint. When our strokes overlap, the 
paint WILL build up and get darker and darker. This happens in a single stroke. 
We do not need to release our mouse button and start painting again in order to 
achieve the build-up. 

You’ll want to use the Flow setting when you want the paint to build up as you 
paint back and forth. You’ll want to use the Opacity setting when you don’t want 
the effect to build up. I find that I use the Opacity setting more frequently be-
cause I tend to overlap my brush strokes when I don’t mean to. It’s also import-

At left, we are using the Brush Tool with the Opacity setting at 20%. No matter how many 
times we brush over the same area, the paint will never build up. At right, we are using the 
Brush Tool with the Flow setting at 20% You can see that as the stroke overlaps itself, the 
paint builds up more and more.
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ant to know that the number that you’d use for Flow will always be lower than 
the number you’d usually use for Opacity. That’s because it will require a much 
lower Flow setting to achieve the same level of opacity as the Opacity setting. 

By default, the paint will not con-
tinue to build up if you keep your 
cursor in one position while hold-
ing the mouse button down. If you 
would like that to be the case, turn 
on the Airbrush setting by clicking 
the icon directly to the right of the 
Flow setting. 

Opacity vs. Fill

At the top of the Layers panel, we 
have settings for Opacity and Fill. At 
first glance, these two seem to do 
the same things. Let’s look at how 
they’re different. 

The Opacity setting affects the total 
contents of the layer, including both 
the pixels and any effects applied to 
the layer. The Fill setting affects only 
the pixel contents of the layer, wheth-
er that be paint, a photograph, etc. It 
does NOT change the effects applied 
to the layer. Those will remain at full 
strength.  

Therefore, if there are no effects ap-
plied to a layer, then Fill and Opacity 
will work exactly the same. If there 

The Airbrush setting will cause the paint to build 
up if you hold your mouse in one position with the 
button pressed down.

Here, we created two identical layers containing 
red circles. On the left circle, we lowered the Fill 
setting to 50% and on the right circle, we low-
ered the Opacity setting to 50%. You can see 
that the effect is identical. 

A Bevel & Emboss style is applied to both layers. 
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are effects applied, like the Bev-
el and Emboss Layer Style ap-
plied in the video example, then 
lowering the Fill setting will 
leave the effect created by that 
style perfectly in place while the 
actual contents of the layer will 
become more transparent. 

Invert vs. Inverse

Any time we refer to the Inverse command, we’re talking about something that 
we’d do to a selection. When we have a selection active and we go to the Select 
menu and choose Inverse, we will get the opposite of the selection we created. 
This means that if we had a circular selection in the middle of the document and 
we used the Inverse command, we would end up with a selection that includes 
everything except the middle of the document. If we don’t have an active selec-
tion, the Inverse command will not be available under the Select menu. 

The Fill setting was set to 50% on the left circle and 
the Opacity was set to 50% on the right circle.  

Left: We have a circular selection in the center of the document and we are choosing the In-
verse command. Right: The Inverse command gave us the opposite of our original selection. 
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The Invert command can be found by going to the main menu and choosing Im-
age > Adjustments > Invert. This command will also give us the opposite of what 
we currently have, but instead of affecting a selection, it will affect the image it-
self. It will turn the image into a negative of what it currently is. If the entire layer 
is filled with white and we use the Invert command, we will get an entire layer full 
of black. 

There is an instance where the Invert and Inverse commands will do the same 
thing, and that is when we view our selection in Quick Mask Mode. When we view 
an image in Quick Mask Mode, our selection is represented as a red overlay. If we 
use the Invert command in this mode, we will get the opposite overlay, and this is 
essentially giving us the opposite of our selection. 

Left: We are choosing the Invert command from the Image menu. Right: The Invert command 
gave us a negative of our image. 

When viewing a se-
lection in Quick Mask 
Mode, the Invert 
command would have 
the same effect as 
the Inverse command, 
in that it’s making a 
change to a selection. 
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Crop vs. Trim

Under the Image menu, we have settings for both Crop and Trim. If we have a 
selection active, both of these options will be available. If we do not have a se-
lection active, the Crop command will not be available. That’s because the Crop 
command will crop the image down to what we currently have selected. If there 
is not a selection, it doesn’t know what to do. 

When we have a selection active and we choose the Crop command, it will crop 
the image into the smallest rectangular document that will contain just the se-
lected area. 

When we choose the Trim command from the Image menu, we’ll be presented 
with some settings. One of the options will crop out all transparent pixels. With 
the other two options, Photoshop will look at what color is occupying either the 
top left pixel or the bottom left pixel and crop the image to remove as much of 
that color as possible. The problem with Photoshop referencing a single pixel is 
that most images, even those containing mostly a single shade, will vary from 
pixel to pixel. This makes the two corner options unusable UNLESS we’ve done 

At left, we have the mug se-
lected and we are choosing the 
Crop command. Above, the im-
age was cropped to the smallest 
rectangle that contains the mug.
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something to the picture first. In the video example, the image layer had a layer 
mask attached to it that made it so only the object (a coffee mug) was visible on 
the layer. A solid color layer was placed underneath the mug layer. In this case, 
the corner trim option would work in cropping everything except the mug be-
cause the solid color layer contains pixels of only one color. 

With the 
image at left, 
using the Trim 
command 
based on one 
of the corner 
pixels would 
not work. 
That’s because 
the back-
ground color 
varies slightly, 
so the pixels 
will vary in 
color.  There is 
also a slice of 
brown in the 
bottom right. 

We altered 
the image, 
creating a 
layer mask for 
the mug layer 
and inserting 
a solid color 
underneath, so 
the Trim com-
mand would 
work using the 
top left or bot-
tom right pixel 
setting.



This vs. That © Ben Willmore, All rights reserved 8

Layer Mask vs. Vector Mask

A layer mask is a grayscale picture at-
tached to a layer where areas of the 
mask that are white leave the layer 
alone and areas that are black hide the 
layer. To create a layer mask, first make 
sure that the layer you want to attach 
the mask to is active. Then click the Lay-
er Mask icon at the bottom of the Layers 
panel. It looks like a rectangle with a cir-
cle inside of it. If you have a selection active when you do this, the selection will 
automatically be applied to the mask, where everything that was selected will be 
white (visible) and everything that was not selected will be black (hidden). 

On first glance, a vector mask looks like 
a layer mask, but the difference is that 
the mask is NOT a grayscale picture 
attached to a layer. It is a path, which 
is something that can be adjusted us-
ing the Path Selection Tool and the Di-
rect Selection Tool. We would use these 
tools to adjust the points and handles 
attached to the path (as opposed to ed-
iting the mask with the Brush Tool, as 
we would with a layer mask). To create 
a vector mask, we need to start with an 
active path.  When you create a shape 
using either the Shape Tool or the Pen 
Tool, there will be a menu on the left 
side of the Options Bar where you can 
determine what kind of result you’d like. 
The options are Shape, Path and Pixels. 
We will choose the Path option. Once 

We had a selection active at the time we 
clicked on the Layer Mask icon, so the selec-
tion was automatically applied to the mask, 
as you can see from the mask thumbnail in 
the Layers panel.

We created an active path using the Shape 
Tool and when we added a vector mask, the 
path was automatically applied to the mask.

The Path Selection Tool is being used to 
alter the path. 
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we have defined a shape, either using the 
Pen Tool or the Shape Tool, we can go to 
the Layer menu and choose Vector Mask > 
Current Path.  

In summary, a layer mask uses pixels, and we would use our common retouching 
tools to make changes to the mask. A vector mask uses a path, which can be 
changed by adjusting the points and handles attached to the path. You can think 
of creating a path as using a pair of scissors that give you a very crisp edge. 

Note that if you have the Command Key (Ctrl on 
Win) held down as you click on the Layer Mask 
icon, you will get a vector mask instead of a lay-
er mask. Additionally, if you click on the Layer 
Mask icon twice, you will get a vector mask in 
addition to a layer mask. 

Layer Effects vs. Layer Styles

When it comes to layer effects and layer styles, 
Adobe uses both terms interchangeably. We 
see the different terms in different areas of Pho-
toshop. For example, the Layer Style icon at the 
bottom of the Layers panel is labeled “FX.” To 
add a layer style, click on this icon and choose 
one of the menu options. The Layer Style dialog 
will appear, showing the settings for the spe-
cific menu option you chose. You can also ac-
cess the Layer Style dialog by going to the main 
menu and choosing Layer > Layer Style. Some 
of the options within this Layer Style menu use 
the word effects (Hide All Effects, Scale Effects) 
and it’s important to know that layer styles and 
layer effects are the same thing. 

The tools we use to change a path.

If we click on the Layer Mask icon 
twice, we can end up with a vector 
mask in addition to a layer mask.

A Layer Style, or Layer Effect, can 
be added by clicking the FX icon at 
the bottom of the Layers panel and 
choosing one of the options from 
the pop-up menu.
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Assign Profile vs Convert to Profile

Under the Edit menu in Photoshop, there are choices for “Assign Profile” and 
“Convert to Profile” and they both have to do with color management and color 
spaces. Let’s look at the difference. 

At the bottom of the Photoshop interface, there is an info bar that displays in-
formation about our document. If it does not already display the document’s 
color profile, we can tell it to do so by clicking on the little arrow to the right of 
the text and choosing Document Profile from the menu that pops up. If we need 

to change the document’s color 
profile, we can do that by using 
the  “Assign Profile” or “Convert to 
Profile”  settings. 

If we choose the “Convert to Pro-
file” option, a dialog will appear 
and the main setting that we’ll 
want to deal with inside this dia-
log is the Destination Space menu. 
This will determine what the new 
color space will be. If we use this 
“Convert to Profile” option, it will 
maintain the current appearance 
of the image. It will simply con-
vert the color profile. 

If we choose the “Assign Profile” option from the Edit menu, we will get a dialog 
that includes a Profile menu. Choosing one of the options within this menu WILL 
change the appearance of your image. For this reason, I would only use this op-
tion if the image did not have a profile at all to begin with. In that case, the info 
bar at the bottom of the Photoshop interface would read “unassigned.” 

The info readout at the bottom of our Photoshop 
interface can be set to display the color space. 

The Convert to Profile dialog. This command will 
not change the look of our picture.


