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High Pass Sharpening

In this lesson, we’re going to learn how to sharpen our images using a technique 
called high pass sharpening. We’ll also look at how this technique relates to the 
Unsharp Mask filter. 

The High Pass filter can be accessed by going to the main menu at the top of 
the interface and choosing Filter > Other > High Pass. When the High Pass dialog 
pops up, you’ll find a Radius slider at the bottom. If you drag the slider all the way 
to the left, you will get solid, 50% gray. As you increase the radius, you’ll start to 
see more and more detail in the preview window. 

The High Pass filter is actually directly related to the Gaussian Blur filter. When 
we apply the Gaussian Blur filter, we increase the radius slider to remove more 
and more detail from the image. The detail that is being removed when using the 
Gaussian Blur Radius slider is the same detail that is being added when using the 
High Pass Radius slider. 

To sharpen an image using the High 
Pass filter, we’ll first need to duplicate 
the image layer. To do this, I like to use 
the keyboard shortcut Command+J 
(Ctrl+J on Win). Then, with the top lay-
er active, we’ll go to the Filter menu 
and choose Other > High Pass. In the 
High Pass dialog, we’ll drag the Radius 
slider up until we can see the fine de-
tails starting to appear and then we’ll 
click OK. Then, we need to change the 
blending mode of this layer to Overlay. 
(The Blending Mode menu is located 
at the top of the Layers panel.)

The High Pass filter is being used to sharpen 
an image. The Radius slider determines how 
much sharpening will be applied.
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Creating an Action for applying high pass: Version 1 

Since the process for high pass sharpening is always the same, we can create a 
couple of actions that will accomplish the task faster. To do this, we’ll open an 
image in Photoshop and make sure the Actions panel is visible. If it’s not, you 
can access it by going to the Window menu and choosing Actions. I’m going 
to create a folder within the Actions panel in which to place the new actions, so 
I’ll click on the New Folder icon at the bottom 
of the Actions panel and name the folder “High 
Pass Sharpening.” With this new folder active, 
we’ll click on the New Action icon at the bottom 
of the Actions panel. In the New Action dialog, 
we’ll name the action “High Pass Sharpening” 
and then click the Record button. You can see 
the little record icon turn red at the bottom of 
the Actions panel, indicating that everything we 
do will be recorded. Now, we’ll follow the steps 
we covered earlier. We’ll start by duplicating the image layer. We’ll then change 
the blending mode of the image duplicate to Overlay. Doing this step before the 
high pass step will allow us to see a realistic preview when we work with the High 

Above are two detail shots of an image. The version on the left is before using the High Pass 
filter and the version on the right is after using the filter. 

After we click the New Action icon, 
the above dialog will appear. Here, 
we can enter a name for the action 
and specify which folder it should 
be placed in. 
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Pass filter. We’ll then go to the Filter menu and choose Other > High Pass. I’ll set 
the Radius slider to the setting I think I would use the most and then we’ll click 
OK.  Lastly, I’ll rename this layer by going to the Layer menu and choosing Re-
name Layer. I’ll name the layer “High Pass Sharpening.” We can now click the Stop 

button at the bottom of the Actions panel in order 
to stop the recording process. Because the high pass 
setting will be different for every image, we need to 
tell the action to pause and ask us for settings at that 
step. If we click on the little gray square to the left of 
the High Pass step in the Actions panel, the action will 
pause at this step and allow us to adjust the Radius 
slider. When we click OK, the action will continue to 
play. To run the action, we can click on the name of 
the action and then hit the Play button at the bottom 
of the Actions panel. 

Creating an Action for applying high pass: Version 2

We’ll now create a second action for high pass sharpening that will work in a 
smarter way than the previous action. We’ll start by clicking the New Action icon 
at the bottom of the Actions panel, naming the action “High Pass Sharpening - 
Smart” and then clicking the Record button. We’ll duplicate the image layer and 
then go to the Filter menu and choose to “Convert for Smart Filters.” This will turn 
the image duplicate into a smart object. I’ll change the blending mode to Over-
lay and then go back to the Filter menu and choose Other > High Pass. I’ll set to 
Radius slider to a setting that’s either low or 0 and I’ll click OK. Then I’ll rename 
the layer by going to the Layer menu, choosing Rename Layer and then typing 
in “High Pass Sharpening.” I’ll hit the Stop button at the bottom of the Actions 
panel. Finally, I will click on the little gray square to the left of the High Pass step 
so that the action pauses and asks for settings at this stage. 

The advantage of this version of the action is that we can go back and change the 
high pass settings at a later time, and that’s because we converted the high pass 

Here, we clicked on the little 
gray square to the left of the 
High Pass step within the 
Actions panel. This tells the 
action to pause at this stage 
to ask for settings. 
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layer into a smart object. If we closed the 
document and opened it later, we could dou-
ble-click on the name “High Pass” beneath 
the High Pass Sharpening layer thumbnail 
and the High Pass dialog will appear so that 
we can adjust the settings. Had we used a 
layer that was not a smart object, the setting 
would be locked in. 

High Pass vs. other filters

The sharpening result we achieve with the High Pass filter 
can be achieved using other methods as well. For example, 
the Unsharp Mask filter is related to the High Pass filter. 
We can access it by going to the main menu and choosing 
Filter > Sharpen > Unsharp Mask. A dialog will appear and 
there will be three sliders at the bottom. We will set the 
Amount slider to 100 and the Threshold slider to 0. Now, 
the Radius slider will work in the same way that the Radius 
slider within the High Pass dialog works. This is the case 
when you use a low radius setting, of around 6 or under. 
Once you go over a slider setting of about 6, you will need 
to gradually lower the Amount slider in order to achieve 
the same result as you would with the High Pass filter. 

Why use High Pass?

If we can get the same results using the Unsharp Mask filter that we can using the 
High Pass filter, when would we choose to use High Pass over Unsharp Mask? The 
answer is when we have a multi-layered document and want to be able to later 
make changes to the underlying layers. 

Because we converted the high pass 
layer for smart filters, we can dou-
ble-click on the filter name at any time 
to adjust the settings. 

Here, we are sharpen-
ing the image using the 
Unsharp Mask filter.



High Pass Sharpening © Ben Willmore, All rights reserved 6

I we wanted to apply the Unsharp Mask filter on a 
multi-layered document, we’d have to either merge 
all of the layers (flattening the document) or create 
a merged version of the entire document on a layer 
at the top of the layer stack. We can do this by se-
lecting the top layer and using the keyboard short-
cut Shift+Command+Option+E (Shift+Ctrl+Alt+E on 
Win). Then, we would apply the Unsharp Mask filter 
on that layer. The problem is that if we want to make 
any changes to the underlying layers, they won’t be 
visible because that merged layer at the top of the 
layer stack is hiding them. 

We’ll now follow the same technique as above, but we will use the High Pass filter 
instead of the Unsharp Mask filter. With the same multi-layered document open, 
we’ll activate the top layer and create a merged copy of the document by us-
ing the keyboard shortcut Shift+Command+Option+E (Shift+Ctrl+Alt+E on Win). 
We’ll then convert this new layer into a smart object so that we have the ability 
to change the settings later, so we’ll go to the main menu and choose Filter > 
Convert for Smart Filters. We’ll next change the blending mode of the layer to 
Overlay. We can now go to the Filter menu and choose Other > High Pass, decide 
how much sharpening we want by using the Radius slider and then click OK. Even 

though the high pass layer is sitting at the top 
of the Layers panel, it is not obscuring the lay-
ers beneath it. We can make changes to those 
underlying layers and see those changes re-
flected in the image. The exception to this 
would be changes to any retouching layers. If 
we change objects in the image, as we would 
when retouching, the result will look odd be-
cause those objects looked different at the 
time we applied the high pass sharpening. 

The top layer is a merged 
copy of the document with 
the Unsharp Mask filter ap-
plied. Any changes made to 
the underlying layers will be 
hidden by this top layer.

After applying the High Pass filter at 
the top of a multi-layered document, 
you can see the odd effect that can 
occur when making changes to an 
underlying retouching layer. 
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Creating an action for a multi-layered file 

The actions we created earlier in the lesson are designed for a document with a 
single, background layer. If we try to use them on a more complex, multi-layered 
document, they won’t work properly. We’ll need to create a different action de-
signed for this kind of document. We’ll start by clicking the New Action icon at 
the bottom of the Actions panel, naming the action “High Pass Sharpening - Lay-
ered Smart” and clicking the Record button. Now we need to start with either the 
top layer active or all layers active, but when recording an action, we can’t just 
click to activate a layer. That’s because an action will record the step based on the 
layer name and the layer name will be different for every document. Instead, we’ll 
go to the Select menu, choose All Layers and then go to the Layer menu, hold 
down the Option key (Alt on Win) and choose Merge Visible. This will give us a 
merged version of the document at the top of the Layers panel. Next, we’ll con-
vert the new layer into a smart object by going to the Filter menu and choosing 
Convert for Smart Filters. We’ll change the blending mode of the layer to Overlay 
and then we’ll apply the High Pass filter, using a relatively low setting (the exact 
setting won’t matter because it will be different for every document) and then 
click OK. Now we will rename the layer by going to the Layer menu, choosing 
Rename Layer and then typing in “High Pass Sharpening” as the new name. We’ll 
now hit the Stop button at the bottom of the Actions panel. Finally, we need to 
click on the little square to the left of the high pass step so the action knows to 
stop and ask us for settings at this stage. 

Let Photoshop decide which action to use

The action we just created was designed for a multi-layered document. If we try 
to use it on a single-layered document, it won’t work. That’s because some of the 
steps (Select All Layers, Merge Visible) use commands that will not be available 
in a single-layered document. 
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To ensure that we use the action designed for our document (single layer or 
multi-layered), we’re going to create another action that will first look at the doc-
ument and determine whether it contains layers. It will then run the appropriate 
action depending on whether the layer has one or more layers. Note that we need 
to have already created the two actions we covered earlier. We’ll click on the 
New Action icon at the bottom of the Actions panel, name the action “High Pass 
Sharpening - Auto” and then click the Record button. I’ll then click on the little 
side menu located in the top right corner of the Actions panel and choose Insert 
Conditional. This will let us ask a question within the action and proceed based on 
the answer. In the Conditional Action dialog, we’ll set the If Current menu to “Doc-
ument has Layers” and set the Then Play Action menu to “High Pass Sharpening 
- Layered Smart.” We’ll set the Else Play Action menu to “High Pass Sharpening 
- Smart” and then click OK. Now, regardless of what type of document we have, 
we can run this action and Photoshop will intelligently choose between the two 
high pass actions and play the appropriate one. 

Left: We clicked on the menu at the 
top right corner of the Actions panel 
and are choosing the “Insert Condi-
tional” option. Above: In the Condition-
al Action dialog, we told Photoshop to 
play the “Layered-Smart” action if the 
document contains layers and to play 
the “Smart” action if the document 
does not contain layers. 


