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Actions II

This lesson will cover some more intermediate and advanced ideas related to ac-
tions. If you are new to actions, I’d recommend that you watch the other Masters 
Academy video on the topic first. 

Loading & Saving Actions

After you’ve created an action, you’ll probably 
want to save it. Know that you can’t save an 
individual action. If you select the action and 
then go to the menu in the top right corner 
of the Actions panel, the Save Actions option 
will be grayed out (aka unavailable). In order 
to save an action, it needs to be in a set, or 
folder. You can create a new folder by click-
ing on the New Folder/Set icon at the bottom 
of the Actions panel and you can move ac-
tions into a folder simply by dragging them 
into one. Save an Action Set/Folder by click-
ing on the set in the Actions panel, clicking on 
the side menu in the top right corner of the 
panel and choosing Save Actions. You’ll be 
prompted to choose a location for the actions 
and if you choose the Actions folder within 
the Photoshop folder on your hard drive (Ap-
plications > Adobe > Photoshop > Presets > 
Actions), then the actions will automatically 
appear in the side menu of the Actions panel. 
If you save them in a different location, you will need to go to that side menu, 
choose Load Actions and then navigate to the location on your hard drive. On the 
Mac, you can double-click on an action file on your hard drive and Photoshop will 
automatically open and load the action. 

When we mention the side menu 
in the Actions panel, we’re refer-
ring to this icon. Clicking it will 
offer a variety of options. 

Click this icon to create a New 
Set (or new folder).

Click this icon to create a New 
Action.
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Creating copies 

Often times, I may create several actions that are all very similar to each other. For 
example, I may create a set of actions that all apply a tinting effect to an image, 
where each action will tint the image with a different color. In a case like this, most 
of the steps for creating those actions will be the same. 

If you click and drag on an action in the Actions pan-
el, you will reposition the action. If you hold down 
the Option key (Alt on Win) as you click and drag, 
you will drag a copy of the action. The action name 
will be the same, but it will have the word “copy” at 
the end. You’ll likely want to rename it to something 
more useful. The ability to create copies of actions 
will allow us to create two or more actions that are 
very similar to each other without having to create 
each one from scratch. After making a copy, we can 
expand the copy in the Actions panel and change 
only the step or steps that we need.  

Note that the same thing can be done for individual steps in an action. If we se-
lect the step or steps that we’d like to copy, we can hold down the Option key (Alt 
on Win) and drag the steps to the action where we’d like to place them. 

Play an action within an action

Photoshop allows us to play an action within an action. We can use an action step 
to tell Photoshop to go and play a different action and then return to the current 
one. To do this, we’ll start creating our action. When we get to the point where 
we want another action to play within the action we’re creating, we’ll click on the 
name of that action and hit the Play button. 

When we move or copy an 
action or a step within an 
action, Photoshop will give 
us feedback (the highlighted 
horizontal line) that shows us 
where the action or step will 
be placed when we release the 
mouse button. 
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When including an action as a “subroutine” 
within another action, know that there are a 
few things that could mess up the process. 
If you either delete or rename an action that 
is included within another action, Photo-
shop will give you an error when attempting 
to play the action. It’s going to reference the 
exact name of the action in order to play it, 
so if it doesn’t exist, Photoshop will not be 
able to play it. In order to prevent this from 
happening, I like to create a folder within my 
Actions panel that is called Subroutines and 
this is where I place any actions that I reg-
ularly use within other actions. This way, I 
know that I shouldn’t delete or rename them. 

Making changes to actions

I sometimes want to refine an action that I made a long time ago. This is com-
pletely doable because you can easily make changes to actions after you’ve cre-
ated them. To make changes to a step in an action, click on the arrow to the left of 
the action name in order to expand the steps. Then click on the step where you’d 
like to add something and click the Record button at the bottom of the Actions 
panel. You can now do something in Photoshop and the step will be added right 
after the step that you had activated. Add as many steps as you’d like and then 
hit the Stop button. Just make sure that you test your action to make sure that it 
plays correctly. 

If you’d like to temporarily deactivate a step in an action, 
click on the little check box to the left of the step name. 
Photoshop will know to leave this step out when playing the 
action. If there is a step that is deactivated within an action, 
then the name of the action will have a red check mark to 

In the highlighted action step above, 
Photoshop is being prompted to run the 
“High Pass Sharpening-Auto” action. 

The Subroutines folder is where I will 
place all of my actions that are included 
within other actions. 

The red check mark 
indicates that there 
is a deactivated step 
within the action. 
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the left of its name. This is just letting you know that one of the included steps 
will not play. 

Slow down the playback speed of an action 

When you play an action, Photoshop will play it as 
quickly as possible, and it’s usually too fast to really see 
what’s going on. If you would like to change that, click 
on the side menu at the top of the Actions panel and 
choose Playback Options. A dialog will appear where 
you can specify your playback speed. By default, it’s 
set to Accelerated. If you’d like to see each step as it’s 
played, choose the Step by Step option. With this set-
ting, Photoshop will play the steps one at a time and it 
will highlight the steps in the Actions panel so you can see what it’s doing. If you 
choose the Pause For option, you can specify how long Photoshop should pause 
between each step in the action. 

You can also play each step manually by double-clicking on the name of each 
step, one by one. Just know that if a step asks you for settings, the settings 
you apply will be remembered within that step and used the next time you play 

the action. For example, if you double-click on a 
Gaussian Blur step and set the Radius slider to 5, 
then the next time you play the action, the Radi-
us slider will automatically be set to 5. If there is 
a little highlighted square to the left of an action 
step, it means that the step will pause to ask you 
for settings. 

You’ll find that when double-clicking on a step, you will sometimes have settings 
pop up that wouldn’t normally pop up when playing the action. If you don’t want 
this to happen, hold down the Command key (Ctrl on Win) when double-clicking 
on the step and it will not ask you for settings. 

The Playback Options allow 
you to specify how quickly 
an action should play.

The highlighted square icon indi-
cates that the action will pause at 
this step and ask for settings.
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Updating an action

After using an action for a while, I sometimes find that the settings I used when 
recording the action really weren’t ideal. For example, let’s say that when record-
ing an action, I used a Gaussian Blur setting of 5, but every time I use the action, I 
need to change it to 50.  There are two ways of updating an action, one of which 
is double-clicking on the name of a step, changing the settings in the dialog that 
pops up and then clicking OK. Alternatively, you could click on the name of the 
action, then click on the side menu at the top of the Actions panel and choose 
Record Again. This will play back the action, paying attention to the settings 
used. It will stop at each dialog so you can enter in new settings and click OK. 

Complex actions and History states

Complex actions can tend to have many, many steps. Know that Photoshop only 
records a certain number of steps in its History. This means that if the action uses 
more steps than Photoshop will remember, you won’t have enough “undos” to 
get the document back to the state it was in before playing the action. 

To specify how much history Photoshop should remember, go to the Photoshop 
menu and choose Preferences > Performance. (In Windows, the Preferences are 
often found under the Edit menu.) Here, you can specify the number of History 
States. This is how many undos you will have. 

If an action contains too many steps for Photo-
shop to remember in its History panel, I will click 
on the little camera icon at the bottom of the His-
tory panel before playing an action. This will create 
a Snapshot, which is a saved version of the docu-
ment that appears at the top of the History panel. 
If you hold down the Option key (Alt on Win) while 

clicking on the camera icon, you’ll be prompted to give the Snapshot a name. If 
you record this process within the action, a Snapshot will automatically be cre-

The Snapshot icon at the bottom 
of the History panel.
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ated when you play the action. You can also include a Snapshot at the end of an 
action. If you do this, you can later go to the top of the History panel and click 
on the Snapshot that will change your document to the state it was in before the 
action was played and then you can click on the snapshot that will change your 
document to the state it was in after the action was played. 

Avoid trouble when creating actions

Sometimes, an action might play well on the image you use to create it, but you 
get an error when you go to play it on another image. Let’s look at what could go 
wrong and learn how to avoid it. 

Foreground/background colors Some filters rely on the fore-
ground and background colors, which can be found at the bot-
tom of the Tool Bar on the left side of the interface. If you had 
your foreground and background colors set to black and white 
while creating the action and then played the action when they 
were set to different colors, you will get a very different result. 
If you know you’ll be using a filter that relies on the foreground 
and/or background colors, set those colors right after you start 
recording. This way, the step will be incorporated into your ac-
tion and the filter will always create the same result. 

The Brush Tool in an action You can use the Brush Tool within an action, but it 
won’t automatically know your brush size unless you include that setting as a 
step in your action. After you start recording the action, set your brush size. Then, 
Photoshop will know to use the same brush size every time the action is played. 

Opening an image within an action If you want to start creating an action when 
you have no open Photoshop documents, your Actions panel may not be visible. 
To access the Actions panel, you can either go to the Window menu and choose 
Actions, or you can choose a workspace from the menu on the right side of the 
Options Bar. 

The foreground 
and background 
swatches can be 
found at the bot-
tom of the Tool Bar.
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You can include your “open document” step as part of your action. Just hit the 
Record button and then open your desired image. Be aware, however, that Pho-
toshop will record that step using the exact image you opened. When you play 
the image back, it will navigate to the image you specified and open it as part 
of the action. This could cause a 
few issues down the line. If you 
delete, move or rename this im-
age, Photoshop may present an 
error when it gets to the open 
image step. 

When you include the “open” step in your action, you’ll 
probably want the user to be able to specify which image 
is opened at this stage. You can achieve that by clicking 
the little gray square to the left of the Open step in the 
Actions panel. This will prompt the user to navigate the 
hard drive to the file they’d like to use. You can also add 
some instructions, known as a stop, to tell the user what 
to do. You can insert a stop by first clicking on the step 

If you have no 
documents open 
in Photoshop, you 
can access your 
panels by choos-
ing a workspace 
from the menu on 
the right side of 
the Options Bar. 
Here, I’m choos-
ing the Essentials 
workspace. 

Here, we opened an image while recording an action. 
You can see that the step includes the exact location 
of the action on my hard drive.

We clicked the square 
icon to the left of the 
Open step. This tells 
the action to pause 
and prompt the user to 
choose an image. 
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in the action that you’d like the stop to appear after and then going to the side 
menu at the top of the Actions panel and choosing Insert Stop. A dialog box will 
appear, inside of which you can type in the instructions, turn on the “Allow Con-
tinue” check box and then click OK. 

The Save command is also something you need to be careful of when including it 
within an action. When you use the Save command within your action, the action 
records what file format you chose along with the settings relating to it as well as 
the location you used. Because of this, if I include the Save command, I will also 
turn on the gray square next to the Save step so that Photoshop prompts the 
user to choose the save location and settings. 

Resizing a picture with an action Whenever you resize an image within an action, 
you need to be aware of how it’s going to be recording things. When you use the 

Image Size command within an action, 
the action will only record the setting you 
changed. For example, if you only changed 
the width of your document, the width is 
the only information that will be recorded 
in the action. If the other information (like 
resolution) is important to you, make sure 
that you change the settings for that oth-
er info when creating the action. 

Here, we are re-
cording a stop in 
the action, which 
is simply a set of 
instructions for the 
user. 

If you use the Image Size dialog within an 
action, be sure to change all the settings 
you want to be included in the action. 
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Sometimes, you’ll run into issues when using both 
vertical and horizontal images. You may want the 
action to resize an image so the longest dimension 
is a particular size. A simple Image Size command 
won’t work because the dimensions will be different 
depending on whether your image is vertical or hori-
zontal. Instead, while recording the action, I will go to 
the File menu and choose Automate > Fit Image. In 
the Fit Image dialog, you will be able to enter in pixel 
dimensions, but instead of resizing to the specific dimensions you choose, it will 
simply ensure that the image does not become larger than the dimensions you 
entered. I will usually enter in the same number for the width and height. Which-
ever of those dimensions is longer will be the length I specified. The other di-
mension will scale accordingly. For example, if I set the Width and Height to 600 
pixels and then run the command on an image that is 800 pixels wide and 400 
pixels tall, then the image will scale to 600 pixels wide by 300 pixels tall. 

Working with layers in actions

When creating actions, you’ll sometimes have to think differently when working 
with layers. If you click on a layer in the Layers panel while recording an action, 
it’s going to record the name of that layer as part of the action. This could cre-
ate problems because your layer names will be different in every document. To 
get around this, you can change which layer you are working on by using your 
keyboard. This will record the action by telling Photoshop to grab the layer that’s 
above (or below) instead of grabbing a layer according to its name. 

Use the following shortcuts to select the layers above and below: 

Select the layer above: Option+ ] on Mac, Alt+ ] on Win

Select the layer below: Option + [ on Mac, Alt + [ on Win

To select more than one layer: Use the shortcuts above, but include the Shift key. 

The Fit Image command will 
not allow the dimensions of 
your image to be larger than 
the size you specify.
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Use the following shortcuts to move the active layer up or down in the layer stack: 

Move a layer up in the layer stack:  Command + ] on Mac, Ctrl + ] on Win

Move a layer down in the layer stack:  Command + [ on Mac, Ctrl + [ on Win

Move a layer to the top of layer stack:  Shift + Command + ] on Mac,  
       Shift + Ctrl + ] on Win

Move a layer to the bottom of the layer stack:  Shift + Command + [ on Mac 
            Shift + Ctrl + [ on Win

Move between documents using keyboard shortcuts

If you need to move between open Photoshop documents within your action, 
you can do so using only keyboard shortcuts:

Move to the next Photoshop document (the tab to the right): Ctrl+Tab

Move to the left in the Photoshop tabs: Shift+Ctrl+Tab

Actions with smart objects and filters

When you apply a filter to a layer that has been converted into a smart object, it 
will be applied as a smart filter. Smart filters are great because the settings can 
be changed later (even if you close the document and open it again later). When 
including a smart filter within an action, put some thought into the order in which 
you apply each step. If you’re creating an effect that involves using a filter set to a 
certain blending mode, it will be useful to change the blending mode first so that 
when you are working with the filter settings, you are seeing what the results will 
look like at the end. For example, when you apply the Emboss filter, the preview 
will be 50% gray unless the blending mode has already been changed to Hard 
Light. If the blending mode has been changed, you’ll be seeing the actual result 
and not the gray preview. For this reason, I would change the blending mode be-
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fore applying the filter settings, so when the action plays back, the blending mode 
will already be changed when the action prompts the user for filter settings. 

With the above information in mind, here is how I would create an action for ap-
plying the Emboss filter to an image:

I’ll click the New action button at the bottom of the 
Actions panel, name the action “Emboss as Smart 
Object” and click Record. I’ll then convert the image 
layer into a smart object by going to the Filter menu 
and choosing Convert for Smart Filters. Then, I’ll go 
back to the Filter menu and choose Stylize > Emboss. 
It doesn’t matter what settings are used here because 
we’re going to come back and change them later so 
I’ll just click OK to close the Emboss dialog. Next, I’ll 
double-click on the little slider icon to the right of the 
Emboss filter in the Layers panel. Filter options will 
appear and I will change the blending mode menu 

at the top of the dia-
log to Hard Light and 
then click OK. Then I 
will click on the word 
Emboss in the Lay-
ers panel and the Emboss settings will appear. I’ll 
adjust the sliders and then click OK. I’ll click the 
Stop button at the bottom of the Actions panel 
to stop recording. Finally, I will click on the gray 
square to the left of the last step in the action 
so that Photoshop will pause at this stage and 
prompt the user to specify the settings for the 
Emboss filter. 

Clicking on the slider icon to the 
right of the Emboss filter name 
will bring up the general filter 
settings, which includes blending 
mode. Clicking on the name of the 
filter (Emboss) will bring up the 
settings specific to that filter. 

The settings for the Em-
boss filter. If the bending 
mode has not already been 
changed, we see this gray 
preview. 
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Conditionals in Actions

When you include a conditional within an action, it will ask a question about the 
picture and proceed with the action based on the answer. When you use condi-
tionals, you will be prompting Photoshop to play an action within an action. You 
can add a conditional by clicking on the side menu at the top of the Actions panel 
and choosing Insert Conditional.

The “If Current” menu at the top of the 
Conditional Action dialog will list sev-
eral conditions that may apply to your 
document. For example, if the current 
document is in landscape orientation, if 
the current document has layers, if the 
current layer has effects, etc. The next 
two menus will allow you to tell Photo-
shop what to do based on the answer 
to the question asked in the top menu. 
If the answer is yes, Photoshop will pro-
ceed by playing the action you specify in 
the “Then Play Action” menu. If the an-
swer is no, then Photoshop will proceed 
by playing the action you specify in the 
“Else Play Action” menu.

Let’s look at how I would use conditionals to create a complex action. I want to 
create an action that will add my copyright in one location for a horizontal image, 
in another location for a vertical image and in yet another location for a square 
image. To do this, I will first need separate actions for inserting the copyright in 
those different locations. Then, I will start recording my “master” action (the one 
that I’ll actually run to add copyright watermarks). I will first create a conditional 
that asks whether the document is square. In the Conditional Action dialog, I will 
set the “If Current” menu to “Document is Square” and then I will set the “Then 

The Conditional Action dialog. The “If Cur-
rent” menu lists all the conditions we can 
work with.
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Play Action” menu to play the action that will put the copyright in the location I 
desire for square images. I will leave the “Else Play Action” menu set to None and 
then click OK. Then I will create another conditional, with the “If Current” menu 
set to “Document is Landscape.” I will set the “Then Play Action” menu to the ac-
tion that places the copyright in the location I desire for landscape images. I will 
set the “Else Play Action” to the action that places the copyright In the location I 
desire for portrait/vertical images. I’ll then click OK and stop recording the action.

Conditionals and color modes You can use a conditional to ensure that your 
finished document is a particular color mode, sRGB for instance. To do this, you 
would first create an action that converts a document to sRGB. Then you would 
create the action you want and include a conditional that specifies the following: 
If the current document profile is sRGB, do nothing. If the current document is 
NOT sRGB, then run the action that converts the document to sRGB.

Conditional Mode Change There is another 
command that you can run within your action 
that will tell Photoshop to make sure the doc-
ument is a specific color mode. You can access 
this command by going to the main menu and 
choosing File > Automate > Conditional Mode 
Change. In the dialog, the command will look 
at which color modes you have checked off 
and tell Photoshop that if the document is in 
one of those modes, then it should convert the 
document to the mode you specify in the “Tar-
get Mode” menu at the bottom of the dialog.

The Conditional Mode Change 
dialog.
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Changing a “subroutine” action for dramatically different results

We’re going to have one action play another action over and over again. This will 
allow us to change just one step in the action that is being repeated in order to 
get a dramatically different result. To start, we’ll click the New Action icon, name 
the action Spin and hit the record button. We’ll then duplicate the active layer 
by typing Command+J (Ctrl+J on Win) and we’ll scale and rotate the duplicate 
with the Free Transform command. We’ll go to the Edit menu and choose Free 
Transform. Then, we’ll scale the layer down a bit and rotate it about 35 degrees 
clockwise. We’ll hit Return/Enter to lock in the transformation and then we’ll hit 
the Stop button at the bottom of the Actions panel.

Next, we’re going to create a new action that will apply the Spin action over and 
over again. We’ll click the New Action icon, name the action Spin x10 and then hit 
the Record button. Then we’ll click on the Spin action in the Actions panel and 
hit the Play button. We’ll repeat this process of clicking the Spin action and then 
hitting the Play button nine more times. Then, we’ll hit the Stop button to stop 
recording the action.

Now, we can make a change to the Spin action and, when we play back the Spin 
x10 action, it will create a different result. Double-clicking on a step will play the 

Here, a simple 
action is being 
created that will 
scale and rotate 
the duplicate of 
our background 
image. The Free 
Transform com-
mand is being 
used to do that.  
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step back AND allow you to change the settings, so that’s what we’ll do with the 
Transform step in the Spin action. We’ll double-click on the “Transform Current 
Layer” step, adjust the size and rotation and then hit the Enter/Return key to lock 
in the transformation. This will update the settings contained in that step. Now, 
when we play back the Spin x10 action, it will produce a very different result.

The Scripts Events Manager

There is a way to trigger an action 
to play every time you launch Pho-
toshop or every time you open an 
image. We’ll go to the File menu 
and choose Scripts > Script Events 
Manager. In the dialog that appears, 
we’ll first make sure that the “En-
able Events to Run Scripts/Actions” 
check box is turned on. Then we’ll 

The result we achieved after running the Spin x10 action the first time is shown on the left. 
We then changed the Spin action and played the Spin x10 action again to achieve the results 
shown on the right.  

The Scripts Event Manager dialog.
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use the Photoshop Event menu to determine what should trigger the action to 
play. You can choose things like Start Application (open Photoshop), New Docu-
ment, Save Document, etc. Then we’ll use the Action menus at the bottom of the 
dialog to specify which action should play. We also need to make sure that we 
click the Add button on the right side of the dialog so that the “event” shows up 
in the list. Then we can click the Done button.


