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Actions

Actions allow you to automate tasks in Pho-
toshop. If you ever complete a multi-step 
task over and over again in your Photoshop 
documents, it can likely be recorded as an 
action. I also use actions for some single-step 
techniques that require specific settings that 
need to be remembered. 

An action will watch what you do in Photo-
shop and reminder the steps you applied so 
that you can play back those steps in future 
documents. If the Actions panel is not already 
visible in your interface, you can access it by 
going to the main menu and choosing Win-
dow > Actions. In the Actions panel, You will 
find one or more folders that contain differ-
ent actions. If you’ve never used the Actions 
panel before, there will be only one folder 
called Default Actions. If you click on the little 
disclosure triangle/arrow to the left of a fold-
er icon, it will expand or collapse the folder 
to show or hide its contents. At the bottom 
of the panel, there is a Play button (to play an 
action), a Record button and a Stop button. 

Let’s start by creating a folder for the actions 
we’ll create in this lesson. To create a folder, 
click on the New Set icon at the bottom of 
the Actions panel. (It looks like a folder icon.) 
You’ll be prompted to give the folder a name 
and then click OK. 

Photoshop’s Actions panel is shown 
above. The zoomed view (directly 
above) shows the bottom of the panel. 
The buttons, from left: Stop, Record, 
Play, New Set (or folder), New action, 
and Delete. 
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Creating an action: Find edges in Multiply

Before creating an action, you’ll need to be sure that your active image is prepped 
and in the state that it should be in to create the action. To create an action, we’ll 
click on the New Action icon at the bottom of the Actions panel. A dialog will 
appear where we can give the action a name and use the Set menu to spec-
ify whether the action should be placed in an existing folder. In this example, 
we’ll name the action “Find Edges in Multiply” and place it inside the “Masters 
Academy Actions” folder I just created. 
You can also give the action a color label 
using the Color menu in this dialog. When 
we’re ready, we’ll click the Record button. 
After hitting Record, the Actions panel will 
pay attention to everything you do in Pho-
toshop that has the potential of changing 
your picture. The Record icon at the bot-
tom of the panel will also turn red, indicat-
ing that you are recording.

To create this “Find Edges in Multiply” action, we’ll first duplicate the image layer 
by issuing the keyboard shortcut Command+J (Ctrl+J on Win). You will see the 
step appear under the action name in the Actions panel. Next, we’ll go to the Fil-
ter menu and choose Stylize > Find Edges. This will drastically change the look 
of our picture. 

In the New Action dialog, we’re giving 
the new action a name and choosing 
what folder, or Set, it should go in. 

We applied the 
Find Edges filter 
and you can see 
that it appears 
as a step in the 
action within 
the Actions pan-
el. When record-
ing an action, 
the record icon 
at the bottom 
will be red. 
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Finally, I will go to the Layers panel and change the 
Blending Mode to Multiply. This will make the white 
areas disappear, and anything that is darker than 
white will darken the picture that’s underneath. Be-
fore stopping the recording process, I will rename the 
top layer so that I understand the layer’s purpose if I 
ever re-open the image in the future. To rename a lay-
er while recording an action, we’ll make sure the layer 
is active and then go to the Layer menu and choose 
Rename Layer. I will rename the layer “Find Edges 
in Multiply.” Then I will stop the action by hitting the 
Stop button at the bottom of the Actions panel. 

After creating an action, it’s always a good idea to immediately test the action to 
make sure it works in the way that you want it to. To play an action, click on the 
name of the action and then click the Play button at the bottom of the Actions 
panel. 

The blending mode of the 
Find Edges layer is being set 
to Multiply. 

A before and after view of our image after we duplicated the image layer, applied the Find 
Edges filter and then set the blending mode to Multiply. 
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Creating an action: High pass sharpening

To create this action, we will open an image and 
then click on the New Action button at the bot-
tom of the Actions panel. In the New Action di-
alog, we will name the action “High Pass Sharp-
ening,” choose the “Masters Academy Actions” 
folder from the set menu and then click Record. 
Then, I will duplicate the image layer by using the 
keyboard shortcut Command+J (Ctrl+J on Win) 
and then I will change the blending mode of this 
new layer to Overlay. Next, I will go to the Filter 
menu and choose Other > High Pass. When the 
dialog appears, I will move the Radius slider to a 
fairly low setting so that it applies enough sharp-
ening without looking gritty. In this example, I used 
a setting of 3.4 and clicked ok. I will then rename this layer by going to the Layer 
menu and choosing Rename Layer. I’ll name the layer “High Pass Sharpening.” 
Finally, I’ll click the Stop button at the bottom of the Actions panel. 

Telling an action to prompt you for settings

In the last action we created, we used a High Pass setting of 3.4 to sharpen the im-
age. But every image is different and other images will likely require different High 
Pass settings in order to achieve the desired outcome. This means that if we use 
that action on another image, the sharpening effect will probably not be optimal. 
This issue is something you’ll frequently run into when creating actions as differ-
ent images require different settings (for all kinds of filters). Because of this, the 
Actions panel allows us to specify that a step in our action should prompt us for 
settings. Click on the little disclosure triangle/arrow to the left of an action name 
to see all of the steps that make up the action. To the left of each step’s name is 
a little gray square. If you click on the square it will become highlighted in white, 
indicating that when the action reaches that step, it will prompt you for settings. 

The High Pass filter is applied to 
our image duplicate. 
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Note that you will only be 
able to do this for steps 
that required you to enter 
settings. When you play 
the action on an image, 
it will pause at the step 
that asks you for settings. 
After you specify those 
settings and click OK, the 
action will continue. 

Creating an action: Emboss

Once again, I will open an image and click the New Ac-
tion icon at the bottom of the Actions panel. I will name 
the action “Emboss Me” and choose “Masters Academy 
Actions” from the Set menu. I’ll click the Record button. 
Just as in the previous actions we created, I’ll duplicate 
the image layer by hitting Command+J (Ctrl+J on Win). 
Then I’ll go to the Filter menu and choose Stylize > Em-
boss. The Emboss dialog will appear, I will set the slid-
ers until I think the effect looks appropriate on the cur-
rent image and then I’ll click OK. Then I will change the 
blending mode of this layer to Hard Light and rename 
the layer “Embossing.” Now, I will hit the Stop button at 
the bottom of the Actions panel. Because the Emboss 
dialog settings will be different for every image, I would 
like the action to pause when it gets to that part and ask 
me to set the Emboss sliders. To have the action prompt 
me to do that, I will click on the little gray square to the 
left of the Emboss step under the “Emboss Me” action 
in the Actions panel. 

When you click the square to the left of a step in the Actions 
panel, the action will pause at that step and prompt you to 
enter settings. 

The Emboss filter is being 
applied. 

We’re clicking on the box 
to the left of the Emboss 
step so the action prompts 
us for settings at this step. 
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Changing to order of steps in an action 

After replaying the last action, I wished 
that I had changed the blending mode of 
the Embossing layer BEFORE I applied 
the emboss effect. This would have given 
me a better preview of the image in the 
Emboss dialog. I don’t need to go back 
and recreate the action though. Instead, 
I can simply drag the step to the desired 
location in the Actions panel. You have to 
be careful when doing this because it will 
change the order in which things happen 
and this could affect the look of your im-
age, but in this case, it’s just a simple shift. 
I will drag the “Set Current Layer” step that changed the blending mode so that 
it appears directly after the “Layer Via Copy” step. Now, the action will play back 
in that order. 

Updating the settings in the step of an action

Let’s say that you create an action and then later decide that you’re not happy 
with the settings you used in one of the action’s steps. As long as the step used a 
feature that required you to enter in some kind of settings, you can go back and 
change those later. Simply double-click on the name of the step and the settings 
dialog will open. You can re-enter in the settings you’d like and then click OK. In 
the video example, I created the action while working with a low res image. I later 
decided that I would be using the action mostly on high res images so I needed 
to update the action so that the Emboss settings were geared toward high res 
images. 

Here, we’re changing the order of steps in 
an action by clicking and dragging on one 
of the steps. 
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Creating a complex action: Frequency separation

When we get into creating more complex actions, we need to pay more attention 
to how the action is being recorded. In this example, we’re going to create an ac-
tion that will set up our image for frequency separation, which is a technique that 
will place the fine details of an image on a separate layer from the overall shading. 
This will allow us to work on the details without affecting the tone, and vise versa. 

To create the action, I’ll open the image and then click the New Action button at 
the bottom of the Actions panel. When the dialog appears, I will name the action 
“Frequency Separation,” I will make sure the Set menu is set to the “Masters Acad-
emy Actions” folder and then I’ll click the Record button. Now, I will duplicate the 
image layer twice by using the keyboard shortcut Command+J (Ctrl+J on Win). 

When I opened the image in Photoshop, the image layer was called “Background.” 
When I duplicated that layer, the new layers were called Layer 1 and Layer 1 copy. 
Knowing how actions work, I realize that this could present a problem if we’re not 
careful about how we record the action. Let’s say that instead of the image layer 
being named “Background,” it is named “Spain 1.”  Then, when the image layer is 
duplicated twice, we would end up with layers called “Spain 1 copy” and “Spain 1 
copy 2.” If I had originally clicked on a layer called “Layer 1” or “Layer 1 copy,” that 
step in the action will be searching for layers with those names. When it doesn’t 
find them, it’s going to give us an error message. We need to think about how to 
get around this before it creates an issue. Instead of clicking on a layer to activate 
it, I will use a keyboard shortcut that tells Photoshop to switch to the layer be-
neath the active layer. This way, the step is not relying on a layer name. 

To activate the layer BELOW the one 
you’re currently on, use the keyboard 
shortcut Option+ [ (Alt+ [ on Win). (That’s 
the left bracket key.) To activate the layer 
ABOVE the layer you’re currently on, use 
the keyboard shortcut Option+ ] (Alt+ ] 
on Win). 

When we switch layers by using keyboard 
shortcuts, the action will not rely on the 
layer’s name.
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After duplicating the image layer twice, the top layer will be active and I will re-
name it by going to the Layer menu, choosing Rename Layer and then typing in 
“High Frequency” for the name. Next, I will switch to the middle layer by using the 
keyboard shortcut Option+ [  (Alt+ [ on Win). This will create an action step titled 
“Select Backward Layer.” Then I will rename this layer by going to the Layer menu, 
choosing Rename Layer and then typing in the name “Low Frequency.” 

Next, I will turn off the visibility of the top layer so that I can apply a blur effect to 
the middle, low frequency, layer. The Low Frequency layer is still active, so I will 
go to the Filter menu and choose Blur > Gaussian Blur. In the dialog, I will drag 
the radius slider to the lowest setting where all of the fine details have gone away 
and then I’ll click OK. 

I will now click on the top layer to activate it and then turn on its visibility.  (Since 
we’ve given the layers unique names, it is now safe to click between layers with-
out creating an issue when the action plays later. With the High Frequency layer 
active, I’ll go to the Image menu and choose Apply Image. In the Apply Image di-
alog, I will set the Layer menu to “Low Frequency” and I will change the Blending 
menu to Subtract. In the Scale field, I will enter 2 and in the Offset field I will enter 
128. I’ll click OK. Lastly, I’ll change the blending mode of the High Frequency layer 
to Linear Light and then hit the Stop button at the bottom of the Actions panel. 

Far left: A Gaussian 
Blur effect is being 
applied to the Low 
Frequency layer. Di-
rectly left: The Ap-
ply Image command 
is being applied to 
the High Frequency 
layer. 
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Looking back at the steps in our action, I 
know that the Gaussian Blur settings will 
be different for every image so I will turn 
on the little gray box to the left of that 
step in the Actions panel. This will cause 
the action to stop and ask us for settings 
at that stage of the playback. 

Including instructions within an action

The other thing I can do is include instructions within the action. This can be use-
ful when you don’t use an action for a while and then need to be reminded of how 
to adjust certain settings. To insert instructions, click on the step in the action af-
ter which you’d like the instructions to appear, click on the little menu icon in the 
top right corner of the Actions panel and choose Insert Stop from the menu that 
appears. A dialog will pop up that allows you to enter text. I will enter the follow-
ing: In Gaussian Blur, find the lowest setting that makes the fine details disappear. 
In the lower left corner of the dialog, I will turn on the “Allow Continue” check box, 
which will cause the step to include a Continue button, and then I’ll click OK. 

We click on the square to the left of the 
Gaussian Blur step so that the action will 
stop and ask for settings at this stage. 

We included a Stop, or a set of instructions, to appear right before the Gaussian Blur step in 
the action. In the actions panel, the step will read “Stop” and when it plays within the action, 
the Photoshop dialog will pop up and give you the instructions. Continue playing the action 
by clicking the Continue button. 
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Disabling stops in an action

Let’s say that an action you use all the time contains several stops (providing in-
structions). You will eventually no longer need the instructions and may prefer to 
not see them. To disable a stop in an action, click on the check box to the left of 
the stop in the Actions panel. 

Creating an action: Make a color wheel

A color wheel can be a useful tool because it helps 
us to visualize what each color’s opposite is. You can 
make a hue less prominent by introducing more of 
the color’s opposite and this can give us more con-
trol when working with our images. The following 
action will be designed to create a color wheel. 

When we start to create the action, we don’t want to 
have a Photoshop document open. If you are seeing 
the New Document dialog when you open Photo-
shop, you can use the menu in the top right of the 
interface in order to choose one of the workspaces. 
This should bring you to Photoshop’s main interface 
where you can access the Actions panel. 

I’ll start by clicking the New Action icon at the bottom of 
the Actions panel. In the New Action Dialog, I’ll name the 
action “Create Color Wheel,” choose Masters Academy 
Actions from the Set menu and then click Record. The 
first step in the action will be to create a new document, 
and whenever I am creating a color wheel, I need to make 
sure that the document is a perfect square. I’ll go to the 
File menu and choose New. In the New Document dia-
log, I’ll enter five inches into the width and height fields 

An example of a color wheel.

The document should 
be a square, so we are 
entering 5” x 5” for the 
dimensions. 
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and then click Create. (It doesn’t matter 
how big your document is, as long as it’s 
square.) Next, I need to make a round se-
lection so I will activate the Elliptical Mar-
quee Tool. I will hold the Shift key while us-
ing the Marquee Tool in order to constrain 
the selection to a perfect circle and I will 
create a circular selection that takes up the 
entire document. 

Then, I will activate the Gradient Tool and 
click on the little down-pointing arrow to 
the right of the gradient preview in the Op-
tions Bar. When the menu of gradient pre-
sets pops up, I’ll choose the one that looks 
like a rainbow. (see screen shot) Then I will 
choose the Angle gradient style, which is 
the third icon to the right of the gradient 
preview. (see screen shot) Next, I’ll position 
my cursor at the center of the circular selec-
tion, I’ll click, drag straight up and then let 
go of the mouse button. We now have our 
color wheel. To get rid of the selection, I’ll 
go to the Select menu and choose Deselect.

We could leave our color wheel as is and 
stop the action recording here, or we could 
take it a step further and include the differ-
ent brightness ranges as well. If we were to 
do that, I would click on the down-point-
ing arrow to the right of the gradient pre-
set bar again and choose the “Foreground 
to Transparent” gradient (making sure the 

The Elliptical Marquee Tool is being used 
to drag out a circular selection that ex-
tends to all four edges of the document.

We’re choosing the spec-
trum gradient (above) 
and the Angle gradient 
style (right). 

To add the tonal range to our wheel, we 
will change the gradient preset to “Fore-
ground to Transparent” (left) and choose 
the Radial gradient style (right). 
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foreground color is set to black) and 
then select the Radial gradient style. 
I’d then position my cursor at the cen-
ter of the circle, click and drag out, and 
then release the mouse button. This will 
darken the center of the wheel. Then, 
I’d switch my foreground color to white 
and turn on the Reverse check box in 
the Options bar. I’d click and drag out 
from the center of the circle again. This 
will lighten the outside, giving us the 
full tonal range as well as the full color 
range. I would then stop recording the 
action. 

Actions & Rulers

When we recorded the color wheel ac-
tion, we used a document setting of 5” 
x 5”. In the future, what if we’d like to 
make the color wheel a different size? 
We could change the settings under 
the step in the action titled Make, but 
when we run the action, the wheel will 
be 5” x 5” regardless of the document 
size. That’s because the Set Selection 
step recorded the size and position of 
the selection. There is a way to correct for this, and it has to do with the settings 
used by your rulers. If you can not see the rulers on the outer edges of your Pho-
toshop window, go to the main menu and choose View > Rulers. The rulers may 
display inches, or they may display another unit. When you record an action, it 

The color wheel that includes the full color 
spectrum and brightness range. 

When the rulers were set to a measurement 
system other than percent, the action step 
records the exact size and position of the 
selection. 
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looks at the measurement system 
currently used by your rulers to 
figure out how the settings should 
be recorded. To change what units 
are used by your rulers, right click 
on one of them and a dropdown 
menu will appear. If you set your 
rulers to the Percent option before 
recording this action, then regard-
less of what document size you use 
in the future, the color wheel will 
always scale to fill the document. 
This teaches us that if we ever want 
to incorporate selections into an action, we may want to have our rulers set to 
Percent. With this color wheel action, I will click on the square to the left of the 
first step, titled Make, so that the action prompts us to enter settings at that stage. 

Creating an action: Desaturate edges

In the next demonstration, we’re going to 
create an action that will cause the edges 
of the picture to be less colorful than the 
middle. This effect will draw the viewer’s 
eye toward the subject of the image. To 
start, I’ll click on the New Action icon at the 
bottom of the Actions panel, I’ll name the 
action “Desaturate Edges,” I’ll choose the 
Masters Academy Actions folder from the 
Set menu and I’ll click the Record button.  
Now, I’ll use the Rectangular Marquee Tool 
to make a selection that is slightly indented 

You can change the measurement system used by 
your rulers by right clicking on your ruler (in any 
spot) and choosing an option from the menu.

The Rectangular Marquee tool is used to 
create a selection that is indented from 
the edges of the document.
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from the edges of the document. Next, I need to inverse my selection so that it’s 
the outer edges of the document that are selected. I’ll go to the Select menu and 
choose Inverse.  I want to soften the edges of this selection and in order to better 
visualize the softening effect, I will hit the Q key to enter Quick Mask Mode. This 
will turn the selection into a red overlay.  I’ll then go to the Filter menu and choose 
Blur > Gaussian Blur. I’ll drag the Radius slider up until the selection has a signifi-
cant softening effect (see screen shot) and then I’ll click OK. 

I can now hit the Q key again to exit Quick Mask Mode and bring us back to our 
“marching ants” selection. Now I want to desaturate the selected outer edges 
of the document so I will click on the Adjustment Layer icon at the bottom of 
the Layers panel and I’ll choose to create a Vibrance Adjustment Layer. (You 
could also use a Hue/Saturation adjustment layer to create the same effect.) 

Because there was a selection active when we 
created the adjustment layer, the selection will 
automatically be applied to the attached layer 
mask. In the Properties panel for the adjustment 
layer, I will drag the Vibrance slider down a good 
amount to desaturate the targeted area. I’ll re-
name the adjustment layer by going to the Layer 

Left: The selection was inverted and then we hit the Q key to enter Quick Mask Mode, which 
allows us to view our selection as a red overlay. Right: In Quick Mask Mode, we are using the 
Gaussian Blur filter to soften the edges of the selection.

A Vibrance adjustment layer was 
created and we are dragging the 
Vibrance slider down so that the 
selected edges of the frame  
become less colorful.
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menu, choosing Rename and entering 
in “Desaturate Edge” as the name. I’ll 
now click the Stop button. Because the 
settings for the Gaussian Blur filter will 
be different for each image, I’ll click the 
square to the left of the Gaussian Blur 
step so that the action pauses at this 
stage to ask for settings. 

Using actions with more complex documents

Up until now, we have created actions using a simple document with a single 
layer named “Background” or we have started with no open document. When 
you begin with a simple document, it’s easy to create actions that run smoothly. 
Sometimes, however, your document won’t be simple. It may have multiple lay-
ers and adjustment layers. Let’s look at a few of the problems we may encounter 
when making actions in situations like this. 

In the example image with the old car, the image layer is a smart object and there 
are certain things that you can’t do to a smart object. There are also two adjust-
ment layers that will not behave the same as normal layers when we apply a filter 
to them. For these reasons, the actions we created in this lesson will not work 
properly in this document. 

If I want to make sure that my actions are 
universally applicable, one of the things I 
could do would be to duplicate the entire 
document, flatten the duplicate and ap-
ply the action steps on a flattened (simpli-
fied) image. To do this, I’ll start recording 
the action and then go to the main menu 
and choose Image > Duplicate. We’ll be 

We clicked on the gray square to the left of 
the Feather step so that the actions pauses 
to ask for settings at this stage.

After hitting the Record button, we are 
duplicating the image and renaming the 
new document to reflect the name of the 
action.
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prompted to give the duplicate a name, and I’ll use the name of the action. Then, 
I’ll go to the Layer menu and choose Flatten Image. From here, I can continue 
recording the action as we’ve done before. If we do this, we can ensure that our 
action will work on multi-layered documents in the future. 

There is also another way that we could make our actions 
universally applicable. We’ll need to create a duplicate of 
a document where it’s all contained within one layer. To do 
this, we’ll first select all of the layers by going to the Select 
menu and choosing All Layers.  Next, we’ll use the key-
board shortcut Shift+Option+Command+E (Shift+Alt+C-
trl+E on Win). This will create a layer at the top of the layer 
stack that is a combination of all the other layers combined. 

Actions ignore some tools

When creating actions, you’ll find that 
some retouching tools (the Brush Tool, 
the Pen Tool, etc.) are completely ignored 
by the action. This is because, by de-
fault, actions record all the steps as sim-
ple text, which includes the name of the 
command and a few numbers represent-
ing the settings you used for that com-
mand. When you start to use something 
like the Brush Tool, the effects can’t be 
recorded as simple text because it would 
have to remember everywhere that you 
painted. If you would like to change this 
default setting so that the action CAN record the use of such tools, click on the 
little menu at the top right corner of the Actions panel and choose “Allow Tool 
Recording.” 

Here, the contents of all 
the layers were merged 
into a single layer, which 
is placed at the top of 
the layer stack.

When we choose “Allow Tool Recording” 
from the Actions panel side menu, the ac-
tion will record tools that it doesn’t usually 
record by default (like the Brush Tool).
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There are also certain commands that 
are not recorded by default because 
they don’t have the potential of chang-
ing your document. An example of this 
would be zooming in or out. If we would 
like these commands to be recorded, I’ll 
first make sure that I have highlighted 
the step in the action that I would like to 
precede the command I’m about to in-
sert. Then I’ll go back to that little menu 
in the corner of the Actions panel and 
choose “Insert Menu Item.” Now, a little 
“Insert Menu Item” dialog will appear and Photoshop will record the next menu 
item I use. If I would like to zoom the document view to 100%, I’ll go to the View 
menu and choose 100%. This command will appear in the “Insert Menu Item” dia-
log and we can click OK to insert the step. 

Applying an action to multiple documents

In some cases, we’ll have multiple images to which we’d like to apply the same 
effect. We can quickly apply an action on multiple documents as long as the ac-
tion does not require any interaction from the user. (If the action pauses to ask 
for settings, we will need to sit at the computer and enter them in for each and 
every image.) We will first select all of the images in Bridge. Then we’ll go to the 
Tools menu and choose Photoshop > Batch. The Batch dialog will appear and 
in the upper left, we will need to choose the action’s folder from the Set menu 
and then choose the specific action we’d like to use from the Action menu. The 
Source menu determines where the image are coming from and since we already 
selected our images in Bridge, we’ll choose Bridge from this menu. At the bottom 
left, there is an Errors menu and this is where we can specify whether we’d like 
the action to stop if an error occurs or if we’d like it to log the error[s] into a file 

Above: We are telling 
Photoshop to record 
a menu item (zoom 
to 100% view) as an 
action step. 

Left: you can see the 
step recorded in the 
Actions panel. 
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for later review. At the top and center of the Batch dialog, there is a Destination 
folder where we can specify what happens to the images after the action is run. If 
we choose None, the documents will stay open in Photoshop. If we choose Save 
and Close, the documents will be saved (with any changes being overwritten) 
and closed and if we choose Folder, we’ll get a separate, brand new file in which 
the end results will be saved.

Here, we are using the Batch dialog (accessed via the Tools menu in Bridge) to run an action 
on several images at once. 


