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Layer Mask Tips & Tricks
There is so much to learn about layer masks, and many of the most useful things 
are shorter tips and tricks, rather than in-depth techniques. Those are what I am 
going to cover in this lesson. 

Creating a new mask filled with black When you create a layer mask, the entire 
mask will be white by default. A perfectly white mask will not hide any of the layer 
that it’s attached to. If you would like the mask to be completely black when you 
add it to a layer, then hold down the Option key (Alt on Win) while clicking on the 
New Layer Mask icon at the bottom of the Layers panel. 

Turning selections into masks If you have a selection active when you add a layer 
mask, it will keep the selected area and mask the rest of the layer. In other words, 
the mask will be white in the area that is selected and black in the areas that are 
not selected. We can change that behavior by holding down the Option key (Alt 
on Win) while creating the layer mask. If you do this, the opposite will happen. 
The selected area will be hidden (that part of the mask will be black) and the rest 
of the area will be visible (those parts of the mask will be white). 

Copying a mask from one layer to another  Let’s say that you have carefully fine-
tuned a layer mask on one layer and you would like to use that same mask and 
apply it to another layer’s mask. To do this, click on the mask and drag it to the 
layer you’d like it to be applied to. This will remove the mask from one layer and 
apply it to another. If you’d like to copy the mask instead of move it (so that both 
layers end up with the same mask), then hold down the Option key (Alt on Win) 
while dragging the mask from one layer to another.  

Disabling and re-enabling masks You can temporarily disable a layer mask by 
holding down the Shift key and clicking the thumbnail for the layer mask. You will 
see a red X appear over the thumbnail for the mask indicating that it’s been dis-
abled. To re-enable the mask, simply do the same thing: hold down the Shift key 
and click on the mask’s thumbnail. 
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View the contents of a mask If you would like to view the full contents of a layer 
mask, hold down the Option key (Alt on Win) and click on the thumbnail for the 
layer mask. This will display the black and white layer mask right in your image 
window so that you can inspect it and fine-tune it. To get out of this view, hold 
down the Option key (Alt on Win) and click on the mask’s thumbnail again. 

Mask overlay When you view the contents of a layer mask, you are seeing the 
black and white mask, but not the image. If you would like to see both the im-

age and the mask at the same time, 
make sure the layer with the mask is 
active and then hit the backslash key 
(\). This will show the mask as a red 
overlay on top of your image. This 
will allow you to see what is hap-
pening with the image that’s being 
masked and will allow you to better 
fine-tune the mask. If you paint with 
black, you’ll be adding to the mask 
and if you paint with white, you’ll be 
subtracting from the mask, and re-
moving the red overlay. 

If the active layer has a mask attached to it, you 
can hit the backslash key (\) to get an overlay of 
the mask on your image. 

Here, we held down the Option key 
and clicked on the mask thumbnail 
in order to view the contents of the 

mask in the main image window. 
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Mask properties If you double-click on the thumbnail for a mask, you may get 
a pop-up dialog that asks you what you would like that command to do. If you 
choose “View Properties,” the Properties panel will appear for that mask and 

this panel includes mask settings such as Density 
and Feather. If you click on the little menu in the top 
right of the Properties panel, a menu will appear and 
you can choose Mask Options. In the Mask Options 
dialog, you can specify what it will look like when 
you overlay the mask on top of the picture. By de-
fault, the overlay color is red, but you can change it 
to whatever you want and you can adjust the opacity 
as well. 

Switch between the layer and the mask Sometimes, I need to quickly switch 
between working on the mask and working on the layer that it’s attached to. 
You can manually do this by clicking on the thumbnails of the layer and the lay-
er mask. You’ll know which is active because little brackets will appear around 
the thumbnail. To quickly do this using key-
board shortcuts, hold down the Command 
key (Ctrl on Win) and type the number 2 to 
activate the layer or hit the backslash key 
to activate the mask. 

Copy an inverted version of a mask We mentioned before that you can copy a 
mask from one layer to another by holding down the Option key and dragging 
the mask thumbnail between layers. You can also copy an inverted version of the 
mask by holding down both the Option key (Alt on Win) and the Shift key at the 
same time while dragging the mask from one layer to another. 

You can choose the color and 
opacity of the mask overlay 
by choosing Mask Options 
from the menu in the top cor-
ner of the Properties panel. 

The little brackets indicate whether the 
layer is active or the mask is active. 

We copied an inverted version of a 
mask from one layer to another by 
holding down the Option and Shift 
keys together.  
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Pasting content into a mask There are some instances where you might want to 
copy the contents of a channel and paste it into your layer mask. In the example 
here, I want to remove the background in this tree image. To do that, I will open 
the Channels panel and choose the channel that contains the most contrast. This 
is the blue channel. I will select the contents of that channel by going to the main 
menu and choosing Select > All and then Edit > Copy. 

Next, I’ll go back to the Layers panel and add a layer mask to the image layer. I 
want to paste what I copied from the blue channel into the layer mask, but in or-
der to paste information into a mask, it must be visible in the main image window. 
You can make the mask visible by showing it as an overlay (by using the back-

slash key) or by making the mask visible by holding 
the Option key (Alt on Win) and clicking on the mask 
thumbnail. In this example, we held down the Option 
key and clicked on the mask thumbnail.  With the mask 
visible, we can now paste (Edit > Paste) the information 
into the mask. 

In this image, the blue channel created the most separation between the trees (what we 
want to isolate) and the background (the sky). A selection was made of the blue channel.

We made the layer mask 
visible and then pasted 
the contents of the blue 
channel into the mask.
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Because I want to separate the trees from the background, I will use a Levels 
adjustment to try and force the sky areas to white and the tree areas to black.  
Finally, I’ll use the Brush Tool to further clean up the mask. 

At this point, the mask is white where the sky is and black where the trees are. 
I want to hide the sky area, so I will invert the mask by using the shortcut Com-
mand+I (Ctrl+I on Win). Then, I’ll Option+click on the mask’s thumbnail again so 
that we are no longer viewing the mask in the image window. 

Converting results of the Blending sliders to a layer mask If you use the Blend If 
sliders within the Layer Styles dialog to try and isolate part of your image, there 
is away to convert those results into a layer mask that can be further edited. Here 
is one way to go about doing that. I’ll first click through the different channels to 
see where the thing I’m trying to isolate separates the most from its surround-
ings. In the example here, I want to isolate the banner and the green channel 
shows the most separation between the banner and the wall. I’m not going to do 
anything in the Channels panel, however. I’ll go back to the Layers panel, click on 
the FX icon at the bottom of the panel and choose Blending Options. The Layer 

After fine-tuning and inverting the mask, we Option+clicked on the layer mask thumbnail 
again to view the results on the image.
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Styles dialog will appear and the Blend If settings can be found near the bottom. 
There is a channel dropdown menu and I’m going to choose the green channel.  
Then, I will drag the left slider under the “This Layer” gradient to the right, hiding 
the dark portions of the selected channel. I’ll work with the slider until the banner 
becomes as isolated as possible and then I’ll click OK. Now, in order to fine-tune 
the results, I’d need to be working on a layer mask. I need to convert the results 
of the Blend If sliders to a layer mask. 

I’ll create a new, empty layer beneath the 
image layer and then duplicate the image 
layer. Next, I want to merge the empty layer 
with the image layer that’s directly above it 
so I will activate the image layer and go to 
the main menu and choose Layer > Merge 
Down. This will make the results of the 
blending sliders permanent instead of an 
adjustable effect.  

The Blend If sliders are being used (With the Blend if menu set to Green) to hide the darker 
parts of the green channel. 

Left: An empty layer was placed at the 
bottom of the layer stack and a du-
plicate of the image layer was placed 
above it. Right: The bottom two layers 
were merged, locking in the effect. 
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To convert that into a layer mask, I’ll first activate the top image layer, click back 
on the FX, choose Blending Options again and then set the Blend If sliders back 
to their default positions. I’ll click OK. Now, I need to load the visible parts of the 
bottom layer as a selection by holding down the Command key (Ctrl on Win) 
and clicking within the thumbnail for that bottom layer. Making sure the top lay-
er is active, I will click on the Layer Mask icon at the bottom of the Layers panel. 
Because there was a selection active, it was automatically applied to the mask. 
Finally, I can throw away the bottom layer. I can now fine-tune the mask, better 
isolating the banner.

Working on a mask with Brush Tool blending modes If you need to adjust a 
complex mask that is working with fine details like hair or fuzz, it can be difficult 
to use the Brush Tool in order to perfectly mask the details. Here’s how we can 
change the blending mode of the Brush Tool in order to help us mask out the 
background while keeping the fine details we want. First, we’ll make sure that 
we’re viewing the mask so we’ll hold down the Option key (Alt on Win) and click 
on the thumbnail for the mask. Then we will activate the Brush Tool, select a soft 
brush and then set the Mode menu in the Options bar to Hard Mix. This mode 

The results of the Blend If sliders have successfully been transferred to a layer mask that we 
can fine-tune and adjust.
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protects the areas that are pure white so that they won’t be affected by painting 
with black. With the brush set to this mode, I can paint with black over the edge 
of this furry subject (a lion) and the areas that are pure white will remain while 
the grayish messy area will be changed to black. Note that if the result is too ex-
treme, as it was in this case, you may have to lower the Opacity setting, which 
can also be found in the Options Bar. If we switch to painting with white, the Hard 
Mix blending mode will protect the areas that are pure black, so they will not be 
affected as you paint. 

Masks & layer styles If you ever work with a layer that has layer styles attached 
to it, those layer styles will be affected by a layer mask. It will think that the shape 
of the layer is different so it will recalculate the layer styles, changing their ap-
pearance. That may not be what you want. If you don’t want this to happen, you 
will have to click on the FX icon at the bottom of the Layers panel and choose 
Blending Options. In the Blending Options dialog, you will find a “Layer Mask 
Hides Effects” check box. Turning this on will make it so the appearance of the 
layer styles don’t change when you add a layer mask. 

Here, we are painting on the mask using a soft-edged brush set to the Hard Mix blending 
mode to clean up the messy parts of the mask where the lion’s fur meets the background.
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Linking and unlinking the image from the mask After adding a layer mask to an 
image layer, you can move the layer around and the mask will move with it. But 
what if that’s not you want? There are some instances where you’ll want to move 
just the mask, or just the image within that mask. In this example, I masked the 
image layer so that it looks as if it appears on the iPad screen. When I went to re-
position and scale the image within that mask, however, the mask moved as well. 
This is not what I wanted. 

If you want to be able to scale or move the picture separately from the layer 
mask, you need to unlink the mask from the layer and you can do this by clicking 
on the little link icon between the image thumbnail and the mask thumbnail in 
the Layers panel. Then you can move and/or scale the image and the mask sep-
arately from one another. You just need to make sure that the correct thumbnail 
is selected in the Layers panel. If you want to move the mask, make sure that the 
mask is selected (it will have brackets around its thumbnail). If you want to move 
the image, make sure the image is selected.

Above: The image layer was masked to ap-
pear as if it’s on the iPad screen. Right: To 
move the image and the mask separately 

from each other, you need to unlink the two 
by clicking on the little link icon. 


