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Complex Masking Tips
In this lesson, we’re going to process a raw file more than once, focusing on how 
to do some complex masking. The example image was captured in a single expo-
sure and then processed twice: once for the sky and once for the foreground. It 
was crucial that I shot in the raw format here because I had to make the sky very 
bright and then bring the detail back in Adobe Camera Raw (ACR). 

Two Rounds of Processing During the first round of processing in ACR, we’ll fo-
cus on making the sky look good. To do that, we’ll bring the Highlights slider all 
the way down and then lower the Exposure slider until the sky looks dark enough.  

The first time 
we processed 
the image, we 
did so to make 
the sky look 
optimal. This 
involved moving 
the Highlights 
slider all the 
way down and 
the Exposure 
slider down a 
bit as well.

Transform Tool Tip: In this image, there was some slight distortion because I 
had to tilt the camera up in order to capture the treetops. To correct for this, I 
used the Transform Tool, which can be found in the tool bar at the top of the 
ACR interface. When activated, drag out lines on objects in your image that 
should be perfectly horizontal or vertical. Once at least two lines have been 
dragged out, ACR will correct the distortion. I dragged out two lines on tree 
trunks that were leaning in the frame in order to make them vertical again.
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After processing the image for the sky, we’ll create a new Snapshot of the im-
age, which will save all of the adjustment settings that were applied. To create a 
Snapshot in ACR, click on the tab on the far right side of the adjustment panel 
(this is the Snapshots tab) and then click the little New icon in the bottom of the 
panel. We’ll name the Snapshot “Sky” and then click OK. Next, we will process the 
image a second time, starting with default settings and then adjusting the sliders 
to make Karen and the trees look good. Once again, we will create a Snapshot of 
these settings, naming the Snapshot “Trees/Karen.” Now, we have two versions of 
the image: one version where the sky looks good and another version where the 
trees and Karen look good. 

Open Images as Photoshop Layers Now we need to open the two versions of the 
image as layers in a single Photoshop document. With the “Trees/Karen” version/
snapshot active, we’ll hold down the Shift key so the “Open Image” button turns 
into the “Open Object” button. We’ll click that “Open Object” button to open 
the image as a Smart Object layer in Photoshop.  (If you’re using Lightroom, you 
would go to the main menu and choose Photo > Edit In > Open as Smart Object 
in Photoshop.)  

We processed the 
image a second 
time, to optimize the 
foreground (the trees 
and Karen), and then 
created a second 
Snapshot inside the 
Snapshots panel in 
ACR.
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Next, we have to get the other version of the image as a second layer in this 
Photoshop document. To do that, we’ll go to the main menu and choose Lay-
er > Smart Objects > New Smart Object via Copy. This will duplicate the Smart 
Object layer in such a way that it will be independent of the original. This means 
that we can make changes to it without affecting the original Smart Object. We’ll 
double-click on the thumbnail image for the new Smart Object layer and it will 
open back in ACR. We’ll go back to the Snapshots tab and load the Sky version 
and click OK. Now we have two Smart Object layers in one Photoshop document: 
One where the sky looks good and one where the foreground looks good. 

Select and Mask After zooming up on the sky area 
and viewing it in both layers, it’s obvious to me that 
the transition between the sky and the palm trees 
looks cleaner in the image that was processed for the 
sky, so this is the layer that we’ll work on. To make a 
selection of the sky, we’ll use the Select and Mask fea-
ture, which can be found under the Select menu. 

When the Select and Mask window opens, we’ll first 
choose what kind of view we’d like to work with. The 
View menu is at the top of the Properties panel and 
you can scroll through them to choose one. In this 
case, I think the red Overlay mode will work the best. 
In this mode, the area that is selected will look normal 
and the area that is not selected will look red. 

We’ll use the Quick Selection Tool, which is at the top 
of the Tool Bar and should be active by default, to start 
painting in the area where the sky is. If you accidentally 
select too much using this tool, you can hold down the 
Option key (Alt on Win) and the cursor will turn into a 
minus sign (-) indicating that you can use the tool to sub-
tract from the selection. Alternatively, you can change 
the tool from add to subtract (and vise versa) by clicking 
the plus and minus icons in the top left corner of the Se-
lect and Mask window. 

The View options in the Select 
and Mask Properties panel. 

With the Quick Selection 
Tool active in the Se-
lect and Mask window, 
you can switch between 
adding and subtracting 
from a selection. 
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After getting a rough selection of the 
sky, we’ll switch to the next tool down, 
which is the Refine Edge Brush Tool. This 
tool will allow you to define areas where 
you want Photoshop to take control over 
what is selected and what isn’t selected. 
With this tool, we’ll use a larger brush and 
zoom up on the picture to better see what 
we’re doing. Then, we’ll only paint where 
the blue sky and the trees are mixed to-
gether. When I release the mouse button, 
Photoshop will take control and attempt 
to select this more complicated edge. 

To see if we missed any spots of sky, I will turn on the “Show Edge” check box, 
which will show where we’ve painted by turning everything else red. The area that’s 
been painted with the Refine Edge Tool is the area where we’re giving Photoshop 
control over what’s happening. In this view, we can see if there are any areas where 
the trees meet the sky where we have not yet painted. There are areas that I missed, 
so I will continue using the Refine Edge Tool to paint over those areas. 

The Refine Edge Brush Tool is being used 
to paint over the edges where we want to 
give Photoshop control of the selection. 
In this case, it’s the areas where the trees 
meet the sky. 

Turning on the Show Edge check box will show us what areas have been painted with the 
Refine Edge Brush Tool. 
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To preview the selection we have, I will change the View menu to On Layers, 
which will treat the unselected area as a mask, hiding that area to reveal what’s 
underneath. Now we can zoom in on the sky and trees to inspect the result. I can 
see that the transition is not as smooth as it should be, so we will continue to 
work on the selection later. 

Before leaving the Select and Mask window, I will go to the Output Settings in the 
Properties panel and specify how the selection should be rendered. I’ll choose 
Selection and then click OK. 

Fine-tune the Layer Mask The marching ants 
selection will appear around the sky area and 
I will turn the selection into a layer mask by 
clicking the New Layer Mask icon at the bot-
tom of the Layers panel. Now we’ll see if we 
can get the edge of the selection to look bet-
ter. When we created the layer mask, the part 
of the mask that is hiding the layer became 
completely black and the part of the mask 
that is revealing the layer became completely 
white. We want to control that transition from 
black to white. 

I’ll first make sure that the mask is active (the little brackets around the thumbnail 
indicate that it’s active.), I’ll zoom in on the sky area of the image and then I’ll go 
to the main menu and choose Image > Adjustments > Levels. In the Levels dialog, 
there are three main controls beneath the bar chart. The slider on the right will 
force more areas to white. In a layer mask, white makes things show up, so this 
slider will make more of the blue sky layer show up. The slider on the left will force 
more areas to black which, in this case, would hide more of the blue sky area. The 
middle slider will control the transition from white to black and this slider is going 
to be the key to improving our mask. I’ll move that slider left and right, looking 
at the effect on the area the trees meet the sky. In this case, dragging the slider 
to the left creates a much smoother transition. The problem is that one setting 
makes the tree trunks look optimal and another setting makes the leaves look 
optimal. Because of this, we’ll have to use two different settings. To start, we’ll 

The selection was turned into a Layer 
Mask. 
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set that center slider in the location that makes the trunks look optimal and then 
click OK. Now we need to use a different setting for the leaves. I’ll go back to the 
main menu and choose Image > Adjustments > Levels a second time and adjust 
the center slider so that the leaves look good. 

The History Panel & History Brush Of course, while this last adjustment improved 
the leaves, it made the tree trunks look bad again, so we need to undo the adjust-
ment just in the areas where the tree trunks are. To do this, I’ll open the History 
panel and click the little square to the left of the last history step, which is titled 
Levels. A little History Brush icon will appear in the square. This means that if we 

paint with the History Brush, we will paint with what 
the image looked like at this stage in the document. 
Now, I will click on the second to last step in the 
History panel to make it active. This will revert the 
picture to what it looked like after the first Levels 
adjustment. Next, we’ll activate the History Brush, 
which can be found in the Tool Bar on the left side 
of the interface. When we paint with the History 
Brush, we will be painting in the version of the im-
age that we assigned in the History panel, which is 
the version of the image after we applied the second 

A Levels adjustment is being made to fine-tune the Layer Mask. The center slider is being 
used to adjust the transition from black to white. At left, the slider is at its default setting. At 
right, it has been adjusted to create a smoother transition. 

In the History Panel, we spec-
ified what state of the image 
we would like to paint in with 
the History Brush and then 
clicked back one step to revert 
the image. 
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Levels adjustment. Using a soft-edged brush, I will use 
the History Brush to paint over the leaves of the trees 
where they meet the sky. After doing this, both the tree 
trunk areas and the leaf areas should look good. 

Decontaminate Colors There is another step we can take to improve the mask 
and make the tree/sky transition look more realistic. Within the Select and Mask 
dialog (accessed by going to the main menu and choosing Select > Select and 
Mask), there is a check box within the Properties panel called “Decontaminate 
Colors.” This setting takes areas that are partially transparent and shifts the color 
to get a better mix of the layer you’re working on and the layer underneath. The 
problem with this setting is that it doesn’t do a great job with trees and it doesn’t 
have an Amount slider to specify the strength of the setting. There is a trick to ac-
cessing an Amount slider, however, and that is by accessing the old Refine Mask 
dialog, which was standard in older versions of Photoshop and was replaced by 
the Select and Mask feature. To access this older feature, hold down the Shift key 
while choosing Select and Mask from the Select menu. When the Refine Edge 
dialog appears, you will see the Decontaminate Colors check box as well as an 
Amount slider beneath it. 

The History 
Brush icon

We accessed the Re-
fine Mask feature by 
holding down the Shift 
key while choosing 
Select and Mask from 
the Select menu. Here, 
we are adjusting the 
Decontaminate Colors 
slider in order to create 
a smoother transition.
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I will move the Amount slider all the way to the left and then gradually move it 
to the right again while looking at the effect on the image. Using a more subtle 
setting is what will ultimately provide the best blending results here. 

Recap To sum things up, we started by processing the image twice (once for 
the sky and once for the trees and Karen) and then bringing those two versions 
as separate Smart Object layers in a single Photoshop document. To blend the 
two images together, we started with Select and Mask in order to get the best 
selection possible. Then we turned that selection into a layer mask and adjusted 
it using Levels. To fine-tune the edge and apply different Levels settings, we used 
the History panel and the History Brush.


