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Layer Tips & Tricks

How to quickly target layers We can change which layer is active by clicking 
on its thumbnail in the Layers panel and we can change their stacking order by 
dragging them up and down in the Layers panel. However, there are faster meth-
ods for doing both of these things and they don’t require the Layers panel to be 
visible. This can be convenient if you ever use the Tab key to hide the side panels 
in order to make your image fill more of the screen. 

With the Move tool active, when you click and drag in your document, you will be 
moving the layer that is currently active. If you’d like to target a specific object 
to make its layer active, hold down the Command key (Ctrl on Win) and when 
you click the mouse button, it will target the top-most layer that contains pixels 
beneath your cursor. 

Note that this feature may work differently if you 
have Layer Groups in your document, and it will de-
pend on the setting that can be found in the Op-
tions Bar when the Move Tool is active. If you have 
the dropdown menu set to Layer, then Command+-
clicking will target the top-most layer beneath your 
cursor. If you have the dropdown menu set to Group, 
it will target an entire group (if there is a layer con-
tained within a group beneath your cursor). 

If there is more than one layer that overlaps beneath your cursor and you would 
like to target one of the underlying layers, right-click on that area in your docu-
ment (or hold down Control while clicking on a one-button mouse) to get a little 
menu that lists all of the underlaying layers and allows you to choose one to make 
it active.

Now let’s say that you want to quickly select more than one layer using the meth-
od described above. First select one layer by holding down the Command key 
(Ctrl on Win) and clicking on an object in your document to activate its layer. 
Then, hold down the Shift and Command keys together (Shift+Ctrl on Win) and 
click on another layer in your document. Adding the Shift key will tell Photoshop 
to add to what’s already selected. 

This setting in the Options Bar 
will determine whether Com-
mand+clicking will select a 
layer or a group.
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Here is another method of selecting multiple layers at once. With the Move Tool 
active, start with your cursor in an empty area within the document (empty mean-
ing checkerboard or the background layer). Then, hold the Command key (Ctrl 
on Win) and click and drag over objects in the document. A box that looks like 
a selection marquee will serve as your guide so that you can see what you’re se-
lecting. Every layer that contains pixels inside this box will become selected in the 
Layers panel. If a layer was selected accidentally, you can deselect it by holding 
the Shift and Command keys while clicking again on the object in your document 
window. 

Auto-Select Layer  With the Move Tool active, the 
Auto-Select Layer setting will be available in the 
Options Bar. It may appear as text with a check box 
or it may appear as an icon on the left side of the 
Options Bar. If you turn this setting on, every time 
you click and drag within your document, the lay-
er directly under your cursor will be activated and 
moved automatically (without holding down the 
Command key). I, personally, find this setting to be 
frustrating so I keep it off. 

Here, we are holding down the Command key and dragging a rectangle out in the docu-
ment. Every layer that contains pixels within that rectangle will be selected. 

The Auto-Select Layer icon in 
the Options Bar (in some ver-
sions, this appears as a check 
box with text. 
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Changing the layer stacking order To move a layer up or down in the layer stack, 
you can drag the layer thumbnail to the position you desire within the Layers pan-
el. If you don’t want to work in the Layers panel, however, there is a faster method. 
With the layer you want to move active, hold down the Command key and then 
use the left and right bracket keys ( [ ] ) to move the layer up and down in the 
layer stack. If you add the Shift key while holding Command+ [ , the layer will be 
sent to the bottom of the layer stack (not below the Background layer though) 
and if you add the Shift key while holding Command+ ], the layer will be moved 
to the top of the layer stack. To reverse the order of several selected layers, go to 
the main menu and choose Layer > Arrange > Reverse. 

Duplicate a layer multiple times To quickly duplicate the active layer, use the key-
board shortcut Command+J (Ctrl+J on Win). Alternatively, you can hold down 
the Option key (Alt on Win) while using the Move Tool to drag out a duplicate of 
the active layer. This allows you to quickly make multiple duplicates of an object 
and place them in different areas within your document. While using the Move 
Tool, if you add the Shift key, you’ll only be able to move the layer perfectly hori-
zontally or vertically.  

Preserving transparency Any transparent areas in a layer will be represented by 
a checkerboard pattern in the layer’s thumbnail in the Layers panel. If you know 
that you would like to make changes to the areas of the layer that actually contain 
pixels but you don’t want those changes to affect the transparent areas, you can 
lock the transparency by clicking the checkerboard icon at the top of the Layers 
panel. This will lock the transparent areas so that they can not be affected by 
the Brush Tool or any other tools. In the example here, the layer contains a soft-

edged, red swirl in the middle of the 
document. After locking the transpar-
ency for this layer, I painted with blue 
on the layer and the only areas affect-
ed were the areas that contained the 
swirl. The brush did not affect any of 
the transparent areas. 

The Lock Transparency setting at the top of 
the Layers panel.
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Now let’s look at how we can preserve transparency while using a fill command. 
To fill a layer with your foreground color, use the keyboard shortcut Option+De-
lete (Alt+Delete on Win). If you would like this command to preserve the trans-
parent areas and only fill the areas containing pixels, add the Shift key. (Shift+Op-
tion+Delete on Mac, Shift+Alt+Delete on Win)

Linking layers When you link multiple layers together, they will move as one unit 
when you reposition or rescale them. This can be convenient when you have a 
complex document where the layers you want to link are not close to each other 
in the Layers panel and don’t have their visibilities turned on at the same time. To 
link multiple layers, first select the layers you want linked and then click the little 
link button at the bottom of the Layers panel. You’ll see a link icon appear next 
to the thumbnails for all the linked layers. If you’d like to temporarily unlink one 
of the layers, hold down the Shift key and click on the link symbol for the layer 
you want to unlink. You’ll see a little red X appear over the icon indicating that it’s 
temporarily unlinked. 

Locking Layers If you know that you’ll 
never want to move a layer, you can 
lock its position by clicking the move 
icon next to the Lock options at the top 
of the Layers panel. I will often times 
do this with my retouching layer that is 
always directly above my background 
layer (which contains my original im-
age) because I know that the retouch-
ing needs to stay perfectly positioned 
over the image layer. 

To link layers, first select the layers and then 
click the Link icon at the bottom of the Lay-
ers panel (above). To temporarily unlink a 
layer, hold Shift and click the link symbol to 
the right of the layer’s name. (right) 

The setting to lock the position of the active 
layer. 
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Filtering Layers When you have a 
complex document that contains 
many, many layers, it can be difficult 
to locate a particular layer in the Lay-
ers panel. To make that easier, you 
can use the Filter bar at the top of 
the Layers panel to search for layers 
based on certain criteria. From left 
to right, the icons will filter by layers 
that contain pixels, adjustment layers, 
type layers, shape layers and Smart 
Object layers. You may also use the 
dropdown menu to search your lay-
ers based on different types of crite-
ria such as Effect, Mode, Color, Name, 
etc. When you have one of these fil-
ters applied, the little red switch icon 
in the filter bar will turn red, indicating 
that you’re limiting the number of lay-
ers you’re looking at. If you no longer want to limit the number of layers you’re 
seeing, click the little switch and all of your layers will become visible in the Layers 
panel again. 

Isolating a layer into its own document You can take a single layer from a multi-lay-
er document and copy it to its own, separate Photoshop document. To do this, 
hold down the Option key (Alt on Win) and drag the layer to the New Layer icon 

at the bottom of the Layers panel. The 
Duplicate Layer dialog will pop up and 
you can use the Document dropdown 
menu to determine whether the layer 
will be duplicated to a New document 
or to another document you have open 
in Photoshop. If you choose to duplicate 
the layer to a new document, you’ll have 

The filter bar at the top of the Layers panel.

The Duplicate Layer dialog box.

The dropdown menu can be used to filter your 
layers based on certain criteria.
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the option to give the new document a name. When the new document appears, 
it will be the same size as the document you duplicated the layer from. If you’d 
like to get rid of any empty space around the layer, go to the main menu and 
choose Image > Trim. 

Removing transparency in a layer There are a few different things you could do to 
a layer that would result in unintended transparency. Let’s say you want to make 
that layer perfectly opaque again. Duplicate the layer multiple times by using the 
keyboard shortcut Command+J (Ctrl+J on Win). Keep using this shortcut until  
you can no longer see through the layer. Then select all copies of the layer with-
in the Layers panel and go to the main menu and choose Layer > Merge Layers. 
Alternatively, you can use the keyboard shortcut Command+E (Ctrl+E on Win). 

Delete hidden layers If you ever finish your work with a document and end up 
will several hidden, unused layers, it might be a good idea to delete these so they 
don’t increase your file size. To do this, click on the little side menu in the top right 
corner of the Layers panel and choose Delete Hidden Layers.

How to quickly toggle visibility When I’m trying to figure out what content/ob-
jects are contained in the layer I’m working on, I will turn the layer visibility on and 
off repeatedly so that I can see what disappears and reappears. To quickly toggle 
the visibility of the active layer, use the keyboard shortcut Command+comma(,)  
(Ctrl+comma on Win). 

Open a flattened version of a PSB file If you have a Photoshop file that exceeds 
four gigabytes, the file format will be PSB instead of PSD and that stands for 
“Photoshop Big.” It is not practical to send someone a file of this size, and it’s even 
inconvenient to open a PSB file because you will get a progress bar in Photoshop. 
Let’s say you’d like to send a flattened, smaller version of this file to someone 
else. A convenient way of doing this would be to hold down Shift+Option and 
double-click on the file thumbnail within Bridge. A Photoshop dialog will appear 
asking you if you want to “Read the composite data instead?” Within a layered 
file, there is also usually a flattened version of the file and Photoshop is asking if 
it should open that flattened version. If you click OK, it will open that version and 
you can save it out as a smaller, flattened file. If you click OK and end up with 
an error, it means that the Maximize Compatibility setting was not turned on for 
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that file. It is this setting that tells Photoshop to include a flattened version of the 
image within the file and allows programs like Lightroom to display the image. 
To make sure the Maximize Compatibility setting is on, go to the main menu and 
choose Photoshop > Preferences > File Handling and make sure the “Maximize 
PSD and PSB file compatibility” check box is turned on. 

The Maximize Compat-
ibility setting within 
the File Handling  
section of the  
Preferences dialog.


