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Customizing Photoshop

There are many different ways of customizing the Photoshop interface to best suit 
your specific needs. You can decide what options appear in the menus, what tools 
are included within the Tool Bar, what your panel configuration will look like, etc. 
In this lesson, we’re going to look at the various ways you can set up Photoshop 
for your workflow. 

The Toolbar

The Toolbar is located by default on the 
very left side of the Photoshop interface 
and contains many tools used in work-
ing with your images. To customize the 
Toolbar, go to the main menu at the top 
of the interface and choose Edit > Tool-
bar. A dialog box will appear and on the 
left side, there is a list of all the tools. 
In the actual Toolbar, some of the tools 
are hidden behind other tools. If you 
click and hold on one of the tool icons, 
a menu will appear that contains all of 
the tools hidden beneath that tool icon. 
In the list of tools on the left side of the 
Customize Toolbar dialog, all of the tools 
are listed, including the hidden ones. To 
the right of the tool’s name, you’ll find 
the keyboard shortcut that can be used 
for quickly accessing the tool. 

Using this tool list, you can decide to 
hide any tools that you never use. For 
example, I hide the 3D Material Drop 

In the Toolbar on the left side of the inter-
face, the tools are grouped together, with 
only one tool per group appearing as an 
icon. Click and hold on an icon to reveal the 
other tools in the same group. 

All of Photoshop’s tools are listed within the 
Customize Toolbar dialog and they are orga-
nized into the groups they appear in within 
the Toolbar. To the right of a tool’s name is 
its keyboard shortcut. 



Customizing Photoshop  © Ben Willmore, All rights reserved 3

Tool because I rarely work with 3D images and I don’t want something I never use 
cluttering up my Toolbar. To remove a tool from the Toolbar, simply drag it to the 
“Extra Tools” area on the right side of the dialog box. 

Customize a tool’s keyboard shortcut  As we mentioned above, the keyboard 
shortcut for a tool will be listed to the right of the tool’s name in the Customize 
Toolbar dialog. If you would like to change the keyboard shortcut to something 
you’ll more easily remember, click on the name of the tool and the shortcut will 
automatically become highlighted. Then you can enter in a new shortcut. 

Ungroup a tool The tools are organized into 
groups within the Toolbar so the icon of one 
tool in the group is visible and the rest are hid-
den behind it. You need to click and hold on the 
icon to reveal all of the tools in the group. To 
remove a tool from the group it’s in, click on the 
name of the tool in the Customize Toolbar dia-
log and drag it out of its group so it appears in 
its own slot. 

Here, I decided 
to hide the 3D 
Material Drop 
Tool so that it 
no longer ap-
pears within my 
Toolbar. I hid the 
tool by dragging 
it from the tool 
list on the left 
into the Extra 
Tools area on the 
right. 

Here, we’re ungrouping a tool from 
its group by dragging it out of the 
group within the Customize Toolbar 
dialog. 
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At the bottom of the Customize Toolbar dialog, 
there is a “Disable Shortcuts for Hidden Tool-
bar Extras” check box. If you turn this on, the 
keyboard shortcuts for any hidden tools (the 
ones you placed in the Extra Tools section) will 
not work. There are also a series of icons at the 
bottom of this dialog and these let you decide 
whether certain items appear in your Toolbar. 
These include the foreground and background 
color swatches, the Quick Mask Mode icon, and 
the toggle Full Screen Modes icon. 

The icons at the bottom of the Cus-
tomize Toolbar dialog allow you to 
hide the various features that appear 
by default at the bottom of the Tool-
bar. 
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Below is a visual list of tools I usually hide or rearrange. The tools highlighted in 
red are the tools I hide because I rarely or never use them. The tools highlighted in 
blue are the ones I rearrange. 
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Accessing hidden tools When you 
hide a tool (or tools) from your 
Toolbar, know that you will still have 
access to those tools. At the bot-
tom of the Toolbar, there is an icon 
that looks like three little dots (see 
screen shot). Click and hold on that 
icon and you’ll get a menu contain-
ing all of the tools you’ve hidden. 

Toolbar Tips

Single-column vs. double-column Toolbar  
By default, the Toolbar is a single column 
on the left side of the screen. If you would 
like the Toolbar to occupy two columns 
instead of one, click on the little double 
arrow icon at the very top of the Toolbar. 
Click on the icon again to return to the sin-
gle-column view. 

Bird’s eye view  If you’re ever zoomed way in on your image and want to see the 
full view of the picture, press and hold on the H key (the keyboard shortcut for the 
Hand Tool) and then click and hold with your mouse to get a zoomed-out view 
of the entire picture. This is called bird’s eye view. When you release the mouse 
button, the view will become zoomed in again. When you temporarily zoom out 
on your image using this technique, there will be a highlighted rectangle on your 
image, which represents the area you were zoomed in on. If you drag your mouse 
to reposition this rectangle, the image will zoom in to that new location when you 
release the mouse button. 

Click the icon 
that looks like 
three little dots 
in order to ac-
cess all the tools 
you’ve hidden 
from your Tool-
bar. 

We’re switching from a single- 
to a double-column Toolbar. 
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Temporarily access a tool  In the tip above, we mentioned that you can hold down 
the H key to temporarily access the Hand Tool. Know that this technique works 
with any of the tools that have keyboard shortcuts. When you press and hold on 
the shortcut key, you will temporarily access the tool until you release the key 
again. If you simply tap on a shortcut key, the tool will become active and it will 
stay active. 

The two tools I access the most via the “press-and-hold” method are the Eyedrop-
per Tool and the Move Tool. I’ll press and hold the I key to temporarily access the 
Eyedropper Tool so that I can sample a color from within the image. 

I’ll often times press and hold the V key to temporarily access the Move Tool. This 
can be convenient when I need to reposition a guide that is on my document. Note 
that holding down the Command key (Ctrl on Win) will also temporarily access 
the Move Tool. 

Assign keyboard shortcuts There are some tools that do not have a keyboard 
shortcut assigned and when you go to the Customize Toolbar dialog, there is 
no option for adding one. An example would be the command for setting your 
foreground color. The Customize Toolbar dialog does not allow you to assign a 
shortcut for this command. Whenever this is the case, know that there is another 

way you can assign a shortcut and 
that is by going to the Edit menu 
and choosing Keyboard Shortcuts. 
When the dialog appears, change 
the “Shortcuts For” menu to Tools. 
Then, scroll down the list of tools 
until you find the tool or command 
you want to set a shortcut for. I 
chose Foreground Color Picker. 
When you click on the name of a 
tool, a text field will appear to the 
right of it, and this is where you 
type in your desired shortcut. 

In the Keyboard Shortcuts dialog, we clicked on 
the name of a tool in order to access the text field  
to type in a new keyboard shortcut.
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Edit Application Menus

The same dialog we used in the 
tip above can be used to custom-
ize the Application Menus, which 
are the menus that appear along 
the top of the interface. In that 
Keyboard Shortcuts and Menus 
dialog box (accessed by going to 
the Edit menu and choosing Key-
board Shortcuts OR Menus), click 
on the Menus tab at the very top 
of the dialog and make sure the “Menus For” menu is set to Application Menus. You 
will see a list of all the menus that span along the top of the interface. Click on a 
menu option and it will expand to show you all of the items that appear within that 
menu. To the right of each choice is an eyeball icon. If you would like to hide any 
of the menu options so that they don’t appear in your menu, click on the eyeball 
icon to turn off its visibility. This allows you to clean up the menus in your interface 

so they only display 
the options you use. 
You can also assign 
a color to your menu 
items by clicking on 
the color field to the 
right of the menu 
option’s name with-
in the Menus dialog. 
I use this feature to 
assign colors to the 
menu options I use 
the most so they re-
ally stand out and are 
easy to spot. 

To customize the Photoshop Application Menus, 
make sure the Menus tab is active within the Key-
board Shortcuts and Menus dialog. Then, use the 
“Menu For” menu to choose Application Menus. 

Click on the eyeball icon to the right of a menu item to hide the 
item from the Photoshop menu. Click on the field to the right of 
the eyeball icon in order to assign a color to the menu item.



Customizing Photoshop  © Ben Willmore, All rights reserved 9

Assign shortcuts to menu items  To assign keyboard shortcuts to different menu 
items, click on the Keyboard Shortcuts tab at the very top of the Keyboard Short-
cuts and Menus dialog box and make sure the “Shortcuts For” menu is set to Ap-
plication Menus. Then, you can scroll down the list of menu items and enter in a 
custom shortcut to the right of a menu option’s name. If you enter a shortcut that 
is already used for another Photoshop command, you’ll see a warning symbol ap-
pear letting you know that the shortcut will be removed from that other command 
if you continue. 

Here, we’re assigning a keyboard shortcut to a specific menu item. We clicked on the Key-
board Shortcuts tab at the very top of the dialog and then chose the Application Menus 
option from the “Shortcuts For” menu. 
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Below are a couple of lists that show what changes I usually make to my menus 
and what keyboard shortcuts I custom-create for my Photoshop commands. 
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How to access hidden menu items When you hide an item from one of your ap-
plication menus, it doesn’t mean that you can no longer access the command. If 
you would like to access a hidden menu item, scroll to the bottom of the menu it 
would normally appear in and click on the “Show All Menu Items” option. Alter-
natively, you can hold down the Command key (Ctrl on Win) as you click on the 
menu name. This will open the menu in a way that displays ALL of the default 
menu items, including the ones you’ve hidden. 

Edit Panel Menus

The various Photoshop panels all contain 
their own menus and you can customize 
these menus as well. Note that all of Photo-
shop’s panels can be accessed by clicking on 
the Window menu and choosing the name 
of the panel. When a panel is expanded, the 
menu will appear as an icon in the upper 
right corner of the panel. To customize one 
of these menus, click on the Edit menu at 
the top of the interface, choose Menus and 
make sure the “Menus For” menu is set to 
Panel Menus. Then, scroll down the list of panels and expand the one you want to 
customize. Here, you can hide a menu option or assign a color, just like we did with 
the Application Menus. To assign a custom keyboard shortcut, click on the Key-
board Shortcuts tab at the very top of the dialog and make sure the “Shortcuts 
For” menu is set to “Panel Menus.” 

The panel menus can be found in the top 
right corner of each panel. These individ-
ual menus can be customized by using 
the settings within the Keyboard Short-
cuts and Menus dialog.
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Below is a list of Panel Menu changes I make in my version of Photoshop

Working with Panels

As we mentioned earlier, you can access any Photoshop panel via the Window 
menu at the top of the interface. Panels can be displayed in one of two ways 
within the interface. They can 
be full-scale with tabs at the 
top. This is how the Layers 
panel appears, by default. They 
can also appear as an icon that 
you can click on to expand the 
panel. If you have a full-scale 
panel and want to convert it 
into an icon panel, click on the 
little double-arrow icon in the 
top right corner of the panel. 
Note that if there are any oth-
er panel tabs grouped with that 

Photoshop’s panels can be viewed as full-scale pan-
els, like the ones highlighted in red, or as icon panels 
(highlighted in blue) where you click on an icon to 
expand the panel. 



Customizing Photoshop  © Ben Willmore, All rights reserved 13

panel, they will also convert to the icon 
view. Click on that same little double-arrow 
icon to convert it back to a full-scale panel. 
When viewing a set of panels in the icon 
view, you can drag the side of the panel 
out so that the panel becomes wider and 
includes text that describes what the panel 
is. I keep my most-used panels in the full-
scale view and then take the panels I use 
less frequently and group them together in 
the icon view so that I can expand them 
only when needed. 

Auto-Collapse Iconic Panels You can set up the iconic panels to auto-collapse 
when you click away from them. To do this, access the Preferences dialog via the 
Photoshop menu (It will be under the Edit menu on Win) and click on the Work-
space category. There, turn on the “Auto-Collapse Iconic Panels” check box and 
click OK. 

Arranging panels  You can rear-
range the panels within the interface 
by clicking and dragging on the tab 
that contains the panel’s name or 
icon. If you drag it out into an empty 
area of the interface, it will become 
a free-floating panel. If you drag it 
within another grouping of panels, 
you’ll see a blue highlight appear, 
showing you the location the panel 
will become docked if you release 
the mouse button. If you’d like to 
move an entire group of panels, click 
and drag on the gray bar that runs 
above the panel tabs. If you would 

Click on the little double arrow icon ( >>) 
to switch between the full scale view and 
the icon view. 

Drag a panel’s tab to change its position. A blue 
highlight will appear, showing you where the 
panel will become docked when you release the 
mouse button. 

Dragging out 
the side of the 
icon panels will 
expand them 
to show their 
name as well.
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like a group of panels to become anchored to the side of your screen, drag the set 
of panels near the edge of the interface until you see a vertical blue bar become 
highlighted. This blue bar shows you where the panel set will be anchored when 
you release the mouse button. 

Closing a panel When you have a single, free-floating panel, you can close the 
panel by clicking the little X icon in the top right corner. If, however, the panel is 
grouped with other panels, you can only close it by clicking on the menu in the top 
right corner of the panel set and choosing Close from the menu that appears. This 
will close the panel that was currently visible in that panel grouping. If you instead 
chose the Close Tab Group from that menu, all of the panels in that grouping will 
be closed. 

To move a group 
of panels, click 
and drag on the 
gray bar above the 
panel tabs. When 
you position the 
grouping next to 
a dividing bar on 
the interface, a 
blue highlight will 
appear, indicat-
ing that the panel 
grouping will be 
docked there if 
you release the 
mouse button. 
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Expanding and contracting panels Double-click on the tab containing the panel 
name to collapse it. This will cause it to take up much less space in your interface. 
Double-click on the name again in order to expand it. You can also drag the sides 
of panels to determine how big or small the panel should be. 

Hide  panels At any time, you can press the Tab key to hide all of the panels in 
the Photoshop interface. Press the Tab key again to make them reappear.  Hitting 
Shift+Tab hides everything except for the Toolbar on the left and the Options Bar 
that runs along the top of the interface. 

How to hide other parts of the interface  If you scroll down to the bottom of the 
Window menu, you’ll find some extra options for toggling the visibility of parts of 
the interface. These include the Toolbar and the Options Bar. There is also an op-
tion for turning the Application Frame on and off. The Application Frame includes 
the solid background you would see if you undocked your image tabs from the 
top of the interface by dragging the tabs into free-floating windows. When you 
turn the Application Frame off, you would see anything you have running behind 
Photoshop on your screen. 

Workspaces 

After you’ve set up your Photoshop inter-
face the way you like it, you can save all 
those settings as a workspace. Click on 
the little menu on the far right side of the 
Options Bar and the Workspace menu 
will appear. There are some default work-
spaces that come with Photoshop, but if 
you choose the New Workspace option, a 
dialog will appear. In this New Workspace 
dialog, you can give the workspace a custom name and use the check boxes to 
specify whether or not the workspace should include the settings for Keyboard 
Shortcuts, Menus and the Toolbar. After you save a custom workspace, it will ap-
pear within that Workspace menu on the right side of the Options Bar. 

The Workspace menu can be found on the 
far right side of the Options Bar at the top 
of the screen.


