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Basic Troubleshooting

Troubleshooting might not be the most exiting thing to learn, but it sure will prove 
to be useful if something doesn’t work the way you expect it to when working in 
Photoshop. In this lesson, we’ll cover the basic troubleshooting techniques that 
could potentially save you from a lot of frustration in the future. 

Feature not working: Selection active?

If you ever try to make a change to your image and nothing seems to happen, 
there are a few things that could be going on. The first thing to check is whether 
or not you have a selection active. If there is a selection active, it’s isolating part 
of your document, making it the only area that you can work on. If the selection is 
very small, it might not be easily visible on your screen. Often times, you might be 
zoomed in to a particular location and don’t realize that there is an active selec-
tion somewhere in the document that is outside of your current view. To check if 
there is a selection active, click on the Select menu at the top of the screen. If the 
Deselect option is available to you, it means that you DO have a selection active. 
Click Deselect to clear the selection. 

Brush Tool not working: Options Bar settings?

If you are using the Brush Tool, noth-
ing seems to be working and there is no 
active selection, the next place to look 
would be in the Options Bar above the 
image window. There, you will find the 
Opacity and Flow settings.  If one or both 
of these settings is at zero or close to it, 
you’re not going to see any change being 
applied with the Brush Tool. The Mode menu can also be found in the Options Bar 
and if it is set to anything other than normal, the Brush Tool will not act in the way 
that you probably expect. 

Here, the Opacity setting for the Brush 
Tool is only at 1%. This made it appear as if 
nothing was happening when we painted 
in the document. 
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Reset tool settings 

If the tool is still not working properly af-
ter checking the things mentioned above, 
you can completely reset the tool settings. 
The icon at the far left side of the Options 
Bar represents the active tool. Right-click 
on the icon and a little menu will pop up. 
Choose “Reset Tool” from that menu. This 
will take all of the options within that Op-
tions Bar and change them back to their 
default settings. 

Adjustment not working: Type layer active?

If you ever go to the Adjustments menu (accessed by going to the main menu and 
choosing Image > Adjustments) and find that all of the adjustments are grayed 
out, there could be a couple of reasons why. Check the Layers panel to make sure 
that the layer you want to work on is actually active and that it’s a normal layer. 
Know that adjustments will not be accessible if the active layer is a text layer. To 
apply an adjustment to a text layer, you would need to either use an adjustment 
layer or rasterize the text layer so that you can apply a regular adjustment. You 
can rasterize a type layer by going to the Type menu and choosing “Rasterize 
Type Layer.” After a type layer has been rasterized, it will no longer be editable. 
Photoshop will just think of it as another image layer. 

Filters not available: RGB mode and 16/bit mode?

All of the filters available in Photoshop can be accessed within the Filter menu at 
the top of the screen. There are some instances, however, where certain filters may 
be grayed out and therefore unusable. If this ever happens, it may have something 
to do with the mode your image is in. You can tell what mode the image is in by 

Reset a tool to its default settings by 
right-clicking on the tool icon at the far left 
side of the Options Bar and choose “Reset 
Tool” from the menu that pops up.
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going to the Image menu at the top of 
the screen and choosing Mode. Most im-
ages are in RGB mode and some of Pho-
toshop’s filters require the image to be 
in RGB mode. If the image is in another 
mode, like CMYK, you will need to switch 
the mode to RGB in order for those filters 
to work. Some of the filters also may not 
be available if the image is in something 
other than 8-bit mode. You can see what 
bit-depth your image is in (and change 
the bit depth setting) by going to that 
same Mode menu. 

Multiple layers active 

There are many features in Photoshop that will not be available if you have more 
than one layer active. If you ever notice that loads of menu items are grayed out, 
look in your Layers panel and make sure that only one layer is active. If you need 
to apply an adjustment to more than one layer, you can do so by using an adjust-
ment layer. An adjustment layer will affect all the layers that lie beneath it in the 
Layers panel. 

Auto-Select Layer 

The Auto-Select Layer feature can really mess you up 
when trying to move layers. Let’s say that you activate a 
layer and then use the Move Tool to try and reposition the 
layer but it’s a different layer that ends up moving. This 
could happen if the Auto-Select Layer feature is turned 
on. When the Move Tool is active, the Auto-Select Layer 

In the Filter 
menu, you 
can see that 
some filters 
are grayed 
out, meaning 
they’re un-
available. This 
could have to 
do with the 
mode your 
image is in. 

The Auto-Select Layer 
setting can be found on 
the left side of the Options 
Bar when the Move Tool is 
active. It will appear as an 
icon or a check box.
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setting can be found near the left side of the Options Bar. Depending on your 
interface, it may appear as an icon or it may appear as a check box. When this 
setting is turned on, any time you click with the Move Tool, it looks at what layer 
contains something directly below your mouse and targets that layer. If you’re not 
used to this setting being turned on, it could become very frustrating when the 
targeted layer keeps changing. When the Auto-Select Layer feature is turned off, 
it will not automatically switch layers. You can activate a layer in the Layers panel 
and then reposition it by using the Move Tool to drag anywhere inside the image 
window. It doesn’t even have to be in a place where the layer contains content. 

Temporarily access Auto-Select Layer feature Note that you can temporarily ac-
tivate the Auto-Select Layer feature while using the Move Tool. To do this, hold 
down the Command key (Ctrl on Win). When the key is held down, the Auto-Select 
Layer feature will be on and you can change layers simply by clicking on objects 
within the document. When you release the key, the feature will turn off again. 

If you decide to keep the Auto-Select Layer fea-
ture turned on, there is one situation that could 
really mess you up. Any layers that are near the 
top of the Layers panel and take up the entire can-
vas space will always be targeted when using the 
Move Tool. An example of this would be a texture 
layer. If you have a layer at the top of the layer 
stack that is designed to create a texture effect in 
your image, it will be impossible to target any oth-
er layer using the Move Tool with the Auto-Select 
Layer feature turned on. That’s because the Move 
Tool will always target the layer containing infor-
mation directly beneath the cursor, and a texture 
layer will ALWAYS be the layer beneath the cursor 
because it takes up the entire document. In order 
to select any other layers, you will need to turn Au-
to-Select Layers off. 

There is a texture layer at the top 
of the Layers panel. When using 
the Move Tool with the Auto-Se-
lect Layer setting turned on, it 
will ALWAYS target that texture 
layer because it takes up the en-
tire document. 
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Feature not working: Finish modal feature?

Photoshop can tend to be very modal, meaning it will enter a certain mode and 
you may have to finish the task you are doing before you will be able to do any-
thing else. For example, when you have an adjustment dialog box open, you will 
not be able to do other things like work with tools. You will need to finish adjusting 
the settings in the dialog box and then click OK or Cancel to close it. Only then 
will you be able to move on and use another feature. Another example would be 
the Free Transform command. If you are using the Free Transform command and 
those Free Transform handles are active in your document, you will not be able to 
apply a filter, adjustment, etc. Those features will be grayed out (meaning unavail-
able) in the menus. 

If features are not available to you and you’re not sure whether or not you’re in 
some type of mode, hit the Return/Enter key and then hit the Escape key. If you 
are in any kind of mode, the Return/Enter key will usually finish that task and take 
you out of that mode. The Escape key will abort whatever task you are doing. 
Therefore, hitting those two keys should ensure that you are exited out of any 
modes. 

In these two screen shots, Photoshop is in some type of mode that 
is preventing us from using any other features. Above, we’re in the 
Hue/Saturation dialog box. At left, we have the Free Transform 
handles active.
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Shortcuts not working: Text field active?

You may notice, at some point, that your keyboard shortcuts stop working. If this 
happens, you likely have an active text field somewhere in your interface and Pho-
toshop thinks that you’re entering text. For example, if you were manually entering 
an opacity setting into the Opacity text field, Photoshop will think that whatever 
you’re typing should be entered into that field. You will have to click away from the 
text field in order for the shortcuts to continue working. 

Adjustment not affecting image: Preview Off? 

When working with the settings for an adjust-
ment, you will usually be able to preview how the 
settings are affecting the image within the im-
age window. But what if you change the settings 
around and don’t see any change to your image? 
In a case like this, the Preview checkbox is likely 
turned off. You simply need to turn it on again. 
The Preview checkbox is usually somewhere near 
the bottom of the adjustment dialog and this is a 
“sticky” setting. If a setting is sticky, it means that 
if you change the setting, it will remain that way 
until you change it back. 

Text not appearing: White on white? 

One of the snags you might run into when using the Text Tool is that you start to 
type in text but nothing appears on the screen. If this happens, first look to see 
what font you’re using. Some fonts have special characters (ex: emojis) that might 
not have a character that coordinates with what you’re typing.  However, more of-
ten than not, this happens when you are using white text on a white background. 

The Preview check box is turned 
off so the image window is not re-
flecting the changes we’re making 
to the adjustment settings. 



Basic Troubleshooting © Ben Willmore, All rights reserved 8

Check to see what your fore-
ground color is to make sure 
that it’s not blending in with 
the document background. If 
you ARE typing with white (on 
a white background), simply 
highlight all of the text by tap-
ping Command+A (Ctrl+A on 
Win) and then clicking on the 
color swatch within the Op-
tions Bar at the top of the im-
age window. This will bring up 
the Color Picker and allow you 
to change the text to a different 
color. 

Brush tip issues: Caps lock? Brush size huge? Preference change?

When using the Brush Tool, your cursor should turn 
into a round tool tip representing the size and shape 
of the brush. If, instead, your cursor only appears as 
a little crosshair, there are a few different things that 
could be going on. In most cases, you probably have 
Caps Lock turned on. This is a feature designed to 
help you pinpoint the exact center point of your 
brush, but it can be very frustrating if you’re used to 
seeing the tool tip preview. Simply turn Caps Lock 
off to get the regular brush view again. 

If Caps Lock is not turned on but you still only see the little crosshair representing 
your brush, then look at the size of the brush. This can happen if your brush is so 
big that it covers a larger area than what is currently visible on your canvas. You 

We’re changing the color of the text with the Color 
Picker, which was accessed by clicking on the color 
swatch in the Options Bar. 

If your cursor looks like this 
crosshair when using the Brush 
Tool, check to make sure that 
Caps Lock is not turned on.
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will need to either zoom out on your image or make the brush smaller in order to 
see the brush tip preview. 

The last thing that could cause 
your cursor to look like a cross-
hair instead of the brush tip would 
be a setting in your preferences. 
Go to the main menu and choose 
Photoshop > Preferences > Cur-
sors. (On Win, that’s Edit > Pref-
erences > Cursors.) If the Painting 
Cursors setting is set to Precise, 
change it back to Standard. 

Here, you can see that the brush is so large that if we zoomed in on the document, it would 
no longer be visible. If you ever can’t find your brush tip, check to see how big your brush is.  
The size setting is in the upper left side of the Options Bar (circled). 

The brush tip will look like a crosshair if the Painting 
Cursors setting in your Preferences is set to Precise. 
Set it back to Standard to get the regular brush tip. 
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Revert document

If you are unhappy with the changes you’ve made to a document and you don’t 
know how to return the image back to a state that you like, you can always re-
vert the image, which will bring it back to the state it was in when you originally 
opened it in Photoshop. Do this by going to the File menu and choosing Revert. 

Image looks different on other screen: No Color Profile? 

The appearance of your image de-
pends a good amount on the color 
profile. If you ever send an image to 
someone else or view the image in 
a web browser and you find that it 
looks different than the way it did 
when you adjusted it in Photoshop, 
the image may have been saved with 
no color profile. When you save an 
image in Photoshop, there will be an 
“Embed Color Profile” check box at 
the bottom of the Save dialog. It’s 
very important to always have this 
setting turned on. It must be turned 
on in order for Photoshop to save 
enough information about the doc-
ument so that it can accurately pres-
ent the image in a different program 
or screen. 

Make sure the “Embed Color Profile” check box 
is turned on when you save your images. 
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Color looks wrong: Is image in sRGB?

Many computer programs aren’t designed to accurately represent color unless 
your image is set up in a certain way.  If you want your images to look good in 
programs that aren’t geared toward professional imaging (email programs, data-
bases, web browsers, etc.), it’s a good idea to use the sRGB color space. When 
creating a new Photoshop document, there will be a Color Mode option within the 
New Document dialog. If it’s not a new document, or you’re working with a docu-
ment that was given to you by someone else, you can always export the image in 
the sRGB mode. To do this, go to the File menu and choose Export > Save for Web 
OR Export > Save As. Choosing either of these options will give you a checkbox 
option to “Convert to sRGB.” 

Filters/adjustments not working: Quick Mask Mode? 

Quick Mask Mode allows you to view an active selection 
as a red overlay on your image. It’s designed to help you 
better see, evaluate and edit a selection. It can also mess 
you up if you get into this mode accidentally. When you’re 
in Quick Mask Mode, any filter or adjustment you use will 
be applied to the selection, not the image. If you happened 
to enter this mode accidentally, and you had no selection 
active, there will be no red overlay and therefore no visual 
indication that you’re in Quick Mask Mode. When you try 
to apply a filter or adjustment, it will appear to do nothing 
because its applying it to the [nonexistent] selection. You 
can get in and out of Quick Mask Mode by hitting the Q 
key on your keyboard or clicking the Quick Mask icon at 
the very bottom of the Toolbar. After you get out of Quick 
Mask Mode, all of your filters, adjustments, etc. should work 
properly again. 

The Quick Mask icon 
at the bottom of the 
Toolbar.


