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The Gradient Tool
In this lesson, we’re going to look at how you can create gradients in Photoshop. 
A gradient simply a smooth transition from one color to another and they can be 
used in several ways. 

The Gradient Tool can be found in the Tool Bar on the left side of the 
interface. When activated, settings relating to the tool will appear in the 
Options Bar above your image window. On the left side of the Options 
Bar, you will see a preview of the gradient you’re about to create. If you click on 
the menu to the right of this preview, you will get a list of gradient presets and 
the first two are the ones you will most commonly use. The first is the Foreground 
to Background gradient and this is the one that will be active by default. When 
you choose this, the gradient will start with the foreground color you currently 
have set and will end with the background color. You can set your foreground and 
background colors by clicking on the swatches at the bottom of the Tool Bar and 
selecting the colors from the Color Picker that pops up. 

To create a gradient in your document, simply click in the area you want the 
gradient to begin and drag your mouse to where you’d like the gradient to end. 
You will see a gradient line appear as a guide while you drag. If you drag out a 
short gradient line, then the transition will be more abrupt and anything beyond 
the ends of the line you draw out will be a solid color. The longer you drag, the 

When the Gradient Tool is active, the set-
tings related to it can be found in the Op-
tions Bar. Clicking on the gradient preview 
menu will give you a list of gradient presets. 

Three commonly-used gradient presets 
use the foreground and background colors. 
Those can be set by clicking on the swatches 
in the Tool Bar to bring up the color picker.
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smoother the gradient will be. If you want your gradient line to be perfectly hor-
izontal or perfectly vertical, then hold down the Shift key as you drag out the 
gradient line. Otherwise, you can create gradients at any angle. 

Usually, the gradient will completely fill your document unless you have a selec-
tion active to limit where it happens. 

The second Gradient Preset, and the other most commonly-used preset,  is Fore-
ground to Transparent. If you use this gradient, it will start with whatever color 
you have selected as your foreground color and end with transparency, revealing 
whatever is in the layers below. 

Gradient Presets As we mentioned before, 
clicking on the gradient preview in the Options 
Bar will give you a menu of gradient presets, 
or the preset picker. If you don’t see a gradient 
that you’d like to use, you can click on the little 
gear icon in the upper right corner of the menu 
to get a list of additional presets that you can 
load. That menu will also give you options for 
how to view the preset list. Many find it conve-
nient to choose the “Large Thumbnail” option 
so the gradients are easier to see. 

In the screen shots above, we added a red line so you can better see how long of a gradient 
line we dragged out. With a longer line, you get a smoother gradient. With a shorter line, 
you get a more abrupt transition. 

Clicking on the gear icon in the 
Gradient Picker will give you a 
menu of additional gradients and 
view options for the gradient list.
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Gradient Options 

The settings for the Gradient Tool can be found within the Options Bar at the top 
of the screen. We’ll look at those one by one: 

Gradient Styles To the right of the gradient preview 
are a series of five icons, which represent the different 
styles of gradients we can use. Let’s look at those. 

Linear Gradient  This is the first icon and the one that is active by de-
fault. Using this option will create a gradient in a straight line. 

Radial Gradient  This is the second icon and it will cause the gradient 
to radiate out in a circle, the center being the location you started to 
click and drag. 

Angle Gradient This gradient sweeps around like a radar image. The 
line that you drag out will be the edge, or the starting and ending point 
of the gradient. 

Reflected Gradient This is very similar to the linear gradient, but it’s 
happening twice, as if it’s being reflected in a mirror. 

Diamond Gradient This gradient creates a diamond shape and the line 
you drag out will create one of the corners of the diamond. 

The Gradient Styles

Linear Radial Angle Reflected Diamond
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Blending Mode The Blending Mode menu determines how the gradient we’re 
about to create will interact with the layer we’re working on. 

Opacity The Opacity setting controls how much you can see through the gradi-
ent to what’s underneath.

Reverse Turning on the Reverse check box will swap the colors so the gradient 
goes in the opposite direction.

Dither This is something that you will likely not notice on screen. You might no-
tice this when you print the image and it looks like a banding effect that appears 
over a gradient. Turning on the Dither check box adds noise to the gradient and 
makes it so that when you print it, the gradient will look smoother.

Transparency Turning this check box on will tell the Gradient Tool to ignore any 
transparency that’s built into a gradient preset. I usually keep this off, because I 
want the gradient presets containing transparency to behave the way in which 
they were designed. 

The Gradient Editor 

When it comes to gradient styles, 
we are not limited to the list of pre-
sets that you find in the preset picker 
menu. We can use the Gradient Edi-
tor to create our own custom gradi-
ents. To access this, we’ll have to start 
by choosing one of the presets that 
is the closest to what we ultimately 
want. Then, we’ll click directly on the 
gradient preview in the Options Bar to 
bring up the Gradient Editor. 

The top area of the Gradient Editor di-
alog contains the same preset thumb-
nails that we find in the Options Bar 
menu. The gradient bar below is where 

The Gradient Editor
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you make changes to the gradient. There are two sets of controls with this bar. 
The controls on the bottom determine the colors in the gradient and the controls 
on the top determine the opacity settings. The Smoothness dropdown menu is a 
setting that will attempt to reduce banding in the final, printed image. When the 
Smoothness is set to 0, it gives you a perfectly even gradient. When the Smooth-
ness is set to 100, it makes less of a change near the ends of the gradient. It makes 
more of the gradient change in the middle. I usually keep this setting at 100. 

Customizing the gradient You can change what colors make up your gradient by 
clicking on the little swatch squares attached to the sliders beneath the gradient 
bar. When you click on one of these squares, the slider arrow becomes black, in-
dicating that it’s the one you’re working on. Settings for that swatch will appear 
below the gradient bar. One of those settings is called “Color” and clicking on it 
will bring up the Color Picker, from which you can choose a different color. If you 
click on the little down-pointing arrow next to the Color setting, you’ll get the 
options to use the foreground and background colors. The Location setting de-
termines where that color appears across the distance of the gradient. I usually 

When you click on one of the slider swatches, it will get a black arrow, indicating that it’s 
active and you can make changes to it using the settings below. 
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don’t enter in numbers for the Location settings. Instead, I drag the color sliders 
manually and this is much easier. When you move the left-most slider to the right, 
anything before it will become a solid color in your gradient. Similarly, moving the 
right slider to the left will make everything after it a solid color. 

In the middle of the gradient, you 
will see a little diamond shape, which 
marks the mid-way point. You can click 
and drag on that diamond to move it 
and therefore change the mid-way 
point of the gradient. (Note that this 
diamond might not be visible if you 
have not clicked on one of the colors.) 

Your gradients are not limited to two colors (a starting and ending color). You can 
have as many colors, or stops, as you want. To add another stop, or color, simply 
click just below the gradient in the place that you want to add the additional color. 

That stop will automatically become 
active and you can use the Color set-
ting below to specify what color you’d 
like it to be. Every time you add a stop, 
a little diamond will be added so that 
one appears at the half-way point be-
tween each color. Note that one of the 
stops needs to be active in order for 
the little diamonds to be visible. 

Once you have your gradient set up, 
you can give it a name within the 
Name field above the gradient bar and 
save it as a preset by clicking the New 
button on the right side of the dialog. 
When you save a preset, it will appear 
in the gradient preset list. 

Clicking and dragging on the diamond shape 
will change where the mid-way point is in 
your gradient. 

We added another stop to this gradient by 
clicking below the gradient bar in the place 
we wanted to add the stop. 
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Adding transparency to a gradient To change the colors in a gradient, we work 
with the sliders below the gradient bar. To change the transparency in a gradient, 
we work with the sliders above the bar. If you want part of your gradient to be 
transparent, click right above the gradient bar in the place you want to add the 
transparency. You’ll see the checkerboard background appear, which indicates 
transparency. You can then control how transparent the area will be by adjusting 
the Opacity slider below the gradient bar. (The gradient stop will need to be ac-
tive in order for the Opacity setting to be available.)

When you have transparency stops in your gradient, the sliders will be black, 
white or gray. A black slider represents an area that you can’t see through at all. 
White represents an area that is completely transparent and gray represents an 
area that is partially transparent. 

To remove a stop from the gradient, whether it be a color stop or a transparency 
stop, simply click and drag them away from the gradient.

Noise Gradients Up until now, we have been creating Solid Gradients. There is 
another type of gradient and that is a noise gradient. You can switch to this 
type of gradient by using the “Gradient Type” dropdown menu in the middle of 
the Gradient Editor dialog. Instead of having a simple transition from one color 

In the left screen shot, we added a transparency stop by clicking above the gradient bar in 
the place we wanted to add the stop. In the screen shot at right, you can see the different 
types of transparency stops. The black represents an area that is solid color, the white rep-
resents an area that is totally transparent and the gray represents an area that is partially 
transparent. 



Video 34 | The Gradient Tool © Ben Willmore, All rights reserved 9

to another, we have transitions that 
are a bit more random in how they 
appear. There are three ways of lim-
iting how the gradient appears and 
those can be changed via the Color 
Mode menu below the gradient bar. 
I usually choose the HSB setting. 
The sliders below the Color Mode 
menu determine how much the gra-
dient can vary between each of the 
different controls. When using the 
HSB setting, the H sliders determine 
how wide of a color range the gradi-
ent can use. The S slider determines 
how much the saturation can vary 
and the B slider determines how 
much the brightness can vary. 

To the right of the sliders is a Randomize button. Clicking on it will give you a dif-
ferent result based on the same settings you specified. You can click this button 
repeatedly until you have a result that you like. 

There are a few more settings to consider when creating a noise gradient and 
those are as follows:

• The Restrict Colors check box will restrict how much of a saturation change 
it’s going to have.

• The Add Transparency check box will incorporate random transparency into 
the gradient. 

• The Roughness dropdown menu allows you to determine how abrupt or 
smooth are the changes in colors are. 

If you create a gradient or gradient set that you’d like to share with someone else, 
click the Save button. You will be prompted to give the set of gradients a name 
and then they will be saved as a file on your hard drive. 

Here, we are creating a noise gradient using the 
HSB Color Mode. 
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Different Uses for Gradients

Create a color wheel We’re going to create a color wheel where the inside grad-
ually becomes white and the outside gradually becomes dark. What this will give 
us is the complete spectrum of colors and tones. 

To start, we’ll create an empty, square document. Then, we’ll use the gradient 
picker dropdown menu and select the rainbow gradient. We’ll set the gradient 
style to the Angle Gradient and then start in the center of the document and drag 
a straight line outward. Because the rainbow gradient starts and ends with the 
same color, you’ll have a seamless color wheel. 

We created a seamless color wheel by choosing the rainbow gradient preset and using the 
Angle gradient style. 
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Next, we want to make the colors fade to white in the center, so we’ll choose the 
Radial Gradient style and then choose the Foreground to Transparent preset. 
We’ll use the foreground/background swatches in the bottom of the Tool Bar to 
change the foreground color to white. We’ll start in the center of the document 
and drag the gradient line toward the edge of the document. This will make the 
center bright.

Now we need to make the outer 
edges to gradually get darker until 
they are black. Switch foreground 
color to black and turn on the Re-
verse check box in the Options Bar. 
(This reverses the beginning and 
ending colors). Click in center again 
and drag a straight line all the way 
to the edge of the document. Note 
that if the fade-out isn’t exactly how 
you’d like it, you can always adjust 
it in the Gradient Editor. The result 
should be a complete color wheel. 

Upper far left: We 
selected the Fore-
ground to Transparent 
preset (with the fore-
ground set to white) 
and the Radial Gra-
dient style. Lower far 
left: We dragged out 
a gradient line from 
the center. Directly 
left: The resulting 
gradient, with white 
in the center. 

The resulting wheel, after adding the black gra-
dient on the edges. 
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Creating a gradient layer You can create a new layer that is a gradient layer by 
doing one of two things. You can click on the Adjustment Layer icon at the bot-
tom of the Layers panel (which looks like a circle that is half white, half black) and 
choose Gradient from the pop-up menu or you can go to the Layer menu and 
choose New Fill Layer > Gradient. When you choose one of those two things, the 
Gradient Fill dialog will appear, from which you can choose a gradient preset. You 
can also specify the type of gradient from the Style menu as well as some of the 
other settings relating to gradients. 

Layer styles A layer style is a setting that’s attached to the layer and where it 
applies is based on the shape of the layer. One of the types of layer styles we can 
apply is a gradient overlay and we will use that to add dimension to a shape. 

We’ll first choose the Ellipse Tool and in the Options Bar, specify that we want to 
create a Shape Layer.  We can also choose the fill color in the Options Bar. 

Then, we’ll click and drag out an ellipse in the document, holding Shift to con-
strain the shape to a perfect circle. This will create a new shape layer that you can 
see in the Layers panel. To add a layer style, click the FX icon at the bottom of the 

When you create a Gradient Fill layer, this dialog will prompt you to choose a gradient pre-
set and specify the gradient style. 
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Layers panel and choose Gradient Overlay from the pop-up menu. Alternatively, 
you can go to the Layer menu and choose Layer Styles > Gradient Overlay. The 
Layer Styles dialog will appear and the gradient overlay settings will be visible.

We want to use a gradient overlay that will add a highlight to our shape. This would 
be a gradient that starts with white and then fades to transparent. To do this, we’ll 
click on the gradient preview menu and choose the Foreground to Transparent 
preset. If our foreground was already set to white, then we’re all set. If it wasn’t, 
then we’ll have to use the Gradient 
Editor (by clicking directly on the 
gradient preview) to change the 
foreground color to white.  Then, 
we’ll use the Style menu to choose 
Radial. If we move the Layer Style 
dialog so that it’s not covering the 
document, we can see the gradi-
ent appearing over the shape layer 
and we can literally click and drag 
over our shape to position the gra-
dient exactly where we want. We’re 
going to place it in the upper left 
portion of the circle and then use 
the Scale slider to adjust the size.

Next, we want to add an outer gradient that’s darker and we will do this within 
the same area of the Layer Style dialog. We want to add another Gradient Over-

lay but use different settings, so we’ll click on the 
little plus icon next to the name “Gradient Over-
lay” on the left side of the dialog. Now we can 
work with the settings to create a new gradient. 
We want this one to be dark, so we’ll click on the 
gradient preset preview and use the Gradient Ed-
itor to make the gradient black to transparent. (In 
our case, we used the Foreground to Transpar-

A Gradient Overlay is being 
applied to create a white 
highlight on the shape. 

The Gradient Overlay settings for 
the dark, outer gradient.
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ent preset because out foreground color was set to 
black.) The location of the gradient is in the center 
of the orb by default and we want the opposite, so 
we’ll turn on the Reverse checkbox, which will put 
the dark gradient on the outside of the orb. We’ll 
then use the Scale and Opacity sliders to fine-tune 
the gradient and make the orb appear three-di-
mensional.

Using a gradient to add color to a grayscale image If you want to add color to 
a grayscale image by any means, you will first need to make sure that the color 
space is not set to grayscale. I usually use the RGB color mode and that can be 
changed by going to the Image menu and choosing Color Space. 

Click the Adjustment Layer icon at the bottom of the Layers panel and choose 
Gradient Map from the menu that appears. (Alternatively, you can go to the main 
menu and choose Layer > New Adjustment Layer > Gradient Map.) The Proper-

ties panel will appear, inside of 
which you will see a gradient 
preview. A Gradient Map con-
verts your image to black and 
white (If it wasn’t black and 
white already) and then re-
places whatever was black in 
your picture with the color on 
the left side of the gradient and 
replaces whatever was white 
in the picture with the color on 
the right side of the gradient. 
If you click on the arrow to the 
right of the gradient, you will 
get the list of gradient presets 
and you can choose whichever 
one you’d like. The main prob-

The resulting orb

A Gradient Map adjustment layer was added and we 
are browsing the list of gradient presets in the menu to 
the right of the gradient bar. 
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lem with this type of adjustment is that it doesn’t try to maintain the brightness 
of your picture, so it will initially look very harsh. You can fix this by using the 
Blending Mode dropdown menu at the top of the Layers panel and choosing Col-
or. The Color mode makes it so that it can only change the color of the layer, but 
not the brightness. 

The default presets may not produce the most desirable effects, so you can use 
the little dropdown menu in the upper right of the Properties panel and choose 
a different set of presets. The Photographic Toning presets can work very nicely, 
as they are much more subtle.

Left: You can choose between different sets of gradient presets by clicking the menu in the 
upper right of the Properties panel. Right: We chose one of the presets from the Photo-
graphic Toning set. 
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Real World Examples

Here are a few real world examples of how gradients were used to enhance some 
images: 

The original image is shown at right. I wanted to 
make it more colorful so I added a Foreground to 
Transparent gradient on an empty layer (with the 
foreground set to a yellow) and then set the blend-
ing mode to Color. 

The original image is shown 
above. A Radial gradient 
was used (set to Reverse) 
to add more yellow to the 
outer portion of the frame. 
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Creating a rainbow using gradients When you activate a tool in Photoshop, any 
presets related to that tool can be found in the Tool Preset Picker, which is the 
icon on the very left side of the Options Bar. By default, there is only one preset 

available when you activate 
the Gradient Tool and that is 
the rainbow gradient. When 
you select this preset, you 
will see that all of the set-
tings in the Options Bar are 
adjusted for that preset. The 
Radial gradient is automat-
ically selected, so you can 
drag out a gradient line to 
create the arc of a rainbow. I 
recommend that you do this 
on a new, empty layer. You 
can then change the opaci-
ty and blending mode of the 
rainbow layer so that it looks 
more realistic.

Applying colors from one image to use in another In this example, we want to 
apply the colors of the sunset in one image and apply them to another image by 
use of a gradient. 

First of all, we want to open the Swatches pan-
el. If it’s not already visible in the interface, you 
can access it by going to the Window menu and 
choosing Swatches. In this panel, your most re-
cently-selected colors will appear within the bar 
at the top. Knowing this, we will open the image 
we want to steal the colors from and activate the 
Eyedropper Tool, clicking on the desired colors to 
add them to this top bar in the Swatches panel. 

The rainbow gradient was selected using the preset 
menu in the far left side of the Options Bar and then ap-
plied to this image in the Overlay blending mode. 

We used the Eyedropper to sam-
ple a handful of colors from an 
image and they appear in the top 
bar of the Swatches panel. 
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Next, we will open the image that we want to apply the colors to. We will click on 
the Adjustment Layer icon at the bottom of the Layers panel and choose to add 
a Gradient Map. We will then change the blending mode of this adjustment layer 
to Color. In the Properties panel, we will choose a preset that has a few colors in 
it and then click on the gradient bar to open the Gradient Editor. Instead of using 
the colors in the original preset, we’re going to use the colors that we added to 
the Swatches panel. When we click to add and adjust the various stops in the 
gradient, we can click on the colors in the Swatches panel to apply them. We’ll 
continue to adjust the gradient, moving the sliders around, so that the look of the 
current images matches the look of the image we sampled the colors from. 

Note that you can drag an adjustment layer between documents in order to ap-
ply the same settings.

A Gradient Map adjustment layer was added to this document and we clicked on the gradi-
ent bar within the Properties panel to open the Gradient Editor. We then used the colors we 
sampled from the first image to create a gradient for the current image. 
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Quick Tips

• When using the gradient tool with a Linear gradient, it’s easy to get the angle 
off just a bit. To avoid this, hold down the Shift key to constrain the angle to 
a 45-degree increment. This means that the gradient will either be perfectly 
horizontal, vertical or at a 45-degree angle. 

• If you want to change your foreground color quickly, hold down the Option 
key to access the Eyedropper Tool. Click to sample somewhere in your image 
and then let go of the Option key. If you would like to quickly switch between 
the foreground and background colors, hit the X key on your keyboard.

• If your gradient settings ever look a bit odd and you cant figure out why, you 
can reset all of the tool settings. Right-click on icon in the far left of the Op-
tions Bar and choose Reset Tool from the menu that appears. This will reset all 
of the tool options to their default settings.

• If you’d like to save a preset that includes not only the gradient colors, but also 
the settings in the Options Bar, go to the icon at the far left of the Options Bar 
and click on the little triangle to the right of it. A menu will appear and you can 
click on the little New icon on the right side to save a new Tool Preset.

 


