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Smart Objects Smart Objects are one of my favorite features in Photoshop 
and I believe that, once you understand how to use them, they can fundamentally 
change the way you think when working with your images. 

When you convert a layer into a Smart Object, it is like putting the layer inside 
of a protective bubble. This means that any changes, effects or adjustments you 
apply to that layer can easily be modified or undone at a later time.

There are a few different ways of converting a layer into a Smart Object, but the 
most common method is to go to the main 
menu and choose Layer > Smart Objects > 
Convert to Smart Object. An icon will ap-
pear in the corner of the layer thumbnail in 
the Layers panel indicating that the layer is 
a Smart Object. Anything you do to a Smart 
Object is merely a setting attached to a layer. 
It’s not permanently changing its contents. 

Smart Objects & Filters When you apply a 
filter to a regular layer, the effect is permanent. You can not change the intensity 
of the filter or un-apply it at a later time. If, instead, you apply a filter to a layer 
that has been converted into a Smart Object, that filter will be applied as a setting 
attached to the layer and it will appear as a separate, indented thumbnail beneath 
the layer thumbnail in the Layers panel. If you double-click on the name of the 
filter in the Layers panel, it will bring up the filter settings so that you can make 
changes at any time.  If you would like to remove a filter completely, you can click 

on the filter name and drag it to 
the trash can icon at the bottom 
of the Layers panel. If you would 
like to remove all filters applied to 
a Smart Object layer, click on the 
word “Smart Filters” and drag them 
to the trash can icon. 

Smart Objects are also very bene-
ficial when it comes to scaling your 
images. If you scale down a regular 

The icon at the bottom right of the  
layer thumbnail indicates that it has 
been converted into a Smart Object. 

When a filter is applied to a Smart Object layer, it 
is applied as a Smart Filter and will appear below 
the layer thumbnail in the Layers panel. 
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layer and then close your document, when you reopen the file again, all of the 
original information in that layer will be gone. This means that you can’t scale the 
layer back up without drastically degrading the image quality. If you scale down 
a layer that has been converted into a Smart Object, you can scale it up again at 
any time and it will maintain the quality of the original image.  

Smart Objects & Layer Styles Layer Styles will behave differently on layers that 
have been converted into Smart Objects, and this can often be very useful. If you 
apply a layer style to a regular layer and then resize or distort that layer, Photo-
shop will act as if you applied the layer style AFTER the change. This means that 
if you enlarge a layer that has a pattern effect applied to it, the pattern will not 
scale up or change orientation. You will simply see more of it. On the other hand, 
if you apply a change to a layer that has been converted into a Smart Object and 
then add a filter, the change will be applied to the filter as well. For example, if you 
apply a pattern effect and then scale up the layer or distort the layer, the pattern 
itself will also be scaled up or distorted. 

Let’s say that you apply an effect to a layer that has been converted into a Smart 

Object and then want to go back and change the effect later. To do this, you will 
have to open the Smart Object, and you can do so by double-clicking on the layer 
thumbnail in the Layers panel. When you open a Smart Object, it will open in a 
separate Photoshop document. In that document, you will see all of the effects 

Left: A pattern was applied to a non-Smart Object layer and the layer is now being enlarged 
and warped. Right: A pattern was applied to a Smart Object and the layer is now being en-
larged and warped. With the Smart Object, the changes are reflected in the pattern.  
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applied in the Layers panel and you can double-click on them to make changes 
to them. When you are done making changes to the Smart Object document, 
simply save and close the document. Now, when you go back to your original 
Photoshop document, the changes you made will be reflected there.

Smart Objects can be created from more than one layer. If you have an object in 
your document that is made up of multiple layers, select all of the layers in the 
Layers panel and then convert them to a Smart Object (via the Layer menu). Any 
time you select multiple layers and convert the layer set into a Smart Object, it 
will act as if all of those layers are combined into one piece. This means that mul-
tiple layers will appear as a single Smart Object within the Layers panel. If you 
double-click on that Smart Object in the Layers panel, the separate Smart Object 
document will open and all of the layers will be visible (and editable) in the Layers 
panel. This can be useful when you want to apply a change to an object made up 
of multiple layers. For example, in the image here, we have a shape layer for the 
flame graphic. Then we have a separate layer that is applying the texture to the 
flame. I want to warp those layers, but when I select both of them and then go 
to the Edit menu, the Warp command is gray (inaccessible). That’s because you 
can’t warp more than one layer at a time. If, however, I convert those layers into 
one combined Smart Object, I can then warp them together. 

The flame graphic is made out of more than one layer in this document. We can convert the 
flame into a Smart Object by selecting all of the layers that make up the flame and then go-
ing to the Layer menu and choosing Smart Objects > Convert to Smart Object. 
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When it comes to type layers, you can’t apply filters to a type layer, and if you try, 
Photoshop will ask you if you want to either rasterize the layer (making the type 
un-editable) or convert the layer into a Smart Object. If you convert the layer into 
a Smart Object, you can then apply the filter without rasterizing the type (mean-
ing you can change it again later).

Smart Objects & Layer Masks When you add a layer mask to a layer that has a 
layer style applied to it, the mask will act differently depending on whether or not 
the layer has been converted into a Smart Object. 

To add a layer mask to a layer, first make sure that the layer is active in the Layers 
panel and then click on the Layer Mask icon at the bottom of the Layers panel. 
When a layer has a mask, any area of the mask that is black will hide the layer 
and any area of the mask that is white will allow the layer to remain visible. When 
you add a new layer mask, it will be completely white by default. To add black, 
and therefore hide areas of the layer, you can use a variety of tools, including the 
Brush Tool, the Shape Tool, etc. Note that the layer mask must be active when 
you are attempting to make changes to it. The little square brackets around the 
mask’s thumbnail in the Layers panel will indicate that the mask is active. If it is 
not active, simply click on the thumbnail to activate it. 

When you paint with black on a layer mask that is attached to a layer that has lay-
er styles applied to it, Photoshop will act as if the layer styles were applied AFTER 
you created the mask. This is often times undesirable. If, however, you converted 
the layer into a Smart Object before adding the layer mask, Photoshop act as if 
any layer styles were applied BEFORE you created the mask. (See screen shots 
for example.)

Left: This shape layer has a series of layer styles applied to it. Center: We added a layer mask 
and then started painting with black on the mask. Right: We first converted the layer into a 
Smart Object, then added a layer mask and started painting with black on the mask. You can 
see how the layer styles behave differently when masked depending on whether the layer 
has been converted into a Smart Object. 



Video 31 | Smart Objects © Ben Willmore, All rights reserved 6

Camera Raw to Smart Object You can tell Camera Raw to open an image as a 
Smart Object in Photoshop. After you’re finished adjusting your photo in Camera 
Raw, you would normally click the “Open Image” button in the bottom right cor-
ner of the screen. If, however, you hold down the Shift key, this button will change 
to say “Open Object.” If you click it (with the Shift key held down), the image will 
open in Photoshop and the image layer will automatically be a Smart Object. 

If you always open your images as Smart Objects in Photoshop, you can change 
Camera Raw so that the Open button will say “Open Object” by default. To do 
this, click on the line of text below your image window (see screen shot). A Work-
flow Options dialog will appear, at the bottom of which will be a “Open in Photo-
shop as Smart Objects” check box. If you turn this check box on, then the default 
for that button will be “Open Object” instead of “Open Image.”

Clicking on the text below the main image window in Camera Raw will give you the Work-
flow Options dialog. At the bottom, you can turn on the “Open in Photoshop as Smart Ob-
jects” check box so that photos are opened as Smart Objects by default. 



Video 31 | Smart Objects © Ben Willmore, All rights reserved 7

When you open a photo as a Smart Object from Camera Raw, that Smart Object 
will have a special feature which will allow you to adjust the raw photo in Camera 
Raw at any time. Simply double-click on the layer thumbnail and Camera Raw will 
open, with all of the settings you last used. You can make any additional adjust-
ments in Camera Raw and when you click OK, that image will automatically be 
updated in your Photoshop document. 

Smart Objects & Compositing Smart Objects can be very useful when compos-
iting images because they allow you to easily change them while maintaining 
any effects or transformations that had been applied. In the example here, we 
wanted to make a photo look as if it was printed on a mug. We first opened the 
image from Camera Raw into Photoshop 
as a Smart Object. Then, we dragged the 
photo into the Photoshop document that 
contained the mug. We free-transformed 
the image so that it was generally the de-
sired size for wrapping around the mug. 
To free-transform a layer, you can use the 
keyboard shortcut Command+T (Ctrl+T 
on Win) to get the free-transform handles 
around the layer. You can maintain the pro-
portions of the layer while re-sizing by hold-
ing down the Shift key while dragging those 
handles. 

Next, we needed to warp the image to make 
it look like it was wrapped around the mug. 
To do this, we chose Edit > Transform > 
Warp from the main menu.  With the Warp 
transform handles visible on the image, you 
can use them to warp and bend the edges 
of the image. You can also click and drag 
within the grid to warp it. Press Return or 
Enter to lock in the transformation. 

A Smart Object image layer is being 
free-transformed to the size of the mug. 

The Smart Object image layer is being 
warped around the mug. 
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Finally, we changed the blending mode of the image layer to Multiply. Multiply 
acts like ink, so it will make the image look as if it was printed on the mug. 

This is the point in which you’ll see the benefits to that image layer being a Smart 
Object. Even though we warped the heck out of the layer, we can still double-click 
on the layer thumbnail in the Layers panel and, because the image was originally 
opened from Camera Raw, it will re-open in Camera Raw with the settings last 
applied to it. In this case, we converted the black and white image back to color, 
optimized it and then clicked OK. When we did so, our Photoshop document 
re-appeared and the Camera Raw adjustments were updated in the image lay-
er. It remembered the warping that was applied and it remembered that it was 
in Multiply mode because those were just settings applied to the outside of the 
Smart Object and they get updated instantaneously when we made changes in-
side the Smart Object.

Left: We double-clicked on the Smart Object image thumbnail to re-open the image in 
Camera Raw and then made additional changes to the photo. Right: When we clicked OK, 
the image went back to Photoshop and all of the Camera Raw changes were reflected in the 
document. 
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Replacing a Smart Object with a different image Any Smart Object image lay-
er can easily be replaced with a different image, providing it has the same di-
mensions. This makes it very easy to create a multi-layer document and quick-
ly replace one part of it. In our mug example, we will 
replace the image that has been placed on the mug. 
With the Smart Object image layer active, we’ll go to 
the main menu and choose Layer > Smart Objects > 
Replace Contents. When you choose this, you will be 
prompted to choose a new file from your hard drive 
and click Place. Note that the file you choose should 
have the same dimensions (width and height in pix-
els) as the current image. We’ll choose a different im-
age, click Place, and because the image is a raw file, it 
opens in Camera Raw first. We simply have to click OK 
and the new image is placed on the mug.

Duplicating Smart Objects 
When you duplicate a Smart 
Object, each duplicate is 
considered as another in-
stance of that same Smart 
Object. (You can duplicate a 
layer by using the keyboard 
shortcut Command+J, or 
Ctrl+J on Win.) This means 
that they all point back to 
the same original content. 
If you double-click on the 
thumbnail for one of those 
Smart Objects to open it, 
make a change and then 
click Save, every instance 
of that Smart Object will be 
updated with the change 
you made.

Replace Contents was used 
to replace the Smart Object 
image on the mug.

A TV graphic was converted into a Smart Object, duplicat-
ed several times and then warped in different ways. When 
we made a change to the Smart Object and clicked Save, 
every instance of the TV was updated in the document.
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Nested Smart Objects  A nested Smart Object is a Smart Object (or objects) 
inside of another Smart Object. To create a nested Smart Object, select two or 
more layers that have already been converted into Smart Objects. Then go to the 
main menu and choose Layer > Smart Objects > Convert to Smart Object. In the 
Layers panel, it will look as if all of those layers have been combined into one. 
You can apply any kind of effects, transformations, warping, etc. on that layer. 
If you’d like to change one of the individual Smart Objects, double-click on the 
layer thumbnail and a new Photoshop document will open that includes all of the 
individual Smart Objects.

The leaf image was cre-
ated, converted into a 
Smart Object and then 
duplicated several times 
to create the fan shape. 
All of the leaf Smart Ob-
jects were then selected 
and turned into a nested 
Smart Object to create 
the final composite at 
left. We can click back 
to the original leaf Smart 
Object, make a change 
and click Save to have 
that change applied to 
all instances of the leaf in 
the final composite. 
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Linked Smart Objects There are two kinds of Smart Objects: Embedded Smart 
Objects and Linked Smart Objects. Embedded Smart Objects are contained with-
in the Photoshop document, and these are the type we’ve been using up until this 
point. Linked Smart Objects are contained on your hard drive and you choose to 
use them as Smart Objects when you import them. To do this, you’d go to the File 
menu and choose Place Linked. You would be prompted to choose an existing 
document on your hard drive and import it as a Smart Object into your current 
Photoshop document. If, at any time, you make a change to that [linked] docu-
ment, it will automatically be updated in any Photoshop documents in which it 
exists as a Smart Object. 

In the example here, I have 
a document that contains a 
graphic used in each chapter 
intro for a Photoshop book. 
The graphic has to be the 
same for each chapter, so I 
used a Linked Smart Object 
for that graphic. This way, if I 
make a change to the chap-
ter intro graphic file, it will 
automatically be updated 
on each chapter intro page 
document. 

Now, let’s say that you are working on a Photoshop document, create a Smart 
Object that consists of multiple layers and then decide that you want this Smart 
Object to exist as a separate document on your hard drive. You can do this by 
going to the main menu and choosing Layer > 
Smart Objects > Convert to Linked. You’ll be 
prompted to give the new document a name 
and choose where it should exist on your hard 
drive. When you have a Linked Smart Object in-
corporated into your document, there will be a 
little link icon in the bottom right corner of the 
layer thumbnail in the Layers panel.

In this example the “Up to Speed” bar was converted into 
a Linked Smart Object, which turned it into a separate file 
on my hard drive. Any time I made a change to this graph-
ic file, it was updated in every document it was used in. 

The icon in the bottom right of the 
layer thumbnail indicates that it is 
a Linked Smart Object. 


